Bug 12098 - Miro player doesn't start
Summary: Miro player doesn't start
Status: RESOLVED WONTFIX
Alias: None
Product: Mageia
Classification: Unclassified
Component: RPM Packages (show other bugs)
Version: Cauldron
Hardware: All Linux
Priority: Normal critical
Target Milestone: ---
Assignee: All Packagers
QA Contact:
URL:
Whiteboard: MGA5TOO
Keywords: NEEDINFO
: 14285 17152 (view as bug list)
Depends on:
Blocks:
 
Reported: 2013-12-23 17:49 CET by Christian Müller
Modified: 2017-11-28 17:10 CET (History)
10 users (show)

See Also:
Source RPM: miro-6.0-4.mga4
CVE:
Status comment:


Attachments

Description Christian Müller 2013-12-23 17:49:13 CET
Description of problem:

The Miro player shipped with Mageia 4b2 (upgraded from mga3) fails to start.

Version-Release number of selected component (if applicable):

miro-6.0-4.mga4

How reproducible:

Install miro via rpmdrake, und try to start it, no window comes up. If I try to 
start it from console, I get this output:

using /usr/bin/gdb
2013-12-23 17:34:43,232 INFO     root: Python version:    2.7.5 (default, Oct 22 2013, 05:48:56) 
[GCC 4.8.2]
2013-12-23 17:34:43,232 INFO     root: Gtk+ version:      (2, 24, 22)
2013-12-23 17:34:43,232 INFO     root: PyGObject version: (2, 28, 6)
2013-12-23 17:34:43,232 INFO     root: PyGtk version:     (2, 24, 0)
** Message: pygobject_register_sinkfunc is deprecated (GstObject)
/usr/lib64/python2.7/site-packages/gst-0.10/gst/__init__.py:193: Warning: cannot register existing type 'GstObject'
  from _gst import *
/usr/lib64/python2.7/site-packages/gst-0.10/gst/__init__.py:193: Warning: g_once_init_leave: assertion 'result != 0' failed
  from _gst import *

(miro.real:3165): GLib-GObject-CRITICAL **: g_type_register_static: assertion 'parent_type > 0' failed
/usr/lib64/python2.7/site-packages/gst-0.10/gst/__init__.py:193: Warning: interface type 'GstImplementsInterface' or prerequisite type '<invalid>' invalid
  from _gst import *


Reproducible: 

Steps to Reproduce:
Comment 1 Damien Lallement 2013-12-24 05:48:41 CET
It's because cauldron have libtorrent-rasterbar7 and miro 6 needs libtorrent-rasterbar6 to work...

Status: NEW => ASSIGNED
CC: (none) => mageia
Hardware: x86_64 => All
Assignee: bugsquad => mageia

Comment 2 Florian Hubold 2014-02-02 20:49:32 CET
Well, now the problem is also with Mageia 4. How to fix this? The changes in libtorrent-rasterbar cannot be backported?

Severity: normal => critical
Version: Cauldron => 4
CC: (none) => doktor5000

Comment 3 Florian Hubold 2014-02-02 20:59:10 CET
FWIW, Mageia 3 also has libtorrent-rasterbar7, and the older mga3 version of miro works just fine. Also rebuilding latest miro from cauldron under Mageia 3, miro works - and that's also using libtorrent-rasterbar7.
Comment 4 Florian Hubold 2014-02-02 21:03:47 CET
Seems more like some gstreamer plugin or python binding for gstreamer is missing ... or webkit:

https://bugs.archlinux.org/task/32424
Also see this openSUSE thread: http://linux.derkeiler.com/Mailing-Lists/SuSE/2013-04/msg01111.html
Christoph Holz 2014-02-03 14:26:54 CET

CC: (none) => christoph.holz

Comment 5 Olivier FAURAX 2014-11-09 23:34:13 CET
Still valid with up-to-date mageia 4.
miro-6.0-4.mga4
python-libtorrent-rasterbar-0.16.17-1.mga4

What about Mageia 5 alpha?

CC: (none) => olivier

Comment 6 Florian Hubold 2014-11-10 20:35:45 CET
(In reply to Olivier FAURAX from comment #5)

> What about Mageia 5 alpha?

Beta, that is. miro starts up normally, using gstreamer0.10 packages.
Comment 7 Christian Müller 2014-11-12 21:54:09 CET
(In reply to Florian Hubold from comment #6)

> Beta, that is. miro starts up normally, using gstreamer0.10 packages.

Can't confirm this. Just installed Mageia 5 x86_64 beta, and miro still isn't working :-(
Comment 8 Florian Hubold 2014-11-15 14:40:27 CET
(In reply to Christian Müller from comment #7)
> miro still isn't working :-(

Meaning what exactly? Please at least attach the full output of miro for a clean start (either move away or rename .miro with e.g. "mv ~/.miro/ ~/.miro-old/" and then start miro from a terminal) and the installed version of miro, otherwise that comment is nearly useless.


miro-6.0-9.mga5 starts just fine here.
Comment 9 Christian Müller 2014-11-15 15:54:29 CET
It's still the same as in my first post: No window comes up.

Clean install of Mageia 5 beta1 64, new user profile, miro-6.0-9.mga5

Console output:

2014-11-15 15:53:55,620 INFO     root: Python version:    2.7.8 (default, Oct 16 2014, 08:50:33) 
[GCC 4.9.2 20141001 (prerelease)]
2014-11-15 15:53:55,620 INFO     root: Gtk+ version:      (2, 24, 25)
2014-11-15 15:53:55,621 INFO     root: PyGObject version: (2, 28, 6)
2014-11-15 15:53:55,621 INFO     root: PyGtk version:     (2, 24, 0)
** Message: pygobject_register_sinkfunc is deprecated (GstObject)
/usr/lib64/python2.7/site-packages/gst-0.10/gst/__init__.py:193: Warning: cannot register existing type 'GstObject'
  from _gst import *
/usr/lib64/python2.7/site-packages/gst-0.10/gst/__init__.py:193: Warning: g_once_init_leave: assertion 'result != 0' failed
  from _gst import *

(miro.real:3246): GLib-GObject-CRITICAL **: g_type_register_static: assertion 'parent_type > 0' failed
/usr/lib64/python2.7/site-packages/gst-0.10/gst/__init__.py:193: Warning: interface type 'GstImplementsInterface' or prerequisite type '<invalid>' invalid
  from _gst import *
Comment 10 Florian Hubold 2014-11-16 10:41:46 CET
Please show the output of 
rpm -qa | grep gst | sort
rpm -qa | grep webkit | sort


FWIW, this is what a normal start looks like here (output trimmed down):

ââ[user1@localhost]â[10:34:44]â[~]
ââââ¼ miro
using /bin/gdb
/home/user1/.gtkrc-2.0:15: error: unexpected character ',', expected keyword - e.g. `style'
PyNotify support disabled on your platform.
2014-11-16 10:35:19,839 INFO     root: Python version:    2.7.8 (default, Oct 16 2014, 08:50:02) 
[GCC 4.9.2 20141001 (prerelease)]
2014-11-16 10:35:19,850 INFO     root: Gtk+ version:      (2, 24, 25)
2014-11-16 10:35:19,853 INFO     root: PyGObject version: (2, 28, 6)
2014-11-16 10:35:19,859 INFO     root: PyGtk version:     (2, 24, 0)                                                                                                   
** Message: pygobject_register_sinkfunc is deprecated (GstObject)                                                                                                      
2014-11-16 10:35:20,394 INFO     root: GStreamer audiosink: gconfaudiosink                                                                                             
2014-11-16 10:35:20,478 INFO     root: GStreamer videosink: gconfvideosink                                                                                             
2014-11-16 10:35:20,481 INFO     root: GStreamer version: GStreamer 0.10.36                                                                                            
2014-11-16 10:35:20,484 INFO     root: GStreamer version: GStreamer 0.10.36                                                                                            
2014-11-16 10:35:20,491 INFO     root: set_renderer: successfully loaded gstreamerrenderer                                                                             
2014-11-16 10:35:20,505 INFO     root: Starting up Miro                                                                                                                
2014-11-16 10:35:20,513 INFO     root: Version:    6.0                                                                                                                 
2014-11-16 10:35:20,529 INFO     root: Revision:   git://github.com/pculture/miro.git - e2e33c40                                                                       
2014-11-16 10:35:20,546 INFO     root: Builder:    iurt@valstar.mageia.org                                                                                             
2014-11-16 10:35:20,562 INFO     root: Build Time: 1415980106.06                                                                                                       
2014-11-16 10:35:20,569 INFO     root: Debugmode:  False                                                                                                               
2014-11-16 10:35:20,575 INFO     root: Reading HTTP Password list                                                                                                      
2014-11-16 10:35:20,590 INFO     root: Starting libCURL thread
2014-11-16 10:35:20,649 INFO     root: Starting event loop thread
2014-11-16 10:35:20,709 INFO     root: Installing deleted file checker...
2014-11-16 10:35:20,758 INFO     root: Restoring database...
2014-11-16 10:35:20,751 INFO     root: Loading core extensions in /usr/share/miro/resources/extensions
2014-11-16 10:35:20,798 INFO     root: Sqlite3 version:   3.8.6
2014-11-16 10:35:20,844 INFO     root: Pysqlite version:  2.6.0
2014-11-16 10:35:20,971 INFO     root: Loading user extensions in /home/user1/.miro/extensions
2014-11-16 10:35:20,993 INFO     root: Language:          [('LANGUAGE', 'en_US.UTF-8:en_US:en'), ('LC_MESSAGES', 'en_US.UTF-8'), ('LANG', 'en_US.UTF-8')]
2014-11-16 10:35:21,024 INFO     root: opening database /home/user1/.miro/sqlitedb
2014-11-16 10:35:21,228 INFO     root: libtorrent:        0.16.17.0
2014-11-16 10:35:21,250 INFO     root: pycurl:            PycURL/7.19.5 libcurl/7.39.0 OpenSSL/1.0.1j zlib/1.2.8 libidn/1.29 libssh2/1.4.3
2014-11-16 10:35:21,924 TIMING   root: Database upgrade time: 1.138
2014-11-16 10:35:21,938 TIMING   root: after db upgrade: 2.6804
2014-11-16 10:35:21,942 INFO     root: Spawning global feed dtv:manualFeed
2014-11-16 10:35:22,002 INFO     root: Spawning global feed dtv:search
2014-11-16 10:35:22,126 INFO     root: Spawning global feed dtv:searchDownloads
2014-11-16 10:35:22,187 INFO     root: Spawning global feed dtv:directoryfeed
2014-11-16 10:35:22,263 INFO     root: Watching directory /home/user1/Videos/Miro with class <class 'miro.frontends.widgets.gtk.gtkdirectorywatch.GTKDirectoryWatcher'>
2014-11-16 10:35:22,350 INFO     root: setup tabs...
2014-11-16 10:35:22,360 INFO     root: Creating site tab order
2014-11-16 10:35:22,387 INFO     root: Creating channel tab order
2014-11-16 10:35:22,410 INFO     root: Creating playlist tab order
2014-11-16 10:35:22,444 INFO     root: setup theme...
2014-11-16 10:35:22,482 INFO     root: Spawning Miro Guide...
2014-11-16 10:35:23,395 INFO     root: Checking movies directory '/home/user1/Videos/Miro/'...
2014-11-16 10:35:23,413 TIMING   root: sending StartupSuccess(): 1.4762
2014-11-16 10:35:23,462 INFO     root: Adding default feeds
2014-11-16 10:35:23,476 INFO     root: adding feed (u'http://feeds.feedburner.com/tedtalks_video', False)
2014-11-16 10:35:23,987 INFO     root: adding feed (u'http://revision3.com/lifehacker/feed/MP4-hd30', False)
2014-11-16 10:35:24,523 INFO     root: adding feed (u'http://feeds.thisamericanlife.org/talpodcast', False)
2014-11-16 10:35:24,851 INFO     root: adding feed (u'http://feeds.themoth.org/themothpodcast', False)
2014-11-16 10:35:27,248 TIMING   root: idle (_install_default_feeds() (using as_urgent)) too slow (3.782 secs)

[snip]
Comment 11 Christian Müller 2014-11-16 10:49:20 CET
(In reply to Florian Hubold from comment #10)
> Please show the output of 
> rpm -qa | grep gst | sort

gstreamer0.10-cdparanoia-0.10.36-9.mga5
gstreamer0.10-ffmpeg-0.10.13-19.mga5
gstreamer0.10-gnomevfs-0.10.36-9.mga5
gstreamer0.10-plugins-base-0.10.36-9.mga5
gstreamer0.10-plugins-good-0.10.31-9.mga5
gstreamer0.10-plugins-ugly-0.10.19-14.mga5.tainted
gstreamer0.10-pulse-0.10.31-9.mga5
gstreamer0.10-python-0.10.22-8.mga5
gstreamer0.10-tools-0.10.36-11.mga5
gstreamer1.0-a52dec-1.4.3-2.mga5.tainted
gstreamer1.0-cdparanoia-1.4.3-2.mga5
gstreamer1.0-flac-1.4.3-2.mga5
gstreamer1.0-gstclutter-2.0.12-5.mga5
gstreamer1.0-libav-1.4.3-4.mga5
gstreamer1.0-plugins-bad-1.4.3-2.mga5.tainted
gstreamer1.0-plugins-base-1.4.3-2.mga5
gstreamer1.0-plugins-good-1.4.3-2.mga5
gstreamer1.0-plugins-ugly-1.4.3-2.mga5.tainted
gstreamer1.0-pulse-1.4.3-2.mga5
gstreamer1.0-soundtouch-1.4.3-2.mga5.tainted
gstreamer1.0-soup-1.4.3-2.mga5
gstreamer1.0-tools-1.4.3-2.mga5
gstreamer1.0-vp8-1.4.3-2.mga5
lib64clutter-gst2.0_0-2.0.12-5.mga5
lib64gstbadbase1.0_0-1.4.3-2.mga5.tainted
lib64gstbadvideo1.0_0-1.4.3-2.mga5.tainted
lib64gstbasecamerabinsrc1.0_0-1.4.3-2.mga5.tainted
lib64gstcodecparsers1.0_0-1.4.3-2.mga5.tainted
lib64gst-gir1.0-1.4.3-2.mga5
lib64gstgl1.0_0-1.4.3-2.mga5.tainted
lib64gstmpegts1.0_0-1.4.3-2.mga5.tainted
lib64gstphotography1.0_0-1.4.3-2.mga5.tainted
lib64gstreamer0.10_0-0.10.36-11.mga5
lib64gstreamer1.0_0-1.4.3-2.mga5
lib64gstreamer-plugins-base0.10_0-0.10.36-9.mga5
lib64gstreamer-plugins-base1.0_0-1.4.3-2.mga5
lib64gstreamer-plugins-base-gir1.0-1.4.3-2.mga5
lib64gsturidownloader1.0_0-1.4.3-2.mga5.tainted
lib64gstwayland1.0_0-1.4.3-2.mga5.tainted
libgstreamer0.10_0-0.10.36-11.mga5
libgstreamer-plugins-base0.10_0-0.10.36-9.mga5
packagekit-gstreamer-plugin-1.0.0-2.mga5

> rpm -qa | grep webkit | sort

lib64kdewebkit5-4.14.2-2.mga5
lib64proxy-webkit-0.4.11-10.mga5
lib64qt5webkit5-5.3.1-3.mga5
lib64qt5webkitwidgets5-5.3.1-3.mga5
lib64qtwebkit2.2_4-2.3.4-1.mga5
lib64smokeqtwebkit3-4.14.2-1.mga5
lib64webkit2gtk4.0_37-2.6.2-2.mga5
lib64webkit2gtk-gir4.0-2.6.2-2.mga5
lib64webkit-gir3.0-2.4.7-1.mga5
lib64webkitgtk1.0_0-2.4.7-1.mga5
lib64webkitgtk3.0_0-2.4.7-1.mga5
libqtwebkit2.2_4-2.3.4-1.mga5
python-qt4-webkit-4.11.2-2.mga5
python-webkitgtk-1.1.8-9.mga5
qtwebkit-qmlplugin-2.3.4-1.mga5
webkit1.0-2.4.7-1.mga5
webkit2-2.6.2-2.mga5
webkit-2.4.7-1.mga5
webkit3.0-2.4.7-1.mga5
webkit3-2.4.7-1.mga5

Hope it helps :-)
Comment 12 Christian Müller 2015-04-26 18:01:05 CEST
Still valid in Mageia 5b3...
Samuel Verschelde 2015-04-26 22:56:38 CEST

Whiteboard: (none) => MGA4TOO
Version: 4 => Cauldron

Comment 13 Olivier FAURAX 2015-09-17 00:42:54 CEST
Still valid in Mageia 5, freshly upgraded from 4.

$ miro
using /usr/bin/gdb
2015-09-17 00:40:58,896 INFO     root: Python version:    2.7.9 (default, Dec 14 2014, 10:12:16) 
[GCC 4.9.2]
2015-09-17 00:40:58,896 INFO     root: Gtk+ version:      (2, 24, 26)
2015-09-17 00:40:58,896 INFO     root: PyGObject version: (2, 28, 6)
2015-09-17 00:40:58,897 INFO     root: PyGtk version:     (2, 24, 0)
** Message: pygobject_register_sinkfunc is deprecated (GstObject)
/usr/lib64/python2.7/site-packages/gst-0.10/gst/__init__.py:193: Warning: cannot register existing type 'GstObject'
  from _gst import *
/usr/lib64/python2.7/site-packages/gst-0.10/gst/__init__.py:193: Warning: g_once_init_leave: assertion 'result != 0' failed
  from _gst import *
/usr/lib64/python2.7/site-packages/gst-0.10/gst/__init__.py:193: Warning: g_type_register_static: assertion 'parent_type > 0' failed
  from _gst import *
/usr/lib64/python2.7/site-packages/gst-0.10/gst/__init__.py:193: Warning: interface type 'GstImplementsInterface' or prerequisite type '<invalid>' invalid
  from _gst import *
Comment 14 Marja Van Waes 2015-10-12 16:21:19 CEST
(In reply to Olivier FAURAX from comment #13)
> Still valid in Mageia 5, freshly upgraded from 4.
> 
> $ miro
> using /usr/bin/gdb
> 2015-09-17 00:40:58,896 INFO     root: Python version:    2.7.9 (default,
> Dec 14 2014, 10:12:16) 
> [GCC 4.9.2]
> 2015-09-17 00:40:58,896 INFO     root: Gtk+ version:      (2, 24, 26)
> 2015-09-17 00:40:58,896 INFO     root: PyGObject version: (2, 28, 6)
> 2015-09-17 00:40:58,897 INFO     root: PyGtk version:     (2, 24, 0)
> ** Message: pygobject_register_sinkfunc is deprecated (GstObject)
> /usr/lib64/python2.7/site-packages/gst-0.10/gst/__init__.py:193: Warning:
> cannot register existing type 'GstObject'
>   from _gst import *
> /usr/lib64/python2.7/site-packages/gst-0.10/gst/__init__.py:193: Warning:
> g_once_init_leave: assertion 'result != 0' failed
>   from _gst import *
> /usr/lib64/python2.7/site-packages/gst-0.10/gst/__init__.py:193: Warning:
> g_type_register_static: assertion 'parent_type > 0' failed
>   from _gst import *
> /usr/lib64/python2.7/site-packages/gst-0.10/gst/__init__.py:193: Warning:
> interface type 'GstImplementsInterface' or prerequisite type '<invalid>'
> invalid
>   from _gst import *

re-assigning to BugSquad, because "Nobody" maintains miro.

Also CC'ing tsome miro-committers

CC: (none) => fundawang, marja11, olav, rverschelde
Whiteboard: MGA4TOO => MGA5TOO
Assignee: mageia => bugsquad

Comment 15 Marja Van Waes 2015-10-12 16:22:25 CEST
s/ASSIGNED/NEW/ because assignee changed

Status: ASSIGNED => NEW

Comment 16 Olav Vitters 2015-12-16 10:38:34 CET
File a bug with Miro upstream to port it to GStreamer 1.x

CC: olav => (none)

Comment 17 Christian Müller 2016-01-03 16:40:37 CET
I did a default installation of mga5-64 as a vbox virtual machine and upgraded it to cauldron with plasma5-desktop, because I was curious, and noticed that miro works... till I installed task-gnome-minimal. After that it fails to start again.
Comment 18 Samuel Verschelde 2016-10-16 15:40:11 CEST
Assigning to all packagers collectively since miro has no registered maintainer.

Keywords: (none) => NEEDINFO
Assignee: bugsquad => pkg-bugs

Comment 19 David GEIGER 2016-10-16 16:52:27 CEST
*** Bug 14285 has been marked as a duplicate of this bug. ***

CC: (none) => bittwister2

Comment 20 David GEIGER 2016-10-16 16:58:14 CEST
I think this package should be now dropped as the project seems dead since latest version published 2013-04-08.

http://ftp.osuosl.org/pub/pculture.org/miro/src/

CC: (none) => geiger.david68210

Comment 21 David GEIGER 2016-11-13 14:33:25 CET
*** Bug 17152 has been marked as a duplicate of this bug. ***
Comment 22 David GEIGER 2016-11-13 17:04:00 CET
miro just removed from cauldron (mga6).
Comment 23 Hans Micheelsen 2017-11-28 00:05:01 CET
Shouldn't this bug be closed?

CC: (none) => micheelsen

Comment 24 Olivier FAURAX 2017-11-28 17:10:46 CET
Yes, Miro has been removed from cauldron, and development is dead.

Resolution: (none) => WONTFIX
Status: NEW => RESOLVED


Note You need to log in before you can comment on or make changes to this bug.