Bug 12059 - svnserve root directory is not /var/lib/svn/repositories/ by default
: svnserve root directory is not /var/lib/svn/repositories/ by default
Status: RESOLVED FIXED
Product: Mageia
Classification: Unclassified
Component: RPM Packages
: 3
: All Linux
: Normal Severity: normal
: ---
Assigned To: Mageia Bug Squad
:
:
:
: Triaged
: 12768
:
  Show dependency treegraph
 
Reported: 2013-12-20 10:43 CET by Yann Ciret
Modified: 2014-02-27 23:15 CET (History)
5 users (show)

See Also:
Source RPM: subversion-1.7.14-1.mga3.src.rpm
CVE:
Status comment:


Attachments

Description Yann Ciret 2013-12-20 10:43:21 CET
Description of problem:
After installing Mageia 3 with all updates, and restore my subversion repository in /var/lib/svn/repositories/ (from a Mageia 2 server), when I attempt to browse a repository from another computer, I have the message "Repository not found".

After investigation, the problem is in /usr/lib/systemd/system/svnserve.service file.
It contain this line to start the subversion server :
ExecStart=/usr/bin/svnserve --daemon --pid-file=/run/svnserve/svnserve.pid $OPTIONS

I need to change this line by to fix remote access (I add the --root option) :
ExecStart=/usr/bin/svnserve --daemon --pid-file=/run/svnserve/svnserve.pid --root=/var/lib/svn/repositories/ $OPTIONS


Reproducible: 

Steps to Reproduce:
Comment 1 David Walser 2013-12-20 20:26:24 CET
Our service file is missing an EnvironmentFile, like Fedora's has:
http://pkgs.fedoraproject.org/cgit/subversion.git/tree/svnserve.service?h=f19

The /etc/sysconfig/svnserve file is here (but we'd change it to say /var/lib/svn):
http://pkgs.fedoraproject.org/cgit/subversion.git/tree/svnserve.sysconf?h=f19
Comment 2 David Walser 2013-12-20 20:37:22 CET
Added in SVN (no pun intended :o).

This will be fixed in Cauldron soon, and in Mageia 3 the next time we update it.
Comment 3 David Walser 2013-12-22 06:55:22 CET
Fixed in Cauldron in subversion-1.8.5-2.mga4.
Comment 4 Yann Ciret 2013-12-23 23:13:15 CET
The fix put « -r=/var/lib/svn/ ».
Shouldn’t it be « -r=/var/lib/svn/repositories/ » ?
Comment 5 David Walser 2013-12-23 23:48:58 CET
(In reply to Yann Ciret from comment #4)
> The fix put « -r=/var/lib/svn/ ».
> Shouldn’t it be « -r=/var/lib/svn/repositories/ » ?

Perhaps.  I'll change it.
Comment 6 David Walser 2014-02-27 23:15:51 CET
Fixed in the subversion-1.7.14-1.1.mga3 update in Bug 12768.

Thanks for the report.

Note You need to log in before you can comment on or make changes to this bug.