Bug 11508 - java-1.7.0-openjdk new security issues fixed in IcedTea 2.4.3
: java-1.7.0-openjdk new security issues fixed in IcedTea 2.4.3
Status: RESOLVED FIXED
Product: Mageia
Classification: Unclassified
Component: Security
: 3
: i586 Linux
: Normal Severity: critical
: ---
Assigned To: QA Team
: Sec team
: http://lwn.net/Vulnerabilities/570812/
: MGA2TOO has_procedure mga2-32-ok mga2...
: validated_update
:
:
  Show dependency treegraph
 
Reported: 2013-10-22 09:16 CEST by Oden Eriksson
Modified: 2013-11-13 20:11 CET (History)
5 users (show)

See Also:
Source RPM: java-1.7.0-openjdk
CVE:


Attachments

Description Oden Eriksson 2013-10-22 09:16:28 CEST
Redhat pushed RHSA-2013-1447 2013-10-21 which fixes a lot of vulnerabilities in java-1.7.0-openjdk.

CVE-2013-5803 OpenJDK: insufficient checks of KDC replies (JGSS, 8014341)
CVE-2013-5772 OpenJDK: insufficient html escaping in jhat (jhat, 8011081)
CVE-2013-5797 OpenJDK: insufficient escaping of window title string (Javadoc, 8016675)
CVE-2013-5784 OpenJDK: insufficient InterfaceImplementor security checks (Scripting, 8017299)
CVE-2013-5790 OpenJDK: insufficient security checks (Beans, 8012071)
CVE-2013-5849 OpenJDK: insufficient DataFlavor security checks (AWT, 8012277)
CVE-2013-5800 OpenJDK: default keytab path information leak (JGSS, 8022931)
CVE-2013-5780 OpenJDK: key data leak via toString() methods (Libraries, 8011071)
CVE-2013-5840 OpenJDK: getDeclaringClass() information leak (Libraries, 8014349)
CVE-2013-5820 OpenJDK: insufficient security checks (JAXWS, 8017505)
CVE-2013-5851 OpenJDK: XML stream factory finder information leak (JAXP, 8013502)
CVE-2013-5778 OpenJDK: image conversion out of bounds read (2D, 8014102)
CVE-2013-5782 OpenJDK: Incorrect awt_getPixelByte/awt_getPixelShort/awt_setPixelByte/awt_setPixelShort image raster checks (2D, 8014093)
CVE-2013-5830 OpenJDK: checkPackageAccess missing security check (Libraries, 8017291)
CVE-2013-5809 OpenJDK: JPEGImageReader and JPEGImageWriter missing band size checks (2D, 8013510)
CVE-2013-5829 OpenJDK: Java2d Disposer security bypass (2D, 8017287)
CVE-2013-5814 OpenJDK: RMIConnection stub missing permission check (CORBA, 8011157)
CVE-2013-5817 OpenJDK: VersionHelper12 does not honor modifyThreadGroup restriction (JNDI, 8013739)
CVE-2013-5842 OpenJDK: ObjectInputStream/ObjectOutputStream missing checks (Libraries, 8014987)
CVE-2013-5850 OpenJDK: Missing CORBA security checks (Libraries, 8017196)
CVE-2013-5802 OpenJDK: javax.xml.transform.TransformerFactory does not properly honor XMLConstants.FEATURE_SECURE_PROCESSING (JAXP, 8012425)
CVE-2013-5804 OpenJDK: javac does not ignore certain ignorable characters (Javadoc, 8016653)
CVE-2013-3829 OpenJDK: java.util.TimeZone does not restrict setting of default time zone (Libraries, 8001029)
CVE-2013-5783 OpenJDK: JTable not properly performing certain access checks (Swing, 8013744)
CVE-2013-5825 OpenJDK: XML parsing Denial of Service (JAXP, 8014530)
CVE-2013-5823 OpenJDK: com.sun.org.apache.xml.internal.security.utils.UnsyncByteArrayOutputStream Denial of Service (Security, 8021290)
CVE-2013-5774 OpenJDK: Inet6Address class IPv6 address processing errors (Libraries, 8015743)
CVE-2013-4002 OpenJDK: XML parsing Denial of Service (JAXP, 8017298)
CVE-2013-5838 OpenJDK: Vulnerability in Libraries component (Libraries, 7023639)



Reproducible: 

Steps to Reproduce:
Comment 1 David Walser 2013-10-22 19:43:29 CEST
Here are links to said advisories.

RHEL5: https://rhn.redhat.com/errata/RHSA-2013-1447.html
RHEL6: https://rhn.redhat.com/errata/RHSA-2013-1451.html

They fixed it by updating to IcedTea 2.4.3.  I'm not sure why the package build ID is the previous 45 instead of the current 60 that's in rawhide (and Cauldron).
Comment 3 Oden Eriksson 2013-10-31 12:31:35 CET
I backported the cauldron java-1.7.0-openjdk for mga3, but there seems to be a problem somehow with icedtea-web, at least when testing at:

http://www.java.com/en/download/installed.jsp
Comment 4 David Walser 2013-11-07 21:09:00 CET
Oden, that Java plugin test page doesn't seem to work for me even with the current version from updates.  Maybe you just need to try a different test page.  At least with the updates version, this page works for me (I haven't tried the updates_testing version):
http://www.javatester.org/version.html
Comment 5 David Walser 2013-11-08 18:25:30 CET
Updated packages uploaded for Mageia 2 and Mageia 3.

Advisory:
========================

Updated java-1.7.0-openjdk packages fix security vulnerabilities:

Multiple input checking flaws were found in the 2D component native image
parsing code. A specially crafted image file could trigger a Java Virtual
Machine memory corruption and, possibly, lead to arbitrary code execution
with the privileges of the user running the Java Virtual Machine
(CVE-2013-5782).

The class loader did not properly check the package access for non-public
proxy classes. A remote attacker could possibly use this flaw to execute
arbitrary code with the privileges of the user running the Java Virtual
Machine (CVE-2013-5830).

Multiple improper permission check issues were discovered in the 2D, CORBA,
JNDI, and Libraries components in OpenJDK. An untrusted Java application or
applet could use these flaws to bypass Java sandbox restrictions
(CVE-2013-5829, CVE-2013-5814, CVE-2013-5817, CVE-2013-5842, CVE-2013-5850,
CVE-2013-5838).

Multiple input checking flaws were discovered in the JPEG image reading and
writing code in the 2D component. An untrusted Java application or applet
could use these flaws to corrupt the Java Virtual Machine memory and bypass
Java sandbox restrictions (CVE-2013-5809).

The FEATURE_SECURE_PROCESSING setting was not properly honored by the
javax.xml.transform package transformers. A remote attacker could use this
flaw to supply a crafted XML that would be processed without the intended
security restrictions (CVE-2013-5802).

Multiple errors were discovered in the way the JAXP and Security components
processes XML inputs. A remote attacker could create a crafted XML that
would cause a Java application to use an excessive amount of CPU and memory
when processed (CVE-2013-5825, CVE-2013-4002, CVE-2013-5823).

Multiple improper permission check issues were discovered in the Libraries,
Swing, JAX-WS, JAXP, JGSS, AWT, Beans, and Scripting components in OpenJDK.
An untrusted Java application or applet could use these flaws to bypass
certain Java sandbox restrictions (CVE-2013-3829, CVE-2013-5840,
CVE-2013-5774, CVE-2013-5783, CVE-2013-5820, CVE-2013-5851, CVE-2013-5800,
CVE-2013-5849, CVE-2013-5790, CVE-2013-5784).

It was discovered that the 2D component image library did not properly
check bounds when performing image conversions. An untrusted Java
application or applet could use this flaw to disclose portions of the Java
Virtual Machine memory (CVE-2013-5778).

Multiple input sanitization flaws were discovered in javadoc. When javadoc
documentation was generated from an untrusted Java source code and hosted
on a domain not controlled by the code author, these issues could make it
easier to perform cross-site scripting attacks (CVE-2013-5804,
CVE-2013-5797).

Various OpenJDK classes that represent cryptographic keys could leak
private key information by including sensitive data in strings returned by
toString() methods. These flaws could possibly lead to an unexpected
exposure of sensitive key data (CVE-2013-5780).

The Java Heap Analysis Tool (jhat) failed to properly escape all data added
into the HTML pages it generated. Crafted content in the memory of a Java
program analyzed using jhat could possibly be used to conduct cross-site
scripting attacks (CVE-2013-5772).

The Kerberos implementation in OpenJDK did not properly parse KDC
responses. A malformed packet could cause a Java application using JGSS to
exit (CVE-2013-5803).

This updates IcedTea to version 2.4.3, which fixes these issues, as well as
several others.

References:
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2013-3829
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2013-4002
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2013-5772
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2013-5774
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2013-5778
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2013-5780
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2013-5782
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2013-5783
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2013-5784
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2013-5790
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2013-5797
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2013-5800
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2013-5802
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2013-5803
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2013-5804
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2013-5809
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2013-5814
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2013-5817
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2013-5820
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2013-5823
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2013-5825
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2013-5829
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2013-5830
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2013-5838
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2013-5840
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2013-5842
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2013-5849
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2013-5850
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2013-5851
http://blog.fuseyism.com/index.php/2013/10/23/security-icedtea-2-4-3-released/
http://www.oracle.com/technetwork/topics/security/cpuoct2013-1899837.html
https://rhn.redhat.com/errata/RHSA-2013-1451.html
========================

Updated packages in core/updates_testing:
========================
java-1.7.0-openjdk-1.7.0.60-2.4.3.1.mga2
java-1.7.0-openjdk-headless-1.7.0.60-2.4.3.1.mga2
java-1.7.0-openjdk-devel-1.7.0.60-2.4.3.1.mga2
java-1.7.0-openjdk-demo-1.7.0.60-2.4.3.1.mga2
java-1.7.0-openjdk-src-1.7.0.60-2.4.3.1.mga2
java-1.7.0-openjdk-javadoc-1.7.0.60-2.4.3.1.mga2
java-1.7.0-openjdk-accessibility-1.7.0.60-2.4.3.1.mga2
java-1.7.0-openjdk-1.7.0.60-2.4.3.1.mga3
java-1.7.0-openjdk-headless-1.7.0.60-2.4.3.1.mga3
java-1.7.0-openjdk-devel-1.7.0.60-2.4.3.1.mga3
java-1.7.0-openjdk-demo-1.7.0.60-2.4.3.1.mga3
java-1.7.0-openjdk-src-1.7.0.60-2.4.3.1.mga3
java-1.7.0-openjdk-javadoc-1.7.0.60-2.4.3.1.mga3
java-1.7.0-openjdk-accessibility-1.7.0.60-2.4.3.1.mga3

from SRPMS:
java-1.7.0-openjdk-1.7.0.60-2.4.3.1.mga2.src.rpm
java-1.7.0-openjdk-1.7.0.60-2.4.3.1.mga3.src.rpm
Comment 6 claire robinson 2013-11-11 18:21:02 CET
In mageia 3 this one can be tested with icedtea-web in a browser, not mageia 2 though which uses 1.6.0 for that.
Comment 7 claire robinson 2013-11-13 10:26:28 CET
Procedure for mga2: https://bugs.mageia.org/show_bug.cgi?id=9775#c4
Comment 8 claire robinson 2013-11-13 11:48:21 CET
Testing complete mga2 32

Confirmed java-1.7.0-openjdk is being used..

$ ll /usr/bin/java
lrwxrwxrwx 1 root root 22 May 21 11:31 /usr/bin/java -> /etc/alternatives/java*

$ ll /etc/alternatives/java
lrwxrwxrwx 1 root root 44 Nov 13 08:54 /etc/alternatives/java -> /usr/lib/jvm/jre-1.7.0-openjdk.i386/bin/java*

Remove old class files..
$ rm -f HelloWorldApp.class OddEven.class

Compile and test with the update java
$ javac HelloWorldApp.java
$ java HelloWorldApp
Hello World!

$ javac OddEven.java 
$ java OddEven

Returns odd or even as expected when a number is entered.
Comment 9 Bill Wilkinson 2013-11-13 15:02:59 CET
Tested mga3-64 with icedteaweb.

Javatester.org version responds with 
Java Version:1.7.0_45 from Oracle Corporation

ll /etc/alternatives/java returns:

lrwxrwxrwx 1 root root 73 Nov 13 08:28 /etc/alternatives/java -> /usr/lib/jvm/java-1.7.0-openjdk-1.7.0.60-2.4.3.1.mga3.x86_64/jre/bin/java*

but java --version returns
java version "1.7.0_45"
OpenJDK Runtime Environment (mageia-2.4.3.1.mga3-x86_64 u45-b15)
OpenJDK 64-Bit Server VM (build 24.45-b08, mixed mode)

HelloWorld and OddEven work as expected, though I'm getting an error on OddEven stating:
Fontconfig warning: "/etc/fonts/conf.d/50-user.conf", line 9: reading configurations from ~/.fonts.conf is deprecated.

It doesn't affect execution, though.

I checked with luigi12 on IRC and _45 is the correct build, so OKing
Comment 10 claire robinson 2013-11-13 15:22:01 CET
The checks were just to ensure java 1.7.0 was being used rather than 1.6.0 with update-alternatives. java --version is better :)
Comment 11 Bill Wilkinson 2013-11-13 17:02:21 CET
Interestingly, I didn't get the fontconfig warning on mga3-32. Maybe something I've only got installed on the laptop?

Anyway, tested mga3-32 as in comment 9, all OK.
Comment 12 claire robinson 2013-11-13 18:06:52 CET
That's unrelated Bill, nothing to worry about. You'll see it when running X apps from cli.

Testing complete mga2 64
Comment 13 claire robinson 2013-11-13 18:08:29 CET
Validating the update, 'advisory' whiteboard tag present :)

Could sysadmin please push from 2&3 core/updates_testing to updates

Thanks!
Comment 14 Thomas Backlund 2013-11-13 20:11:01 CET
Update pushed:
http://advisories.mageia.org/MGASA-2013-0322.html

Note You need to log in before you can comment on or make changes to this bug.