Bug 11167 - simple-scan don't accept accented characters
Summary: simple-scan don't accept accented characters
Status: NEW
Alias: None
Product: Mageia
Classification: Unclassified
Component: RPM Packages (show other bugs)
Version: Cauldron
Hardware: All Linux
Priority: Normal normal
Target Milestone: ---
Assignee: David GEIGER
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-09-05 10:07 CEST by Denis Prost
Modified: 2020-01-12 15:02 CET (History)
7 users (show)

See Also:
Source RPM: simple-scan-3.6.0-3.mga3.i586.rpm
CVE:
Status comment:


Attachments
simple-scan -d output (27.31 KB, text/plain)
2013-09-06 20:42 CEST, Denis Prost
Details
simple-scan error dialog box (68.08 KB, image/png)
2013-12-24 10:36 CET, Denis Prost
Details

Description Denis Prost 2013-09-05 10:07:08 CEST
Description of problem:

after scanning a document, if I try to save it with accented characters in its filename, or if I try to create a folder that contains accented characters in its name, I get an error box saying "invalid filename".

Version-Release number of selected component (if applicable):

3.6.0-3.mga3 (but also happens with simple-scan 3.9.90-1.mga4 in cauldron)

How reproducible: everytime


Steps to Reproduce:
1. scan a document
2. try to save it as "document numérisé.jpg"
3. You'll get an error box "invalid filename"


Reproducible: 

Steps to Reproduce:
Comment 1 Manuel Hiebel 2013-09-06 18:47:15 CEST
what are the output if you run simple-scan in a teminal with "-d" as parameter ?
Comment 2 Denis Prost 2013-09-06 20:42:06 CEST
Here it is, from startup to quit, and between both, one scan with my webcam and attempt to save it as "document nuùmérisé.jpg"

CC: (none) => denis.prost

Comment 3 Denis Prost 2013-09-06 20:42:46 CEST
Created attachment 4336 [details]
simple-scan -d output
Manuel Hiebel 2013-09-09 19:28:20 CEST

Attachment 4336 mime type: application/octet-stream => text/plain

Comment 4 Manuel Hiebel 2013-09-09 19:29:20 CEST
no more ideas

Keywords: (none) => Triaged
Assignee: bugsquad => mageia

Comment 5 Damien Lallement 2013-09-19 17:34:27 CEST
Can you try with 3.9.91 from cauldron please?
Comment 6 Denis Prost 2013-09-19 18:24:24 CEST
sorry, I cannot succeed testing it :
when I tried to install simple-scan from cauldron, it claimed for a libcolord2 dependency, so I installed it also from cauldron and then could install simple-scan.
But now, when I try to run simple-scan, I get an error :
--------
simple-scan: /lib/libudev.so.1: version `LIBUDEV_196' not found (required by /lib/libcolordprivate.so.2)
--------
and trying to install libudev1 from cauldron fails :
---------
[root@localhost Téléchargements]# rpm -ivh libudev1-206-8.mga4.i586.rpm 
Preparing...                          ################################# [100%]
	file /usr/lib/libudev.so.1 from install of libudev1-206-8.mga4.i586 conflicts with file from package libudev1-195-22.mga3.i586
------------
Comment 7 Damien Lallement 2013-09-20 01:45:55 CEST
I can reproduce for now with 3.6.0 and 3.9.91.
Let me investigate more... :-)
Comment 8 Damien Lallement 2013-10-01 15:00:32 CEST
I meant, I can't reproduce... Oops.

Status: NEW => ASSIGNED

Comment 9 Denis Prost 2013-10-01 15:11:17 CEST
That's strange.
Is there anything I could do that could help debug it ?
Comment 10 Damien Lallement 2013-12-24 01:53:54 CET
I still can't reproduce. Can you give me more information on your Mageia installation if bug still available please?
Comment 11 Denis Prost 2013-12-24 08:34:15 CET
Sure, what kind of information do you need ?
Comment 12 Damien Lallement 2013-12-24 08:40:20 CET
- If it's still available on your computer.
- If your are using KDE or GNOME.
- If your système is in French or English or other.
- If you have only one locale installed on your computer or more.
- If you can make a screenshot of the popup about bad filename.

Thanks!
Comment 13 Denis Prost 2013-12-24 10:36:04 CET
Created attachment 4664 [details]
simple-scan error dialog box

simple-scan error dialog box when trying to save "document numérisé".jpg
Comment 14 Denis Prost 2013-12-24 10:37:50 CET
thank you Damien for taking care of that bug.

1) Yes, it is still available
2) I'm using XFCE with KDM login manager
3) My system is in french
4) I don't know how to check installed locales, I tried this :
----------
[denis@localhost ~]$ localectl
   System Locale: LANG=fr_FR.UTF-8
       VC Keymap: n/a
      X11 Layout: n/a
----------
And localedrake shows that the chosen language is french.
I guess there is a finer way to check locales, but I don't know how

5) attached above is the screenshot

Regards,

Denis
Comment 15 Marja Van Waes 2015-03-31 16:06:31 CEST
Mageia 3 changed to end-of-life (EOL) status 4 months ago.
http://blog.mageia.org/en/2014/11/26/lets-say-goodbye-to-mageia-3/ 

Mageia 3 is no longer maintained, which means that it will not receive any further security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of Mageia
please feel free to click on "Version" change it against that version of Mageia
and reopen this bug.

Thank you for reporting this bug and we are sorry it could not be fixed.

--
The Mageia Bugsquad

Resolution: (none) => OLD
Status: ASSIGNED => RESOLVED

Comment 16 Denis Prost 2015-03-31 21:08:33 CEST
The Problem still exists with mageia 5 beta 3

Version: 3 => Cauldron
Status: RESOLVED => REOPENED
Resolution: OLD => (none)

Sylvain ZUCCA 2015-08-09 14:36:57 CEST

CC: (none) => sylvainsjc

Comment 17 papoteur 2015-08-09 19:53:30 CEST
Hello,
The message comes from GtkFileChooser, not from SimpleScan.
Thus I suppose that other application could be affected.

CC: (none) => yves.brungard_mageia

Comment 18 Marja Van Waes 2015-10-12 17:07:59 CEST
(In reply to papoteur from comment #17)
> Hello,
> The message comes from GtkFileChooser, not from SimpleScan.
> Thus I suppose that other application could be affected.

reassigning to bugsquad, because simple-scan no longer has a maintainer.

also removing "Triaged" because of the above remark.

Before we try to find out what is going on: did anybody recently hit this bug in Mageia 5 and/or cauldron?

Assignee: mageia => bugsquad
Keywords: Triaged => NEEDINFO
CC: (none) => marja11

Comment 19 papoteur 2016-02-17 09:43:44 CET
Yes, I just hit this bug, although I used to use it without problems by now.
Comment 20 papoteur 2016-02-17 14:00:27 CET
I have reported the problem upstream.
https://bugs.launchpad.net/simple-scan/+bug/1546523
papoteur 2016-02-17 19:54:52 CET

Hardware: i586 => All
Assignee: bugsquad => geiger.david68210

Comment 21 papoteur 2016-05-27 10:58:59 CEST
Indication from upstream report:
The warning message comes from GTK+, not simple-scan. But I have other GTK application in which I can use "é" in file names.
Version : simple-scan-3.14.0-3.mga5
On Mageia 5.
lib64gtk+2.0_0-2.24.26

The log file contains only the final file name.
The warning box has no title and says exactly : "Nom de fichier non valide" or when launched with LANGUAGE=C prefix: "Invalid file name"

The message comes from gtk/gtkfilechooserdefault.c line 1037
https://git.gnome.org/browse/gtk+/tree/gtk/gtkfilechooserdefault.c?h=gtk-2-24#n1037
papoteur 2016-05-27 11:10:49 CEST

CC: (none) => hugo.pereira

Comment 22 papoteur 2016-05-27 11:42:02 CEST
Hello,
I have found a workaround.
I had a file ~/.config/gtkfilechooser.ini with this content:
[Filechooser Settings]
LocationMode=path-bar
ShowHidden=true
ShowSizeColumn=true
GeometryX=2394
GeometryY=170
GeometryWidth=972
GeometryHeight=720
SortColumn=name
SortOrder=ascending
StartupMode=recent

I don't know when or from where it came, and which setting induce the bad behaviour.
But by deleting it, the filechooser dialog box works fine now. \o/
Dimitrios Glentadakis 2016-06-05 08:38:08 CEST

CC: (none) => dglent

Comment 23 David GEIGER 2019-12-30 07:04:05 CET
Does this issue still happens on current Mageia 7?
Comment 24 Denis Prost 2019-12-30 07:30:36 CET
I'm sorry, I can't tell, I don't have a Mageia 7 install.

Regards,

Denis
Comment 25 Dimitrios Glentadakis 2019-12-30 07:57:44 CET
Present in Mageia 7, i have modified manually the translation of 'Scanned Documment.pdf' output to workaround this issue [Greek local]
Comment 26 David GEIGER 2019-12-30 11:59:33 CET
a patch was added by dtux in Cauldron who should fix this issue, so I added the same for mga7.

Please test the upcoming simple-scan-3.32.2.1-2.1.mga7 in Core/Updates_testing repo!
Comment 27 David GEIGER 2019-12-30 13:32:33 CET
Here on my mga7 for x86_64 I can confirm that now accented characters works now!

It properly display "Nom: Document numérisé.pdf"
Comment 28 papoteur 2020-01-02 15:34:27 CET
Hello,
Installed simple-scan-3.32.2.1-2.1.mga7
Launched simple-scan
Got a scan.
Clicked to save.
Suggested name is "Document numérisé.pdf".
Saved in ~/Documents
No error, however nothing is stored :/
Comment 29 papoteur 2020-01-02 15:38:03 CET
And if I select jpeg format, then I get "Invalid file name" for "Document numérisé.jpg"
Comment 30 papoteur 2020-01-02 21:26:36 CET
Added a bug report by Gnome https://gitlab.gnome.org/GNOME/simple-scan/issues/147
Comment 31 Frédéric "LpSolit" Buclin 2020-01-12 15:02:48 CET
Could the GTK2 vs GTK3 problem with the file chooser be due to a wrong dependency when building the RPM? This bug is really painful.

CC: (none) => LpSolit
Status: REOPENED => NEW
Keywords: NEEDINFO => (none)


Note You need to log in before you can comment on or make changes to this bug.