Bug 11003 - epson-inkjet-printer-escpr, Epson ESC/P-R printer/scanner drivers
Summary: epson-inkjet-printer-escpr, Epson ESC/P-R printer/scanner drivers
Status: NEW
Alias: None
Product: Mageia
Classification: Unclassified
Component: New RPM package request (show other bugs)
Version: Cauldron
Hardware: All Linux
Priority: Normal enhancement
Target Milestone: ---
Assignee: All Packagers
QA Contact:
URL: http://download.ebz.epson.net/dsc/sea...
Depends on:
Blocks: 18367
  Show dependency treegraph
Reported: 2013-08-14 22:53 CEST by Hook
Modified: 2017-01-10 01:29 CET (History)
6 users (show)

See Also:
Source RPM: epson-inkjet-printer-escpr
Status comment:


Description Hook 2013-08-14 22:53:41 CEST
This is a package request for the official Epson ESC/P-R printer drivers, wich are under the GPLv2+ license.

This package supports many Epson drivers and is considered stable in Fedora.

The SRPM link points out to Fedora's Spec file, not to a full SRPM.

P.S. The old ESC/P drivers were under a different license, that is correct. The ESC/P-R are under GPVv2.
more info: http://download.ebz.epson.net/la/linux/


Steps to Reproduce:
Hook 2013-08-14 23:40:43 CEST

URL: http://avasys.jp/english/linux_e/ => http://download.ebz.epson.net/dsc/search/01/search/?OSC=LX

Manuel Hiebel 2013-08-15 00:08:45 CEST

Source RPM: https://apps.fedoraproject.org/packages/epson-inkjet-printer-escpr/sources/ => 1.2.2-2.1lsb3.2.fc19

Comment 1 Hook 2013-09-22 16:37:53 CEST
The official Epson RPM works out of the box also in Magiea.

I just installed them and they work fine.
Comment 2 Kristoffer Grundström 2014-07-09 21:08:12 CEST
For me, it doesn't work on the WF-2530 model.

There are packages to install to get the FAX-feature and network-services working and for the printer to be found in cups.

Here's the page with needed official packages from Epson:


CC: (none) => kristoffer.grundstrom1983

Kristoffer Grundström 2014-07-09 21:08:35 CEST

Priority: Normal => High

Mike Crecelius 2015-03-29 18:53:12 CEST

CC: (none) => mike.crecelius
Summary: Add epson-inkjet-printer-escpr (the official and fully GPLv2) drivers => epson-inkjet-printer-escpr, Epson ESC/P-R printer drivers

Comment 3 Marja Van Waes 2016-03-14 10:15:55 CET
(In reply to Hook from comment #0)
> This is a package request for the official Epson ESC/P-R printer drivers,
> wich are under the GPLv2+ license.
> This package supports many Epson drivers and is considered stable in Fedora.
> The SRPM link points out to Fedora's Spec file, not to a full SRPM.

IINM, epson-inkjet-printer-escpr-1.5.2-2.1lsb3.2.fc24.src.rpm is the newest SRPM

> P.S. The old ESC/P drivers were under a different license, that is correct.
> The ESC/P-R are under GPVv2.
> more info: http://download.ebz.epson.net/la/linux/

Assigning to all packagers collectively

Priority: High => Normal
CC: (none) => marja11
Assignee: bugsquad => pkg-bugs
Source RPM: 1.2.2-2.1lsb3.2.fc19 => epson-inkjet-printer-escpr
Severity: normal => enhancement

Comment 4 Hook 2016-04-01 08:53:14 CEST
Can we please include it in Mageia 6, so Epson scanning will finally work?
Marja Van Waes 2016-05-05 14:47:48 CEST

Blocks: (none) => 18367

Comment 5 Kristoffer Grundström 2016-05-26 05:55:58 CEST
There's an even newer version out for this package in OpenSuse: http://rpm.pbone.net/index.php3/stat/26/dist/46/size/2909661/name/epson-inkjet-printer-escpr-1.6.1-31.3.src.rpm
Comment 6 Marja Van Waes 2016-08-10 19:41:08 CEST
On the 25th of July, Phillipem uploaded the following packages to 
Cauldron's core/updates_testing:




@ Anyone reading this:

* If this bug is valid for you in cauldron, then please test whether updating your system-config-printer packages to version 1.5.7-5.mga6 fixes the problem and report back in this bug report.

* If you do not have this bug in cauldron, but you do run cauldron, then please update those packages, too, and report in bug 18367 whether they work as expected.

CC: (none) => makowski.mageia

Comment 7 Renato Dali 2016-10-16 19:00:26 CEST
After installing Mga6sta1, I added all the usual repos, but didn't do a full update. Instead, I chose the hardware module and tried to add my printer (an Epson L805).

It was correctly found on my local network and when I clicked on next, it asked that I select the model or provide a ppd file. As I usual (for me), I got the ppd from another machine (on which I had installed the official driver by hand) and provided to the installer.

After a short while the following message was displayed (translated back from Portuguese, so please bear with me):

"Error in CUPS server
There has been an error during CUPS operation: Success"

Not sure if that is an error or not, but soon after another message appeared:

"Driver Missing

The "Epson-L805" printer requires the program "usr/lib/cups/filter/epson-escpr-wrapper", but it is not installed. Please install it before using the printer."

I guess that means the bug is valid.

As asked, I already reported in bug 18367 the success of installing the same printer by hand -- in essence, a) install downloaded Epson RPMs and b) add printer with MCC.

Next step: updating the system-config-printer* packages which requires an update of rpm and a reboot. To be continued after the jump... :-)

CC: (none) => mkare

Comment 8 Renato Dali 2016-10-16 19:33:45 CEST
Actually, the reboot was recommended because "glibc" was updated.

Prior to that, there was a message asking about printing a test page. I clicked "OK" or "yes" and it didn't get printed (the printer queue shows a stopped job because of a "printer configuration error"). As expected.

I then deleted the previously added printer, checked to see the updated versions of system-config-printer* -- now at 1.5.8 -- and tried to add the L805 again.

It was immediately found via DNS-SD (Zeroconf, I learned) and I opted to accept the suggestion.

After installation (without asking for a ppd), I tried to print a page and the job queue now shows the job with the message: "Processing - disconnected?".

New tentative done by providing the printer network address yielded the same "stopped (or idle) - printer configuration error" message.

My conclusions:
a) that the bug is valid and
b) AFAIU, Hook wants Mageia to provide the Epson official RPM driver packages.

While this would be nice, it represents added work for the distro maintainers and, what is worse, the drivers could be updated upstream rendering the versions in Mageia repos obsolete.

In my particular case, the drivers are graciously provided by Epson and thus without support. Printing in Linux with this printer is very simplistic -- I didn't find a place to change the resolution (though I suspect it can be done by editing the ppd).
Comment 9 Hook 2016-10-16 23:09:28 CEST
The big issue with not using the official drivers is not as much printing as scanning.

Iâve been on Mageia since 4 now, and I am still unable to use the scanner on my Epson XP-305 all-in-one (I have to either use a Mint or Windows box to scan).
Comment 10 Renato Dali 2016-10-17 00:10:16 CEST
Please see this link; is not about Mageia, but it's about your printer:


Usually on Linux one scans with sane/Xsane... I myself have a separate scanner not a multifunction.

Good luck!


1)Epson is known to refuse scanning without ink (I've read about it).
2)HP tried to complain about third-party inks.

Be sure you're giving money to them... or else...
Comment 11 Hook 2016-10-17 15:42:53 CEST
I am fully aware, that usually you scan with SANE and not CUPS, but the official GPL Epson driver bundle includes both.

(also I do have iscan installed, and still no luck on *Mageia* via WiFi. Works on other distros)

Summary: epson-inkjet-printer-escpr, Epson ESC/P-R printer drivers => epson-inkjet-printer-escpr, Epson ESC/P-R printer/scanner drivers

Comment 12 Nicolas Salguero 2016-10-17 16:07:08 CEST
(In reply to Hook from comment #11)
> (also I do have iscan installed, and still no luck on *Mageia* via WiFi.
> Works on other distros)

With my Epson XP-710, I was able to scan through WiFi using iscan but I needed to add a package named iscan-network-nt, for which there is no source code.


CC: (none) => nicolas.salguero

Comment 13 Renato Dali 2017-01-10 01:29:02 CET
An update from me:

First, sorry for a lot of confusions I made in my previous posts.

From a standard Mga6 netinstall, I found that there are two ways to install my Epson wi-fi printer:


Download and install the already mentioned Epson drivers. After that, it is only a matter of using Drakconf to install the printer, optionally shared in the local network.


After doing the step 1 above -- and making sure the printer is shared --, another possibility is to use the first computer as a printer driver (i.e. using CUPS). In this mode there is no need to install the Epson-provided drivers; this is important because these drivers require LSB -- which some distros offer (e.g. Mageia) while others don't (AFAIK, Ubuntu and derivatives).

In mode 2, it is very important to configure the personal firewall with Drakconf and allow incoming internet connections to CUPS.

It is shameful to admit, but I lost a lot of time because I had the strange notion that such firewall permissions would be automatically set when one chooses to have a _shared_ printer. I may misremember it, but didn't Mandriva/Mandrake work that way once? Is that insecure?

I don't know whether this answer Marja's question in comment #6, but everything is working for me.

Don't forget to make sure the first computer always get the same IP address -- this can be done in the wi-fi router, for example, usually in DHCP configuration.


I know it's the opposite of what I said before, but would bug 20037 play a role in Hook's problem? Would that somehow fix the present bug, too? (by not reclassifying his printer as a scanner, I mean).

Note You need to log in before you can comment on or make changes to this bug.