Bug 10669 - otrs missing a requires for perl-DBD-mysql and has non-functional cp in postinstall scriptlet
: otrs missing a requires for perl-DBD-mysql and has non-functional cp in posti...
Status: RESOLVED FIXED
Product: Mageia
Classification: Unclassified
Component: RPM Packages
: 3
: All Linux
: Normal Severity: normal
: ---
Assigned To: Daniel Lucio
:
:
: MGA2TOO
: Junior_job
: 12473
:
  Show dependency treegraph
 
Reported: 2013-07-01 00:42 CEST by Dave Hodgins
Modified: 2014-03-04 17:37 CET (History)
2 users (show)

See Also:
Source RPM: otrs-3.2.8-1.mga3.src.rpm
CVE:


Attachments

Description Dave Hodgins 2013-07-01 00:42:55 CEST
As per https://bugs.mageia.org/show_bug.cgi?id=10352#c10 and the following
comment, otrs has a cd and cp stmt, that doesn't do anything except create
an error message during installation.  Also, a requires for perl-DBD-mysql
should be added.


Reproducible: 

Steps to Reproduce:
Comment 1 Daniel Lucio 2013-08-26 21:01:27 CEST
3.2.9-1 is in update_testings, please give a try
Comment 2 David Walser 2013-08-26 22:32:51 CEST
otrs-3.2.9-1.mga3 was already pushed as an update in Bug 10927.

If you made an additional change to it, please add a subrel (of 1) to it.
Comment 3 David Walser 2013-09-05 18:08:08 CEST
You could update to otrs 3.2.10 and we can push that to fix this:
http://www.otrs.com/en/open-source/community-news/release-notes/release-notes-otrs-help-desk-3210/

If it fixes any security issues, that's not immediately obvious.
Comment 4 Samuel Verschelde 2014-01-28 09:39:52 CET
What about this bug report. Is there an update to handle to QA or not yet?
Comment 5 David Walser 2014-03-04 17:37:00 CET
Apparently fixed when we issued the next otrs update.

Daniel committed fixes for Mageia 3 and Cauldron:
http://svnweb.mageia.org/packages/updates/3/otrs/current/SPECS/otrs.spec?r1=464200&r2=471998
http://svnweb.mageia.org/packages/cauldron/otrs/current/SPECS/otrs.spec?r1=464199&r2=471997

Note You need to log in before you can comment on or make changes to this bug.