Bug 10657 - exo fails to open magnet links
Summary: exo fails to open magnet links
Alias: None
Product: Mageia
Classification: Unclassified
Component: RPM Packages (show other bugs)
Version: 3
Hardware: x86_64 Linux
Priority: Normal normal
Target Milestone: ---
Assignee: QA Team
QA Contact:
Whiteboard: has_procedure mga3-32-ok mga3-64-ok
Keywords: validated_update
Depends on:
Reported: 2013-06-29 18:50 CEST by Pavel Kreuzt
Modified: 2013-08-11 14:59 CEST (History)
5 users (show)

See Also:
Source RPM: exo-0.10.2-3.mga3
Status comment:


Description Pavel Kreuzt 2013-06-29 18:50:28 CEST
When trying to download a torrent from a magnet link in chromium-browser (which relays on xdg-open) it claims it "cannot detect URI scheme" of the magnet link. I tried to set it manually with:

$ xdg-mime default qBittorrent.desktop application/x-bittorrent x-scheme-handler/magnet

but it doesn't work either.

Version: xdg-utils-1.1.0-0.0git20121008.2mga3

How reproducible: Open chromium and browse to a torrent download page like http://thepiratebay.sx/ and try click on any magnet link.


Steps to Reproduce:
Comment 1 Derek Jennings 2013-06-29 21:33:26 CEST
Are you using xfce?


CC: (none) => derekjenn

Comment 2 Pavel Kreuzt 2013-06-30 19:09:39 CEST
Yes, I'm using XFCE, but I heard xdg-open was patched in other distros to keep it usable in XFCE
Comment 3 Jani Välimaa 2013-06-30 20:23:27 CEST
Could you test with new exo [1] from core/updates_testing? Synced one patch from cauldron's exo [2] which should fix this issue.

[1] exo-0.10.2-3.1.mga3
[2] http://svnweb.mageia.org/packages/updates/3/exo/current/SOURCES/exo-0.10.2-fix-uri-handling.patch?view=markup&pathrev=448608

CC: (none) => jani.valimaa

Comment 4 Pavel Kreuzt 2013-06-30 21:09:28 CEST
Tested, I don have a test system so I compiled and installed userland only for testing. The patch seems to work:

$ ./exo-open magnet:?xt=urn:btih:bd33b71fa679be359348a03b4b8e044a9753d00a&dn=We+Got+Married+E176+%28130629%29&tr=udp%3A%2F%2Ftracker.openbittorrent.com%3A80&tr=udp%3A%2F%2Ftracker.publicbt.com%3A80&tr=udp%3A%2F%2Ftracker.istole.it%3A6969&tr=udp%3A%2F%2Ftracker.ccc.de%3A80&tr=udp%3A%2F%2Fopen.demonii.com%3A1337
[2] 7551
[3] 7552
[4] 7553
[5] 7554
[6] 7555
[7] 7556
[1]   Output 1                exo-open magnet:?xt=urn:btih:bd33b71fa679be359348a03b4b8e044a9753d00a
[2]   Hecho                   ./exo-open magnet:?xt=urn:btih:bd33b71fa679be359348a03b4b8e044a9753d00a
[3]   Done                   dn=We+Got+Married+E176+%28130629%29
[4]   Done                   tr=udp%3A%2F%2Ftracker.openbittorrent.com%3A80
[5]   Done                   tr=udp%3A%2F%2Ftracker.publicbt.com%3A80
[6]-  Done                   tr=udp%3A%2F%2Ftracker.istole.it%3A6969
[7]+  Done                   tr=udp%3A%2F%2Ftracker.ccc.de%3A80
Jani Välimaa 2013-06-30 21:47:25 CEST

Summary: xdg-open fails to open magnet links => exo fails to open magnet links
Source RPM: xdg-utils-1.1.0-0.0git20121008.2mga3 => exo-0.10.2-3.mga3

Comment 5 Jani Välimaa 2013-07-01 18:00:54 CEST
A simple test case would be nice for QA team. So it can officially test this fix and we can then push this update to Core Release. :)
Comment 6 Manuel Hiebel 2013-07-03 11:14:35 CEST
comment 0 ?
Comment 7 Pavel Kreuzt 2013-07-03 18:46:03 CEST
Sorry, I don't have much experience with development, what do you mean "test case"? Isn't it enought with https://bugs.mageia.org/show_bug.cgi?id=10657#c4 ?
Comment 8 Jani Välimaa 2013-07-19 09:10:18 CEST
OK, test case is described in comment 0. Please test.

Assignee: bugsquad => qa-bugs

Comment 9 claire robinson 2013-07-22 13:45:39 CEST
According to madb there are libs with this update too, it's important to list the rpm's and srpms being updated please Jani.

Please see: https://wiki.mageia.org/en/Updates_policy#Maintainer_.28or_any_interested_packager.29
Comment 10 claire robinson 2013-07-22 13:47:01 CEST
*** Arch: i586 ***

RPMs from 'core-updates_testing'

*** Arch: x86_64 ***

RPMs from 'core-updates_testing'

SRPMs from 'core-updates_testing'
Comment 11 claire robinson 2013-07-22 14:28:59 CEST
Testing mga3 32

Opening a mageia magnet link in chromium found through thepiratebay (via a proxy as it's supposedly censored/blocked here - Shame on you uk.gov!) shows the error..

Unable to detect the URI-scheme of "magnet:?xt=..etc.

After installing the update..

Failed to open URI "magnet:?xt=urn:btih:98b91cec54ec82ae7cde4ef129f7fec3df6b2c8b&dn=Mageia+3+x86_64+DVD&tr=udp%3A%2F%2Ftracker.openbittorrent.com%3A80&tr=udp%3A%2F%2Ftracker.publicbt.com%3A80&tr=udp%3A%2F%2Ftracker.istole.it%3A6969&tr=udp%3A%2F%2Ftracker.ccc.de%3A80&tr=udp%3A%2F%2Fopen.demonii.com%3A1337".

The specified location is not supported.

Not sure if this means it's fixed and something unrelated isn't working or it's still broken.

Whiteboard: (none) => has_procedure

Comment 12 claire robinson 2013-07-22 14:35:12 CEST
$ exo-open magnet:?xt=urn:btih:98b91cec54ec82ae7cde4ef129f7fec3df6b2c8b&dn=Mageia+3+x86_64+DVD&tr=udp%3A%2F%2Ftracker.openbittorrent.com%3A80&tr=udp%3A%2F%2Ftracker.publicbt.com%3A80&tr=udp%3A%2F%2Ftracker.istole.it%3A6969&tr=udp%3A%2F%2Ftracker.ccc.de%3A80&tr=udp%3A%2F%2Fopen.demonii.com%3A1337
[1] 31798
[2] 31799
[3] 31800
[4] 31801
[5] 31802
[6] 31803
[2]   Done                    dn=Mageia+3+x86_64+DVD
[3]   Done                    tr=udp%3A%2F%2Ftracker.openbittorrent.com%3A80
[4]   Done                    tr=udp%3A%2F%2Ftracker.publicbt.com%3A80
[5]-  Done                    tr=udp%3A%2F%2Ftracker.istole.it%3A6969
[6]+  Done                    tr=udp%3A%2F%2Ftracker.ccc.de%3A80
claire robinson 2013-07-22 15:30:17 CEST

Whiteboard: has_procedure => has_procedure feedback

Comment 13 claire robinson 2013-07-29 16:20:38 CEST
Jani, could you see comment 11 please. Thanks.
Comment 14 Jani Välimaa 2013-07-29 16:32:56 CEST
(In reply to claire robinson from comment #13)
> Jani, could you see comment 11 please. Thanks.

Can't test currently by myself as my mga3 box's power supply died. Did you install qbittorrent and use xdg-mime cmd from comment 0 before trying to dl magnet link?
Comment 15 claire robinson 2013-07-29 16:35:48 CEST
hrm, no, but i do have other torrent things installed. 
I'll do so and re-test to make sure.

IIRC it gave the same error with exo-open in comment 12 too.
Comment 16 claire robinson 2013-07-29 16:53:12 CEST
Yep, confirmed. With either transmission or qbittorrent installed it works fine.

I should have checked that really, sorry for the delay caused.

Testing complete mga3 32

Whiteboard: has_procedure feedback => has_procedure mga3-32-ok

Comment 17 Dave Hodgins 2013-08-11 07:03:34 CEST
Advisory 10657.adv uploaded to svn. Testing Mageia 3 x86_64 shortly.

CC: (none) => davidwhodgins

Comment 18 Dave Hodgins 2013-08-11 07:08:50 CEST
Testing complete on Mageia 3 x86_64.

Could someone from the sysadmin team push 10657.adv to updates.

Keywords: (none) => validated_update
Whiteboard: has_procedure mga3-32-ok => has_procedure mga3-32-ok mga3-64-ok
CC: (none) => sysadmin-bugs

Comment 19 Thomas Backlund 2013-08-11 14:59:46 CEST
Update pushed:

CC: (none) => tmb
Resolution: (none) => FIXED

Note You need to log in before you can comment on or make changes to this bug.