Bug 10480 - Update amarok to the version 2.7.1
Summary: Update amarok to the version 2.7.1
Alias: None
Product: Mageia
Classification: Unclassified
Component: RPM Packages (show other bugs)
Version: 3
Hardware: All Linux
Priority: Normal critical
Target Milestone: ---
Assignee: QA Team
QA Contact:
URL: http://amarok.kde.org/en/releases/2.7.1
Whiteboard: mga3-64-ok mga3-32-ok
Keywords: Triaged, validated_update
Depends on: 10600
Blocks: 10341
  Show dependency treegraph
Reported: 2013-06-10 20:52 CEST by Olivier Delaune
Modified: 2013-09-03 21:34 CEST (History)
5 users (show)

See Also:
Source RPM: amarok-2.7.0-1.mga3
Status comment:

Screenshot of amarok showing popup saying to check internet connection. (115.09 KB, image/png)
2013-09-03 03:31 CEST, Dave Hodgins

Description Olivier Delaune 2013-06-10 20:52:02 CEST
Hello, amarok 2.7.0 crashes all the time when you are just playing music on your local collection (for example you can read http://www.mageialinux-online.org/forum/topic-15648+crash-permanents-d-amarok.php in French). Amarok developers are aware about that problem and they have released a corrective version (http://amarok.kde.org/en/releases/2.7.1)
Please, could you package this version?
Thanks in advance

PS: if you really need, I can provide you a complete crash report.


Steps to Reproduce:
Comment 1 Manuel Hiebel 2013-06-10 21:01:23 CEST
cf https://bugs.mageia.org/show_bug.cgi?id=10341#c3

Keywords: (none) => Triaged
Assignee: bugsquad => juan.baptiste

Juan Luis Baptiste 2013-06-12 07:45:07 CEST


Comment 2 Juan Luis Baptiste 2013-06-12 20:24:46 CEST
Ok, there's an updated package in core/updates_testing, please test and report back.
Juan Luis Baptiste 2013-06-12 20:26:15 CEST

Blocks: (none) => 10341

Comment 3 Olivier Delaune 2013-06-13 07:18:55 CEST
I installed the 2.7.1 version on two computers. On my laptop, everything looks like to work fine. However on my desktop, I got an error message. In french, it is written 

Amarok n'a pas trouvé de module de collection. Il est probable qu'Amarok soit installé sous le mauvais préfixe ; veuillez corriger votre installation en utilisant : 
$ cd /path/to/amarok/source-code/
$ su -c "make uninstall"
$ cmake -DCMAKE_INSTALL_PREFIX=`kde4-config --prefix` && su -c "make install"
$ kbuildsycoca4 --noincremental
$ amarok
De plus amples informations peuvent être trouvées dans le fichier README. Pour plus d'assistance, rejoignez-nous sur le canal #amarok de irc.freenode.net

If you do not understand French, it says that amarok cannot find the collection module and that is probable that Amarok is installed with a wrong prefix. Finally, it suggests to fix the installation. I did not get this message on my laptop.
Comment 4 Olivier Delaune 2013-06-13 11:15:55 CEST
In fact, I got the same error on my laptop. So the problem is the same on my both computers.
Comment 5 Olivier Delaune 2013-06-13 17:35:15 CEST
I found the message in English. It is:

Amarok could not find any collection plugins. It is possible that Amarok is installed under the wrong prefix, please fix your installation using:
$ cd /path/to/amarok/source-code/
$ su -c "make uninstall"
$ cmake -DCMAKE_INSTALL_PREFIX=`kde4-config --prefix` && su -c "make install"
$ kbuildsycoca4 --noincremental
$ amarok
Comment 6 Juan Luis Baptiste 2013-06-25 07:13:32 CEST
This last issue is because there's a full KDE update to 4.10.4 in core/updates_testing, so amarok was built against that version on the build system. 

You have two options:

1. Install the KDE update from core/updates_testing.
2. Wait for the official update and then install this amarok update.

I tested the first option and amarok starts successfully.
Comment 7 Olivier Delaune 2013-06-25 19:37:25 CEST
Indeed, I installed all the packages of KDE SC 4.10.4 and the problem has dissapeared.
In addition, this 2.7.1 version seems to fix the problems of crashes. Bug is solved for me on Mageia 3, 64-bits.
David Walser 2013-08-10 22:06:10 CEST

Depends on: (none) => 10600

Comment 8 Manuel Hiebel 2013-09-01 16:07:22 CEST
update pushed

Resolution: (none) => FIXED

Comment 9 David Walser 2013-09-01 20:41:16 CEST
Not yet, this has never been assigned to QA and wasn't pushed with the KDE update.

Now that KDE is pushed, this can be done.

Note to QA: this fixes some critical issues and has been stalled by the KDE update, so I would consider this high priority.

If there are any issues with it, it may need rebuilt against the KDE update.  IIRC, the packages in updates_testing were built when KDE 4.10.4 was in updates_testing.


This updates Amarok to verson 2.7.1, fixing several issues.

Updated packages in core/updates_testing:

from amarok-2.7.1-1.mga3.src.rpm

CC: (none) => juan.baptiste, luigiwalser
Hardware: x86_64 => All
Resolution: FIXED => (none)
Assignee: juan.baptiste => qa-bugs

Comment 10 Olivier Delaune 2013-09-02 21:28:52 CEST
Tested on Mageia 3 64-bits. The problem described here (crashes) has disappeared. It is good for me.
Comment 11 David Walser 2013-09-02 21:31:51 CEST
Thanks Oliver.  Now we need a test on i586.

Whiteboard: (none) => mga3-64-ok

Comment 12 Dave Hodgins 2013-09-03 03:31:29 CEST
Created attachment 4316 [details]
Screenshot of amarok showing popup saying to check internet connection.

Testing on Mageia 3 i586.

As shown in the attached screenshot, it's complaining that it can't
access "Free Music Charts", telling the user to check their internet

Can that be disabled?

When running in debug mode, there are some errors shown ...
amarok:                 [ERROR__] [MySqlStorage] "GREPME MySQLe query failed! (1146) Table 'amarok.magnatune_moods' doesn't exist on select count( mood ), mood from magnatune_moods GROUP BY mood;" 
amarok: [ERROR__] [MySqlStorage] "GREPME MySQLe query failed! (1146) Table 'amarok.jamendo_genre' doesn't exist on SELECT DISTINCT jamendo_genre.id, jamendo_genre.name  FROM  jamendo_genre WHERE 1  GROUP BY jamendo_genre.name;" 
amarok: [ERROR__] [MySqlStorage] "GREPME MySQLe query failed! (1146) Table 'amarok.magnatune_genre' doesn't exist on SELECT DISTINCT magnatune_genre.id, magnatune_genre.name  FROM  magnatune_genre WHERE 1  GROUP BY magnatune_genre.name;" 

Other then that, it seems to be working fine.

Can these issues be fixed or would you like the update validated?

CC: (none) => davidwhodgins

Comment 13 David Walser 2013-09-03 03:38:08 CEST
Like I said before, this fixes some critical issues and has been waiting *way* too long because of the KDE update.  You can disable the Jamendo and Magnatune plugins with Settings > Configure Amarok > Plugins.  IINM the Free Music Charts thing isn't a regression from 2.7.0 and can probably also be fixed through configuration.  Unless there's some major issue, let's please validate this.
Comment 14 David Walser 2013-09-03 03:51:40 CEST
(In reply to David Walser from comment #13)
> IINM the Free Music Charts thing isn't a regression from 2.7.0 and can probably
> also be fixed through configuration.

Just a followup on this, it's been there for 4.5 years and can be disabled also:
Settings > Configure Amarok > Scripts.
Comment 15 Dave Hodgins 2013-09-03 07:54:34 CEST
Advisory 10480.adv uploaded to svn. Validating the update.

Someone from the sysadmin team please push 10480.adv to updates.

Keywords: (none) => validated_update
Whiteboard: mga3-64-ok => mga3-64-ok mga3-32-ok
CC: (none) => sysadmin-bugs

Comment 16 Thomas Backlund 2013-09-03 21:34:59 CEST
Update pushed:

CC: (none) => tmb
Resolution: (none) => FIXED

Note You need to log in before you can comment on or make changes to this bug.