Bug 8838 - digikam cannot import from PTP cameras
Summary: digikam cannot import from PTP cameras
Alias: None
Product: Mageia
Classification: Unclassified
Component: RPM Packages (show other bugs)
Version: 4
Hardware: x86_64 Linux
Priority: High critical
Target Milestone: ---
Assignee: Nicolas Lécureuil
QA Contact:
Whiteboard: NEEDHELP
Depends on:
Reported: 2013-01-27 12:39 CET by José Jorge
Modified: 2015-10-25 12:10 CET (History)
3 users (show)

See Also:
Source RPM: digikam
Status comment:

digikam3.5 importation NOK from Canon G10 camera (422.51 KB, image/jpeg)
2014-02-10 16:41 CET, kalagani kalagani
digikam3.5 importation OK from SD card (311.83 KB, image/jpeg)
2014-02-10 17:17 CET, kalagani kalagani

Description José Jorge 2013-01-27 12:39:30 CET
From digikam log, when connecting a PTP camera it is added to the import list. When clicking on it nothing happens :

digikam(4316)/digikam (core): Failed to get information for the listed camera 
digikam(4316)/digikam (core): Failed to detect camera with GPhoto2 from Solid information 

Importing with gwenview works
Manuel Hiebel 2013-02-10 13:58:37 CET

Assignee: bugsquad => anaselli

Comment 1 Angelo Naselli 2013-02-10 14:47:33 CET
could you try with the last digikam?
Comment 2 José Jorge 2013-02-11 10:56:01 CET
I have found a workaround : adding manually a USB-PTP camera works, looks like the bug is only with automaticaly populated cameras
Angelo Naselli 2013-08-06 15:21:54 CEST

Whiteboard: (none) => NEEDHELP

Angelo Naselli 2014-01-05 10:24:05 CET

CC: (none) => anaselli
Assignee: anaselli => mageia

Comment 3 kalagani kalagani 2014-01-08 17:22:00 CET
With digikam-3.1.0-2.mga3 difference with José is digikam see my Canon G10 and his SD card at "Importation" but unfortunately with error in displaying, some pictures are in double or triple, or in different folders.
A topic is existing about that
with some log from the "echo run |gdb digikam" command

CC: (none) => kalagani

Comment 4 kalagani kalagani 2014-01-17 16:52:27 CET
using digikam from Cauldron mageia4, I have the same problem described previously
I found same photo with different date in twenty different folders!!!
So like digikam is using PTP protol across gphoto:
or MTP (maybe?)


Priority: Normal => High
Severity: normal => major

Comment 5 kalagani kalagani 2014-02-10 16:41:57 CET
Created attachment 4970 [details]
digikam3.5 importation NOK from Canon G10 camera

Snapshot taken on importation from my Canon PowerShot G10.
This camera is seen by digikam, see at the bottom rigth.

You can see all folders have same name=DCIM
The first folder embbeds only one picture date=07/08/2012
In the second folder, you retrieve this picture with date=08/09/2012
In the third folder, you retrieve this picture with date=10/09/2012

Same behavior with the first picture in the second folder, you retrieve it in first position in the third folder...
I retrieved this picture 26 times in 26 different folders!!!!

I shoote picture in mode JPG+RAW
My camera is set to create automaticly new folder each week.

rpm -qa |egrep -i 'digikam|gphoto|mtp' |sort

Note: this problem did not exist with digikam-1.9.0-1.1.mga1 on Mageia1
and occured with digikam-2.6.0-1.mga2
This problem is only a part belong other regressions summarized below in french
kalagani kalagani 2014-02-10 16:43:44 CET

Version: Cauldron => 4
Severity: major => critical

Comment 6 kalagani kalagani 2014-02-10 17:17:46 CET
Created attachment 4971 [details]
digikam3.5 importation OK from SD card

Now versus previoulsly attachment
snapshot in same condition but from SD card not in the camera but in a reader I have on my screen.

You can see now folders have different name=xxxCANON
The first folder embbeds always the only one picture with the rigth date=07/03/2012 now instead of 07/08/2012
And in the other folders, you do not retrieve this picture!

About the picture seen twice in the previously snapshot, you cannot see because her rigth date=24/12/2011 involving before the right referenced first picture date=07/03/2012...

So, it seems problems comes when digikam use protocol/process (ptp, mtp, other?) to import pictures from camera.
Comment 7 Olivier Delaune 2014-03-16 11:55:50 CET
Some similar problems are reported on bugs.kde.org, such as https://bugs.kde.org/show_bug.cgi?id=330062 or https://bugs.kde.org/show_bug.cgi?id=307599
If you know how to compile digikam from sources, you can try to test digikam 4.0 beta 3 (http://www.digikam.org/node/710). The main developer says that a lot of improvement have been done about ptp/mtp support in this version.

So, you can test it to see if your problem is solved on this beta version. If not, I suggest you to open a bug report on bugs.kde.org; the digikam developer is very active.

CC: (none) => olivier.delaune

Comment 8 kalagani kalagani 2014-11-25 18:33:44 CET
I made (in March like you suggest) 4.0 beta compilation with success on my Cauldron4 PC, but same bad result, several same picture seen across my Canon G10 on USB link.
But today stable 4.0 compilations successful also and pb seems to have disappeared.
Verification on my Cauldron4 PC:
3.14.18-desktop-3.mga4 with KDE 4.11.4-1
and also on a HPxw9400 workstation with Mageia4: 
3.14.24-server-1.mga4 and KDE 4.12.5-1

Maybe, this stable 4.0 could be put in the core update repository!
Comment 9 Olivier Delaune 2014-11-25 19:27:35 CET
Since the release of the 4.0 version, a lot of new versions were released. Few days ago, the 4.5.0 version was released. Could you try it and see if your problem is still solved. If so, I am not aware of the update policies, but we could imagine that this new version of digikam be proposed in Testing. What are you thinking Nicolas?
Comment 10 kalagani kalagani 2014-11-25 22:23:45 CET
I saw the other new stable releases, but on Mageia4, compilation do not success because current version for some package do not meet the required version!

digikam-4.5.0 and 4.4.0
-- Could NOT find Exiv2: Found unsuitable version "0.23.0", but required is at least "0.24" (found /usr/lib64/libexiv2.so)
digikam-4.3.0 and 4.2.0 et 4.1.0
-- OpenCV: Found version (required: 2.4.9)

Only the 4.0.0 meets required version!
Comment 11 Olivier Delaune 2014-11-25 22:26:37 CET
Ok. In that case, it could be a fair option to upgrade digiKam to the 4.0 version. The other solution is to patch the current version of digiKam with the code that fixes your problem. I think the first option is the easiest.
Comment 12 Samuel Verschelde 2015-09-21 13:18:10 CEST
Mageia 4 changed to end-of-life (EOL) status on 2015-09-19. It is is no longer 
maintained, which means that it will not receive any further security or bug 
fix updates.

Package Maintainer: If you wish for this bug to remain open because you plan to 
fix it in a currently maintained version, simply change the 'version' to a later 
Mageia version.

Bug Reporter: Thank you for reporting this issue and we are sorry that we weren't 
able to fix it before Mageia 4's end of life. If you are able to reproduce it 
against a later version of Mageia, you are encouraged to click on "Version" and 
change it against that version of Mageia. If it's valid in several versions, 
select the highest and add MGAxTOO in whiteboard for each other valid release.
Example: it's valid in cauldron and Mageia 5, set to cauldron and add MGA5TOO.

Although we aim to fix as many bugs as possible during every release's lifetime, 
sometimes those efforts are overtaken by events. Often a more recent Mageia 
release includes newer upstream software that fixes bugs or makes them obsolete.

If you would like to help fixing bugs in the future, don't hesitate to join the
packager team via our mentoring program [1] or join the teams that fit you 
most [2].

[1] https://wiki.mageia.org/en/Becoming_a_Mageia_Packager
[2] http://www.mageia.org/contribute/
Comment 13 José Jorge 2015-10-25 12:10:44 CET
MGA5 has a Digikam that works

Resolution: (none) => OLD

Note You need to log in before you can comment on or make changes to this bug.