Bug 7979 - Wrong call to glib in pidgin-encryption-3.1-1 prevents compilation of the packet
: Wrong call to glib in pidgin-encryption-3.1-1 prevents compilation of the packet
Status: RESOLVED FIXED
Product: Mageia
Classification: Unclassified
Component: RPM Packages
: Cauldron
: x86_64 Linux
: Normal Severity: normal
: ---
Assigned To: Shlomi Fish
:
:
:
:
:
:
  Show dependency treegraph
 
Reported: 2012-11-04 21:47 CET by Maat
Modified: 2012-11-05 23:17 CET (History)
0 users

See Also:
Source RPM: pidgin-encryption-3.1-1.mga2.src.rpm
CVE:
Status comment:


Attachments
patched srpm to illustrate the problem (593.81 KB, application/octet-stream)
2012-11-04 21:49 CET, Maat
Details

Description Maat 2012-11-04 21:47:13 CET
Description of problem:

pidgin-encryption dos not compile on cauldron

Version-Release number of selected component (if applicable):

pidgin-encryption-3.1-1.mga2.src.rpm

How reproducible:

Always

Steps to Reproduce:
1. install pidgin-encryption-3.1-1.mga2.src.rpm
2. try to compile with rpmbuild -ba
3. See the error

(thanks wally_ for helping me or irc)
Comment 1 Maat 2012-11-04 21:49:59 CET
Created attachment 3040 [details]
patched srpm to illustrate the problem

The attached srpm is likely to be non compilant with mageia stric policies but at least it will point precisely where the problem is (see new_glib.patch inside SOURCES)
Comment 2 Shlomi Fish 2012-11-05 23:01:06 CET
Thanks!

(In reply to comment #1)
> Created attachment 3040 [details]
> patched srpm to illustrate the problem
> 
> The attached srpm is likely to be non compilant with mageia stric policies but
> at least it will point precisely where the problem is (see new_glib.patch
> inside SOURCES)

Your patch was applied in pidgin-encryption-3.1-2mga3, which was just built by the build system, so I'm closing this bug. Maybe this bug should also be reported upstream (and the patch provided).
Comment 3 Manuel Hiebel 2012-11-05 23:17:11 CET
>so I'm closing this bug.
really :)

Note You need to log in before you can comment on or make changes to this bug.