Bug 7759 - emacs info viewer doesn't support xz compressed info files
: emacs info viewer doesn't support xz compressed info files
Status: RESOLVED FIXED
Product: Mageia
Classification: Unclassified
Component: RPM Packages
: 2
: All Linux
: Normal Severity: normal
: ---
Assigned To: QA Team
:
:
: MGA2-64-OK MGA2-32-OK has_procedure
: PATCH, validated_update
:
:
  Show dependency treegraph
 
Reported: 2012-10-10 12:38 CEST by Götz Waschk
Modified: 2012-10-29 20:11 CET (History)
4 users (show)

See Also:
Source RPM: emacs-23.3-8.1.mga2.src.rpm
CVE:
Status comment:


Attachments
add xz support to info mode (1.17 KB, patch)
2012-10-10 12:57 CEST, Götz Waschk
Details | Diff

Description Götz Waschk 2012-10-10 12:38:48 CEST
Try to load any info file in emacs that was compressed with xz, e.g.
open info mode in emacs and try to click on tar, you will get the message:
Info file tar does not exist

this works fine with info files compressed with lzma, e.g. sed.info.lzma.

The stand-alone info viewer supports both formats.
Comment 1 Götz Waschk 2012-10-10 12:57:33 CEST
Created attachment 2936 [details]
add xz support to info mode

It just needs a simple patch like the already included lzma support patch.
Comment 2 Thierry Vignaud 2012-10-17 13:42:23 CEST
Why don't you apply for a packager account and apply the patch yourself?
Comment 3 Thierry Vignaud 2012-10-17 13:59:20 CEST
A package is being submited to core/updates_testing.
Please test
Comment 4 Götz Waschk 2012-10-17 14:46:03 CEST
I have requested a packager account already, see https://bugs.mageia.org/show_bug.cgi?id=7605
Comment 5 Götz Waschk 2012-10-18 14:06:29 CEST
I can confirm that the package from updates/testing fixed the bug.
Comment 6 Manuel Hiebel 2012-10-26 23:37:27 CEST
if the package stay in testing it's useless 
https://wiki.mageia.org/en/Updates_policy


Suggested Advisory:
-------------
Updated emacs fix reading xz info pages.

https://bugs.mageia.org/show_bug.cgi?id=7759
-------------

SRPM: emacs-23.3-8.2.mga2.src.rpm

QA: procedure is in comment 0
ALL: feel free to complete the advisory
Comment 7 Manuel Hiebel 2012-10-26 23:39:02 CEST
oupsy

Suggested Advisory:
-------------
Updated emacs fix reading xz compressed files.

https://bugs.mageia.org/show_bug.cgi?id=7759
-------------
Comment 8 Olivier Delaune 2012-10-27 07:49:07 CEST
Testing complete on Mageia 2 64-bits. It works fine for me also.
Comment 9 Carolyn Rowse 2012-10-29 19:55:32 CET
Tested on Mga2 32-bit.  Bug reproduced, tried with several files including tar, bash, gawk and finding files and none worked.  After update, all opened fine.


Update validated.

See comment 6 for SRPM.
See comment 7 for advisory.

Could sysadmin please push from core/updates_testing to core/updates.

Thank you.


Carolyn
Comment 10 Thomas Backlund 2012-10-29 20:11:54 CET
Update pushed:
https://wiki.mageia.org/en/Support/Advisories/MGAA-2012-0213

Note You need to log in before you can comment on or make changes to this bug.