Bug 7292 - Loss of sound on laptop internal speakers
: Loss of sound on laptop internal speakers
Status: RESOLVED INVALID
Product: Mageia
Classification: Unclassified
Component: RPM Packages
: 2
: x86_64 Linux
: Normal Severity: major
: ---
Assigned To: Colin Guthrie
:
:
:
:
:
:
  Show dependency treegraph
 
Reported: 2012-09-02 10:27 CEST by Jeff Robins
Modified: 2013-01-23 07:45 CET (History)
2 users (show)

See Also:
Source RPM:
CVE:
Status comment:


Attachments
Output from alsa-info when sound is not wokring (18.18 KB, application/octet-stream)
2012-09-02 10:28 CEST, Jeff Robins
Details
pacmd info output when sound is working (21.21 KB, text/plain)
2012-09-02 10:30 CEST, Jeff Robins
Details
pacmd info output when sound is NOT working (16.40 KB, text/plain)
2012-09-02 10:31 CEST, Jeff Robins
Details
Output from alsa-info when sound IS wokring (18.74 KB, application/octet-stream)
2012-09-02 11:00 CEST, Jeff Robins
Details
Output from alsa-info after sound stops wokring while playing youtube video (18.73 KB, application/octet-stream)
2012-09-02 11:06 CEST, Jeff Robins
Details

Description Jeff Robins 2012-09-02 10:27:53 CEST
Description of problem:
After playing a few videos on youtube or after a hibernation, sound no longer comes out of the laptop's internal speakers.  The headphone jack still works.  I didn't have this problem under Mageia 1.

Version-Release number of selected component (if applicable):
2.0.0-1.mga2

How reproducible:
Always

Steps to Reproduce:
1. Play video on youtube, notice sound plays from laptop's internal speakers
2. Hibernate
3. Play video on youtube, notice sound does not plas from laptop's internal speakers
4. Plug in headphones and hear sound from the headphones
5. Remove headphones and sound still won't play from internal speakers
Comment 1 Jeff Robins 2012-09-02 10:28:40 CEST
Created attachment 2723 [details]
Output from alsa-info when sound is not wokring
Comment 2 Jeff Robins 2012-09-02 10:30:35 CEST
Created attachment 2724 [details]
pacmd info output when sound is working
Comment 3 Jeff Robins 2012-09-02 10:31:18 CEST
Created attachment 2725 [details]
pacmd info output when sound is NOT working
Comment 4 Jeff Robins 2012-09-02 11:00:35 CEST
Created attachment 2726 [details]
Output from alsa-info when sound IS wokring
Comment 5 Jeff Robins 2012-09-02 11:06:47 CEST
Created attachment 2727 [details]
Output from alsa-info after sound stops wokring while playing youtube video
Comment 6 Jeff Robins 2012-09-02 11:13:08 CEST
After looking at the alsa-info outputs, I think it looks like my sound card is going into a sleep mode (D3).  Unfortunately, the headphones work in the sleep mode.

Also, I just realized that I placed some information and comments in bug report 6756.  I apologize for starting a new bug report, but in my defense I have a 1 month old newborn and no memory of posting earlier.  Sleep deprivation sucks.

Thank you,

Jeff
Comment 7 Jeff Robins 2012-09-02 12:52:25 CEST
I can get sound back by doing :

#rmmod -f snd_hda_intel
#modprobe -v snd_hda_intel

I have to force the removal because the module is in use.  I would rather prevent it from failing in the first place though.
Comment 8 Jeff Robins 2012-09-03 08:37:41 CEST
Also, the sound will eventually disappear again and require the module reload somewhere between 2 and 10 minutes.

I tried passing different options (power_save, model) to snd_hda_intel, but I can't keep the sound from failing.
Comment 9 Jeff Robins 2012-09-06 17:28:02 CEST
Additional bug reports from gentoo:

http://forums.gentoo.org/viewtopic-t-932038.html?sid=2bee6543c63f2342057c71bc876e7273

A message on the alsa user mailing list:

http://www.mail-archive.com/alsa-user@lists.sourceforge.net/msg28769.html

Any idea where I can go from here?

Thank you,

Jeff
Comment 10 Colin Guthrie 2012-09-17 10:19:01 CEST
Seems like a kernel error, but judging by your excellent research, nothing has been fixed there yet (of course something between 3.5.0->3.5.4 might have helped, but has yet to be confirmed).

Best approach is to contact the alsa-devel mailing list about it. It should be more effective than the alsa-user list. You can also try directly CC'ing people who have committed to the kernel driver for intel-hda, especially if they made power saving related changes.

Sorry I can't be more helpful, but you've pretty much done all the hard work already!
Comment 11 Jeff Robins 2012-10-18 20:50:40 CEST
I asked some questions on the mailing list and Takashi Iwai said that they had some complaints from Lenovo users, but also that they thought it was a problem due to over-heating and not divers.  

I don't think it's due to over-heating because I can re-enable the sound in less than a second after it turns off using hda_verb (I'm getting good at it and I have a script I can run) and it runs for another couple of minutes without a problem.  If it can cool off enough in 1 sec to run for another couple of minutes without reaching the same state, then it should never get hot enough to reach the over-temp state in the first place.  I'm not a physicist, but I do electronics design, many times for extended temperature operation, so I can  make that statement with fairly high confidence.  I plan to take the laptop into Best Buy shortly and have them clean it of dust and such so that I can double check though.

I also checked in Windows and it does happen there, but it didn't used to.  I know this because my wife and I watched multiple hours of movies on Netflix on Aug 5th without a problem.  

I asked a follow-up question about firmware for the codec and I am waiting for a response.
Comment 12 Colin Guthrie 2012-10-19 10:47:21 CEST
Thanks for the follow up info. It's interesting to see that Windows is now having a similar problem, but also curious that it didn't always. I wonder if the driver has different tolerances or something under windows for thermal cut off? Anyway Takashi is infinitely more informed than me in this arena so I think keeping on track with the upstream discussion is the best course of action :) Keep up the good work!
Comment 13 Jeff Robins 2013-01-23 07:45:42 CET
Update:
It was the motherboard.

I was trying to find time to collect some data for the ALSA guys, but the warranty on the laptop was almost up so I had to send it in to Best Buy while it was still covered.  They replaced the motherboard, battery and hard-drive and now everything works perfectly.  They said all three items failed their testing, so they just replaced them.

Closing as resolved, invalid.

Note You need to log in before you can comment on or make changes to this bug.