Bug 5810 - No RAM is shown in harddrake
Summary: No RAM is shown in harddrake
Status: RESOLVED FIXED
Alias: None
Product: Mageia
Classification: Unclassified
Component: RPM Packages (show other bugs)
Version: Cauldron
Hardware: All Linux
Priority: Low minor
Target Milestone: ---
Assignee: Thierry Vignaud
QA Contact:
URL:
Whiteboard: MGA4TOO MGA5TOO
Keywords:
: 10130 11908 (view as bug list)
Depends on:
Blocks:
 
Reported: 2012-05-09 20:35 CEST by Norbert Marchl
Modified: 2015-05-15 11:54 CEST (History)
6 users (show)

See Also:
Source RPM: harddrake-ui
CVE:
Status comment:


Attachments
dmidecode dump from my 4 cpu system (9.09 KB, text/plain)
2012-05-11 15:14 CEST, Bit Twister
Details
dmidecode dump from my 2 cpu system (14.99 KB, text/plain)
2012-05-11 15:15 CEST, Bit Twister
Details
dmidecode out put (10.45 KB, text/plain)
2012-05-20 15:54 CEST, John Bowden
Details
dmidecode -t 17 - RAM info output (2.40 KB, text/plain)
2015-01-17 08:36 CET, Martin Volf
Details
display "Memory Device" too (1.30 KB, patch)
2015-05-07 11:52 CEST, Thierry Vignaud
Details | Diff
enables to test with a file containing dmidecode output (707 bytes, patch)
2015-05-07 11:56 CEST, Thierry Vignaud
Details | Diff
mga5rc-harddrake2-memory-screenshot (85.03 KB, image/png)
2015-05-11 17:44 CEST, Martin Volf
Details

Description Norbert Marchl 2012-05-09 20:35:55 CEST
Description of problem: I know it isn't a real BUG, but can user make confuse.
I see only CPU Cache 1 + 2m but I can't see my RAM (1.5 GB)


Version-Release number of selected component (if applicable): Mageia 2 RC


How reproducible:


Steps to Reproduce:
1.
2.
3.
Norbert Marchl 2012-05-09 20:36:56 CEST

CC: (none) => norbert.marchl

Comment 1 Manuel Hiebel 2012-05-09 21:06:46 CEST
lspcidrake -v give what ?

Source RPM: (none) => drakxtools
Severity: normal => minor
Assignee: bugsquad => thierry.vignaud

Comment 2 Manuel Hiebel 2012-05-09 22:10:45 CEST
from the reporter in private:

>
Her the thext from Lspcidrake -v :

unknown         : ATI Technologies Inc|RV350 AS [Radeon 9550] (Secondary) [DISPLAY_OTHER] (vendor:1002 device:4173 subv:196d subd:1019)
Card:ATI Radeon X1950 and earlier: ATI Technologies Inc|RV350 AS [Radeon 9550] [DISPLAY_VGA] (vendor:1002 device:4153 subv:196d subd:1018)
shpchp          : nVidia Corporation|nForce2 AGP [BRIDGE_PCI] (vendor:10de device:01e8) (rev: c1)
sata_nv         : nVidia Corporation|nForce2 Serial ATA Controller [STORAGE_IDE] (vendor:10de device:008e subv:1849 subd:008e) (rev: a3)
pata_amd        : nVidia Corporation|MCP2A IDE [STORAGE_IDE] (vendor:10de device:0085 subv:1849 subd:0085) (rev: a3)
shpchp          : nVidia Corporation|MCP2A PCI Bridge [BRIDGE_PCI] (vendor:10de device:008b) (rev: a3)
snd_intel8x0    : nVidia Corporation|MCP2S AC'97 Audio Controller [MULTIMEDIA_AUDIO] (vendor:10de device:008a subv:1849 subd:9761) (rev: a1)
forcedeth       : nVidia Corporation|MCP2A Ethernet Controller [BRIDGE_OTHER] (vendor:10de device:008c subv:1849 subd:0900) (rev: a3)
ehci_hcd        : nVidia Corporation|MCP2A USB Controller [SERIAL_USB] (vendor:10de device:0088 subv:1849 subd:0088) (rev: a2)
ohci_hcd        : nVidia Corporation|MCP2A USB Controller [SERIAL_USB] (vendor:10de device:0087 subv:1849 subd:0087) (rev: a1)
ohci_hcd        : nVidia Corporation|MCP2A USB Controller [SERIAL_USB] (vendor:10de device:0087 subv:1849 subd:0087) (rev: a1)
i2c_nforce2     : nVidia Corporation|MCP2A SMBus [SERIAL_SMBUS] (vendor:10de device:0084 subv:1849 subd:0084) (rev: a1)
unknown         : nVidia Corporation|MCP2A ISA bridge [BRIDGE_ISA] (vendor:10de device:0080 subv:1849 subd:0080) (rev: a3)
unknown         : nVidia Corporation|nForce2 Memory Controller 5 [MEMORY_RAM] (vendor:10de device:01ef subv:1849 subd:01ef) (rev: c1)
unknown         : nVidia Corporation|nForce2 Memory Controller 2 [MEMORY_RAM] (vendor:10de device:01ec subv:1849 subd:01ec) (rev: c1)
unknown         : nVidia Corporation|nForce2 Memory Controller 3 [MEMORY_RAM] (vendor:10de device:01ed subv:1849 subd:01ed) (rev: c1)
unknown         : nVidia Corporation|nForce2 Memory Controller 4 [MEMORY_RAM] (vendor:10de device:01ee subv:1849 subd:01ee) (rev: c1)
unknown         : nVidia Corporation|nForce2 Memory Controller 1 [MEMORY_RAM] (vendor:10de device:01eb subv:1849 subd:01eb) (rev: c1)
unknown         : nVidia Corporation|nForce2 IGP2 [BRIDGE_HOST] (vendor:10de device:01e0 subv:1849 subd:01e0) (rev: c1)
hub             : Linux 3.3.4-desktop586-1.mga2 ohci_hcd|OHCI Host Controller [Hub|Unused|Full speed (or root) hub] (vendor:1d6b device:0001)
hub             : Linux 3.3.4-desktop586-1.mga2 ehci_hcd|EHCI Host Controller [Hub|Unused|Full speed (or root) hub] (vendor:1d6b device:0002)
hub             : Linux 3.3.4-desktop586-1.mga2 ohci_hcd|OHCI Host Controller [Hub|Unused|Full speed (or root) hub] (vendor:1d6b device:0001)

I hope  this helps. (sorry I don't tell this is KDE)
Comment 3 Bit Twister 2012-05-10 01:51:02 CEST
same problem with clean install of Mageia-2-rc-x86_64-DVD.iso + updates.
Only shows l1, l2, l3 cache.

snippet from hwinfo
  Memory Device: #19
    Location: "DIMM3"
    Bank: "BANK2"
    Manufacturer: "Micron"
    Serial: "C2861E29"
    Asset Tag: "AssetTagNum2"
    Part Number: "16JTF25664AZ-1G4F1"
    Memory Array: #15
    Form Factor: 0x09 (DIMM)
    Type: 0x18 (Other)
    Type Detail: 0x0080 (Synchronous)
    Data Width: 64 bits
    Size: 2 GB
    Speed: 1333 MHz
  Memory Device: #20
    Location: "DIMM4"
    Bank: "BANK3"
    Manufacturer: "Micron"
    Serial: "A6861E29"
    Asset Tag: "AssetTagNum3"
    Part Number: "16JTF25664AZ-1G4F1"
    Memory Array: #15
    Form Factor: 0x09 (DIMM)
    Type: 0x18 (Other)
    Type Detail: 0x0080 (Synchronous)
    Data Width: 64 bits
    Size: 2 GB
    Speed: 1333 MHz

Hardware: i586 => All
CC: (none) => junk_no_spam

Thierry Vignaud 2012-05-10 09:46:17 CEST

Priority: Normal => Low

Comment 4 Norbert Marchl 2012-05-11 10:22:57 CEST
(In reply to comment #3)
> same problem with clean install of Mageia-2-rc-x86_64-DVD.iso + updates.
> Only shows l1, l2, l3 cache.
> 
> snippet from hwinfo
>   Memory Device: #19
>     Location: "DIMM3"
>     Bank: "BANK2"
>     Manufacturer: "Micron"
>     Serial: "C2861E29"
>     Asset Tag: "AssetTagNum2"
>     Part Number: "16JTF25664AZ-1G4F1"
>     Memory Array: #15
>     Form Factor: 0x09 (DIMM)
>     Type: 0x18 (Other)
>     Type Detail: 0x0080 (Synchronous)
>     Data Width: 64 bits
>     Size: 2 GB
>     Speed: 1333 MHz
>   Memory Device: #20
>     Location: "DIMM4"
>     Bank: "BANK3"
>     Manufacturer: "Micron"
>     Serial: "A6861E29"
>     Asset Tag: "AssetTagNum3"
>     Part Number: "16JTF25664AZ-1G4F1"
>     Memory Array: #15
>     Form Factor: 0x09 (DIMM)
>     Type: 0x18 (Other)
>     Type Detail: 0x0080 (Synchronous)
>     Data Width: 64 bits
>     Size: 2 GB
>     Speed: 1333 MHz

Now I boot Mageia Live CD on my second machine. Here is all OK.

My first machine (without showing RAM) is a ASRock K7NF2-RAID mainbord.
My second machine (with showing showing RAM] is a ASUS P5PL2-E motherboard.

I hope this helps
Comment 5 Thierry Vignaud 2012-05-11 15:01:48 CEST
can you attach output of dmidecode?
eg the dmi.txt file resulting from running the "dmicode>dmi.txt" command

Severity: minor => enhancement
Keywords: (none) => NEEDINFO

Thierry Vignaud 2012-05-11 15:02:55 CEST

Summary: No RAM ist shown in Mageia-Controllcenter => No RAM ist shown in harddrake

Thierry Vignaud 2012-05-11 15:03:04 CEST

Summary: No RAM ist shown in harddrake => No RAM is shown in harddrake

Comment 6 Bit Twister 2012-05-11 15:14:56 CEST
Created attachment 2270 [details]
dmidecode dump from my 4 cpu system

Ram memory modules do show up on my old single 64 bit system.
Comment 7 Bit Twister 2012-05-11 15:15:51 CEST
Created attachment 2271 [details]
dmidecode dump from my 2 cpu system
Comment 8 Norbert Marchl 2012-05-11 16:36:00 CEST
(In reply to comment #5)
> can you attach output of dmidecode?
> eg the dmi.txt file resulting from running the "dmicode>dmi.txt" command

dmidecode from my 1 cpu system:

# dmidecode 2.11
SMBIOS 2.3 present.
7 structures occupying 417 bytes.
Table at 0x000FC190.

Handle 0x0000, DMI type 0, 20 bytes
BIOS Information
	Vendor: American Megatrends Inc.
	Version: P1.30
	Release Date: 07/31/2006
	Address: 0xF0000
	Runtime Size: 64 kB
	ROM Size: 512 kB
	Characteristics:
		PCI is supported
		BIOS is upgradeable
		BIOS shadowing is allowed
		Boot from CD is supported
		Selectable boot is supported
		BIOS ROM is socketed
		EDD is supported
		5.25"/1.2 MB floppy services are supported (int 13h)
		3.5"/720 kB floppy services are supported (int 13h)
		3.5"/2.88 MB floppy services are supported (int 13h)
		Print screen service is supported (int 5h)
		8042 keyboard services are supported (int 9h)
		Serial services are supported (int 14h)
		Printer services are supported (int 17h)
		CGA/mono video services are supported (int 10h)
		ACPI is supported
		USB legacy is supported
		AGP is supported
		LS-120 boot is supported
		ATAPI Zip drive boot is supported
		BIOS boot specification is supported

Handle 0x0001, DMI type 1, 25 bytes
System Information
	Manufacturer:         
	Product Name: K7NF2-RAID
	Version: 1.00
	Serial Number: 00000000
	UUID: 00020003-0004-0005-0006-000700080009
	Wake-up Type: Power Switch

Handle 0x0002, DMI type 2, 8 bytes
Base Board Information
	Manufacturer:         
	Product Name: K7NF2-RAID
	Version: 1.00
	Serial Number: 00000000

Handle 0x0003, DMI type 4, 35 bytes
Processor Information
	Socket Designation: CPU Socket
	Type: Central Processor
	Family: Athlon XP
	Manufacturer: AMD              
	ID: A0 06 00 00 FF FB 83 03
	Signature: Family 6, Model 10, Stepping 0
	Flags:
		FPU (Floating-point unit on-chip)
		VME (Virtual mode extension)
		DE (Debugging extension)
		PSE (Page size extension)
		TSC (Time stamp counter)
		MSR (Model specific registers)
		PAE (Physical address extension)
		MCE (Machine check exception)
		CX8 (CMPXCHG8 instruction supported)
		APIC (On-chip APIC hardware supported)
		SEP (Fast system call)
		MTRR (Memory type range registers)
		PGE (Page global enable)
		MCA (Machine check architecture)
		CMOV (Conditional move instruction supported)
		PAT (Page attribute table)
		PSE-36 (36-bit page size extension)
		MMX (MMX technology supported)
		FXSR (FXSAVE and FXSTOR instructions supported)
		SSE (Streaming SIMD extensions)
	Version: mobile AMD Athlon(tm) XP-M 2000+                    
	Voltage: 3.3 V 2.9 V
	External Clock: 100 MHz
	Max Speed: 1650 MHz
	Current Speed: 1650 MHz
	Status: Populated, Enabled
	Upgrade: Socket A (Socket 462)
	L1 Cache Handle: 0x0004
	L2 Cache Handle: 0x0005
	L3 Cache Handle: Not Provided
	Serial Number: To Be Filled By O.E.M.
	Asset Tag: To Be Filled By O.E.M.
	Part Number: To Be Filled By O.E.M.

Handle 0x0004, DMI type 7, 19 bytes
Cache Information
	Socket Designation: L1-Cache
	Configuration: Enabled, Not Socketed, Level 1
	Operational Mode: Varies With Memory Address
	Location: Internal
	Installed Size: 128 kB
	Maximum Size: 128 kB
	Supported SRAM Types:
		Pipeline Burst
	Installed SRAM Type: Pipeline Burst
	Speed: Unknown
	Error Correction Type: Single-bit ECC
	System Type: Data
	Associativity: 4-way Set-associative

Handle 0x0005, DMI type 7, 19 bytes
Cache Information
	Socket Designation: L2-Cache
	Configuration: Enabled, Not Socketed, Level 2
	Operational Mode: Varies With Memory Address
	Location: Internal
	Installed Size: 512 kB
	Maximum Size: 512 kB
	Supported SRAM Types:
		Pipeline Burst
	Installed SRAM Type: Pipeline Burst
	Speed: Unknown
	Error Correction Type: Single-bit ECC
	System Type: Unified
	Associativity: 4-way Set-associative

Handle 0x0006, DMI type 127, 4 bytes
End Of Table
Comment 9 John Bowden 2012-05-20 15:54:06 CEST
Created attachment 2349 [details]
dmidecode out put
Comment 10 John Bowden 2012-05-20 15:55:22 CEST
The 720d93a589120abc27a9ec80a54c04f4  Mageia-2-LiveCD-KDE4-Europe2-x86_64-CD.iso running in live mode shows the correct cache and dimm layout and amounts on my asrock 64bit single core board. It has a nvidia chipset. so does the installed version. I have included the dmidecode live cd test rc2.txt as an attachment.

CC: (none) => led43john

Comment 11 Marja Van Waes 2012-05-26 13:06:26 CEST
Hi,

This bug was filed against cauldron, but we do not have cauldron at the moment.

Please report whether this bug is still valid for Mageia 2.

Thanks :)

Cheers,
marja
Comment 12 Bit Twister 2012-05-26 16:27:35 CEST
(In reply to comment #11)


> Please report whether this bug is still valid for Mageia 2.

still valid on my clean Mageia 2 install.

CC: junk_no_spam => (none)
Keywords: NEEDINFO => (none)

Comment 13 Rohit Pathak 2014-03-26 07:28:43 CET
I am unable the see the RAM on harddrake2. I am using Mageia 4 on a HP Probook 430.

CC: (none) => xrohit

Comment 14 Martin Volf 2015-01-17 08:34:30 CET
The same issue on Mageia 4.1 (64bit), Mageia 5b2 (64bit).

---
# harddrake2
[root@localhost yullaw]# LC_ALL=C harddrake2
Subroutine Gtk3::main redefined at /usr/lib/perl5/vendor_perl/5.20.1/Gtk3.pm line 296.

(drakhardware:13788): Gtk-WARNING **: GtkImage 0x2d6be40 adjusted size vertical min 47 natural 47 must not decrease below min 48 natural 48

(drakhardware:13788): Gtk-WARNING **: GtkImage 0x2d6be40 attempted to adjust its size allocation from -12,1 805x54 to 0,0 793x55. adjust_size_allocation must keep allocation inside original bounds
Argument "bold" isn't numeric in subroutine entry at /usr/lib/perl5/vendor_perl/5.20.1/Gtk3.pm line 1122.
Argument "bold" isn't numeric in subroutine entry at /usr/lib/perl5/vendor_perl/5.20.1/Gtk3.pm line 1122.
Argument "bold" isn't numeric in subroutine entry at /usr/lib/perl5/vendor_perl/5.20.1/Gtk3.pm line 1122.
Argument "bold" isn't numeric in subroutine entry at /usr/lib/perl5/vendor_perl/5.20.1/Gtk3.pm line 1122.
Argument "bold" isn't numeric in subroutine entry at /usr/lib/perl5/vendor_perl/5.20.1/Gtk3.pm line 1122.
Argument "bold" isn't numeric in subroutine entry at /usr/lib/perl5/vendor_perl/5.20.1/Gtk3.pm line 1122.
Warning: skip "Type" field => "DIMM"

Warning: skip "string" field => "Socket Designation: DIMM1
Bank Connections: None
Current Speed: Unknown
Type: DIMM
Installed Size: 4096 MB (Single-bank Connection)
Enabled Size: 4096 MB (Single-bank Connection)
Error Status: OK
"

Warning: skip "Error Status" field => "OK"

modinfo: ERROR: Module  not found.

---
What is appeared in the window:
-------------------------------
Bank connections: âNone

Speed: âUnknown

Enabled Size: â4096 MB (Single-bank Connection)

Installed size: â4096 MB (Single-bank Connection)

Name: âDIMM1

Type: âMemory Module

---
# dmidecode -t 17  â attached output below

CC: (none) => yullaw

Comment 15 Martin Volf 2015-01-17 08:36:08 CET
Created attachment 5820 [details]
dmidecode -t 17 - RAM info output
Comment 16 Samuel Verschelde 2015-05-06 20:22:30 CEST
*** Bug 10130 has been marked as a duplicate of this bug. ***

CC: (none) => lmiller

Comment 17 Samuel Verschelde 2015-05-06 20:25:02 CEST
Setting severity to major, since a major feature in harddrake2 is broken.

Leaving priority low, though, since this is the maintainer's choice (I would raise it at least to normal given the number of duplicates I've seen)

Severity: enhancement => major

Samuel Verschelde 2015-05-06 20:25:28 CEST

Whiteboard: (none) => MGA4TOO MGA5TOO

Comment 18 Thierry Vignaud 2015-05-07 11:28:58 CEST
Not displaying RAM is a minor thing.

Harddrake only looks for "Cache" & "Memory Module". There's none in attachment 5820 [details]

I think I should just drop the "memory" from harddrake view, aka reverting most of this commit:
http://gitweb.mageia.org/software/drakx/commit/perl-install?id=c1c7b5d9db

That's not something we can configure anyway...

Source RPM: drakxtools => harddrake-ui
Severity: major => minor

Comment 19 Thierry Vignaud 2015-05-07 11:52:40 CEST
Created attachment 6462 [details]
display "Memory Device" too

Works fine but for attachment #2349 [details] where it results in duplicates as dmitable has both "Memory Device" & "Memory Module".
We could exclude one of them if both types are present.
Comment 20 Thierry Vignaud 2015-05-07 11:56:18 CEST
Created attachment 6463 [details]
enables to test with a file containing dmidecode output

This patch enables to test previous patch with any of the attached dmidecode "outputs".

As some were not really the output (as in "dmidecode > foobar.txt") but pasting in an editor, some needs editing (replacing 8 spaces at beginning of lines by 1 tab, removing command header (eg: "localhost# dmidecode") else we cannot parse them.
Comment 21 Mageia Robot 2015-05-07 17:30:24 CEST
commit 1663047db15a3cb0f9a45c7841eeff00536ff811
Author: Thierry Vignaud <thierry.vignaud@...>
Date:   Thu May 7 07:07:10 2015 -0400

    fix detecting some memory chips (mga#5810)
    
    side effect: one more string to translate
---
 Commit Link:
   http://gitweb.mageia.org/software/drakx/commit/?id=1663047db15a3cb0f9a45c7841eeff00536ff811
Comment 22 Martin Volf 2015-05-11 17:44:00 CEST
Created attachment 6512 [details]
mga5rc-harddrake2-memory-screenshot
Comment 23 Martin Volf 2015-05-11 17:46:11 CEST
@tv

Thank you for the new patch. It is tested on MGA5RC and works fine, see attached screenshot from my notebook above.

Please be so kind and add next outputs that the user can see:
- Manufacturer
- Form Factor
- Serial Number
Comment 24 Thierry Vignaud 2015-05-11 18:01:12 CEST
I forgot to close this one

Status: NEW => RESOLVED
Resolution: (none) => FIXED

Comment 25 Samuel Verschelde 2015-05-15 11:54:26 CEST
*** Bug 11908 has been marked as a duplicate of this bug. ***

CC: (none) => junk4nospam


Note You need to log in before you can comment on or make changes to this bug.