Bug 5756 - Gnome Online Accounts segfaults after adding an account. (rpm missing)
Summary: Gnome Online Accounts segfaults after adding an account. (rpm missing)
Alias: None
Product: Mageia
Classification: Unclassified
Component: RPM Packages (show other bugs)
Version: Cauldron
Hardware: x86_64 Linux
Priority: Normal normal
Target Milestone: ---
Assignee: Olav Vitters
QA Contact:
Whiteboard: MGA2TOO 3alpha2
Keywords: PATCH
Depends on:
Blocks: 6133
  Show dependency treegraph
Reported: 2012-05-05 12:30 CEST by Frederic Bezies
Modified: 2012-12-10 13:32 CET (History)
1 user (show)

See Also:
Source RPM: gnome-online-accounts
Status comment:

report.bug.gz of my installation. (262.08 KB, application/gzip)
2012-05-05 18:03 CEST, Frederic Bezies
report.bug.gz from my RC DVD installation in virtualbox. (217.16 KB, application/gzip)
2012-05-10 06:15 CEST, Frederic Bezies

Description Frederic Bezies 2012-05-05 12:30:47 CEST
Description of problem: I installed Mageia 2 with net-install iso. When I try to add my google account in gnome online account tool, it crashes after I authorize access to my datas.

Got this in terminal when using dmesg | tail :

[   98.627225] gnome-control-c[2703]: segfault at 78 ip 00007f6269ea302b sp 00007fffa9e2d3a0 error 4 in libgoa-backend-1.0.so.0.0.0[7f6269e95000+1b000]

When I do a tail /var/log/messages, I got something like this error message.

Version-Release number of selected component (if applicable): libgoa1.0_0-3.4.1-1.mga2

How reproducible: See details

Steps to Reproduce:

1. Just add an account into gnome online account tool.
Comment 1 Frederic Bezies 2012-05-05 13:20:51 CEST
It crashes because gnome-online-account rpm is not installed. An installation bug ?
Comment 2 Manuel Hiebel 2012-05-05 15:44:04 CEST
can you attach the file /root/drakx/report.bug.gz ?

At least it seems missing in the task-gnome or gnome-control-center

Assignee: bugsquad => olav
Summary: Gnome Online Accounts segfaults after adding an account. => Gnome Online Accounts segfaults after adding an account. (rpm missing)

Comment 3 Frederic Bezies 2012-05-05 18:03:49 CEST
Created attachment 2187 [details]
report.bug.gz of my installation.
Manuel Hiebel 2012-05-06 13:16:17 CEST

Source RPM: (none) => gnome-online-accounts

Comment 4 Frederic Bezies 2012-05-10 06:14:33 CEST
Package missing in Release Candidate too :(

Used DVD to install a RC version of Mageia with gnome, and gnome-online-accounts is still not installed.

Could be a bad thing for new users trying to use gnome accounts.
Comment 5 Frederic Bezies 2012-05-10 06:15:15 CEST
Created attachment 2236 [details]
report.bug.gz from my RC DVD installation in virtualbox.
Comment 6 Manuel Hiebel 2012-05-10 12:10:32 CEST
I asked the iso maker to include it in the DVD, but indeed there is no require or suggest.
Comment 7 Olav Vitters 2012-05-14 11:23:19 CEST
Could you please install debug packages and provide a backtrace using that?
Comment 8 Frederic Bezies 2012-05-14 12:44:51 CEST
Of course. Will do this asap ;)
Comment 9 Frederic Bezies 2012-05-14 14:43:10 CEST
Some more infos : task-gnome doesn't grab missing rpm.

Olav : crash only occurs because gnome-online-account rpm is missing on installation.
Comment 10 Olav Vitters 2012-05-14 22:13:18 CEST
I don't care that gnome-online-accounts solves the crashes. I'd like to know where it crashes. If it only needs some png files, I should split up the package.

e.g. task-gnome should NOT require gnome-online-accounts

dependency is somewhere between libgoa and goa.
Comment 11 Frederic Bezies 2012-05-15 09:02:39 CEST
Looking at error log, and as an end user, to me it is a bug in libgoa.

Besides this, let me be stupid : why not shipping goa while it has an entry in user menu ?

I'm just a stupid user trying to help. Close this bug if you want, but not shipping goa and its depends while installing gnome is like proposing a car with only 3 wheels.

It won't work.

Have a good day.
Comment 12 Olav Vitters 2012-05-15 19:30:46 CEST
Because it might be better technically to go for another solution.

e.g. if libgoa wants stuff from goa, then make a goa-common with only the bits that are needed and have libgoa only require goa-common, not entire goa
Comment 13 Frederic Bezies 2012-05-19 19:22:57 CEST
Sorry for answering so late, but I didn't find debug file related to libgoa. Which packages ?
Comment 14 Marja Van Waes 2012-05-26 13:09:10 CEST

This bug was filed against cauldron, but we do not have cauldron at the moment.

Please report whether this bug is still valid for Mageia 2.

Thanks :)


Keywords: (none) => NEEDINFO

Comment 15 Frederic Bezies 2012-05-26 16:34:54 CEST
Still valid. Verified it a few hours ago. See in comment #13...

Version: Cauldron => 2

Sander Lepik 2012-05-26 16:42:33 CEST

Keywords: NEEDINFO => (none)
CC: (none) => sander.lepik

Manuel Hiebel 2012-05-28 16:16:03 CEST

Blocks: (none) => 6133

Comment 16 Marja Van Waes 2012-07-06 15:05:31 CEST
Please look at the bottom of this mail to see whether you're the assignee of this  bug, if you don't already know whether you are.

If you're the assignee:

We'd like to know for sure whether this bug was assigned correctly. Please change status to ASSIGNED if it is, or put OK on the whiteboard instead.

If you don't have a clue and don't see a way to find out, then please put NEEDHELP on the whiteboard.

Please assign back to Bug Squad or to the correct person to solve this bug if we were wrong to assign it to you, and explain why.

Thanks :)


@ the reporter and persons in the cc of this bug:

If you have any new information that wasn't given before (like this bug being valid for another version of Mageia, too, or it being solved) please tell us.

@ the reporter of this bug

If you didn't reply yet to a request for more information, please do so within two weeks from now.

Thanks all :-D
Comment 17 Frederic Bezies 2012-10-22 15:52:28 CEST
Sorry for answering so late, real life and others things happened.

I installed Mageia 3 alpha 2 - from DVD - and this package is still not installed. Could be a blocking problem for lot of people which are looking for a fully working Gnome environment.

And sorry, sorry, sorry - did I say sorry ? - for the lateness :(
Manuel Hiebel 2012-10-26 23:26:07 CEST

Keywords: (none) => PATCH
Version: 2 => Cauldron
Whiteboard: (none) => MGA2TOO 3alpha2

Comment 18 Olav Vitters 2012-12-10 13:32:59 CET
Sorry, took ages to do what you suggested. Cannot think of anything else..

Resolution: (none) => FIXED

Note You need to log in before you can comment on or make changes to this bug.