Bug 3714 - Mgaonline is blocked by lxdm
Summary: Mgaonline is blocked by lxdm
Alias: None
Product: Mageia
Classification: Unclassified
Component: RPM Packages (show other bugs)
Version: Cauldron
Hardware: All Linux
Priority: Normal normal
Target Milestone: ---
Assignee: Mageia Bug Squad
QA Contact:
Depends on: 4406
  Show dependency treegraph
Reported: 2011-12-12 08:31 CET by Georges Eckenschwiller
Modified: 2012-05-24 21:19 CEST (History)
6 users (show)

See Also:
Source RPM: lxdm
Status comment:


Description Georges Eckenschwiller 2011-12-12 08:31:40 CET
I use as display manager lxdm and Xfce as desktop.
I get regularly  a message
"Le mot de passe n'est pas valide.
Veuillez essayer à nouveau"

I see that this is the time where mgaonline is launched.
(by changing the frequency of mgaonline).

The problem exists with mageia 1 and with cauldron.

With kdm there is no problem.
But kdm is not optimal with Xfce  (too many dependencies on qt).

A user of PCLinuxOS think it's linked to consolehelper.
Comment 1 Manuel Hiebel 2011-12-12 22:31:18 CET
(In reply to comment #0)
> Hello,
> A user of PCLinuxOS think it's linked to consolehelper.

Something missing ?

CC: (none) => ennael1, fundawang, mageia, thierry.vignaud
Source RPM: (none) => lxdm

Comment 2 Georges Eckenschwiller 2011-12-13 07:00:55 CET
(In reply to comment #1)
> (In reply to comment #0)
> > Hello,
> > A user of PCLinuxOS think it's linked to consolehelper.
> Something missing ?

I think it is a bad translation.

A user of PCLinuxOS thinks that the problem could be caused by consolehelper.
Comment 3 Georges Eckenschwiller 2012-01-13 18:05:01 CET
I wonder if the cause is not the same as for the bug 3936.
Georges Eckenschwiller 2012-02-04 17:38:09 CET

Depends on: (none) => 4406

Comment 4 Mark Meyer 2012-02-08 07:56:56 CET
I tracked this down to mgaapplet (via xprop _NET_WM_PID). Basically adding the following line to your /etc/pam.d/urpmi.updates file fixes this issue:

session optional pam_ck_connector.so

CC: (none) => ofosos

Comment 5 Mark Meyer 2012-02-08 08:30:38 CET
Darn. After updating it still pops up several screens with 'The password...'.
Comment 6 Mark Meyer 2012-02-11 16:34:38 CET
apparently running `mkxauth -c' fixes this. For a more permanent fix try adding that line to /etc/lxdm/PostLogin and logging out and back in again.

On my system lxdm writes a corrupted .Xauthority file and the command above writes it anew. Could you verify if that is what's causing the problem by running

xauth -f ~/.Xauthority nlist $DISPLAY

The above command should list some information. However under lxdm it doesn't output a single line.

If you can confirm, I'll be looking into a fix for upstream.
Comment 7 Georges Eckenschwiller 2012-02-11 20:43:18 CET
I tested the solution with mageia1 and with cauldron.
I do not obtain any more the message of blocking.

It remains to verify if mgaapplet work correctly.
I shall see tomorrow, after an update of my local mirror of cauldron.
Comment 8 Georges Eckenschwiller 2012-02-12 11:23:01 CET
I had updates for mageia1 and for cauldron.

Mgaapplet works now correctly, in both cases.
Is it possible to patch the lxdm package, while waiting for the correction upstream?
Jani Välimaa 2012-02-25 09:16:12 CET

CC: (none) => jani.valimaa

Comment 9 Jani Välimaa 2012-02-25 12:22:31 CET
Added mkxauth to PostLogin script and pushed new release. Please test it.

This also fixed my problem where I couldn't start netcenter by clicking net_applet in system tray. Before it just said my password was wrong even I didn't enter it to anywhere.
Comment 10 Georges Eckenschwiller 2012-02-26 10:18:56 CET
By me too, everything works. I close the report.

Resolution: (none) => FIXED

Comment 11 Georges Eckenschwiller 2012-05-22 16:15:38 CEST
I just repeat the installation of lxdm with mageia1.
The problem is still present with mageia1

Resolution: FIXED => (none)

Comment 12 Georges Eckenschwiller 2012-05-24 21:19:31 CEST
I was wrong. 
I just tested and mgaapplet works correctly with Mageia1, without further corrective.

Resolution: (none) => FIXED

Note You need to log in before you can comment on or make changes to this bug.