Bug 32198 - Blank pdf output from cups-pdf 3.0.1-3.mga9
Summary: Blank pdf output from cups-pdf 3.0.1-3.mga9
Status: NEW
Alias: None
Product: Mageia
Classification: Unclassified
Component: RPM Packages (show other bugs)
Version: 9
Hardware: All Linux
Priority: High major
Target Milestone: ---
Assignee: QA Team
QA Contact:
Keywords: IN_ERRATA9
Depends on:
Reported: 2023-08-28 16:27 CEST by Dusan Pavlik
Modified: 2023-09-04 10:52 CEST (History)
3 users (show)

See Also:
Source RPM: cups-pdf-3.0.1-3.mga9.src.rpm
Status comment:

Diff from https://raw.githubusercontent.com/archlinux/svntogit-packages/packages/cups-pdf/trunk/remove-deprecated-ghostscript-setpdfwrite-operator.diff (2.36 KB, patch)
2023-08-29 18:33 CEST, Dave Hodgins
Details | Diff
wrong output from patched cups-pdf (41.26 KB, application/pdf)
2023-08-31 18:02 CEST, Dusan Pavlik

Description Dusan Pavlik 2023-08-28 16:27:13 CEST
Description of problem:
If I printing to cups-pdf printer. Output is one blank pdf page.

Version-Release number of selected component (if applicable):
cup-pdf 3.0.1-3.mga9

How reproducible:

Steps to Reproduce:
1. Select printer cup-pdf
2. Printing
Dusan Pavlik 2023-08-28 16:27:28 CEST

Version: Cauldron => 9

Comment 1 Lewis Smith 2023-08-28 21:15:06 CEST
Please say what desktop you are using. Does this happen when printing from any application?

I need to try this.

Source RPM: (none) => cups-pdf-3.0.1-3.mga9.src.rpm
Summary: Blank pdf output from cup-pdf 3.0.1-3.mga9 => Blank pdf output from cups-pdf 3.0.1-3.mga9
CC: (none) => lewyssmith

Comment 2 Lewis Smith 2023-08-28 21:38:19 CEST
Cauldron/Mageia 9, LxQt, cups-pdf-3.0.1-3.mga9
I installed the package, and used MCC to 'add' the cups-pdf 'printer'. It then appeared as an option in print dialogues. (Also an entry for 'cups-pdf-linux', which if selected did not activate the print button).
Tried printing to it from two different applications, single pages; in both cases the result was a blank page.

No visible maintainer for this; and cups itself has various committers; so assigning this bug globally.

Assignee: bugsquad => pkg-bugs
Severity: normal => major
CC: lewyssmith => (none)

Comment 3 Dave Hodgins 2023-08-29 02:03:31 CEST
# cat /var/log/cups/cups-pdf-Generic-CUPS-PDF-Printer_log
Mon Aug 28 19:17:00 2023  [ERROR] Can't read
Mon Aug 28 19:17:01 2023  [ERROR] ghostscript reported an error
Mon Aug 28 19:17:01 2023  [STATUS] PDF creation successfully finished

Might be an error in parameters specified in /etc/cups/cups-pdf.conf to
properly pass the pdf to ghostscript. Not sure though.

CC: (none) => davidwhodgins

Comment 4 Dusan Pavlik 2023-08-29 06:56:54 CEST
I mean there is solution


ps. I using wine programs and I need output to pdf
Comment 6 David GEIGER 2023-08-30 06:09:41 CEST
Please the upcoming cups-pdf-3.0.1-3.1.mga9 update.

Assigning to QA,

Packages in 9/Core/Updates_testing:


CC: (none) => geiger.david68210
Assignee: pkg-bugs => qa-bugs

Comment 7 Dusan Pavlik 2023-08-31 18:00:40 CEST
I install cups-pdf-3.0.1-3.1.mga9.x86_64.rpm    

But output is wrong.  See attachment.
Comment 8 Dusan Pavlik 2023-08-31 18:02:48 CEST
Created attachment 13961 [details]
wrong output from  patched cups-pdf
Comment 9 Dave Hodgins 2023-08-31 19:48:44 CEST
Confirmed it still doesn't work properly. Trying to print a text file
with some characters set to bold/italic, to pdf from oowriter, the pdf has ...

So there's something wrong with generating of the pdf document.
Comment 10 Morgan Leijström 2023-09-03 22:59:53 CEST
Just noting cups-pdf is not in a a released media, so this issue is not for errata  (even though this problematic cups-pdf-3.0.1-3 is in release *repository*)

CC: (none) => fri

Comment 11 Dave Hodgins 2023-09-03 23:36:00 CEST
The errata isn't just for things on the iso images. It's also for anything that
breaks or requires manual changes after upgrading from m8 to m9.
Comment 12 Morgan Leijström 2023-09-03 23:43:06 CEST
Upgrading breaks pdf printing.


Keywords: (none) => IN_ERRATA9
Priority: Normal => High

Comment 13 Morgan Leijström 2023-09-04 10:52:59 CEST
Updated errata with tips on workarounds: many programs can export pdf by other means.



Users need to go hunting for where the output file gets stuffed away.
Here using cuips.pdf the file gets "hidden" in ~/Desktop - not localised.

(Desktop have different names in different languages, plus some desktop systems do not always show its content as desktop.)
And nowhere in the setup procedure nor settings nor print dialogue (what I can find) or when it prints, user is told where the output will go or how to set it.
Did I miss something, is this a bug or should I post an enhancement request?

Note You need to log in before you can comment on or make changes to this bug.