Bug 31236 - Pulse Audio broke in latest updates
Summary: Pulse Audio broke in latest updates
Status: RESOLVED DUPLICATE of bug 31235
Alias: None
Product: Mageia
Classification: Unclassified
Component: RPM Packages (show other bugs)
Version: Cauldron
Hardware: All Linux
Priority: Normal major
Target Milestone: ---
Assignee: Thierry Vignaud
QA Contact:
Depends on:
Reported: 2022-12-06 21:24 CET by Brian Rockwell
Modified: 2022-12-07 21:07 CET (History)
3 users (show)

See Also:
Source RPM:
Status comment:

Journal of objects installed today (11.25 KB, text/plain)
2022-12-06 21:25 CET, Brian Rockwell
dmesg (52.56 KB, text/plain)
2022-12-06 21:27 CET, Brian Rockwell

Description Brian Rockwell 2022-12-06 21:24:36 CET
Description of problem:  Audio quit working after 6-Dec updates installed

Version-Release number of selected component (if applicable):  Cauldron

How reproducible:  Try to play sound and get errors

$ mplayer *.mp3
Creating config file: /home/brian/.mplayer/config
MPlayer 1.5-10.mga9-12 (C) 2000-2022 MPlayer Team
do_connect: could not connect to socket
connect: No such file or directory
Failed to open LIRC support. You will not be able to use your remote control.

Playing 84_2022112942556.mp3.
libavformat version 59.27.100 (external)
Audio only file format detected.
Load subtitles in ./
Trying to force audio codec driver family libmad...
Opening audio decoder: [libmad] libmad mpeg audio decoder
AUDIO: 44100 Hz, 2 ch, s16le, 96.0 kbit/6.80% (ratio: 12000->176400)
Selected audio codec: [mad] afm: libmad (libMAD MPEG layer 1-2-3)
AO: [pulse] 44100Hz 2ch s16le (2 bytes per sample)
Video: no video
Starting playback...
A:  -0.0 (unknown) of 1843.0 (30:43.0) ??,?% 
Audio device got stuck!
A:  -0.0 (unknown) of 1843.0 (30:43.0) ??,?% 
Audio device got stuck!
A:  -0.0 (unknown) of 1843.0 (30:43.0) ??,?% 
Audio device got stuck!
A:  -0.0 (unknown) of 1843.0 (30:43.0) ??,?% 
Audio device got stuck!
A:  -0.0 (unknown) of 1843.0 (30:43.0) ??,?% 

MPlayer interrupted by signal 2 in module: play_audio
Audio device got stuck!
A:  -0.0 (unknown) of 1843.0 (30:43.0) ??,?% 

Exiting... (Quit)

Steps to Reproduce:  this was working prior to updates
1.  Will not work in firefox or chome
2.  mplayer fails

Attaching install log.  NOt I thought it was firefox at first so installed chromium.  Same issue and hten tried mplayer.
Comment 1 Brian Rockwell 2022-12-06 21:25:12 CET
Created attachment 13548 [details]
Journal of objects installed today
Comment 2 Brian Rockwell 2022-12-06 21:27:06 CET
Created attachment 13549 [details]
Comment 3 Dave Hodgins 2022-12-06 23:49:43 CET
Workaround for now. As the user logged in, run ...
$ systemctl --user stop pipewire.service pipewire.socket
$ systemctl --user disable pipewire.service pipewire.socket

CC: (none) => davidwhodgins

Comment 4 Brian Rockwell 2022-12-07 00:49:13 CET
Thanks Dave - that worked.
Comment 5 Dave Hodgins 2022-12-07 00:56:58 CET
Assigning to tv, the maintainer of pipewire.

Assignee: bugsquad => thierry.vignaud

Comment 6 Paul Blackburn 2022-12-07 04:03:10 CET
Tried Dave's suggestion from comment 3 with install of Mageia-9-beta1-x86_64.iso

Does not seem to get sound working.

[mpb@h30-mageia9-beta1 ~]$ systemctl --user stop pipewire.service pipewire.socket
Failed to stop pipewire.service: Unit pipewire.service not loaded.
Failed to stop pipewire.socket: Unit pipewire.socket not loaded.

[mpb@h30-mageia9-beta1 ~]$ systemctl --user disable pipewire.service pipewire.socket
Failed to disable unit: Unit file pipewire.service does not exist.

CC: (none) => paul.blackburn

Comment 7 Lewis Smith 2022-12-07 21:07:37 CET
This is a follow-on of bug 31235, which was closed but now re-opened. Since that is the oldest, making this bug a duplicate of that.

*** This bug has been marked as a duplicate of bug 31235 ***

Resolution: (none) => DUPLICATE
CC: (none) => lewyssmith

Note You need to log in before you can comment on or make changes to this bug.