Bug 31107 - Knotes don't work
Summary: Knotes don't work
Alias: None
Product: Mageia
Classification: Unclassified
Component: RPM Packages (show other bugs)
Version: 9
Hardware: All Linux
Priority: Normal normal
Target Milestone: ---
Assignee: QA Team
QA Contact:
Whiteboard: MGA9-64-OK
Keywords: validated_update
Depends on: 32953
  Show dependency treegraph
Reported: 2022-11-11 18:03 CET by Jose Manuel López
Modified: 2024-03-22 02:55 CET (History)
3 users (show)

See Also:
Source RPM: akonadi-notes-23.04.1-1.mga9.src.rpm
Status comment:


Description Jose Manuel López 2022-11-11 18:03:53 CET
Description of problem: I have tried that if I don't install knotes during Mageia installation, and after I want install it, Knotes don't work becaus don't install the necessary libraries for work and open notes in desktop.

I have checket that knotes depends or need of Akonadi-kde, but altough this package install too, knotes don't work still. The package akonadi-mime is necessary too. 

Version-Release number of selected component (if applicable): Knotes in Mageia 8

How reproducible: Don't install knotes during installation Mageia, or install after in a desktop without knotes.

Steps to Reproduce:
1. Install knotes in a desktop without it
2. Open knotes, don't work
3. Install akonadi-kde and akonadi-mime packages, now knotes will work fine.
Comment 1 Dave Hodgins 2022-11-11 19:33:31 CET
Looks like akonadi-notes should require akonadi and akonadi should require

Currently akonadi-mime is only required by kmail and akonadi by akonadi-kde
and kopete.

Assigning to Nicolas.

CC: (none) => davidwhodgins
Assignee: bugsquad => mageia
Source RPM: knotes => akonadi-notes-20.12.0-1.mga8.src.rpm

Comment 2 Jose Manuel López 2023-09-22 17:29:36 CEST
Still unresolved since Mageia 8. Can we modify the spec so that knotes requires the two dependencies indicated in the bug?

Comment 3 Jose Manuel López 2024-01-22 12:00:07 CET

Any news about this bug? I see that in Mageia 9 there is still the same problem of lack of dependencies for Knotes to work correctly.
katnatek 2024-01-22 19:51:45 CET

Version: 8 => 9
Source RPM: akonadi-notes-20.12.0-1.mga8.src.rpm => akonadi-notes-23.04.1-1.mga9.src.rpm

David GEIGER 2024-03-09 09:12:28 CET

Blocks: (none) => 32953

Comment 4 katnatek 2024-03-09 20:18:06 CET
Tested in VM Mageia 9 x86_64 lxqt

This is fixed with knotes-23.04.3-1.mga9 in testing
Comment 5 Morgan Leijström 2024-03-17 00:08:03 CET
So I think we should close this bug so it does not block the Plasma update bug which will then ship the fix?

CC: (none) => fri

katnatek 2024-03-17 00:30:54 CET

Depends on: (none) => 32953
Blocks: 32953 => (none)

Comment 6 Jose Manuel López 2024-03-20 17:41:24 CET

I have installed Knotes 23.04.3 from testing repos. Now, it install the required dependencies, and works fine in real installation of Mageia 9 Plasma x86_64.

For me, we can validate the new version and close this bug.

Comment 7 Morgan Leijström 2024-03-20 17:55:24 CET
Thank you :)
BTW seems we forgot to assign this to QA

Assignee: mageia => qa-bugs

Morgan Leijström 2024-03-20 17:55:55 CET

Whiteboard: (none) => MGA9-64-OK
Keywords: (none) => validated_update
CC: (none) => sysadmin-bugs

Comment 8 katnatek 2024-03-22 02:55:09 CET

Resolution: (none) => FIXED

Note You need to log in before you can comment on or make changes to this bug.