Bug 29840 - GNOME system tray incompatible because of TopIconsPlus
Summary: GNOME system tray incompatible because of TopIconsPlus
Alias: None
Product: Mageia
Classification: Unclassified
Component: RPM Packages (show other bugs)
Version: Cauldron
Hardware: All Linux
Priority: Normal normal
Target Milestone: ---
Assignee: GNOME maintainers
QA Contact:
Depends on:
Reported: 2022-01-03 08:40 CET by Franz Holzinger
Modified: 2022-01-05 11:36 CET (History)
1 user (show)

See Also:
Source RPM: gnome-shell-extension-topicons-27-1.mga8.src.rpm
Status comment:


Description Franz Holzinger 2022-01-03 08:40:56 CET
Ater a login with GDM and GNOME desktop I immediately get an error dialog box:

HPLIP Status Service

No system tray detected on this system.

Unable to start, exiting.



TopIconsPlus shows an error:
This extension is incompatible with the current version of GNOME.

See also 
Comment 1 sturmvogel 2022-01-03 11:23:48 CET
Additional info. The solution from bug #23795 doesn't work anymore because the developement of gnome-shell-extension-topicons https://github.com/phocean/TopIcons-plus stopped and the successor is gnome-shell-extension-appindicator https://github.com/ubuntu/gnome-shell-extension-appindicator. It should be replaced in cauldron/Mageia 9.

A manual test by installing the new extension via https://extensions.gnome.org/extension/615/appindicator-support/ under cauldron worked and solved the above error. This extension should be packed for cauldron/Mageia 9.
Comment 2 sturmvogel 2022-01-03 11:30:07 CET
To make it more clear: gnome-shell-extension-topicons is not compatible with new gnome shell versions like we use in cauldron.
Comment 3 Lewis Smith 2022-01-03 20:01:32 CET
Thanks to both of you for the report & comments.

Assigning to the Gnome people; this will have to be reflected in future Gnome installs.

Assignee: bugsquad => gnome

Comment 4 Jani Välimaa 2022-01-04 14:57:23 CET
Should be fixed with gnome-shell-extension-appindicator-41-1.mga9. Imported it based on .spec from Fedora.

$ urpmq --obsoletes gnome-shell-extension-appindicator
gnome-shell-extension-topicons[< 27-2]

CC: (none) => jani.valimaa

Comment 5 sturmvogel 2022-01-05 03:30:16 CET
After installation of gnome-shell-extension-appindicator-41-1.mga9 and a necessary restart (i didn't test if log out/log in is enough), the extension is available under the extension menu. Enabling it removes the error from the initial post. Problem solved.
Comment 6 Jani Välimaa 2022-01-05 09:30:17 CET
Can you check what's the output of the following cmd?
$ rpm -qa *appindicator*

I think appindicator lib or gir pkg is also required. ATM they're not pulled automatic with the pkg.
Comment 7 sturmvogel 2022-01-05 10:46:05 CET
[gnome@localhost ~]$ rpm -qa *appindicator*
[gnome@localhost ~]$

It's a Virtualbox Gnome installation updated from Mageia 8 to cauldron.
Comment 8 Jani Välimaa 2022-01-05 11:36:46 CET
OK, I added libappindicator-gtk3 requires to gnome-shell-extension-appindicator-41-2.mga9.

Closing as FIXED. Feel free to reopen if needed.

Resolution: (none) => FIXED

Note You need to log in before you can comment on or make changes to this bug.