Bug 29457 - qt5pas was built from outdated sources of Lazarus
Summary: qt5pas was built from outdated sources of Lazarus
Status: NEW
Alias: None
Product: Mageia
Classification: Unclassified
Component: RPM Packages (show other bugs)
Version: 8
Hardware: All Linux
Priority: Normal normal
Target Milestone: ---
Assignee: QA Team
QA Contact:
URL:
Whiteboard: MGA8-64-OK
Keywords: validated_update
Depends on:
Blocks:
 
Reported: 2021-09-13 00:03 CEST by Artem Kurashov
Modified: 2021-09-17 14:11 CEST (History)
4 users (show)

See Also:
Source RPM: qt5pas-2.6-4.mga8.src.rpm
CVE:
Status comment:


Attachments

Description Artem Kurashov 2021-09-13 00:03:26 CEST
Software that uses qt5pas library may fails to build in the case it was built from outdated version of Lazarus.

Currently in the Mageia 8 version of the Lasarus is 2.0.10.2, but qt5pas library was built from Lazarus 1.8.4.
Comment 1 Jani Välimaa 2021-09-13 18:21:52 CEST
qt5pas library build should be merged into lazarus pkg, if it uses the same source. Then it will be always up to date.
Comment 2 Jani Välimaa 2021-09-13 18:44:35 CEST
(In reply to Jani Välimaa from comment #1)
> qt5pas library build should be merged into lazarus pkg, if it uses the same
> source. Then it will be always up to date.

NVM. Merging into lazarus pkg will cause issues with %mkrel when lazarus version changes as ​qt5pas seems to be versioned independently.

Adding a note about updating qt5pas also to lazarus spec might be sufficient.
Comment 3 Lewis Smith 2021-09-13 20:52:15 CEST
@Artem : thank you for this report.
 lib64qt5pas1 :
Summary     : Free Pascal Qt5 binding
Description :
The Free Pascal Qt5 binding that allows Free Pascal
to interface with the C++ Library Qt.
 lazarus :
Summary     : Lazarus Component Library and IDE for Freepascal
Description :
Lazarus is a free and opensource RAD tool for freepascal using the lazarus
component library - LCL, which is also included in this package.

@Jani : Thank you for fielding this, and already having done something about it! You clearly understand what it is about, so permit me to assign the bug to you.

Assignee: bugsquad => jani.valimaa

Comment 4 Jani Välimaa 2021-09-14 17:50:48 CEST
Pushed qt5pas-2.6-4.1.mga8 to core/updates_testing. Please test.

The pkg is built from lazarus 2.0.10-2 sources, the same version as shiped with mga8.

SRPM(S):
qt5pas-2.6-4.1.mga8

RPM(S):
lib(64)qt5pas1-2.6-4.1.mga8
lib(64)qt5pas-devel-2.6-4.1.mga8

Assignee: jani.valimaa => qa-bugs
CC: (none) => jani.valimaa

Comment 5 Herman Viaene 2021-09-15 13:48:51 CEST
MGA8-64 Plasma on Lenovo B50
No installation issues.
No previous updates on this and
# urpmq --whatrequires-recursive lib64qt5pas1
lib64qt5pas1
Did some reading on this , an to me it seems a lib used in development, so I OK the update on clean install. Unless someone has another idea.

CC: (none) => herman.viaene
Whiteboard: (none) => MGA8-64-OK

Comment 6 Thomas Andrews 2021-09-17 14:11:53 CEST
Validating.

CC: (none) => andrewsfarm, sysadmin-bugs
Keywords: (none) => validated_update


Note You need to log in before you can comment on or make changes to this bug.