Bug 29447 - qtwebengine5 new security issues fixed upstream in 5.15.6
Summary: qtwebengine5 new security issues fixed upstream in 5.15.6
Status: NEW
Alias: None
Product: Mageia
Classification: Unclassified
Component: Security (show other bugs)
Version: 8
Hardware: All Linux
Priority: Normal normal
Target Milestone: ---
Assignee: QA Team
QA Contact: Sec team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-09-08 22:19 CEST by David Walser
Modified: 2021-09-15 15:17 CEST (History)
1 user (show)

See Also:
Source RPM: qtwebengine5-5.15.5-1.mga8.src.rpm
CVE:
Status comment:


Attachments

Description David Walser 2021-09-08 22:19:29 CEST
Fedora has issued an advisory on September 7:
https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/thread/LMVCTGROJF6NNTYL2FOLPBBG6DMG6K45/

It updates the bundled Chromium code to a newer version with more security fixes.

Advisory:
========================

Updated qtwebengine5 packages fix security vulnerabilities:

The qtwebengine5 package has been updated to version 5.15.6, fixing several
security issues in the bundled chromium code.

References:
https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/thread/LMVCTGROJF6NNTYL2FOLPBBG6DMG6K45/
========================

Updated packages in core/updates_testing:
========================
qtwebengine5-5.15.6-1.mga8
qtwebengine5-doc-5.15.6-1.mga8
libqt5pdf5-5.15.6-1.mga8
libqt5webengine-devel-5.15.6-1.mga8
libqt5webengine5-5.15.6-1.mga8
libqt5webenginewidgets5-5.15.6-1.mga8
libqt5pdfwidgets5-5.15.6-1.mga8
libqt5webenginecore5-5.15.6-1.mga8

from qtwebengine5-5.15.6-1.mga8.src.rpm
Comment 1 Herman Viaene 2021-09-15 15:17:49 CEST
MGA8-64 Plasma on Lenovo B50
No installation issues.
Ref bug 29249 for tests.
Tried different sites with konqueror. All display text and images OK, but on none do videos play,and at the CLI I see many of those:

[17816:13:0915/150026.298277:ERROR:batching_media_log.cc(38)] MediaEvent: {"error":"FFmpegDemuxer: no supported streams"}
[17816:1:0915/150026.300199:ERROR:batching_media_log.cc(35)] MediaEvent: {"pipeline_error":14}

Testing the previous update on the same laptop with the same sites did not bring this problem forward. I don't know what to make of it.

CC: (none) => herman.viaene


Note You need to log in before you can comment on or make changes to this bug.