Bug 28868 - purple-facebook: Parse error: unexpected identifier `taNewMessage', expected value
Summary: purple-facebook: Parse error: unexpected identifier `taNewMessage', expected ...
Status: NEW
Alias: None
Product: Mageia
Classification: Unclassified
Component: RPM Packages (show other bugs)
Version: 8
Hardware: All Linux
Priority: Normal normal
Target Milestone: ---
Assignee: QA Team
QA Contact:
URL: https://github.com/dequis/purple-face...
Whiteboard: MGA7TOO
Keywords:
Depends on:
Blocks:
 
Reported: 2021-05-02 04:25 CEST by Johnny A. Solbu
Modified: 2021-05-13 01:37 CEST (History)
1 user (show)

See Also:
Source RPM: purple-facebook-0.9.6-5.mga8
CVE:
Status comment:


Attachments

Description Johnny A. Solbu 2021-05-02 04:25:49 CEST
The last 2 days day I have been unable to chat on Facebook using the purple-facebook plugin.
It connects just fine, the contact list populates fine, but whenever I receive a message on Facebook, it instantly disconnect, waits a few seconds and then reconnects.
But I don't receive any messages, which renders the thing useless.


Steps to Reproduce:
1. Login to Facebook using Pigdin and this plugin.
2. Receive a message from any contact, and watch the pidgin client imediately disconnect, then reconnects after about 5 seconds, and still not receving any message. (Can be triggered by seding a message using a desktop webbrowser and send a message on Facebook. The pidgin client should receive your outgoing message, except not with this bug in effect.)
Johnny A. Solbu 2021-05-02 04:27:15 CEST

Source RPM: (none) => purple-facebook-0.9.6-5.mga8
Version: Cauldron => 8
Whiteboard: (none) => MGA7TOO

Comment 1 Johnny A. Solbu 2021-05-02 04:50:50 CEST
I have pushed updated packages to the to mga7 and mga8 testing repos.
cauldron package is fixed.

Updated packages in core/updates_testing:
========================

MGA7:
purple-facebook-0.9.6-1.3.mga7

MGA8:
purple-facebook-0.9.6-5.1.mga8



Suggested Advisory:
========================

Updated purple-facebook package fixes a connection error

purple-facebook disconnects when receving a message.
This update fixes this.

See upstream bugreport.

Reference:
- https://github.com/dequis/purple-facebook/issues/514
========================
Comment 2 Johnny A. Solbu 2021-05-02 04:53:08 CEST
Assign to QA for testing and approval.

Assignee: cooker => qa-bugs

Comment 3 Herman Viaene 2021-05-10 14:17:55 CEST
MGA7-64 on Lenvo B50
No installation issues.
I have no intention to come any miles near to facebook, so all I can confirm is that it doesnot blow up anything else.

CC: (none) => herman.viaene

Comment 4 Johnny A. Solbu 2021-05-13 01:37:56 CEST
(In reply to Herman Viaene from comment #3)
> MGA7-64 on Lenvo B50
> No installation issues.
> I have no intention to come any miles near to facebook, so all I can confirm
> is that it doesnot blow up anything else.

I completely forgot to state that I use this plugin myself, and after patching it with this fix, it now works for me.

Note You need to log in before you can comment on or make changes to this bug.