Bug 28529 - frozen-bubble 2.212.0-35 gives loadable library and perl binaries are mismatched
Summary: frozen-bubble 2.212.0-35 gives loadable library and perl binaries are mismatched
Status: NEW
Alias: None
Product: Mageia
Classification: Unclassified
Component: RPM Packages (show other bugs)
Version: 8
Hardware: All Linux
Priority: Normal normal
Target Milestone: ---
Assignee: QA Team
QA Contact:
URL:
Whiteboard: MGA8-64-OK
Keywords: validated_update
Depends on:
Blocks:
 
Reported: 2021-03-05 16:20 CET by Andy Jefferson
Modified: 2021-04-20 18:14 CEST (History)
4 users (show)

See Also:
Source RPM: frozen-bubble-2.212.0-35.mga8.src.rpm
CVE:
Status comment:


Attachments

Description Andy Jefferson 2021-03-05 16:20:00 CET
Description of problem:
MGA8 install (64 bit)
Install
frozen-bubble-2.212.0-35.mga8
perl-base-5.32.1-1.mga8
and other MGA8 standard perl libraries required to satisfy dependencies (installed using Mageia Control Center). Need any other version info, just ask which one you need

Version-Release number of selected component (if applicable):
2.212.0-35.mga8

How reproducible:
Try to start frozen-bubble

Steps to Reproduce:
1. execute "frozen-bubble"
2. gives error on console
lib/Games/FrozenBubble/CStuff.c: loadable library and perl binaries are mismatched (got handshake key 0xcd00080, needed 0xed00080)
Comment 1 Lewis Smith 2021-03-05 21:14:56 CET
Thank you for reporting this.
Assigning it to akien for this SRPM.

Source RPM: (none) => frozen-bubble-2.212.0-35.mga8.src.rpm
Assignee: bugsquad => rverschelde

Comment 2 David Walser 2021-03-06 00:43:36 CET
It just needs to be rebuilt.
Comment 3 Chris Denice 2021-03-27 13:34:37 CET
All right, confirm, and rebuild pushed to updates_testing.

But I am sorry, I screwed up the versioning with subrel, unless a sysadmin removes my mistake, the new version is:

frozen-bubble-2.212.0-36.mga8

landing in updates_testing.

CC: (none) => eatdirt

David Walser 2021-04-19 00:17:33 CEST

CC: (none) => rverschelde
Assignee: rverschelde => qa-bugs

Comment 4 Thomas Andrews 2021-04-20 18:14:05 CEST
I love this game on my Android tablet, but I miss the touch screen on my computer. Oh, well.

Installed frozen-bubble and dependencies, confirmed the problem. Updated frozen-bubble using qarepo, problem goes away and frozen bubble runs fine.

OK here. Validating.

CC: (none) => andrewsfarm, sysadmin-bugs
Whiteboard: (none) => MGA8-64-OK
Keywords: (none) => validated_update


Note You need to log in before you can comment on or make changes to this bug.