Bug 28443 - The Gimp plugin is not built .... and the gutenprint-gimp2 rpm missing
Summary: The Gimp plugin is not built .... and the gutenprint-gimp2 rpm missing
Alias: None
Product: Mageia
Classification: Unclassified
Component: RPM Packages (show other bugs)
Version: 8
Hardware: All Linux
Priority: Normal normal
Target Milestone: ---
Assignee: QA Team
QA Contact:
Whiteboard: MGA8-64-OK
Keywords: advisory, validated_update
Depends on:
Reported: 2021-02-26 12:24 CET by Philippe Didier
Modified: 2021-03-02 23:35 CET (History)
5 users (show)

See Also:
Source RPM: gutenprint-5.3.4-2.mga8.src
Status comment:

diff for the spec file (2.16 KB, patch)
2021-02-26 12:25 CET, Philippe Didier
Details | Diff
patch from fedora (3.30 KB, patch)
2021-02-26 12:26 CET, Philippe Didier
Details | Diff
script python (35.32 KB, text/x-python3)
2021-02-26 12:27 CET, Philippe Didier

Description Philippe Didier 2021-02-26 12:24:05 CET
I think I found an explanation : some trouble appeared when gimp3 was introduced in Cauldron... and then pulled out 

I will provide a diff for the spec file
and some patches and a python script (from fedora)
Comment 1 Philippe Didier 2021-02-26 12:25:40 CET
Created attachment 12396 [details]
diff for the spec file

diff for the spec file
Comment 2 Philippe Didier 2021-02-26 12:26:45 CET
Created attachment 12397 [details]
patch from fedora
Comment 3 Philippe Didier 2021-02-26 12:27:17 CET
Created attachment 12398 [details]
script python
Comment 4 David GEIGER 2021-02-26 13:10:13 CET
Done for Cauldron and also for mga8 in Core/Updates_testing repo!

CC: (none) => geiger.david68210

Comment 5 Philippe Didier 2021-02-26 14:30:00 CET
Thanks David
I will test it from update-testing repo
(I've to uninstall my own packages first)

NB it perhaps won't work for Gimp3 and need to be modified again
Comment 6 Philippe Didier 2021-02-26 18:40:21 CET

So I uninstalled my own packages 
I installed the core rpms
no plugin

I updated from /core/update/testing
went smooth

but !!!
As gutenprint-gimp2 was not installed (of course) the update does not bring it...
And you have to go to the CCM and choose to add it.

Nevertheless once installed it works perfectly :
it's shown as "print with gutenprint" in Gimp's menu
It prints perfectly (lots of options : more than with simple "print" menu

So MGA8-64-OK

This was a clean install of Mageia8 RC (using a backup of my /home/myname)

I think this needs something to add in the erratas 

1) When upgrading from Mageia7 the gimp plugin (gutenprint-gimp2.rpm) is certainly uninstalled (obsolete) and you need to add it manually after the upgrade and having updated Mageia8

2) On a fresh install, updating is not enough to make gutenprint-gimp2 reappear
Comment 7 David GEIGER 2021-02-27 08:39:19 CET
Assigning to QA now,


The gimp 2 plugin was disable during the mageia8 development cycle, so this update simply re-enable this plugin.


Packages in 8/core/updates_testing:


Source RPM: 

Assignee: bugsquad => qa-bugs

Manuel Hiebel 2021-03-01 19:59:20 CET

Whiteboard: (none) => MGA8-64-OK

Comment 8 Thomas Andrews 2021-03-01 21:15:35 CET
i5-2500, Intel graphics, 64-bit mga8 Plasma install.

Checked Gimp, no gutenprint option. Checked with rpmdrake, gutenprint-gimp2 isn't even available.

Used QA Repo to get the above packages, but gutenprint-gimp2 was not among those updated, so apparently, not a requirement. Checked again with rpmdrake with the local QA repo still active, and gutenprint-gimp2 was there, so I installed it.

Mo installation issues. Ran Gimp again, this time there was a gutenprint option. Configured gutenprint to the closest option available to my HP Deskjet 5650, and printed a photo. Worked great.

Confirming the OK, and validating. Advisory in Comment 7.

CC: (none) => andrewsfarm, sysadmin-bugs
Keywords: (none) => validated_update

Comment 9 Aurelien Oudelet 2021-03-01 22:32:34 CET
Advisory pushed to SVN.

CC: (none) => ouaurelien
Keywords: (none) => advisory

Comment 10 Philippe Didier 2021-03-02 09:46:32 CET
(In reply to Thomas Andrews from comment #8)

> Mo installation issues. Ran Gimp again, this time there was a gutenprint
> option. Configured gutenprint to the closest option available to my HP
> Deskjet 5650, and printed a photo. Worked great.
If your HP printer is not in the list provided by gutenprint, you can use the ppd file from the hplip-model-data.rpm
You can find it in /usr/share/ppd/HP/
it's a compressed file (gz) with its entire name : hp-deskjet_5650.ppd.gz
Copy it in your home directory and uncompress it 

In Gimp open a picture and choose print with gutenprint
in the gimp plugin  create a new printer and choose the ppd file in your directory 
You will have all the precise settings for your printer

(Something to add in the wiki ?)
Comment 11 Morgan Leijström 2021-03-02 13:23:44 CET
(In reply to Philippe Didier from comment #10)
> (Something to add in the wiki ?)

A wiki page about printing would be great.

And some printers deserve own pages that could be linked from it.

CC: (none) => fri

Comment 12 Mageia Robot 2021-03-02 23:35:08 CET
An update for this issue has been pushed to the Mageia Updates repository.


Resolution: (none) => FIXED

Note You need to log in before you can comment on or make changes to this bug.