Bug 28255 - hovering the cursor over desktop icons has an unusual effect ,Plasma
Summary: hovering the cursor over desktop icons has an unusual effect ,Plasma
Status: NEW
Alias: None
Product: Mageia
Classification: Unclassified
Component: RPM Packages (show other bugs)
Version: Cauldron
Hardware: All Linux
Priority: Normal normal
Target Milestone: Mageia 8
Assignee: Mageia Bug Squad
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-01-29 23:14 CET by ben mcmonagle
Modified: 2021-02-01 14:32 CET (History)
3 users (show)

See Also:
Source RPM:
CVE:
Status comment:


Attachments
distorted icons (26.14 KB, image/png)
2021-01-29 23:15 CET, ben mcmonagle
Details
Screenshot with mouse hovering over desktop icon, no distortion (576.29 KB, image/png)
2021-02-01 01:01 CET, Dave Hodgins
Details

Description ben mcmonagle 2021-01-29 23:14:38 CET
Description of problem: hovering the cursor over desktop icons edge has an unusual effect ,Plasma Live. the effect remains even when the cursor is removed 


Version-Release number of selected component (if applicable):
Mageia-8-rc-Live-Plasma-x86_64
DATE.txt: Fri 29 Jan 2021 10:55:45 AM CET
md5sum:   f7f172f6dddeacfa139fbe4f0d9a7ac8

How reproducible:


Steps to Reproduce:
1.boot live Plasma to desktop
2.hover mouse to edge of icon and observe effect as attached 
3.
Comment 1 ben mcmonagle 2021-01-29 23:15:25 CET
Created attachment 12281 [details]
distorted icons
Comment 2 ben mcmonagle 2021-01-29 23:27:00 CET
also affects panel items,icons and application tabs
ben mcmonagle 2021-01-30 04:10:08 CET

Summary: hovering the cursor over desktop icons has an unusual effect ,Plasma Live => hovering the cursor over desktop icons has an unusual effect ,Plasma

ben mcmonagle 2021-01-30 04:10:16 CET

Target Milestone: --- => Mageia 8

Comment 3 ben mcmonagle 2021-01-30 04:10:54 CET
affects CI 64 as well (all DE install)
Comment 4 ben mcmonagle 2021-01-30 04:18:07 CET
spcidrake
unknown         : Intel Corporation|7 Series/C210 Series Chipset Family PCI Express Root Port 3 [BRIDGE_PCI] (rev: c4)
xhci_pci        : Intel Corporation|7 Series/C210 Series Chipset Family USB xHCI Host Controller [SERIAL_USB] (rev: 04)
Card:Intel 810 and later: Intel Corporation|3rd Gen Core processor Graphics Controller [DISPLAY_VGA] (rev: 09)
iwlwifi         : Intel Corporation|Centrino Advanced-N 6235 [NETWORK_OTHER] (rev: 24)
ehci_pci        : Intel Corporation|7 Series/C216 Chipset Family USB Enhanced Host Controller #1 [SERIAL_USB] (rev: 04)
unknown         : Intel Corporation|7 Series/C210 Series Chipset Family KT Controller [COMMUNICATION_SERIAL] (rev: 04)
ehci_pci        : Intel Corporation|7 Series/C216 Chipset Family USB Enhanced Host Controller #2 [SERIAL_USB] (rev: 04)
unknown         : Intel Corporation|7 Series/C210 Series Chipset Family PCI Express Root Port 2 [BRIDGE_PCI] (rev: c4)
unknown         : Intel Corporation|3rd Gen Core processor DRAM Controller [BRIDGE_HOST] (rev: 09)
e1000e          : Intel Corporation|82579LM Gigabit Network Connection (Lewisville) [NETWORK_ETHERNET] (rev: 04)
snd_hda_intel   : Intel Corporation|7 Series/C216 Chipset Family High Definition Audio Controller [MULTIMEDIA_AUDIO_DEV] (rev: 04)
sdhci_pci       : Ricoh Co Ltd|PCIe SDXC/MMC Host Controller [SYSTEM_OTHER] (rev: 07)
mei_me          : Intel Corporation|7 Series/C216 Chipset Family MEI Controller #1 [COMMUNICATION_OTHER] (rev: 04)
unknown         : Intel Corporation|7 Series/C210 Series Chipset Family PCI Express Root Port 6 [BRIDGE_PCI] (rev: c4)
lpc_ich         : Intel Corporation|QM77 Express Chipset LPC Controller [BRIDGE_ISA] (rev: 04)
unknown         : Intel Corporation|7 Series/C216 Chipset Family PCI Express Root Port 1 [BRIDGE_PCI] (rev: c4)
unknown         : Intel Corporation|7 Series Chipset Family 6-port SATA Controller [AHCI mode] [STORAGE_SATA] (rev: 04)
hub             : Linux 5.10.11-desktop-1.mga8 ehci_hcd|EHCI Host Controller [Hub|Unused|Full speed (or root) hub]
hub             : Intel Corp.|Integrated Rate Matching Hub [Hub|Unused|Full speed (or root) hub]
hub             : O2 Micro, Inc.|Oz776 1.1 Hub [Hub|Unused|Full speed (or root) hub]
unknown         : O2|O2Micro CCID SC Reader [Chip/SmartCard]
btusb           : Intel Corp.|Centrino Bluetooth Wireless Transceiver [Wireless|Radio Frequency|Bluetooth]
uvcvideo        : Chicony Electronics Co.,Ltd.|TOSHIBA Web Camera - HD [Video|Video Control]
hub             : Linux 5.10.11-desktop-1.mga8 ehci_hcd|EHCI Host Controller [Hub|Unused|Full speed (or root) hub]
hub             : Intel Corp.|Integrated Rate Matching Hub [Hub|Unused|Full speed (or root) hub]
unknown         : AuthenTec, Inc.|Fingerprint Sensor
cdc_acm         : TOSHIBA |H5321 gw [Communications|Abstract (modem)|AT-commands (v.25ter)]
hub             : Linux 5.10.11-desktop-1.mga8 xhci-hcd|xHCI Host Controller [Hub|Unused|Full speed (or root) hub]
usb_storage     : Lexar|USB Flash Drive [Mass Storage|SCSI|Bulk-Only]
hub             : Linux 5.10.11-desktop-1.mga8 xhci-hcd|xHCI Host Controller [Hub|Unused|Full speed (or root) hub]
Comment 5 Lewis Smith 2021-01-31 21:56:55 CET
Thanks for the screenshot, it really does help to make the point.
The distortion seems a sort of overlay.

When you first noticed this, it was I think on the Live Plasma desktop.
Did it persist in the installed system after reboot?

> affects CI 64 as well (all DE install)
Before and after updating the installed system? Because on my regular M8 system, which should be equivalent, Plasma does not show any such behaviour.

Does anyone else in QA notice this? There are Plasma groupies.

CC: (none) => lewyssmith

Comment 6 ben mcmonagle 2021-01-31 22:09:44 CET
(In reply to Lewis Smith from comment #5)
> 
> 
> When you first noticed this, it was I think on the Live Plasma desktop.
yes
> Did it persist in the installed system after reboot?
> 
yes
> > affects CI 64 as well (all DE install)

yes
> Before and after updating the installed system?
pass
> Because on my regular M8
> system, which should be equivalent, Plasma does not show any such behaviour.
> 
> Does anyone else in QA notice this? There are Plasma groupies.
will ask
Comment 7 Dave Hodgins 2021-01-31 23:46:22 CET
I can not recreate the problem. When I hover over an icon, I get a white
rectangle with black text. This is both in live mode from a usb stick and
post install.

CC: (none) => davidwhodgins

Comment 8 Dave Hodgins 2021-02-01 01:01:22 CET
Created attachment 12294 [details]
Screenshot with mouse hovering over desktop icon, no distortion
Comment 9 Lewis Smith 2021-02-01 09:10:01 CET
@Ben
Thanks for the answers. Does this happen on just one machine (re comment 4)?
If so, a closer look on the video side:
 $ lspci -v
and please post *only* the "VGA" section. Also:
 $ inxi -Gxx
Dave has already added his bit (how did you get that screenshot? PrintScreen key? If so - where does the screenshot go? I have never found it).

Any other feedback from qa-discuss? It looks the sort of thing anyone would notice immediately.
Comment 10 Dave Hodgins 2021-02-01 09:17:03 CET
The image from pressing the print screen key is saved in ~/Pictures/ though
you can change the destination directory by specifying the path to use as
part of the file name, or selecting the directory.
Comment 11 Lewis Smith 2021-02-01 09:25:00 CET
Thanks. I see: in this case, it invokes the Plasma screenshooter 'Spectacle'. I thought it was a lower-level function. First time I have seen any reaction from it!
Comment 12 Aurelien Oudelet 2021-02-01 14:32:17 CET
Sometimes, the Print Screen Key is not relied to Plasma's Spectacle if there are too many programs which reclaim this shortcut.

Going back to this BR, I can't reproduce it on real hardware

M8 x86_64, Core i5 6600K, 16 Go Ram, Geforce GTX 1660 Ti 6Go GDDR6,
nvidia-current nonfree drivers. Kernel 5.10.12-desktop.
Mageia 8 installed with 8RC take 5, classic ISO.

CC: (none) => ouaurelien


Note You need to log in before you can comment on or make changes to this bug.