Bug 2816 - [Regression] hplip's /usr/lib/cups/filter/pstotiff broken
: [Regression] hplip's /usr/lib/cups/filter/pstotiff broken
Status: RESOLVED FIXED
Product: Mageia
Classification: Unclassified
Component: RPM Packages
: 1
: All Linux
: Normal Severity: normal
: ---
Assigned To: QA Team
:
:
:
: validated_update
:
:
  Show dependency treegraph
 
Reported: 2011-09-23 14:06 CEST by Florian Hubold
Modified: 2011-10-09 08:57 CEST (History)
8 users (show)

See Also:
Source RPM: hplip-3.11.7-1.1.mga1.src.rpm
CVE:


Attachments

Description Florian Hubold 2011-09-23 14:06:16 CEST
Description of problem:

As reported by Thomas Lottmann on the mageia-discuss mailing list here:
https://www.mageia.org/pipermail/mageia-discuss/20110923/005458.html
citing the included /var/log/cups/error.log:

/usr/lib/cups/filter/pstotiff: ligne10: -dNOPAUSE : commande introuvable

This is caused by a broken Patch from Fedora, missing a "\" at the end of the line, causing the next line to be considered as newline. The effect of this seems to not have been noticed by the testing so far. The fix is already available, i'm just waiting for my mentor to comment on some other questions about patches-to-be-added when issuing another update for hplip for Mageia 1.
Comment 1 Florian Hubold 2011-09-27 19:24:16 CEST
There is now hplip-3.11.7-1.2.mga1 in core/updates_testing to validate.


Suggested advisory:
-------------------
This update fixes the following regression:

A missing "\" at the end of a line in /usr/lib/cups/filter/pstotiff causes this whole filter to fail, resulting in not being able to print on at least Photosmart 7050. This was reported [1] by Thomas Lottmann and has now been fixed.

[1] https://www.mageia.org/pipermail/mageia-discuss/20110923/005458.html

Other fixes in this release:

- Fixed a hpcups crash when a required plugin is missing 

- Fixed an xsane crash when doing a multi-image scan

-------------------------------------------------------
Steps to reproduce:

- install/update to update candidate
- when you have a HP printer, check that all functions still work
and there are no regressions, especially that Photosmart 7050 now works again.
Comment 2 Derek Jennings 2011-10-01 15:36:04 CEST
hplip-3.11.7-1.2.mga1.x86_64.rpm verified OK on x86_64
Tested using Deskjet 7400
All functions work including scanning, printing, and hp-toolbox. Sorry no Photosmart to try out.
Comment 3 claire robinson 2011-10-05 11:41:23 CEST
It updates fine for me i586 but I'm unable to test it.
Comment 4 Samuel Verschelde 2011-10-07 23:43:15 CEST
Thomas, can you confirm that it fixes your printing problem? (and tell us on what arch)
Comment 5 Florian Hubold 2011-10-08 02:25:25 CEST
Actually from his comments on the mailing list the cause of his printing problems is another one, fixing of this regression was merely fall-out from doing support on the hplip faction.

So the answer to your question is no, but this regression is fixed now ;)
Comment 6 Samuel Verschelde 2011-10-08 09:33:39 CEST
(In reply to comment #5)
> Actually from his comments on the mailing list the cause of his printing
> problems is another one, fixing of this regression was merely fall-out from
> doing support on the hplip faction.
> 
> So the answer to your question is no, but this regression is fixed now ;)

Did people confirm that this update candidate works, for example on the -discuss mailing list, or must we go and find testers for it?
Comment 7 Florian Hubold 2011-10-08 09:42:45 CEST
(In reply to comment #6)
 
> Did people confirm that this update candidate works, for example on the
> -discuss mailing list, or must we go and find testers for it?
No and yes. That's why i've asked Claire to resend the QA call for testing to -discuss, but until now no replies so far, but she replied in-thread.

I've now resent Dave's original mail for the first hplip update.
Comment 8 isadora 2011-10-08 11:46:47 CEST
Installed:

- hplip-3.11.7-1.2.mga1.x86_64
- hplip-doc-3.11.7-1.2.mga1.x86_64
- hplip-gui-3.11.7-1.2.mga1.x86_64
- hplip-hpijs-3.11.7-1.2.mga1.x86_64
- hplip-hpijs-ppds-3.11.7-1.2.mga1.x86_64
- hplip-model-data-3.11.7-1.2.mga1.x86_64

Slow download.
Installation without problems.
HP Device Manager starts without problems.
All settings remained.
Printing to HP Color Laserjet CP1515n worked flawlessly.
Comment 9 Marja van Waes 2011-10-08 15:31:06 CEST
HP Deskjet 5652 on Linksys printserver, tested with hplip 3.11.7-1.2.mga1, X86_64 

Printing before installing and after installing + restarting cups: no differences observed, works fine, so far no regression seen.

I didn't yet manage to install the i586 version on my old laptop, so that test will follow later
Comment 10 Marja van Waes 2011-10-08 15:56:50 CEST
HP Deskjet 5652 on Linksys printserver, tested with hplip 3.11.7-1.2.mga1 i586

Worked fine before updating to this version of hplip. After updating + restarting cups printing works just as good as before
Comment 11 claire robinson 2011-10-08 16:14:57 CEST
Thankyou Marja and isadora!

Can we call on you again for future updates please?



Validating the update.


Advisory:
-------------------
This update fixes the following regression:

A missing "\" at the end of a line in /usr/lib/cups/filter/pstotiff causes this
whole filter to fail, resulting in not being able to print on at least
Photosmart 7050. This was reported [1] by Thomas Lottmann and has now been
fixed.

[1] https://www.mageia.org/pipermail/mageia-discuss/20110923/005458.html

Other fixes in this release:

- Fixed a hpcups crash when a required plugin is missing 

- Fixed an xsane crash when doing a multi-image scan

-------------------------------------------------------

SRPM: hplip-3.11.7-1.2.mga1.src.rpm 


Could sysadmin please push from core/updates_testing to core/updates

Thankyou!
Comment 12 Marja van Waes 2011-10-08 16:18:59 CEST
(In reply to comment #11)
> Thankyou Marja and isadora!
> 
> Can we call on you again for future updates please?
> 

When they are as easy to test as this one: sure!
Comment 13 isadora 2011-10-08 16:21:20 CEST
As Marja said ;-)
Comment 14 claire robinson 2011-10-08 16:49:16 CEST
Thankyou :)

It is mainly having the right hardware to test with.

Sysadmin please push with details in comment 11

Thanks!
Comment 15 D Morgan 2011-10-08 23:44:32 CEST
update pushed.
Comment 16 Jari S 2011-10-09 08:57:25 CEST
Photosmart Prem C310 series works fine, both scanning and printing.

Note You need to log in before you can comment on or make changes to this bug.