Bug 27677 - Update request: openafs-1.8.6-2.mga7
Summary: Update request: openafs-1.8.6-2.mga7
Status: NEW
Alias: None
Product: Mageia
Classification: Unclassified
Component: RPM Packages (show other bugs)
Version: 7
Hardware: All Linux
Priority: High major
Target Milestone: ---
Assignee: QA Team
QA Contact:
URL:
Whiteboard:
Keywords:
: 27431 (view as bug list)
Depends on:
Blocks:
 
Reported: 2020-11-28 21:19 CET by Thomas Backlund
Modified: 2021-01-10 19:01 CET (History)
3 users (show)

See Also:
Source RPM: openafs
CVE:
Status comment:


Attachments

Description Thomas Backlund 2020-11-28 21:19:13 CET
OpenAFS updated to 1.9.0 for kernel 5.9 support

SRPMS:
openafs-1.9.0-1.mga7.src.rpm

i586:
dkms-libafs-1.9.0-1.mga7.noarch.rpm
libopenafs2-1.9.0-1.mga7.i586.rpm
libopenafs-devel-1.9.0-1.mga7.i586.rpm
libopenafs-static-devel-1.9.0-1.mga7.i586.rpm
openafs-1.9.0-1.mga7.i586.rpm
openafs-client-1.9.0-1.mga7.i586.rpm
openafs-doc-1.9.0-1.mga7.noarch.rpm
openafs-server-1.9.0-1.mga7.i586.rpm

x86_64:
dkms-libafs-1.9.0-1.mga7.noarch.rpm
lib64openafs2-1.9.0-1.mga7.x86_64.rpm
lib64openafs-devel-1.9.0-1.mga7.x86_64.rpm
lib64openafs-static-devel-1.9.0-1.mga7.x86_64.rpm
openafs-1.9.0-1.mga7.x86_64.rpm
openafs-client-1.9.0-1.mga7.x86_64.rpm
openafs-doc-1.9.0-1.mga7.noarch.rpm
openafs-server-1.9.0-1.mga7.x86_64.rpm
Comment 1 David Walser 2020-11-28 21:59:16 CET
*** Bug 27431 has been marked as a duplicate of this bug. ***

CC: (none) => luigiwalser

Comment 3 Thomas Backlund 2020-11-28 22:14:27 CET
(In reply to David Walser from comment #1)
> *** Bug 27431 has been marked as a duplicate of this bug. ***

Ah, didn-t see that one... sorry about that...

And now when reading that I realized that I missed this is a dev version :/
Gah, I should not be so fast sometimes..


I see in the stable branch:
http://git.openafs.org/?p=openafs.git;a=shortlog;h=refs/heads/openafs-stable-1_8_x

are fixes for linux 5.9...

I think I'll rollback to stable 1.8.6 + fixes for mga7...

But I'll let 1.9. be in Cauldron, and we'll roll that up to stable 2.0 when it happends..

Keywords: (none) => feedback

Comment 4 David Walser 2020-11-28 22:16:05 CET
Sounds like a good plan.
Comment 5 Thomas Backlund 2020-11-28 23:18:50 CET
So that is now 1.8.6 + all fixes from upstream openafs-stable-1_8_x branch


SRPM:
openafs-1.8.6-2.mga7.src.rpm


i586:
dkms-libafs-1.8.6-2.mga7.noarch.rpm
libopenafs2-1.8.6-2.mga7.i586.rpm
libopenafs-devel-1.8.6-2.mga7.i586.rpm
libopenafs-static-devel-1.8.6-2.mga7.i586.rpm
openafs-1.8.6-2.mga7.i586.rpm
openafs-client-1.8.6-2.mga7.i586.rpm
openafs-doc-1.8.6-2.mga7.noarch.rpm
openafs-server-1.8.6-2.mga7.i586.rpm


x86_64:
dkms-libafs-1.8.6-2.mga7.noarch.rpm
lib64openafs2-1.8.6-2.mga7.x86_64.rpm
lib64openafs-devel-1.8.6-2.mga7.x86_64.rpm
lib64openafs-static-devel-1.8.6-2.mga7.x86_64.rpm
openafs-1.8.6-2.mga7.x86_64.rpm
openafs-client-1.8.6-2.mga7.x86_64.rpm
openafs-doc-1.8.6-2.mga7.noarch.rpm
openafs-server-1.8.6-2.mga7.x86_64.rpm

Summary: Update request: openafs-1.9.0-1.mga7 => Update request: openafs-1.8.6-2.mga7
Keywords: feedback => (none)

Comment 6 Herman Viaene 2020-12-05 17:44:55 CET
MGA7-64 MATE on Peaq C1011
No installation issues
Tried to follow Len's tests in bug 27053, but hardly understood all the implications of these, so did also some of my  own from bug 25816.
# systemctl start openafs-server

# systemctll status openafs-server
-bash: systemctll: command not found
[root@mach6 ~]# systemctl -l status openafs-server
● openafs-server.service - OpenAFS Server Service
   Loaded: loaded (/usr/lib/systemd/system/openafs-server.service; disabled; vendor preset: disabled)
   Active: active (running) since Sat 2020-12-05 15:54:12 CET; 49s ago
 Main PID: 6422 (bosserver)
    Tasks: 1 (limit: 2288)
   Memory: 5.3M
   CGroup: /system.slice/openafs-server.service
           └─6422 /usr/sbin/bosserver -nofork

Dec 05 15:54:12 mach6.hviaene.thuis systemd[1]: Started OpenAFS Server Service.

# ls /etc/openafs
bosserver.rxbind  cacheinfo  CellServDB  CellServDB.dist  CellServDB.local  server/  ThisCell

# systemctl start openafs-client

# systemctl -l status openafs-client
● openafs-client.service - OpenAFS Client Service
   Loaded: loaded (/usr/lib/systemd/system/openafs-client.service; disabled; vendor preset: disabled)
   Active: active (running) since Sat 2020-12-05 15:58:54 CET; 51s ago
  Process: 6647 ExecStartPre=/bin/sed -n w/etc/openafs/CellServDB /etc/openafs/CellServDB.local /etc/openafs/CellServDB.dist (code=exited, sta>
  Process: 6648 ExecStartPre=/bin/chmod 0644 /etc/openafs/CellServDB (code=exited, status=0/SUCCESS)
  Process: 6649 ExecStartPre=/sbin/modprobe libafs (code=exited, status=0/SUCCESS)
  Process: 6652 ExecStart=/sbin/afsd $AFSD_ARGS (code=exited, status=0/SUCCESS)
 Main PID: 6661 (afsd)
    Tasks: 1 (limit: 2288)
   Memory: 8.2M
   CGroup: /system.slice/openafs-client.service
           └─6661 /sbin/afsd -dynroot -fakestat -afsdb

Dec 05 15:58:54 mach6.hviaene.thuis systemd[1]: Starting OpenAFS Client Service...
Dec 05 15:58:54 mach6.hviaene.thuis afsd[6652]: afsd: All AFS daemons started.
Dec 05 15:58:54 mach6.hviaene.thuis afsd[6652]: afsd: All AFS daemons started.
Dec 05 15:58:54 mach6.hviaene.thuis systemd[1]: Started OpenAFS Client Service.

# bos listhosts mach6.hviaene.thuis -localauth
bos: running unauthenticated
Cell name is localcell
    Host 1 is mach6.hviaene.thuis

As normal user
$ ls /afs
acm-csuf.org/                 eng.utah.edu/                  laroia.net/                   p-ng.si/
acm.jhu.edu/                  epfl.ch/                       lcp.nrl.navy.mil/             psc.edu/
adrake.org/                   epitech.net/                   le.infn.it/                   psi.ch/
afs.ietfng.org/               es.net/                        lnf.infn.it/                  psm.it/
and more ......

$ cd /afs/openstack.org
$ ls
developer-docs/  docs/  docs-old/  mirror/  project/  service/  user/

# afsio help
afsio: Commands are:
append          append to a file in AFS
apropos         search by help text
etc ....
# cmdebug -help
Usage: cmdebug -servers <server machine> [-port <IP port>] [-long]
         [-refcounts] [-callbacks] [-ctime] [-addrs] [-cache] [-cellservdb]
         [-help]
etc ....

# cd /etc/openafs
# ll
total 96
-rw-r--r-- 1 root root    10 Dec  5 15:54 bosserver.rxbind
-rw-r--r-- 1 root root    31 Nov 28 23:06 cacheinfo
-rw-r--r-- 1 root root 37197 Dec  5 15:58 CellServDB
-rw-r--r-- 1 root root 37197 Nov 28 23:06 CellServDB.dist
-rw-r--r-- 1 root root     0 Dec  5 15:46 CellServDB.local
drwxr-xr-x 2 root root  4096 Dec  5 15:54 server/
-rw-r--r-- 1 root root    12 Nov 28 23:06 ThisCell

# wget http://dl.central.org/dl/cellservdb/CellServDB
--2020-12-05 17:23:19--  http://dl.central.org/dl/cellservdb/CellServDB
Resolving dl.central.org (dl.central.org)... 128.2.13.212
Connecting to dl.central.org (dl.central.org)|128.2.13.212|:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 35258 (34K)
Saving to: ‘CellServDB.1’

CellServDB.1                        100%[==================================================================>]  34.43K  --.-KB/s    in 0.1s    

2020-12-05 17:23:20 (352 KB/s) - ‘CellServDB.1’ saved [35258/35258]

# echo grand.central.org > /etc/openafs/ThisCell
# df /var/cache/openafs
Filesystem      Size  Used Avail Use% Mounted on
/dev/mmcblk1p2   15G  7.7G  6.0G  57% /
# df -h | grep -i afs
AFS             2.0T     0  2.0T   0% /afs
# df -h | grep mmc
/dev/mmcblk1p2   15G  7.7G  6.0G  57% /
/dev/mmcblk1p4  7.7G  850M  6.8G  11% /home
/dev/mmcblk1p1  499M  196K  498M   1% /boot/EFI

Looks all very much similar to previous tests, so OK for me

Whiteboard: (none) => MGA7-64-OK
CC: (none) => herman.viaene

Comment 7 David Walser 2020-12-05 18:20:31 CET
Hi Herman, I just wanted to make sure you tested this with kernel 5.9.x.
Comment 8 Herman Viaene 2020-12-06 11:06:47 CET
No, it was 5.7.19. Besides, I haven't noticed 5.9 in this list. I don't look at it every day, but still..........
Herman Viaene 2020-12-06 11:06:58 CET

Whiteboard: MGA7-64-OK => (none)

Comment 9 Thomas Backlund 2020-12-06 11:13:18 CET
(In reply to Herman Viaene from comment #8)
> No, it was 5.7.19. Besides, I haven't noticed 5.9 in this list. I don't look
> at it every day, but still..........

Yeah, kernel-5.9.12-1.mga7 is in updates_testing, but not assigned to QA yet as I still need to fix nvidia-current driver.


But as long as you dont rely on nvidia-current, you can update to 5.9.12 as we are using the same kernel in current beta2 isos...
Comment 10 Thomas Backlund 2020-12-26 22:59:05 CET
I've just tested that this one still builds ok with kernel-5.10.3-1.mga7 tracked in bug 27938
Aurelien Oudelet 2021-01-10 19:01:10 CET

Priority: Normal => High
CC: (none) => ouaurelien
Severity: normal => major


Note You need to log in before you can comment on or make changes to this bug.