Bug 27007 - In Plasma, the Firefox menu entry should not be under the "Plus" submenu of the Internet menu
Summary: In Plasma, the Firefox menu entry should not be under the "Plus" submenu of t...
Status: RESOLVED FIXED
Alias: None
Product: Mageia
Classification: Unclassified
Component: RPM Packages (show other bugs)
Version: 7
Hardware: All Linux
Priority: Low normal
Target Milestone: ---
Assignee: KDE maintainers
QA Contact:
URL:
Whiteboard: MGA7TOO, fixed in CAULDRON
Keywords: Triaged
Depends on:
Blocks:
 
Reported: 2020-07-26 19:47 CEST by Frédéric "LpSolit" Buclin
Modified: 2020-09-19 18:10 CEST (History)
3 users (show)

See Also:
Source RPM: firefox-68.12-2.mga7.src.rpm
CVE:
Status comment:


Attachments
screenshot (300.56 KB, image/png)
2020-07-26 19:47 CEST, Frédéric "LpSolit" Buclin
Details

Description Frédéric "LpSolit" Buclin 2020-07-26 19:47:48 CEST
Created attachment 11770 [details]
screenshot

See the screenshot: the Firefox entry appears under the "Plus" submenu. It should be one level higher, with other apps.
Comment 1 Aurelien Oudelet 2020-07-27 16:52:15 CEST
I reproduce this bug.

Eagle eyes, that is not on top Network menu.

But, by default, firefox is pinned on bookmarks at left on top Plasma Kicker menu, as you can see in attached screenshot.

CC: (none) => ouaurelien

Comment 2 Frédéric "LpSolit" Buclin 2020-07-27 16:53:34 CEST
(In reply to Aurelien Oudelet from comment #1)
> But, by default, firefox is pinned on bookmarks at left on top Plasma Kicker
> menu, as you can see in attached screenshot.

I know, but such a popular application shouldn't be in a submenu. :)
Comment 3 Aurelien Oudelet 2020-07-27 16:57:01 CEST
Add Lewis in order to transmit to devs.

CC: (none) => lewyssmith

Comment 4 Lewis Smith 2020-07-27 21:51:48 CEST
Thank you Frédéric for the screenshot; it often helps a lot to 'see' the problem.

"In Plasma, the Firefox link should not be under the "Plus" submenu"
Why not? Does it matter?
This is not a bug. The first level menu in Plasma systems shows principally Plasma/KDE applications; most others are put in the 'more' sub-menu. I just changed to Plasma to check...
In your screenshot, the most obvious non Plasma/KDE Internet application in the first menu is FileZilla. For the rest...
It is true that some major (& lesser) non-KDE/Plasma applications show up in the first menu (e.g. Gimp, all LibreOffice, VLC). I do not think this warrants being a bug (close invalid), but let it through in case a kind person chooses to put Firefox at the same menu level as the other major non-KDE examples cited.

The new browser to replace Konqueror is Falkon, which I recommend. Perversely, this is in the 'more' sub-menu!

Assignee: bugsquad => kde
Priority: Normal => Low
Severity: normal => enhancement
Summary: In Plasma, the Firefox link should not be under the "Plus" submenu => In Plasma, the Firefox menu entry should not be under the "Plus" submenu of the Internet menu

Comment 5 David GEIGER 2020-08-01 13:33:39 CEST
Should be fixed with latest firefox-78.1.0-1.mga8 update!

CC: (none) => geiger.david68210

Comment 6 Lewis Smith 2020-08-01 20:35:31 CEST
Thank you yet again David for making yet another customer happy!

@Frédéric : when you get the Firefox update, please confirm that it answers your complaint. I am closing the bug fixed in anticipation; it can be re-opened if necessary.

Resolution: (none) => FIXED
Status: NEW => RESOLVED

Comment 7 Frédéric "LpSolit" Buclin 2020-08-03 16:11:44 CEST
(In reply to Lewis Smith from comment #6)
> @Frédéric : when you get the Firefox update, please confirm that it answers
> your complaint.

Yes, this is fine now, thanks!
Comment 8 Aurelien Oudelet 2020-09-07 22:02:14 CEST
Thanks you Lewis and all, but we should reopen this as it is also affect Mageia 7.1.
We could do it, as Mageia 8 is not already published.

Suggested Advisory:
========================

Updated firefox packages fix wrong application place in Plasma Application menu

On Plasma Workspace Environment, the firefox application is located in a Plus sub-menu in Internet section of Menu applications. The updated firefox package puts the shortcut on the top level of the Internet menu like Mozilla Thunderbird is already if installed.



========================
Proposed SRPM version
firefox-68.12-3.mga7.src.rpm

Keywords: (none) => Triaged
Whiteboard: (none) => MGA7TOO, fixed in CAULDRON
Assignee: kde => qa-bugs
Severity: enhancement => normal
Resolution: FIXED => (none)
Target Milestone: --- => Mageia 7
Version: Cauldron => 7
Status: RESOLVED => REOPENED
Source RPM: firefox-78.0.2-1.mga8.src.rpm => firefox-68.12-2.mga7.src.rpm

Aurelien Oudelet 2020-09-07 22:02:29 CEST

Assignee: qa-bugs => kde

Comment 9 Frédéric "LpSolit" Buclin 2020-09-08 00:58:04 CEST
(In reply to Aurelien Oudelet from comment #8)
> Thanks you Lewis and all, but we should reopen this as it is also affect
> Mageia 7.1.
> We could do it, as Mageia 8 is not already published.


I think it's way too late to change this in Mageia 7. Let's keep it for Mageia 8 only.
Comment 10 Aurelien Oudelet 2020-09-19 18:10:59 CEST
(In reply to Frédéric "LpSolit" Buclin from comment #9)
> (In reply to Aurelien Oudelet from comment #8)
> > Thanks you Lewis and all, but we should reopen this as it is also affect
> > Mageia 7.1.
> > We could do it, as Mageia 8 is not already published.
> 
> 
> I think it's way too late to change this in Mageia 7. Let's keep it for
> Mageia 8 only.

Status: REOPENED => RESOLVED
Resolution: (none) => FIXED
Target Milestone: Mageia 7 => ---


Note You need to log in before you can comment on or make changes to this bug.