Bug 26641 - libreoffice new security issue CVE-2020-12801
Summary: libreoffice new security issue CVE-2020-12801
Status: NEW
Alias: None
Product: Mageia
Classification: Unclassified
Component: Security (show other bugs)
Version: 7
Hardware: All Linux
Priority: Normal normal
Target Milestone: ---
Assignee: QA Team
QA Contact: Sec team
URL: https://www.libreoffice.org/about-us/...
Whiteboard:
Keywords:
: 26166 (view as bug list)
Depends on: 26672
Blocks:
  Show dependency treegraph
 
Reported: 2020-05-19 12:41 CEST by papoteur
Modified: 2020-06-03 14:30 CEST (History)
8 users (show)

See Also:
Source RPM: libreoffice-6.2.8.2-1.mga7.src.rpm
CVE:
Status comment:


Attachments
Package list for 64-bit machine (1.36 KB, text/plain)
2020-05-22 10:35 CEST, Len Lawrence
Details

Description papoteur 2020-05-19 12:41:16 CEST
Crash-recovered MSOffice encrypted documents defaulted to not to using encryption on next save

Announced: May 28, 2020

Fixed in: 6.3.6/6.4.3

Description:

If LibreOffice has an encrypted document open and crashes, that document is auto-saved encrypted. On restart, LibreOffice offers to restore the document and prompts for the password to decrypt it. If the recovery is successful, and if the file format of the recovered document was not LibreOffice's default ODF file format, then affected versions of LibreOffice default that subsequent saves of the document are unencrypted.
 
This may lead to a user accidentally saving a MSOffice file format document unencrypted while believing it to be encrypted.

In the fixed versions, encrypted recovered MSOffice format documents default to encrypted save.
papoteur 2020-05-19 12:41:55 CEST

Whiteboard: (none) => MGA7TOO

papoteur 2020-05-19 14:40:16 CEST

Summary: libreoffice => libreoffice new security issue CVE-2020-12801
Source RPM: libreoffice new security issue CVE => libreoffice

David Walser 2020-05-19 22:12:43 CEST

Source RPM: libreoffice => libreoffice-6.2.8.2-1.mga7.src.rpm
Component: RPM Packages => Security
Whiteboard: MGA7TOO => (none)
QA Contact: (none) => security
Version: Cauldron => 7
Status comment: (none) => Fixed upstream in 6.3.6

Comment 1 Nicolas Lécureuil 2020-05-20 18:40:07 CEST
rpms:

libabw1-0.1.3-1.mga7
libabw-devel-0.1.3-1.mga7
libabw-doc-0.1.3-1.mga7
libabw-tools-0.1.3-1.mga7
libabw-debugsource-0.1.3-1.mga7
libabw-debuginfo-0.1.3-1.mga7
libabw1-debuginfo-0.1.3-1.mga7
libabw-tools-debuginfo-0.1.3-1.mga7
libcdr0.1_1-0.1.6-1.mga7
libcdr-devel-0.1.6-1.mga7
libcdr-doc-0.1.6-1.mga7
libcdr-tools-0.1.6-1.mga7
libcdr-debugsource-0.1.6-1.mga7
libcdr-debuginfo-0.1.6-1.mga7
libcdr0.1_1-debuginfo-0.1.6-1.mga7
libcdr-tools-debuginfo-0.1.6-1.mga7
libmwaw0.3_3-0.3.16-1.mga7
libmwaw0.3-devel-0.3.16-1.mga7
libmwaw-doc-0.3.16-1.mga7
libmwaw-tools-0.3.16-1.mga7
libmwaw-debugsource-0.3.16-1.mga7
libmwaw-debuginfo-0.3.16-1.mga7
libmwaw0.3_3-debuginfo-0.3.16-1.mga7
libmwaw-tools-debuginfo-0.3.16-1.mga7
libvisio0.1_1-0.1.7-1.mga7
libvisio-devel-0.1.7-1.mga7
libvisio-doc-0.1.7-1.mga7
libvisio-tools-0.1.7-1.mga7
libvisio-debugsource-0.1.7-1.mga7
libvisio-debuginfo-0.1.7-1.mga7
libvisio0.1_1-debuginfo-0.1.7-1.mga7
libvisio-tools-debuginfo-0.1.7-1.mga7
libwps-devel-0.4.11-1.mga7
libwps-tools-0.4.11-1.mga7
libwps0.4_4-0.4.11-1.mga7
libwps-doc-0.4.11-1.mga7
libwps-debugsource-0.4.11-1.mga7
libwps-debuginfo-0.4.11-1.mga7
libwps-tools-debuginfo-0.4.11-1.mga7
libwps0.4_4-debuginfo-0.4.11-1.mga7
libqrcodegen1-1.5.0-6.mga7
libqrcodegen-devel-1.5.0-6.mga7
libqrcodegencpp1-1.5.0-6.mga7
libqrcodegencpp-devel-1.5.0-6.mga7
python3-qrcodegen-1.5.0-6.mga7
qr-code-generator-debugsource-1.5.0-6.mga7
qr-code-generator-debuginfo-1.5.0-6.mga7
libqrcodegen1-debuginfo-1.5.0-6.mga7
libqrcodegencpp1-debuginfo-1.5.0-6.mga7
mdds-devel-1.5.0-1.mga7
libfmt-devel-6.2.1-1.mga7
libfmt6-6.2.1-1.mga7
fmt-debugsource-6.2.1-1.mga7
libfmt6-debuginfo-6.2.1-1.mga7
libspdlog-devel-1.6.0-1.mga7
libspdlog1-1.6.0-1.mga7
spdlog-debugsource-1.6.0-1.mga7
libspdlog1-debuginfo-1.6.0-1.mga7
libixion0.15_0-0.15.0-6.mga7
libixion-devel-0.15.0-6.mga7
libixion-tools-0.15.0-6.mga7
python3-libixion-0.15.0-6.mga7
libixion-doc-0.15.0-6.mga7
libixion-debugsource-0.15.0-6.mga7
libixion-debuginfo-0.15.0-6.mga7
libixion0.15_0-debuginfo-0.15.0-6.mga7
libixion-tools-debuginfo-0.15.0-6.mga7
python3-libixion-debuginfo-0.15.0-6.mga7
liborcus0.15_0-0.15.3-4.mga7
liborcus-devel-0.15.3-4.mga7
liborcus-tools-0.15.3-4.mga7
liborcus-python3-0.15.3-4.mga7
liborcus-doc-0.15.3-4.mga7
liborcus-debugsource-0.15.3-4.mga7
liborcus-debuginfo-0.15.3-4.mga7
liborcus0.15_0-debuginfo-0.15.3-4.mga7
liborcus-tools-debuginfo-0.15.3-4.mga7
liborcus-python3-debuginfo-0.15.3-4.mga7


From:
libabw-0.1.3-1.mga7
libcdr-0.1.6-1.mga7
libmwaw-0.3.16-1.mga7
libvisio-0.1.7-1.mga7
libwps-0.4.11-1.mga7
libixion-0.15.0-6.mga7
mdds-1.5.0-1.mga7
fmt-6.2.1-1.mga7
spdlog-1.6.0-1.mga7
qr-code-generator-1.5.0-6.mga7

CC: (none) => mageia

Nicolas Lécureuil 2020-05-20 18:41:39 CEST

Assignee: bugsquad => mageia

Comment 3 David Walser 2020-05-20 21:24:32 CEST
Also (since we're going for 6.4.4 now):
https://wiki.documentfoundation.org/ReleaseNotes/6.4
Comment 4 Nicolas Lécureuil 2020-05-21 10:57:44 CEST
Advisory:
This update increase Libreoffice to version 6.4.4.2
It fixes Security issues and add kf5 support.

If LibreOffice has an encrypted document open and crashes, that document is auto-saved encrypted. On restart, LibreOffice offers to restore the document and prompts for the password to decrypt it. If the recovery is successful, and if the file format of the recovered document was not LibreOffice's default ODF file format, then affected versions of LibreOffice default that subsequent saves of the document are unencrypted.
 
This may lead to a user accidentally saving a MSOffice file format document unencrypted while believing it to be encrypted.

In the fixed versions, encrypted recovered MSOffice format documents default to encrypted save.


References:
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2020-12801
https://www.libreoffice.org/about-us/security/advisories/cve-2020-12801/
https://wiki.documentfoundation.org/ReleaseNotes/6.4

rpms:

libabw1-0.1.3-1.mga7
libabw-devel-0.1.3-1.mga7
libabw-doc-0.1.3-1.mga7
libabw-tools-0.1.3-1.mga7
libabw-debugsource-0.1.3-1.mga7
libabw-debuginfo-0.1.3-1.mga7
libabw1-debuginfo-0.1.3-1.mga7
libabw-tools-debuginfo-0.1.3-1.mga7
libcdr0.1_1-0.1.6-1.mga7
libcdr-devel-0.1.6-1.mga7
libcdr-doc-0.1.6-1.mga7
libcdr-tools-0.1.6-1.mga7
libcdr-debugsource-0.1.6-1.mga7
libcdr-debuginfo-0.1.6-1.mga7
libcdr0.1_1-debuginfo-0.1.6-1.mga7
libcdr-tools-debuginfo-0.1.6-1.mga7
libmwaw0.3_3-0.3.16-1.mga7
libmwaw0.3-devel-0.3.16-1.mga7
libmwaw-doc-0.3.16-1.mga7
libmwaw-tools-0.3.16-1.mga7
libmwaw-debugsource-0.3.16-1.mga7
libmwaw-debuginfo-0.3.16-1.mga7
libmwaw0.3_3-debuginfo-0.3.16-1.mga7
libmwaw-tools-debuginfo-0.3.16-1.mga7
libvisio0.1_1-0.1.7-1.mga7
libvisio-devel-0.1.7-1.mga7
libvisio-doc-0.1.7-1.mga7
libvisio-tools-0.1.7-1.mga7
libvisio-debugsource-0.1.7-1.mga7
libvisio-debuginfo-0.1.7-1.mga7
libvisio0.1_1-debuginfo-0.1.7-1.mga7
libvisio-tools-debuginfo-0.1.7-1.mga7
libwps-devel-0.4.11-1.mga7
libwps-tools-0.4.11-1.mga7
libwps0.4_4-0.4.11-1.mga7
libwps-doc-0.4.11-1.mga7
libwps-debugsource-0.4.11-1.mga7
libwps-debuginfo-0.4.11-1.mga7
libwps-tools-debuginfo-0.4.11-1.mga7
libwps0.4_4-debuginfo-0.4.11-1.mga7
libqrcodegen1-1.5.0-6.mga7
libqrcodegen-devel-1.5.0-6.mga7
libqrcodegencpp1-1.5.0-6.mga7
libqrcodegencpp-devel-1.5.0-6.mga7
python3-qrcodegen-1.5.0-6.mga7
qr-code-generator-debugsource-1.5.0-6.mga7
qr-code-generator-debuginfo-1.5.0-6.mga7
libqrcodegen1-debuginfo-1.5.0-6.mga7
libqrcodegencpp1-debuginfo-1.5.0-6.mga7
mdds-devel-1.5.0-1.mga7
libfmt-devel-6.2.1-1.mga7
libfmt6-6.2.1-1.mga7
fmt-debugsource-6.2.1-1.mga7
libfmt6-debuginfo-6.2.1-1.mga7
libspdlog-devel-1.6.0-1.mga7
libspdlog1-1.6.0-1.mga7
spdlog-debugsource-1.6.0-1.mga7
libspdlog1-debuginfo-1.6.0-1.mga7
libixion0.15_0-0.15.0-6.mga7
libixion-devel-0.15.0-6.mga7
libixion-tools-0.15.0-6.mga7
python3-libixion-0.15.0-6.mga7
libixion-doc-0.15.0-6.mga7
libixion-debugsource-0.15.0-6.mga7
libixion-debuginfo-0.15.0-6.mga7
libixion0.15_0-debuginfo-0.15.0-6.mga7
libixion-tools-debuginfo-0.15.0-6.mga7
python3-libixion-debuginfo-0.15.0-6.mga7
liborcus0.15_0-0.15.3-4.mga7
liborcus-devel-0.15.3-4.mga7
liborcus-tools-0.15.3-4.mga7
liborcus-python3-0.15.3-4.mga7
liborcus-doc-0.15.3-4.mga7
liborcus-debugsource-0.15.3-4.mga7
liborcus-debuginfo-0.15.3-4.mga7
liborcus0.15_0-debuginfo-0.15.3-4.mga7
liborcus-tools-debuginfo-0.15.3-4.mga7
liborcus-python3-debuginfo-0.15.3-4.mga7
libreoffice-6.4.4.2-1.mga7
libreoffice-filters-6.4.4.2-1.mga7
libreoffice-core-6.4.4.2-1.mga7
libreoffice-pyuno-6.4.4.2-1.mga7
libreoffice-base-6.4.4.2-1.mga7
libreoffice-bsh-6.4.4.2-1.mga7
libreoffice-rhino-6.4.4.2-1.mga7
libreoffice-officebean-6.4.4.2-1.mga7
libreoffice-officebean-common-6.4.4.2-1.mga7
libreoffice-wiki-publisher-6.4.4.2-1.mga7
libreoffice-nlpsolver-6.4.4.2-1.mga7
libreoffice-ogltrans-6.4.4.2-1.mga7
libreoffice-pdfimport-6.4.4.2-1.mga7
libreoffice-opensymbol-fonts-6.4.4.2-1.mga7
libreoffice-writer-6.4.4.2-1.mga7
libreoffice-emailmerge-6.4.4.2-1.mga7
libreoffice-calc-6.4.4.2-1.mga7
libreoffice-draw-6.4.4.2-1.mga7
libreoffice-impress-6.4.4.2-1.mga7
libreoffice-math-6.4.4.2-1.mga7
libreoffice-graphicfilter-6.4.4.2-1.mga7
libreoffice-xsltfilter-6.4.4.2-1.mga7
libreoffice-postgresql-6.4.4.2-1.mga7
libreoffice-ure-6.4.4.2-1.mga7
libreoffice-ure-common-6.4.4.2-1.mga7
libreoffice-sdk-6.4.4.2-1.mga7
libreoffice-sdk-doc-6.4.4.2-1.mga7
libreoffice-glade-6.4.4.2-1.mga7
libreoffice-librelogo-6.4.4.2-1.mga7
libreoffice-data-6.4.4.2-1.mga7
libreoffice-x11-6.4.4.2-1.mga7
libreoffice-gtk3-6.4.4.2-1.mga7
libreoffice-kde5-6.4.4.2-1.mga7
libreoffice-kf5-6.4.4.2-1.mga7
libreofficekit-6.4.4.2-1.mga7
libreofficekit-devel-6.4.4.2-1.mga7
libreoffice-gdb-debug-support-6.4.4.2-1.mga7
libreoffice-langpack-en-6.4.4.2-1.mga7
libreoffice-help-en-6.4.4.2-1.mga7
autocorr-en-6.4.4.2-1.mga7
libreoffice-debugsource-6.4.4.2-1.mga7
libreoffice-debuginfo-6.4.4.2-1.mga7
libreoffice-core-debuginfo-6.4.4.2-1.mga7
libreoffice-pyuno-debuginfo-6.4.4.2-1.mga7
libreoffice-base-debuginfo-6.4.4.2-1.mga7
libreoffice-officebean-debuginfo-6.4.4.2-1.mga7
libreoffice-ogltrans-debuginfo-6.4.4.2-1.mga7
libreoffice-pdfimport-debuginfo-6.4.4.2-1.mga7
libreoffice-writer-debuginfo-6.4.4.2-1.mga7
libreoffice-calc-debuginfo-6.4.4.2-1.mga7
libreoffice-impress-debuginfo-6.4.4.2-1.mga7
libreoffice-math-debuginfo-6.4.4.2-1.mga7
libreoffice-graphicfilter-debuginfo-6.4.4.2-1.mga7
libreoffice-postgresql-debuginfo-6.4.4.2-1.mga7
libreoffice-ure-debuginfo-6.4.4.2-1.mga7
libreoffice-sdk-debuginfo-6.4.4.2-1.mga7
libreoffice-glade-debuginfo-6.4.4.2-1.mga7
libreoffice-x11-debuginfo-6.4.4.2-1.mga7
libreoffice-gtk3-debuginfo-6.4.4.2-1.mga7
libreoffice-kde5-debuginfo-6.4.4.2-1.mga7
libreoffice-kf5-debuginfo-6.4.4.2-1.mga7
libreofficekit-debuginfo-6.4.4.2-1.mga7

From:
libabw-0.1.3-1.mga7
libcdr-0.1.6-1.mga7
libmwaw-0.3.16-1.mga7
libvisio-0.1.7-1.mga7
libwps-0.4.11-1.mga7
libixion-0.15.0-6.mga7
mdds-1.5.0-1.mga7
fmt-6.2.1-1.mga7
spdlog-1.6.0-1.mga7
qr-code-generator-1.5.0-6.mga7
libreoffice-6.4.4.2-1.mga7

Assignee: mageia => qa-bugs
Status comment: Fixed upstream in 6.3.6 => (none)

Comment 5 Jose Manuel López 2020-05-21 13:51:38 CEST
I reported a few days ago in the bug: https://bugs.mageia.org/show_bug.cgi?id=26166, that we already have in Mga7 to libreoffice out of support according to its official website.

The stable version for business environments is in 6.3.6.

If you are updating to the new version, it will be good to close the two bugs.

CC: (none) => joselp

Comment 6 Thomas Andrews 2020-05-21 14:17:34 CEST
(In reply to Jose Manuel López from comment #5)
> I reported a few days ago in the bug:
> https://bugs.mageia.org/show_bug.cgi?id=26166, that we already have in Mga7
> to libreoffice out of support according to its official website.
> 
> The stable version for business environments is in 6.3.6.
> 
> If you are updating to the new version, it will be good to close the two
> bugs.

Wait for that until this one is tested and pushed. Once that happens, the bugs can be closed as no longer valid.

CC: (none) => andrewsfarm

Comment 7 David Walser 2020-05-21 14:38:59 CEST
The release notes for 6.3 should also be in the advisory.
Comment 8 Nicolas Lécureuil 2020-05-21 15:06:42 CEST
*** Bug 26166 has been marked as a duplicate of this bug. ***
Morgan Leijström 2020-05-21 15:16:49 CEST

CC: (none) => fri

Comment 9 Nicolas Lécureuil 2020-05-21 15:44:06 CEST
Advisory:
This update increase Libreoffice to version 6.4.4.2
It fixes Security issues and add kf5 support.

If LibreOffice has an encrypted document open and crashes, that document is auto-saved encrypted. On restart, LibreOffice offers to restore the document and prompts for the password to decrypt it. If the recovery is successful, and if the file format of the recovered document was not LibreOffice's default ODF file format, then affected versions of LibreOffice default that subsequent saves of the document are unencrypted.
 
This may lead to a user accidentally saving a MSOffice file format document unencrypted while believing it to be encrypted.

In the fixed versions, encrypted recovered MSOffice format documents default to encrypted save.


References:
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2020-12801
https://www.libreoffice.org/about-us/security/advisories/cve-2020-12801/
https://wiki.documentfoundation.org/ReleaseNotes/6.3
https://wiki.documentfoundation.org/ReleaseNotes/6.4

rpms:

libabw1-0.1.3-1.mga7
libabw-devel-0.1.3-1.mga7
libabw-doc-0.1.3-1.mga7
libabw-tools-0.1.3-1.mga7
libabw-debugsource-0.1.3-1.mga7
libabw-debuginfo-0.1.3-1.mga7
libabw1-debuginfo-0.1.3-1.mga7
libabw-tools-debuginfo-0.1.3-1.mga7
libcdr0.1_1-0.1.6-1.mga7
libcdr-devel-0.1.6-1.mga7
libcdr-doc-0.1.6-1.mga7
libcdr-tools-0.1.6-1.mga7
libcdr-debugsource-0.1.6-1.mga7
libcdr-debuginfo-0.1.6-1.mga7
libcdr0.1_1-debuginfo-0.1.6-1.mga7
libcdr-tools-debuginfo-0.1.6-1.mga7
libmwaw0.3_3-0.3.16-1.mga7
libmwaw0.3-devel-0.3.16-1.mga7
libmwaw-doc-0.3.16-1.mga7
libmwaw-tools-0.3.16-1.mga7
libmwaw-debugsource-0.3.16-1.mga7
libmwaw-debuginfo-0.3.16-1.mga7
libmwaw0.3_3-debuginfo-0.3.16-1.mga7
libmwaw-tools-debuginfo-0.3.16-1.mga7
libvisio0.1_1-0.1.7-1.mga7
libvisio-devel-0.1.7-1.mga7
libvisio-doc-0.1.7-1.mga7
libvisio-tools-0.1.7-1.mga7
libvisio-debugsource-0.1.7-1.mga7
libvisio-debuginfo-0.1.7-1.mga7
libvisio0.1_1-debuginfo-0.1.7-1.mga7
libvisio-tools-debuginfo-0.1.7-1.mga7
libwps-devel-0.4.11-1.mga7
libwps-tools-0.4.11-1.mga7
libwps0.4_4-0.4.11-1.mga7
libwps-doc-0.4.11-1.mga7
libwps-debugsource-0.4.11-1.mga7
libwps-debuginfo-0.4.11-1.mga7
libwps-tools-debuginfo-0.4.11-1.mga7
libwps0.4_4-debuginfo-0.4.11-1.mga7
libqrcodegen1-1.5.0-6.mga7
libqrcodegen-devel-1.5.0-6.mga7
libqrcodegencpp1-1.5.0-6.mga7
libqrcodegencpp-devel-1.5.0-6.mga7
python3-qrcodegen-1.5.0-6.mga7
qr-code-generator-debugsource-1.5.0-6.mga7
qr-code-generator-debuginfo-1.5.0-6.mga7
libqrcodegen1-debuginfo-1.5.0-6.mga7
libqrcodegencpp1-debuginfo-1.5.0-6.mga7
mdds-devel-1.5.0-1.mga7
libfmt-devel-6.2.1-1.mga7
libfmt6-6.2.1-1.mga7
fmt-debugsource-6.2.1-1.mga7
libfmt6-debuginfo-6.2.1-1.mga7
libspdlog-devel-1.6.0-1.mga7
libspdlog1-1.6.0-1.mga7
spdlog-debugsource-1.6.0-1.mga7
libspdlog1-debuginfo-1.6.0-1.mga7
libixion0.15_0-0.15.0-6.mga7
libixion-devel-0.15.0-6.mga7
libixion-tools-0.15.0-6.mga7
python3-libixion-0.15.0-6.mga7
libixion-doc-0.15.0-6.mga7
libixion-debugsource-0.15.0-6.mga7
libixion-debuginfo-0.15.0-6.mga7
libixion0.15_0-debuginfo-0.15.0-6.mga7
libixion-tools-debuginfo-0.15.0-6.mga7
python3-libixion-debuginfo-0.15.0-6.mga7
liborcus0.15_0-0.15.3-4.mga7
liborcus-devel-0.15.3-4.mga7
liborcus-tools-0.15.3-4.mga7
liborcus-python3-0.15.3-4.mga7
liborcus-doc-0.15.3-4.mga7
liborcus-debugsource-0.15.3-4.mga7
liborcus-debuginfo-0.15.3-4.mga7
liborcus0.15_0-debuginfo-0.15.3-4.mga7
liborcus-tools-debuginfo-0.15.3-4.mga7
liborcus-python3-debuginfo-0.15.3-4.mga7
libreoffice-6.4.4.2-1.mga7
libreoffice-filters-6.4.4.2-1.mga7
libreoffice-core-6.4.4.2-1.mga7
libreoffice-pyuno-6.4.4.2-1.mga7
libreoffice-base-6.4.4.2-1.mga7
libreoffice-bsh-6.4.4.2-1.mga7
libreoffice-rhino-6.4.4.2-1.mga7
libreoffice-officebean-6.4.4.2-1.mga7
libreoffice-officebean-common-6.4.4.2-1.mga7
libreoffice-wiki-publisher-6.4.4.2-1.mga7
libreoffice-nlpsolver-6.4.4.2-1.mga7
libreoffice-ogltrans-6.4.4.2-1.mga7
libreoffice-pdfimport-6.4.4.2-1.mga7
libreoffice-opensymbol-fonts-6.4.4.2-1.mga7
libreoffice-writer-6.4.4.2-1.mga7
libreoffice-emailmerge-6.4.4.2-1.mga7
libreoffice-calc-6.4.4.2-1.mga7
libreoffice-draw-6.4.4.2-1.mga7
libreoffice-impress-6.4.4.2-1.mga7
libreoffice-math-6.4.4.2-1.mga7
libreoffice-graphicfilter-6.4.4.2-1.mga7
libreoffice-xsltfilter-6.4.4.2-1.mga7
libreoffice-postgresql-6.4.4.2-1.mga7
libreoffice-ure-6.4.4.2-1.mga7
libreoffice-ure-common-6.4.4.2-1.mga7
libreoffice-sdk-6.4.4.2-1.mga7
libreoffice-sdk-doc-6.4.4.2-1.mga7
libreoffice-glade-6.4.4.2-1.mga7
libreoffice-librelogo-6.4.4.2-1.mga7
libreoffice-data-6.4.4.2-1.mga7
libreoffice-x11-6.4.4.2-1.mga7
libreoffice-gtk3-6.4.4.2-1.mga7
libreoffice-kde5-6.4.4.2-1.mga7
libreoffice-kf5-6.4.4.2-1.mga7
libreofficekit-6.4.4.2-1.mga7
libreofficekit-devel-6.4.4.2-1.mga7
libreoffice-gdb-debug-support-6.4.4.2-1.mga7
libreoffice-langpack-en-6.4.4.2-1.mga7
libreoffice-help-en-6.4.4.2-1.mga7
autocorr-en-6.4.4.2-1.mga7
libreoffice-debugsource-6.4.4.2-1.mga7
libreoffice-debuginfo-6.4.4.2-1.mga7
libreoffice-core-debuginfo-6.4.4.2-1.mga7
libreoffice-pyuno-debuginfo-6.4.4.2-1.mga7
libreoffice-base-debuginfo-6.4.4.2-1.mga7
libreoffice-officebean-debuginfo-6.4.4.2-1.mga7
libreoffice-ogltrans-debuginfo-6.4.4.2-1.mga7
libreoffice-pdfimport-debuginfo-6.4.4.2-1.mga7
libreoffice-writer-debuginfo-6.4.4.2-1.mga7
libreoffice-calc-debuginfo-6.4.4.2-1.mga7
libreoffice-impress-debuginfo-6.4.4.2-1.mga7
libreoffice-math-debuginfo-6.4.4.2-1.mga7
libreoffice-graphicfilter-debuginfo-6.4.4.2-1.mga7
libreoffice-postgresql-debuginfo-6.4.4.2-1.mga7
libreoffice-ure-debuginfo-6.4.4.2-1.mga7
libreoffice-sdk-debuginfo-6.4.4.2-1.mga7
libreoffice-glade-debuginfo-6.4.4.2-1.mga7
libreoffice-x11-debuginfo-6.4.4.2-1.mga7
libreoffice-gtk3-debuginfo-6.4.4.2-1.mga7
libreoffice-kde5-debuginfo-6.4.4.2-1.mga7
libreoffice-kf5-debuginfo-6.4.4.2-1.mga7
libreofficekit-debuginfo-6.4.4.2-1.mga7

From:
libabw-0.1.3-1.mga7
libcdr-0.1.6-1.mga7
libmwaw-0.3.16-1.mga7
libvisio-0.1.7-1.mga7
libwps-0.4.11-1.mga7
libixion-0.15.0-6.mga7
mdds-1.5.0-1.mga7
fmt-6.2.1-1.mga7
spdlog-1.6.0-1.mga7
qr-code-generator-1.5.0-6.mga7
libreoffice-6.4.4.2-1.mga7
Comment 10 Jose Manuel López 2020-05-21 16:55:08 CEST
Hi, I have installed in Mga7-x64. No issues, Writer, Calc, Impress, Draw, works fine. And I have installed in Mga7-x64 in my real computer activating testing repositories. Works fine, Calc, dinamic tables, Writer, no issues. I have seen some interesting improvements in this version.

Greetings and Thanks!!
Comment 11 Len Lawrence 2020-05-22 10:35:17 CEST
Created attachment 11654 [details]
Package list for 64-bit machine

CC: (none) => tarazed25

Comment 12 Len Lawrence 2020-05-22 10:38:31 CEST
mga7, x86_64

Thanks Jose for those thorough tests.
For my own peace of mind I installed all of the packages except debuginfo before updating and then ran the update to confirm that it would run smoothly.  All OK.
Have attached a list of the specific package for this machine.
Comment 13 Herman Viaene 2020-05-22 14:23:40 CEST
MGA7-64 Plasma on Lenovo B50
Installation: I did not install the debug- and devel packages, and in this way I remarked that the libwps-doc needed the lib64wps-devel paackage. That was the only one in the whole series.
Continuing installation and testing.

CC: (none) => herman.viaene

Comment 14 Herman Viaene 2020-05-22 14:44:31 CEST
Tested with existing odt, doc, docx, ods, xls, xlsx, odpand odb files. All OK.
Comment 15 Thomas Andrews 2020-05-23 14:56:06 CEST
Tested on an HP Probook 6550b, 64-bit Plasma system.

Attempted to use the 64-bit list at http://madb.mageia.org/tools/listRpmsForQaBug/bugnum/26641/application/0 with qarepo. That list is either incomplete or out of date, as the result had several missing dependencies.

Attempted to use the package list provided by Len (thanks!) in qarepo as it is, but it needed the "*" wild card added to the end of each before it would work. Once I took care of that, I was able to proceed with the update.

Non-English testers should note that the only language packages listed in both Comment 9 and Len's list are for English. You will need to add the packages for your language. (autocorr, libreoffice-help, libreoffice-langpack)

Once I had a workable package list for qarepo, all packages installed cleanly. Tried several existing ods, doc, and odt files, all worked fine. No issues noted, but then I have never used all the features that Libreoffice has to offer.
Comment 16 Morgan Leijström 2020-05-24 02:41:26 CEST
Thanks for this great update!

OK 64 bit Plasma, Nvidia.  Only a bit of calc and writer yet though.

Quick thoughts:

Strange that the devel file lib64fmt-devel-6.2.1-1.mga7.x86_64 is required by lib64spdlog1 ?!

Some filters such as libreoffice-pdfimport gets installed bys just selecting libreoffice-6.4.4.2-1.mga7, but not some other filters like visio import, and qr code generator.

Makes me winder if we should make a libreoffice-full package for pulling all bell and whistle.  Or change package libreoffice to pull everything (except devel), and a new libreoffice-minimal skip a lot like now.
Comment 17 Morgan Leijström 2020-05-24 10:51:55 CEST
There is a small translation glitch in the dialogue that pops up if i try to close a document without saving first: all is in Swedish except the button "Don't save".

Do we have the latest translation fixes or is it a complete upstream issue?
Comment 18 PC LX 2020-05-25 00:02:25 CEST
Installed and tested without issues.

Tested with a bunch of files and file formats. I only use a small subset of features but those all worked. No issues or regressions noticed.


System: Mageia 7, x86_64, Plasma DE, LXQt DE, Intel CPU, nVidia GPU using nvidia340 proprietary driver.


$ uname -a
Linux marte 5.6.14-desktop-2.mga7 #1 SMP Wed May 20 23:14:20 UTC 2020 x86_64 x86_64 x86_64 GNU/Linux
$ rpm -qa | grep libreoffice | sort
libreoffice-base-6.4.4.2-1.mga7
libreoffice-calc-6.4.4.2-1.mga7
libreoffice-core-6.4.4.2-1.mga7
libreoffice-data-6.4.4.2-1.mga7
libreoffice-draw-6.4.4.2-1.mga7
libreoffice-emailmerge-6.4.4.2-1.mga7
libreoffice-graphicfilter-6.4.4.2-1.mga7
libreoffice-gtk3-6.4.4.2-1.mga7
libreoffice-help-en-6.4.4.2-1.mga7
libreoffice-help-pt-6.4.4.2-1.mga7
libreoffice-help-pt_BR-6.4.4.2-1.mga7
libreoffice-impress-6.4.4.2-1.mga7
libreoffice-kf5-6.4.4.2-1.mga7
libreoffice-langpack-en-6.4.4.2-1.mga7
libreoffice-langpack-pt-6.4.4.2-1.mga7
libreoffice-langpack-pt_BR-6.4.4.2-1.mga7
libreoffice-math-6.4.4.2-1.mga7
libreoffice-ogltrans-6.4.4.2-1.mga7
libreoffice-opensymbol-fonts-6.4.4.2-1.mga7
libreoffice-pdfimport-6.4.4.2-1.mga7
libreoffice-pyuno-6.4.4.2-1.mga7
libreoffice-ure-6.4.4.2-1.mga7
libreoffice-ure-common-6.4.4.2-1.mga7
libreoffice-wiki-publisher-6.4.4.2-1.mga7
libreoffice-writer-6.4.4.2-1.mga7
libreoffice-x11-6.4.4.2-1.mga7
libreoffice-xsltfilter-6.4.4.2-1.mga7

CC: (none) => mageia

Comment 19 Thomas Andrews 2020-05-25 05:35:01 CEST
Dell Inspiron 5100, 32-bit Xfce system. Packages updated without incident, except that qarepo didn't like the various debug packages on the list.

Tried several documents, no issues noted. Giving this a 32-bit OK. Also giving it a 64-bit OK, although I wonder about the devel package dependency noted in Comment 16.

Whiteboard: (none) => MGA7-32-OK MGA7-64-OK

Comment 20 David Walser 2020-05-25 15:58:02 CEST
Yeah that should be looked into.  Also, libfmt is in another bug, is there a dependency?
Comment 21 Thomas Andrews 2020-05-26 03:40:15 CEST
Taking back the OKs until this is cleared up.

Whiteboard: MGA7-32-OK MGA7-64-OK => (none)

Comment 22 Nicolas Lécureuil 2020-05-26 10:04:13 CEST
libfmt is a bugfix, updating it allowed to fix the packaging of it.

We should push kodi and celestia rebuild with it.
David Walser 2020-05-29 03:20:09 CEST

Depends on: (none) => 26672

Comment 23 Brian Rockwell 2020-06-03 14:30:31 CEST
I installed libreoffice from the list above and it seemed to work fine.  In fact, I forgot about it.

I'll do another install and add kodi and celestia to it.

CC: (none) => brtians1


Note You need to log in before you can comment on or make changes to this bug.