Bug 26440 - Suspend hangs, user loose work. Regression in kernel 5.5.15 from 5.5.14
Summary: Suspend hangs, user loose work. Regression in kernel 5.5.15 from 5.5.14
Alias: None
Product: Mageia
Classification: Unclassified
Component: RPM Packages (show other bugs)
Version: 7
Hardware: All Linux
Priority: Normal critical
Target Milestone: ---
Assignee: Kernel and Drivers maintainers
QA Contact:
Depends on:
Reported: 2020-04-05 22:21 CEST by Morgan Leijström
Modified: 2020-04-23 09:49 CEST (History)
1 user (show)

See Also:
Source RPM: kernel-5.5.15-3.mga7.src.rpm
Status comment:

lspci -v from Dell Precision M4400 (11.84 KB, text/plain)
2020-04-05 22:59 CEST, Morgan Leijström

Description Morgan Leijström 2020-04-05 22:21:12 CEST
Regression compared to 5.5.14 , 64 bit:

Suspend fail on my Dell precision M4400
Last two lines in log (from journalctl -b -1 next boot):
systemd [1]: Reached target Sleep.
systemd [1]: Starting Suspend... 

System is completely dead, not responding to any key combination, but keyboard and power lamp are still lit.  Need power button to shut off.  This is critical as user may loose work.

I have tried 5.5.15-3 four times, always fail.
5.5.14 more times, never fail.
Morgan Leijström 2020-04-05 22:21:35 CEST

Assignee: bugsquad => kernel

Comment 1 Thomas Backlund 2020-04-05 22:28:25 CEST
what exact hw is that ?

there is not that much patches between 5.5.14-1 and 5.5.15-3

CC: (none) => tmb

Comment 2 Thomas Backlund 2020-04-05 22:34:10 CEST
And you can still use the older 5.5.14 kernel for now
Comment 3 Morgan Leijström 2020-04-05 22:55:13 CEST
Yes the 5.5.14 still works as installed.

The machine also have Bug 26338 - Intermittent failure early in boot, Intel Q9100, foor all kernels i have tried  (got the machine recently)

I will grab lspci from it.

Anything else that may help?
Comment 4 Morgan Leijström 2020-04-05 22:59:19 CEST
Created attachment 11575 [details]
lspci -v from Dell Precision M4400
Comment 5 Morgan Leijström 2020-04-05 23:06:25 CEST
CPU: Intel Core 2 Quad 9100 2,26GHz
Family 6, Model 23, Stepping 10, Cpuid 13
Comment 6 Morgan Leijström 2020-04-23 09:49:20 CEST
OK again with kernel 5.6.6 :)

Maybe luck, but closing for now.

Resolution: (none) => FIXED

Note You need to log in before you can comment on or make changes to this bug.