Bug 25784 - automultiplechoice.sty is not included in the package
Summary: automultiplechoice.sty is not included in the package
Status: NEW
Alias: None
Product: Mageia
Classification: Unclassified
Component: RPM Packages (show other bugs)
Version: 7
Hardware: x86_64 Linux
Priority: Normal normal
Target Milestone: ---
Assignee: David GEIGER
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-11-29 10:56 CET by Franck Butelle
Modified: 2019-12-11 23:17 CET (History)
0 users

See Also:
Source RPM: auto-multiple-choice-1.4.0-1.mga7.src.rpm
CVE:
Status comment:


Attachments
exam source (test case) (707 bytes, text/plain)
2019-12-06 11:05 CET, Franck Butelle
Details
scaned copies (11.29 KB, application/pdf)
2019-12-06 11:06 CET, Franck Butelle
Details

Description Franck Butelle 2019-11-29 10:56:40 CET
When trying to compile an existing project with this package
auto-multiple-choice gui complains about automultiplechoice.sty missing.
I try to download the original tarball of version 1.4.0, compile it
(partially), pick the generated automultiplechoice.sty and copy it in
/usr/share/texmf-local/tex/latex
then sudo mktexlsr
to update the hashes and it works...
Well auto-multiple-choice still complains about difference of version
between the version of the application and the version of style file:
version of AMC is "@/PACKAGE_V_STY/@"...

How reproducible : always
Comment 1 Lewis Smith 2019-11-29 21:27:42 CET
Assigning to you, David, as you did the latest build for this thing. And it has no registered maintainer.

Assignee: bugsquad => geiger.david68210

Comment 2 David GEIGER 2019-12-05 14:20:11 CET
Please test with the upcoming auto-multiple-choice-1.4.0-1.1.mga7 in Core/Updates_testing repo!
Comment 3 Franck Butelle 2019-12-05 22:29:43 CET
Well, at least there is automultiplechoice.sty in this new package,
but a new problem arise :
$ auto-multiple-choice &
[1] 4872
$ Unknown action gui at /usr/bin/auto-multiple-choice line 79.
 
auto-multiple-choice is a Perl script trying on line 79
to exec another perl script,
that it is strange because I can exec 
/usr/lib64/AMC/perl/AMC-gui.pl
and it works

Oh I found it : line 28 of /usr/bin/auto-multiple-choice
it must be /usr/lib64/AMC and not /usr/lib/AMC
Comment 4 David GEIGER 2019-12-06 06:58:46 CET
Fixed with auto-multiple-choice-1.4.0-1.2.mga7
Comment 5 Franck Butelle 2019-12-06 11:04:08 CET
Thank you for reacting so fast !

Well I tried with my old projects : first steps are ok now :
compile and compute layout detection.

But when I want to capture data (scans) it loops for a long time 
just to list the directory and then I am not able to load the pdf containing the scans (the ok button is always gray).
I haven't find where is the problem. 

I will try to make a minimum test case and upload it.
Comment 6 Franck Butelle 2019-12-06 11:05:54 CET
Created attachment 11385 [details]
exam source (test case)
Comment 7 Franck Butelle 2019-12-06 11:06:34 CET
Created attachment 11386 [details]
scaned copies
Comment 8 Franck Butelle 2019-12-11 23:17:01 CET
Quite strange, I rechecked it and... it works !
Thanks !

Note You need to log in before you can comment on or make changes to this bug.