Bug 25658 - aqhbci-5.7.8-3.mga7.x86_64 conflicts with aqbanking-5.99.40beta-1.mga7.x86_64
Summary: aqhbci-5.7.8-3.mga7.x86_64 conflicts with aqbanking-5.99.40beta-1.mga7.x86_64
Status: ASSIGNED
Alias: None
Product: Mageia
Classification: Unclassified
Component: RPM Packages (show other bugs)
Version: 7
Hardware: All Linux
Priority: Normal normal
Target Milestone: ---
Assignee: QA Team
QA Contact:
URL:
Whiteboard: MGA7-64-OK
Keywords: validated_update
Depends on:
Blocks:
 
Reported: 2019-11-05 20:22 CET by papoteur
Modified: 2019-11-14 01:41 CET (History)
4 users (show)

See Also:
Source RPM:
CVE:
Status comment:


Attachments

Description papoteur 2019-11-05 20:22:03 CET
Description of problem:
During upgrade of Mga6 to 7 :
Can't be installed:
aqhbci-5.7.8-3.mga7.x86_64 (en raison de conflit avec aqbanking-5.99.40beta-1.mga7.x86_64)
Comment 1 José Jorge 2019-11-06 11:16:38 CET
Yes, I changed from conflicts to obsoletes in release 2, please ensure the upgrade goes better using the one from testing.

CC: (none) => lists.jjorge

Comment 2 José Jorge 2019-11-06 11:53:17 CET
(In reply to José Jorge from comment #1)
> Yes, I changed from conflicts to obsoletes in release 2, please ensure the
> upgrade goes better using the one from testing.

In fact a did a release 3, with lib obsoletes moved from lib-devel to lib.
I hope this will prevent devel libs install on upgrade.

Status: NEW => ASSIGNED

Comment 3 José Jorge 2019-11-06 17:49:21 CET
I have found 4 more forgotten obsoletes, now all should be fixed : I have tested installing all aqbanking 5.7.8 sub packages, and then upgrading.
Comment 4 papoteur 2019-11-08 15:51:02 CET
Hi José,
Do you need some tests, so you will submit your change to QA?
Comment 5 José Jorge 2019-11-08 17:51:57 CET
How to test on MGA 7 :
1. install the rpms without the update media :
urpmi --searchmedia release aqbanking aqhbci aqpaypal aqebics
2. then try to update from testing
urpmi --searchmedia testing aqbanking

It should remove all hbci ebics paypal things.

Suggested advisory :
The previous update of aqbanking did not obsolete all the removed packages, making hard to upgrade from MGA6. This update obsoletes all the packages removed from aqbanking spec file.

SRPM:
aqbanking-5.99.40beta-4.mga7.srpm

RPMS:
aqbanking-5.99.40beta-4.mga7.i586.rpm
libaqbanking43-5.99.40beta-4.mga7.i586.rpm
libaqbanking-devel-5.99.40beta-4.mga7.i586.rpm

Assignee: pkg-bugs => qa-bugs

Comment 6 Len Lawrence 2019-11-09 07:25:23 CET
Mageia7, x86_64

Before update, installed:
     1/14: ktoblzcheck          
     2/14: lib64ktoblzcheck1    
     3/14: lib64gwengui-gtk3_0  
     4/14: lib64gwenhywfar78    
     5/14: gwenhywfar           
     6/14: lib64gwenhywfar60    
     7/14: lib64aqbanking35     
     8/14: aqbanking-5.7.8-3.mga7            
     9/14: lib64aqhbci24        
    10/14: aqhbci               
    11/14: lib64aqebics0        
    12/14: lib64aqpaypal0       
    13/14: aqpaypal             
    14/14: aqebics              

Updates testing enabled.
Afterwards:
(medium "Core Updates Testing (distrib5)")
  aqbanking                      5.99.40beta  4.mga7        x86_64  
  lib64aqbanking43               5.99.40beta  4.mga7        x86_64  

Preparing...                     #############################################
      1/2: lib64aqbanking43      #############################################
      2/2: aqbanking             #############################################
removing package aqpaypal-5.7.8-3.mga7.x86_64
      1/7: removing aqpaypal-5.7.8-3.mga7.x86_64
                                 #############################################
removing package aqhbci-5.7.8-3.mga7.x86_64
      2/7: removing aqhbci-5.7.8-3.mga7.x86_64
                                 #############################################
removing package aqebics-5.7.8-3.mga7.x86_64
      3/7: removing aqebics-5.7.8-3.mga7.x86_64
                                 #############################################
      4/7: removing aqbanking-5.7.8-3.mga7.x86_64
                                 #############################################
removing package lib64aqhbci24-5.7.8-3.mga7.x86_64
      5/7: removing lib64aqhbci24-5.7.8-3.mga7.x86_64
                                 #############################################
removing package lib64aqebics0-5.7.8-3.mga7.x86_64
      6/7: removing lib64aqebics0-5.7.8-3.mga7.x86_64
                                 #############################################
removing package lib64aqpaypal0-5.7.8-3.mga7.x86_64
      7/7: removing lib64aqpaypal0-5.7.8-3.mga7.x86_64
                                 #############################################

Does what you asked.

Whiteboard: (none) => MGA7-64-OK
CC: (none) => tarazed25

Comment 7 Thomas Andrews 2019-11-14 01:41:37 CET
Validating. Advisory in Comment 5.

CC: (none) => andrewsfarm, sysadmin-bugs
Keywords: (none) => validated_update


Note You need to log in before you can comment on or make changes to this bug.