Bug 25582 - In Cairo-dock , the powermanager and weather plugins don't show any information.
Summary: In Cairo-dock , the powermanager and weather plugins don't show any information.
Status: REOPENED
Alias: None
Product: Mageia
Classification: Unclassified
Component: RPM Packages (show other bugs)
Version: 7
Hardware: x86_64 Linux
Priority: Normal normal
Target Milestone: ---
Assignee: David GEIGER
QA Contact:
URL:
Whiteboard:
Keywords: feedback
Depends on:
Blocks:
 
Reported: 2019-10-17 15:44 CEST by Daniel BEZIVIN
Modified: 2020-08-30 23:40 CEST (History)
6 users (show)

See Also:
Source RPM: cairo-dock-plugins-3.4.1-12.mga7.src.rpm
CVE:
Status comment:


Attachments

Description Daniel BEZIVIN 2019-10-17 15:44:56 CEST
I am using cairo-dock  3.4.1-5.mga7 in Mageia 7.1 , both in a plasma5 and a Xfce4 environment. Some plugins (applets) don't work at all :
Particuliarly the weather plugin and the powermanager plugin. None of these two can get informations from the net or from system or from to display at screen. 


Version-Release number of selected component (if applicable): 3.4.1-5.mga7


How reproducible: Install cairo-dock in xfce4 or plasma5 . Install wheatherter and powermanager plugins

See here a piece of the result of "cairo-dock -l debug " :
"debug   : (/home/iurt/rpmbuild/BUILD/cairo-dock-plug-ins-3.4.1/powermanager/src/powermanager-proc-acpi.c:_find_battery_in_dir:46)
  powermanager: no battery in /proc/acpi/battery
debug   : (/home/iurt/rpmbuild/BUILD/cairo-dock-plug-ins-3.4.1/powermanager/src/powermanager-sys-class.c:_find_battery_in_dir:73)
    examen de la batterie '/sys/class/power_supply/AC0/type' ...
debug   : (/home/iurt/rpmbuild/BUILD/cairo-dock-plug-ins-3.4.1/powermanager/src/powermanager-sys-class.c:_find_battery_in_dir:73)
    examen de la batterie '/sys/class/power_supply/BAT0/type' ...
debug   : (/home/iurt/rpmbuild/BUILD/cairo-dock-plug-ins-3.4.1/powermanager/src/powermanager-sys-class.c:_find_battery_in_dir:79)
    myData.cBatteryStateFilePath: /sys/class/power_supply/BAT0/uevent
debug   : (/home/iurt/rpmbuild/BUILD/cairo-dock-plug-ins-3.4.1/powermanager/src/powermanager-sys-class.c:cd_get_stats_from_sys_class:151)
  la batterie a ete connectee
cd_get_stats_from_sys_class: assertion 'str != NULL' failed
debug   : (/home/iurt/rpmbuild/BUILD/cairo-dock-plug-ins-3.4.1/powermanager/src/powermanager-draw.c:update_icon:84)
  update_icon (on battery: 0 -> 1; time:0.0 -> 0.0 ; charge:0.0 -> 0.0)"

About weather plugin, it asks wether a web connexion is active....
Daniel BEZIVIN 2019-10-17 15:46:02 CEST

Hardware: All => x86_64

Comment 1 Lewis Smith 2019-10-18 11:53:17 CEST
Thank you for the report.
Assigning it to Shlomi as the relevant maintainer.

Assignee: bugsquad => shlomif
Source RPM: cairo-dock-powermanager, cairo-dock-weather => cairo-dock-plugins-3.4.1-12.mga7.src.rpm

Comment 2 David GEIGER 2019-10-18 17:01:21 CEST
Please test the new upcoming set of cairo-dock-plugins in Core/Updates_testing repo!

- cairo-dock-plugins-3.4.1-12.1.mga7

CC: (none) => geiger.david68210

Comment 3 Daniel BEZIVIN 2019-10-18 20:17:28 CEST
Update tested : good job, version 3.4.1.12.1 works very well.
Thanks for all

Status: NEW => RESOLVED
Resolution: (none) => FIXED

Comment 4 David GEIGER 2019-10-19 07:22:40 CEST
Assigning to QA,


Advisory:
========================

Some plugins does not work properly due to lack of build dependencies (especially the Weather and the Powermanager plugins), so this update fixes this issue enabling some applet:

  * re-enable UPower support
  * re-enable Weblets applet with webkit2 support
  * switch to zeitgeist 2.0
  * enable GMenu applet with libgnome-menu-3.0 support
  * backport upstream patches (sync with latest master branch)

========================

Packages in 7/core/updates_testing:
========================
cairo-dock-plugins-3.4.1-12.1.mga7.i586.rpm
cairo-dock-plugins-i18n-3.4.1-12.1.mga7.i586.rpm
cairo-dock-animated-icons-3.4.1-12.1.mga7.i586.rpm
cairo-dock-clock-3.4.1-12.1.mga7.i586.rpm
cairo-dock-composite-manager-3.4.1-12.1.mga7.i586.rpm
cairo-dock-desklet-rendering-3.4.1-12.1.mga7.i586.rpm
cairo-dock-dialog-rendering-3.4.1-12.1.mga7.i586.rpm
cairo-dock-dnd2share-3.4.1-12.1.mga7.i586.rpm
cairo-dock-drop_indicator-3.4.1-12.1.mga7.i586.rpm
cairo-dock-dustbin-3.4.1-12.1.mga7.i586.rpm
cairo-dock-icon-effect-3.4.1-12.1.mga7.i586.rpm
cairo-dock-illusion-3.4.1-12.1.mga7.i586.rpm
cairo-dock-kde-integration-3.4.1-12.1.mga7.i586.rpm
cairo-dock-logout-3.4.1-12.1.mga7.i586.rpm
cairo-dock-mail-3.4.1-12.1.mga7.i586.rpm
cairo-dock-motion_blur-3.4.1-12.1.mga7.i586.rpm
cairo-dock-musicPlayer-3.4.1-12.1.mga7.i586.rpm
cairo-dock-quick-browser-3.4.1-12.1.mga7.i586.rpm
cairo-dock-rendering-3.4.1-12.1.mga7.i586.rpm
cairo-dock-terminal-3.4.1-12.1.mga7.i586.rpm
cairo-dock-powermanager-3.4.1-12.1.mga7.i586.rpm
cairo-dock-shared-files-3.4.1-12.1.mga7.i586.rpm
cairo-dock-shortcuts-3.4.1-12.1.mga7.i586.rpm
cairo-dock-show_mouse-3.4.1-12.1.mga7.i586.rpm
cairo-dock-systray-3.4.1-12.1.mga7.i586.rpm
cairo-dock-toons-3.4.1-12.1.mga7.i586.rpm
cairo-dock-weather-3.4.1-12.1.mga7.i586.rpm
cairo-dock-xgamma-3.4.1-12.1.mga7.i586.rpm
cairo-dock-alsamixer-3.4.1-12.1.mga7.i586.rpm
cairo-dock-cairo-penguin-3.4.1-12.1.mga7.i586.rpm
cairo-dock-slider-3.4.1-12.1.mga7.i586.rpm
cairo-dock-stack-3.4.1-12.1.mga7.i586.rpm
cairo-dock-System-monitor-3.4.1-12.1.mga7.i586.rpm
cairo-dock-wifi-3.4.1-12.1.mga7.i586.rpm
cairo-dock-xfce-integration-3.4.1-12.1.mga7.i586.rpm
cairo-dock-tomboy-3.4.1-12.1.mga7.i586.rpm
cairo-dock-netspeed-3.4.1-12.1.mga7.i586.rpm
cairo-dock-switcher-3.4.1-12.1.mga7.i586.rpm
cairo-dock-dbus-3.4.1-12.1.mga7.i586.rpm
cairo-dock-showdesktop-3.4.1-12.1.mga7.i586.rpm
cairo-dock-gnome-integration-3.4.1-12.1.mga7.i586.rpm
cairo-dock-clipper-3.4.1-12.1.mga7.i586.rpm
cairo-dock-gmenu-3.4.1-12.1.mga7.i586.rpm
cairo-dock-keyboard-indicator-3.4.1-12.1.mga7.i586.rpm
cairo-dock-weblets-3.4.1-12.1.mga7.i586.rpm
cairo-dock-rssreader-3.4.1-12.1.mga7.i586.rpm
cairo-dock-Folders-3.4.1-12.1.mga7.i586.rpm
cairo-dock-remote-control-3.4.1-12.1.mga7.i586.rpm
cairo-dock-vala-3.4.1-12.1.mga7.i586.rpm
cairo-dock-status-notifier-3.4.1-12.1.mga7.i586.rpm
cairo-dock-recent-events-3.4.1-12.1.mga7.i586.rpm
cairo-dock-impulse-3.4.1-12.1.mga7.i586.rpm
cairo-dock-screenshot-3.4.1-12.1.mga7.i586.rpm
cairo-dock-sound-effects-3.4.1-12.1.mga7.i586.rpm

cairo-dock-plugins-3.4.1-12.1.mga7.x86_64.rpm
cairo-dock-plugins-i18n-3.4.1-12.1.mga7.x86_64.rpm
cairo-dock-animated-icons-3.4.1-12.1.mga7.x86_64.rpm
cairo-dock-clock-3.4.1-12.1.mga7.x86_64.rpm
cairo-dock-composite-manager-3.4.1-12.1.mga7.x86_64.rpm
cairo-dock-desklet-rendering-3.4.1-12.1.mga7.x86_64.rpm
cairo-dock-dialog-rendering-3.4.1-12.1.mga7.x86_64.rpm
cairo-dock-dnd2share-3.4.1-12.1.mga7.x86_64.rpm
cairo-dock-drop_indicator-3.4.1-12.1.mga7.x86_64.rpm
cairo-dock-dustbin-3.4.1-12.1.mga7.x86_64.rpm
cairo-dock-icon-effect-3.4.1-12.1.mga7.x86_64.rpm
cairo-dock-illusion-3.4.1-12.1.mga7.x86_64.rpm
cairo-dock-kde-integration-3.4.1-12.1.mga7.x86_64.rpm
cairo-dock-logout-3.4.1-12.1.mga7.x86_64.rpm
cairo-dock-mail-3.4.1-12.1.mga7.x86_64.rpm
cairo-dock-motion_blur-3.4.1-12.1.mga7.x86_64.rpm
cairo-dock-musicPlayer-3.4.1-12.1.mga7.x86_64.rpm
cairo-dock-quick-browser-3.4.1-12.1.mga7.x86_64.rpm
cairo-dock-rendering-3.4.1-12.1.mga7.x86_64.rpm
cairo-dock-terminal-3.4.1-12.1.mga7.x86_64.rpm
cairo-dock-powermanager-3.4.1-12.1.mga7.x86_64.rpm
cairo-dock-shared-files-3.4.1-12.1.mga7.x86_64.rpm
cairo-dock-shortcuts-3.4.1-12.1.mga7.x86_64.rpm
cairo-dock-show_mouse-3.4.1-12.1.mga7.x86_64.rpm
cairo-dock-systray-3.4.1-12.1.mga7.x86_64.rpm
cairo-dock-toons-3.4.1-12.1.mga7.x86_64.rpm
cairo-dock-weather-3.4.1-12.1.mga7.x86_64.rpm
cairo-dock-xgamma-3.4.1-12.1.mga7.x86_64.rpm
cairo-dock-alsamixer-3.4.1-12.1.mga7.x86_64.rpm
cairo-dock-cairo-penguin-3.4.1-12.1.mga7.x86_64.rpm
cairo-dock-slider-3.4.1-12.1.mga7.x86_64.rpm
cairo-dock-stack-3.4.1-12.1.mga7.x86_64.rpm
cairo-dock-System-monitor-3.4.1-12.1.mga7.x86_64.rpm
cairo-dock-wifi-3.4.1-12.1.mga7.x86_64.rpm
cairo-dock-xfce-integration-3.4.1-12.1.mga7.x86_64.rpm
cairo-dock-tomboy-3.4.1-12.1.mga7.x86_64.rpm
cairo-dock-netspeed-3.4.1-12.1.mga7.x86_64.rpm
cairo-dock-switcher-3.4.1-12.1.mga7.x86_64.rpm
cairo-dock-dbus-3.4.1-12.1.mga7.x86_64.rpm
cairo-dock-showdesktop-3.4.1-12.1.mga7.x86_64.rpm
cairo-dock-gnome-integration-3.4.1-12.1.mga7.x86_64.rpm
cairo-dock-clipper-3.4.1-12.1.mga7.x86_64.rpm
cairo-dock-gmenu-3.4.1-12.1.mga7.x86_64.rpm
cairo-dock-keyboard-indicator-3.4.1-12.1.mga7.x86_64.rpm
cairo-dock-weblets-3.4.1-12.1.mga7.x86_64.rpm
cairo-dock-rssreader-3.4.1-12.1.mga7.x86_64.rpm
cairo-dock-Folders-3.4.1-12.1.mga7.x86_64.rpm
cairo-dock-remote-control-3.4.1-12.1.mga7.x86_64.rpm
cairo-dock-vala-3.4.1-12.1.mga7.x86_64.rpm
cairo-dock-status-notifier-3.4.1-12.1.mga7.x86_64.rpm
cairo-dock-recent-events-3.4.1-12.1.mga7.x86_64.rpm
cairo-dock-impulse-3.4.1-12.1.mga7.x86_64.rpm
cairo-dock-screenshot-3.4.1-12.1.mga7.x86_64.rpm
cairo-dock-sound-effects-3.4.1-12.1.mga7.x86_64.rpm

Source RPM: 
========================
cairo-dock-plugins-3.4.1-12.1.mga7.src.rpm

Status: RESOLVED => REOPENED
Resolution: FIXED => (none)
Assignee: shlomif => qa-bugs

Comment 5 David GEIGER 2019-10-19 08:47:16 CEST
(In reply to Daniel BEZIVIN from comment #3)
> Update tested : good job, version 3.4.1.12.1 works very well.
> Thanks for all

Which architecture are you using? 64 or 32
Comment 6 Daniel BEZIVIN 2019-10-19 09:05:17 CEST
I'm using 64 bits architecture.
Comment 7 Len Lawrence 2019-10-23 13:26:05 CEST
Mageia 7, x86_64

Installed all the packages before updating and tried it out.  Invoked the Cairo-dock from the system menus and it duly appeared.  It seemed to work OK to start with until I looked for the weather applet.  Tried the help button to see if there was any information on accessing applets only to find it froze up; could not exit from help.  The rest of the desktop was virtually inaccessible with the mouse pointer  advancing at a rate of about 1 metre per century before the dock crashed and disappeared.

Updated all the packages.
Launched the dock again, removed the black border.  Noted that the systems menu had been added to the lineup and an entry for emacs which I was using to edit this report.  No sign of a weather applet nor does the Xfce desktop seem to list one - not there by default.  Help does not freeze or crash - but see later.  Chose a music player.  As far as I can tell most of it is working.  

$ rpm -qa | grep cairo-dock-weather
cairo-dock-weather-3.4.1-12.1.mga7

Had a look at main-dock.conf and cairo-dock.conf - no clues there.  weather.conf is all about the desklet itself.  No indication about how to add desklets to the dock.  The second time I tried to use help it froze and the dock became unresponsive.

Daniel says cairo-dock is OK but I shall leave this a while for other members of the QA team to try out.  It looks to me as if it still needs adjustment.

CC: (none) => tarazed25

Comment 8 Len Lawrence 2019-10-24 11:28:28 CEST
Adding feedback marker because it seems likely that there is a problem at my end considering that this application works perfectly for somebody who is used to it.  Is there some kind of setup or configuration needed to get it to work properly.  Could the hangup be caused by a race condition or other kind of conflict?  The Xfce panels are still there.  Mutually exclusive?

Keywords: (none) => feedback

Comment 9 Jose Manuel López 2019-12-18 11:44:48 CET
I have tried this version of cairo-dock. Some plugins like "Folders" fail. When you try to open a folder you get "Failed to mount".

I'd already reported it in bug: <a href=”https://bugs.mageia.org/show_bug.cgi?id=20581”>Bug 20581</a>


Greetings!!

CC: (none) => joselp

Shlomi Fish 2020-04-01 08:50:58 CEST

CC: (none) => shlomif
Summary: In Cairo-dock ,plugins powermanager and wheather don't show any information. => In Cairo-dock , the powermanager and weather plugins don't show any information.

Comment 10 Jose Manuel López 2020-04-01 10:26:16 CEST
I have tried a new installation of cairo-dock in clean Mageia 7.1 Plasma.

Plugins still not working.

Greetings!
Comment 11 Thomas Andrews 2020-05-13 01:21:10 CEST
I tried this too on a 64-bit Plasma system. After installing the current cairo-dock and all dependencies that came up, and after watching a (probably dated) Youtube tutorial, I attempted to change some configurations. I was able to move the dock to the side and add some things, but when I went to open folders or edit the weather plugin, they failed.

The updates installed without incident. After the update, there was no difference. The things that failed before failed again, and in the same way. So now there are three of us that cannot get it to work, but the reporter can.

I am wondering, is it possible that there is a missing dependency or two that the reporter has installed but the rest of us do not?

CC: (none) => andrewsfarm

Comment 12 Thomas Andrews 2020-05-16 06:08:54 CEST
Len, to configure cairo-dock, right-click on the dock or virtual desktops and select cairo-dock/Configure. But...

Tried this once more from the command line. This is what I saw in Konsole: (I had already chosen the OpenGL backend. Graphics card is an AMD HD 8490.)

$ cairo-dock
warning :  (/home/iurt/rpmbuild/BUILD/cairo-dock-core-3.4.1/src/implementations/cairo-dock-egl.c:gldi_register_egl_backend:232)  
  Cairo-Dock was not built with EGL support
warning :  (/home/iurt/rpmbuild/BUILD/cairo-dock-core-3.4.1/src/implementations/cairo-dock-glx.c:_initialize_opengl_backend:129)  
  couldn't find an appropriate visual, trying to get one without Stencil buffer
(it may cause some little deterioration in the rendering) ...

 ============================================================================
        Cairo-Dock version : 3.4.1
        Compiled date      : Sep 23 2018 07:03:18
        Built with GTK     : 3.22
        Running with OpenGL: 1
 ============================================================================

g_file_test: assertion 'filename != NULL' failed
g_file_test: assertion 'filename != NULL' failed

(cairo-dock:17189): Gtk-WARNING **: 23:49:24.987: Theme parsing error: <data>:7:1467: The :insensitive pseudo-class is deprecated. Use :disabled instead.

(cairo-dock:17189): Gtk-WARNING **: 23:49:24.988: Theme parsing error: <data>:7:3649: The :inconsistent pseudo-class is deprecated. Use :indeterminate instead.
('new owner:', dbus.String(u':1.110'))
connect...
-> connected to cairo-dock
Cairo-Dock - Launcher API Daemon is already running (26136)
warning :  (/home/iurt/rpmbuild/BUILD/cairo-dock-core-3.4.1/src/gldit/cairo-dock-utils.c:cairo_dock_launch_command_sync_with_stderr:260)  
  which: no iwconfig in (/usr/local/bin:/usr/bin:/bin:/usr/local/games:/usr/games:/usr/lib64/qt5/bin:/home/tom/bin)

warning :  (/home/iurt/rpmbuild/BUILD/cairo-dock-core-3.4.1/src/gldit/cairo-dock-keybinder.c:init_object:358)  
  Couldn't bind '<Control>F12' (Log out: Show the logout menu)
 This shortkey is probably already used by another applet or another application
warning :  (/home/iurt/rpmbuild/BUILD/cairo-dock-plug-ins-3.4.1/weather/src/applet-read-data.c:cd_weather_get_distant_data:343)  
  weather : uncorrect data (no connection ?)
warning :  (/home/iurt/rpmbuild/BUILD/cairo-dock-plug-ins-3.4.1/weather/src/applet-read-data.c:cd_weather_get_distant_data:357)  
  weather : uncorrect data (no connection ?)
_cd_find_volume_name_from_drive_name: assertion 'pDrive != NULL' failed
_cd_find_volume_name_from_drive_name: assertion 'pDrive != NULL' failed
_cd_find_volume_name_from_drive_name: assertion 'pDrive != NULL' failed
_get_desktop_bg_surface: assertion 'iRootPixmapID != 0' failed
warning :  (/home/iurt/rpmbuild/BUILD/cairo-dock-plug-ins-3.4.1/switcher/src/applet-load-icons.c:cd_switcher_load_desktop_bg_map_surface:197)  
  couldn't get the wallpaper
warning :  (/home/iurt/rpmbuild/BUILD/cairo-dock-plug-ins-3.4.1/weather/src/applet-read-data.c:cd_weather_get_distant_data:343)  
  weather : uncorrect data (no connection ?)
warning :  (/home/iurt/rpmbuild/BUILD/cairo-dock-plug-ins-3.4.1/weather/src/applet-read-data.c:cd_weather_get_distant_data:357)  

The weather plug-in warning keeps repeating as it keeps trying to make a connection, sometimes with a 343, sometimes with a 357. Wifi Internet connection is working perfectly.

Something sure looks seriously wrong to me.
Comment 13 Len Lawrence 2020-06-28 18:24:06 CEST
Just checked in.  Shall have another go later.
Comment 14 Len Lawrence 2020-06-28 18:50:02 CEST
mga7, x86_64

@TJ - thanks for the tips.

Made sure that all the release packages were in place and tried loading cairo-dock from the system tools menu.  That worked OK this time - no race conditions anyway.  The application tabs worked fine and the weather applet installed OK.    Clicking on the icon takes the user to the browser where a site can be selected and which shows the weather for that location, in the browser.  At this stage I do not know if that is all it is supposed to do - rather expected a popup on-screen but there does not seem to be a way to configure the applet to do that and remember the location.

Cairo-dock was installed with no acceleration because nvidia has not taken on this partition.  Going to shift operations to another installation.
Comment 15 Len Lawrence 2020-06-28 19:12:04 CEST
Well, that was not such a good idea.  After logging in on another partition the screen started to flash continuously.  No way out but to hit the restart button.
Can only guess that the cairo-dock installation left some trace in the user files which caused a conflict.  Maybe there is a launcher script which is run automatically, which would certainly cause a problem where the application is not installed.  For Mate it is not included in the startup applications but the desktop does remember running applications on logout.  However I had selected  "close session" in the cairo-dock logout.
Comment 16 Len Lawrence 2020-06-28 19:23:40 CEST
To cure the problem I had to go back to the other partition, login and logout and then login on the desired partition.  Phew!
Comment 17 Len Lawrence 2020-06-28 19:50:47 CEST
Starting fresh installation, release packages first then straight to updates.

$ cairo-dock

(cairo-dock:1380): dbind-WARNING **: 18:28:55.760: Couldn't register with accessibility bus: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.
warning :  (/home/iurt/rpmbuild/BUILD/cairo-dock-core-3.4.1/src/implementations/cairo-dock-egl.c:gldi_register_egl_backend:232)  
  Cairo-Dock was not built with EGL support

 ============================================================================
	Cairo-Dock version : 3.4.1
	Compiled date      : Sep 23 2018 07:03:18
	Built with GTK     : 3.22
	Running with OpenGL: 1
 ============================================================================

g_file_test: assertion 'filename != NULL' failed
g_file_test: assertion 'filename != NULL' failed

(cairo-dock:1380): Gtk-WARNING **: 18:28:55.905: Theme parsing error: <data>:7:1467: The :insensitive pseudo-class is deprecated. Use :disabled instead.

(cairo-dock:1380): Gtk-WARNING **: 18:28:55.905: Theme parsing error: <data>:7:3649: The :inconsistent pseudo-class is deprecated. Use :indeterminate instead.
Launcher-API-Daemon: registered as Unity: <dbus.service.BusName com.canonical.Unity on <dbus._dbus.SessionBus (session) at 0x7f26f2f3bd10> at 0x7f26f2f3fbd0>
connect...
-> connected to cairo-dock
('new owner:', dbus.UTF8String(':1.483'))
cairo_dock_create_surface_from_image_simple: assertion 'cImageFile != NULL' failed
_cd_find_volume_name_from_drive_name: assertion 'pDrive != NULL' failed
_cd_find_volume_name_from_drive_name: assertion 'pDrive != NULL' failed
warning :  (/home/iurt/rpmbuild/BUILD/cairo-dock-plug-ins-3.4.1/kde-integration/src/applet-vfs.c:vfs_backend_get_file_info:307)  
  gnome_integration : Error when getting information for file “/home/lcl/Desktop/nvidia-current-settings.png”: No such file or directory
.....
warning :  (/home/iurt/rpmbuild/BUILD/cairo-dock-plug-ins-3.4.1/weather/src/applet-read-data.c:cd_weather_get_distant_data:343)  
  weather : uncorrect data (no connection ?)
warning :  (/home/iurt/rpmbuild/BUILD/cairo-dock-plug-ins-3.4.1/weather/src/applet-read-data.c:cd_weather_get_distant_data:357)  
  weather : uncorrect data (no connection ?)

The weather applet appeared in the dock.

Clicking on it raises a popup saying "No data available - Retrying now".
Left click on applet -> Weather -> Edit -> Detach places the applet on-screenas a blank panel.  A middle-click on that tries to fetch data
warning :  (/home/iurt/rpmbuild/BUILD/cairo-dock-plug-ins-3.4.1/weather/src/applet-read-data.c:cd_weather_get_distant_data:357)  
  weather : uncorrect data (no connection ?)
The handbook says you can find your location via the config panel - which is....?  Returned it to the dock.  It no longer responds to a double-click (should go to weather.com I think).  The edit function does nothing useful.  Looks like there may even be a regression from the release version because weather.com no longer shows.
Comment 18 Len Lawrence 2020-06-28 19:52:53 CEST
Another  message which keeps appearing is: 
sh: kioclient: command not found
David Walser 2020-08-30 23:40:10 CEST

CC: (none) => qa-bugs
Assignee: qa-bugs => geiger.david68210


Note You need to log in before you can comment on or make changes to this bug.