Bug 25544 - Warning: org.freedesktop.Platform.openh264 needs a later flatpak version message.
Summary: Warning: org.freedesktop.Platform.openh264 needs a later flatpak version mess...
Status: ASSIGNED
Alias: None
Product: Mageia
Classification: Unclassified
Component: RPM Packages (show other bugs)
Version: 7
Hardware: All Linux
Priority: Normal minor
Target Milestone: ---
Assignee: Neal Gompa
QA Contact:
URL:
Whiteboard:
Keywords:
: 25463 (view as bug list)
Depends on:
Blocks:
 
Reported: 2019-10-09 22:29 CEST by Ezequiel Partida
Modified: 2020-09-18 18:48 CEST (History)
5 users (show)

See Also:
Source RPM: Flatpak 1.4.1-1.mga7
CVE:
Status comment:


Attachments

Description Ezequiel Partida 2019-10-09 22:29:17 CEST
Description of problem:

Everytime I use the command flatpak update I get this message:

Warning: org.freedesktop.Platform.openh264 needs a later flatpak version
Installation complete.

Fortunately everthing seems to work fine.

Flatpak 1.4.1-1.mga7

Regards
Comment 1 Lewis Smith 2019-10-10 09:45:49 CEST
Thank you Ezequiel for this notification.
Assigning to Neal for 'flatpak' (not to be confused with 'flatpack'!).

Severity: normal => minor
Assignee: bugsquad => ngompa13

Florian Hubold 2019-11-08 14:35:15 CET

CC: (none) => doktor5000

Comment 2 David Walser 2019-11-26 21:36:04 CET
*** Bug 25463 has been marked as a duplicate of this bug. ***

CC: (none) => fri

Comment 3 Hurr 2019-11-26 21:53:25 CET
Due to this bug, spotify flatpak package doesn't work (as reflected in bug 25463).

Are you planning to update the flatpak package?

I also tried with https://github.com/leamas/spotify-make, but I have the same problem as @morgano in https://forums.mageia.org/en/viewtopic.php?f=4&t=12393&p=76928&hilit=spotify#p76928: apparently incorrect version of openssl :-(

Regards.

CC: (none) => peixe80

Giuseppe Merigo 2019-12-13 14:08:11 CET

CC: (none) => g.merigo

Comment 4 Morgan Leijström 2020-01-04 22:14:07 CET
Another reason to update our old flatpak is security.
Especially as new versions of firejail (bug 26013) lack support for flatpak.
Luděk Janča 2020-01-15 13:21:09 CET

CC: (none) => joelp

Comment 5 Luděk Janča 2020-01-15 13:24:13 CET
I cannot install anything from flathub, because of this bug.
Comment 6 Neal Gompa 2020-01-16 05:01:55 CET
(In reply to Morgan Leijström from comment #4)
> Another reason to update our old flatpak is security.
> Especially as new versions of firejail (bug 26013) lack support for flatpak.

You're not supposed to use firejail with flatpak...

Anyway, I'm working on the rebase for Cauldron and figuring out what to do for Mageia 7.

Status: NEW => ASSIGNED

Comment 7 Morgan Leijström 2020-01-16 09:13:27 CET
(In reply to Neal Gompa from comment #6)
> You're not supposed to use firejail with flatpak...

Ah, so practically no regression then :)

> Anyway, I'm working on the rebase for Cauldron and figuring out what to do
> for Mageia 7.

Thank you :)
Comment 8 Aurelien Oudelet 2020-09-07 16:04:36 CEST
$ flatpak install org.freedesktop.Platform.openh264
Looking for matches…
Found similar ref(s) for ‘org.freedesktop.Platform.openh264’ in remote ‘flathub’ (system).
Use this remote? [Y/n]: y
Similar refs found for ‘org.freedesktop.Platform.openh264’ in remote ‘flathub’ (system):

   1) runtime/org.freedesktop.Platform.openh264/x86_64/2.0
   2) runtime/org.freedesktop.Platform.openh264/x86_64/19.08

Which do you want to use (0 to abort)? [0-2]: 2


        ID                                           Arch              Branch           Remote            Download
 1. [✓] org.freedesktop.Platform.openh264            x86_64            19.08            flathub           1.0 kB / 117 bytes

Installation complete.

Seems to work...
Comment 9 Hurr 2020-09-12 20:21:35 CEST
Yes, now it works :-)
Comment 10 Morgan Leijström 2020-09-12 23:07:37 CEST
@Hurr: What works?
For me Spotify (as you wrote about in your last reply) launches but do not show pictures and can not play.
Comment 11 Florian Hubold 2020-09-18 18:04:59 CEST
(In reply to Morgan Leijström from comment #10)
> @Hurr: What works?

initial installation and update of openh264 via flatpak.

If you have an issue about spotify, better create a separate bugreport for that.
Comment 12 Morgan Leijström 2020-09-18 18:48:16 CEST
I do not care much about Spotify more than just as an example, but flatpak generally.

Also see Bug 27126

See Also: (none) => https://bugs.mageia.org/show_bug.cgi?id=27126


Note You need to log in before you can comment on or make changes to this bug.