Bug 25534 - Akonadi IMAPs daemon incorrectly uses system wide proxy settings
Summary: Akonadi IMAPs daemon incorrectly uses system wide proxy settings
Status: NEW
Alias: None
Product: Mageia
Classification: Unclassified
Component: RPM Packages (show other bugs)
Version: 7
Hardware: x86_64 Linux
Priority: Normal normal
Target Milestone: ---
Assignee: QA Team
QA Contact:
URL: https://bugs.kde.org/show_bug.cgi?id=...
Whiteboard: MGA7-64-OK
Keywords: validated_update
Depends on:
Blocks:
 
Reported: 2019-10-07 10:04 CEST by Nicolas Costes
Modified: 2019-11-14 02:29 CET (History)
4 users (show)

See Also:
Source RPM: kimap-19.04.0-1.mga7.src.rpm
CVE:
Status comment:


Attachments
List of installed packages, akonadi messages (31.80 KB, text/plain)
2019-11-02 18:32 CET, Ulrich Beckmann
Details
CLI output of akonadictl restart (11.96 KB, text/plain)
2019-11-02 18:35 CET, Ulrich Beckmann
Details

Description Nicolas Costes 2019-10-07 10:04:30 CEST
Description of problem:

The Akonadi IMAPs daemon incorrectly uses the system wide proxy settings. It used to work fine, even when using a proxy (it would ignore it).

Version-Release number of selected component (if applicable):


How reproducible:

This is my job computer, our company is behind a proxy. The IMAP server is inside the company. I tried to setup "no_proxy", change KDE/Plasma proxy setting to various values/no value at all : no change ! I cannot get my emails.

PS : I installed this Mageia 7 from scratch, it is not an upgrade from 6.

I only have one Mageia 7 computer, cannot test on another one.

Steps to Reproduce:
1. Setup the system wide proxy setting in Drakconf
2. Setup Kmail IMAPs account (inside the compagny, no need for proxy)
3. Kmail won't access the IMAPs server; packet sniffing shows that the process "akonadi_imap_resource" makes CONNECT requests to our company proxy (which refuses imaps)


Temporary - but not acceptable - solution : I removed the system-wide proxy settings and configured it inside the various programs that need it. But this breaks some programs that don't have a proxy setting en rely on the system-wide setting.
Comment 1 Nicolas Costes 2019-10-07 10:48:54 CEST
Another temporary workaround : start Akonadi from the command line.

$ unset http_proxy; akonadictl start
Comment 2 David GEIGER 2019-10-07 15:35:37 CEST
Please file a bug upstream for such as issue:

https://bugs.kde.org/

CC: (none) => geiger.david68210

Comment 3 Nicolas Costes 2019-10-07 17:34:42 CEST
I did : https://bugs.kde.org/show_bug.cgi?id=412702
Comment 4 Lewis Smith 2019-10-07 21:17:08 CEST
Thank you Nicolas for this report, for bugging it upstream, and noting here the upstream bug URL.
Thank you DavidG for giving the upstream bug reporting URL.
With all that done, this bug header fields set accordingly, assigning to the KDE team.

URL: (none) => https://bugs.kde.org/show_bug.cgi?id=412702
Keywords: (none) => UPSTREAM
Assignee: bugsquad => kde

Comment 5 Nicolas Costes 2019-10-09 08:20:47 CEST
I have got a reply from upstream (Laurent Montel <montel@kde.org>), he marked the bug as RESOLVED FIXED :

"it was implemented after your 19.04.
So you need to update your pim version."


Is there any chance we can backport the change in Mageia 7 ?
Comment 6 David GEIGER 2019-10-09 16:27:56 CEST
Assigning to QA,


Advisory:
========================

This kimap update is to provide an explicit option to not use the system proxy setting for IMAP connections.
If the system proxy settings are set to use the environment variables http_proxy etc (for compatibility with non-KDE applications), then they are also used for IMAP connections. This is rarely required and will fail unless the proxy is transparent enough. See https://bugs.kde.org/show_bug.cgi?id=407685 and related bugs.

These changes adds an IMAP account option to use the proxy for connection (the default is off) and adds in kdepim-runtime the GUI for the setting, which appears as an additional option in the "Advanced" tab of the account settings dialogue.


For reference:
https://phabricator.kde.org/D21463
https://phabricator.kde.org/D21464

========================

Packages in 7/core/updates_testing:
========================
kimap-common-19.04.0-1.1.mga7.i586.rpm
libkf5imap5-19.04.0-1.1.mga7.i586.rpm
libkf5imap-devel-19.04.0-1.1.mga7.i586.rpm

kimap-common-19.04.0-1.1.mga7.x86_64.rpm
lib64kf5imap5-19.04.0-1.1.mga7.x86_64.rpm
lib64kf5imap-devel-19.04.0-1.1.mga7.x86_64.rpm

akonadi-kde-19.04.0-1.1.mga7.i586.rpm
libakonadi-singlefileresource5-19.04.0-1.1.mga7.i586.rpm
libmaildir5-19.04.0-1.1.mga7.i586.rpm
libakonadi-filestore5-19.04.0-1.1.mga7.i586.rpm
libkmindexreader5-19.04.0-1.1.mga7.i586.rpm
libfolderarchivesettings5-19.04.0-1.1.mga7.i586.rpm
kdepim-runtime-handbook-19.04.0-1.1.mga7.noarch.rpm

akonadi-kde-19.04.0-1.1.mga7.x86_64.rpm
lib64akonadi-singlefileresource5-19.04.0-1.1.mga7.x86_64.rpm
lib64maildir5-19.04.0-1.1.mga7.x86_64.rpm
lib64akonadi-filestore5-19.04.0-1.1.mga7.x86_64.rpm
lib64kmindexreader5-19.04.0-1.1.mga7.x86_64.rpm
lib64folderarchivesettings5-19.04.0-1.1.mga7.x86_64.rpm

Source RPM: 
========================
kimap-19.04.0-1.1.mga7.src.rpm
kdepim-runtime-19.04.0-1.1.mga7.src.rpm

Assignee: kde => qa-bugs
Source RPM: (none) => kimap-19.04.0-1.mga7.src.rpm

Comment 7 Ulrich Beckmann 2019-11-02 18:32:22 CET
Created attachment 11340 [details]
List of installed packages, akonadi messages

CC: (none) => bequimao.de

Comment 8 Ulrich Beckmann 2019-11-02 18:35:43 CET
Created attachment 11341 [details]
CLI output of akonadictl restart

I don't use a system proxy or a proxy setup for Akonadi.
I upgrade the packages and found no regressions.

Ulrich
Comment 9 Ulrich Beckmann 2019-11-09 22:58:52 CET
As there is no taker from qa with a dedicated proxy, I set the test as ok.

Ulrich

Whiteboard: (none) => MGA7-64-OK

Comment 10 Nicolas Costes 2019-11-12 14:54:24 CET
Hello, how can I help test the fix ? Or will it be soon pushed to the updates ?
Comment 11 Ulrich Beckmann 2019-11-12 19:55:13 CET
You are welcome to give your ok as the bug reporter.
If any doubts about the procedure, please ask on the mailing list 
qa-discuss@ml.mageia.org or in the Mageia forums.

Anyhow, next and last step will be the validation of the bug report and tests. That will happen in a few days.

Ulrich
Comment 12 Nicolas Costes 2019-11-13 08:02:25 CET
Ok, I will test and confirm it works, when the new packages are pushed to 7. :)
Comment 13 David GEIGER 2019-11-13 08:08:02 CET
(In reply to Nicolas Costes from comment #12)
> Ok, I will test and confirm it works, when the new packages are pushed to 7.
> :)

Nop, you have to test it right now with the "Testing" one, it's still you who made this request. Without test it can't be pushed to the "Update" repo!
Comment 14 Nicolas Costes 2019-11-13 08:12:40 CET
Good, where are the packages, can you please tell me ?
Comment 15 David GEIGER 2019-11-13 08:19:17 CET
(In reply to Nicolas Costes from comment #14)
> Good, where are the packages, can you please tell me ?

see the list in comment 6 (Packages in 7/core/updates_testing)
Comment 16 Nicolas Costes 2019-11-13 19:49:39 CET
Ok, great. I updated selectively some packages (I wanted to avoid the side effects of updating the numerous packages awaiting for testing) : Kmail now works fine, the "connect using the system proxy settings" checkbox appeared and does its job when checked/unchecked.

Thanks a lot :) !


Updated packages :

akonadi-kde-2:19.04.0-1.1.mga7.x86_64
glibc-6:2.29-18.mga7.x86_64
lib64kf5imap5-19.04.0-1.1.mga7.x86_64
lib64maildir5-2:19.04.0-1.1.mga7.x86_64
Comment 17 Thomas Andrews 2019-11-14 02:29:37 CET
Since the reporter has confirmed that his issue has been fixed, I'm validating, and removing the UPSTREAM marker. Advisory in Comment 6.

Thank you, Nicolas.

CC: (none) => andrewsfarm, sysadmin-bugs
Keywords: UPSTREAM => validated_update


Note You need to log in before you can comment on or make changes to this bug.