Bug 25333 - Bugfix Update For Nextcloud in MGA7 : 15.0.11
Summary: Bugfix Update For Nextcloud in MGA7 : 15.0.11
Status: RESOLVED FIXED
Alias: None
Product: Mageia
Classification: Unclassified
Component: RPM Packages (show other bugs)
Version: 7
Hardware: All Linux
Priority: Normal normal
Target Milestone: ---
Assignee: QA Team
QA Contact:
URL:
Whiteboard: MGA7-64-OK MGA7-32-OK
Keywords: advisory, validated_update
Depends on:
Blocks:
 
Reported: 2019-08-20 10:19 CEST by José Jorge
Modified: 2019-09-22 09:07 CEST (History)
5 users (show)

See Also:
Source RPM: nextcloud
CVE:
Status comment:


Attachments

Description José Jorge 2019-08-20 10:19:27 CEST
Advisory:
Nextcloud project provides monthly bugfix updates.
This version 15.0.11 brings several months of fixes since the 15.0.6 version packaged in MGA7.

Ref : https://nextcloud.com/changelog/#latest15

SRPM :

nextcloud-15.0.11-1.mga6.srpm

RPMS :

nextcloud-15.0.11-1.mga6.noarch.rpm
nextcloud-mysql-15.0.11-1.mga6.noarch.rpm
nextcloud-postgresql-15.0.11-1.mga6.noarch.rpm
nextcloud-sqlite-15.0.11-1.mga6.noarch.rpm
José Jorge 2019-08-20 10:24:43 CEST

CC: (none) => lists.jjorge

Comment 1 José Jorge 2019-08-20 11:35:19 CEST
Tested by myself in a production server. All Ok.

Whiteboard: (none) => MGA7-64-OK

Comment 2 Thomas Backlund 2019-08-31 11:52:38 CEST
Um, you list *mga6* rpms and add an OK for mga7.... thats now how this works

Whiteboard: MGA7-64-OK => (none)
CC: (none) => tmb

Comment 3 José Jorge 2019-08-31 11:55:39 CEST
(In reply to Thomas Backlund from comment #2)
> Um, you list *mga6* rpms and add an OK for mga7.... thats now how this works

Sorry, I wrote manually the list from a previous advisory, copy/paste error. This is really about MGA7!

Here it is fixed :

SRPM :

nextcloud-15.0.11-1.mga7.srpm

RPMS :

nextcloud-15.0.11-1.mga7.noarch.rpm
nextcloud-mysql-15.0.11-1.mga7.noarch.rpm
nextcloud-postgresql-15.0.11-1.mga7.noarch.rpm
nextcloud-sqlite-15.0.11-1.mga7.noarch.rpm
Comment 4 Herman Viaene 2019-09-20 15:32:34 CEST
MGA7-64 Plasma on Lenovo B50
No  installation issues.
I was talked into give this update a try, but that's not a nice experience. The wiki link in the list yields nothing, and the recent update bugs give very little info how to proceed.
Googled around and was lead to believe that the SQLite option did not work anymore, and all is needed is just browse to the nextcloud. But when there choosing mysql, one is asked to refer to some nextcloud user/database.
Gave up on that path and tried the SQLite option, and that made me a page where I cn upload files. So should be OK.

CC: (none) => herman.viaene

Comment 5 Brian Rockwell 2019-09-21 16:55:54 CEST
Sorry Herman - you and I will have to share on getting a wiki updated sometime.

Since this swill likely be deployed on the below OS version I went ahead and installed it.  This is on a VM.

- cpupower-5.2.16-2.mga7.x86_64
- kernel-desktop-5.2.16-2.mga7-1-1.mga7.x86_64
- kernel-desktop-latest-5.2.16-2.mga7.x86_64
- microcode-0.20190918-1.mga7.nonfree.noarch


I rebooted

- installed Postgresql 11.5 started that
- installed Nextcloud 15.06 started httpd and set up new admin user
- test 15.06 by adding user b2 (because I'm so innovative).
- added text document
- added photo


All worked as expected.

# systemctl stop httpd


-----


The following 3 packages are going to be installed:

- nextcloud-15.0.11-1.mga7.noarch
- nextcloud-mysql-15.0.11-1.mga7.noarch
- nextcloud-postgresql-15.0.11-1.mga7.noarch

2.2MB of additional disk space will be used.

-- restarting service
# systemctl start httpd

went to URL - got the following message

"Nextcloud will be updated to version 15.0.11"

- after it did some work.
"Update to 15.0.11

The update was successful. Redirecting you to Nextcloud in 0 seconds."


---- 

logged into b2 user and confirmed photo added before was there and then added another.
logged into administrator account and updated a document that I added, then I added another user to the system and confirmed that worked as well

This upgrade is successful.

CC: (none) => brtians1
Whiteboard: (none) => MGA7-64-OK

Thomas Backlund 2019-09-21 17:08:21 CEST

Keywords: (none) => advisory, validated_update
CC: (none) => sysadmin-bugs

Comment 6 Mageia Robot 2019-09-21 18:06:32 CEST
An update for this issue has been pushed to the Mageia Updates repository.

https://advisories.mageia.org/MGAA-2019-0138.html

Status: NEW => RESOLVED
Resolution: (none) => FIXED

Comment 7 Brian Rockwell 2019-09-21 18:10:46 CEST
José Jorge

I went for a straight install on 32-bit and got the message.

"Error

It looks like you are trying to reinstall your Nextcloud. However the file CAN_INSTALL is missing from your config directory. Please create the file CAN_INSTALL in your config folder to continue."

We probably need to get a sub-fix out with a fix to the config file for new installs.
Comment 8 Brian Rockwell 2019-09-21 18:45:59 CEST
well the fix is super easy at least.

Using root I created a file in the /etc/nextcloud directory

# touch CAN_INSTALL
# chown apache CAN_INSTALL


restart httpd and it works.
Comment 9 Brian Rockwell 2019-09-21 18:46:47 CEST
FYI

This 32-bit test was with Mariadb.

Yes installed to "My Maria" by Brooks & Dunn
Brian Rockwell 2019-09-21 18:46:57 CEST

Whiteboard: MGA7-64-OK => MGA7-64-OK MGA7-32-OK

Comment 10 Herman Viaene 2019-09-22 09:07:53 CEST
I forgot to mention that I had to do the same as Comment 7.

Note You need to log in before you can comment on or make changes to this bug.