Bug 25330 - Unable to run docker-compose due to a broken dependency in python-jsonschema
Summary: Unable to run docker-compose due to a broken dependency in python-jsonschema
Status: RESOLVED FIXED
Alias: None
Product: Mageia
Classification: Unclassified
Component: RPM Packages (show other bugs)
Version: 7
Hardware: All Linux
Priority: Normal normal
Target Milestone: ---
Assignee: QA Team
QA Contact:
URL:
Whiteboard: MGA7-64-OK
Keywords: advisory, validated_update
: 24706 (view as bug list)
Depends on:
Blocks:
 
Reported: 2019-08-20 02:19 CEST by Bruno Cornec
Modified: 2019-09-21 18:06 CEST (History)
4 users (show)

See Also:
Source RPM: python-jsonschema
CVE:
Status comment:


Attachments

Description Bruno Cornec 2019-08-20 02:19:12 CEST
After installing docker-compose and trying to run it on a working yml file, python aborts with an error, because of a missing dependency (python2-functools32 required by python-jsonschema)
Comment 1 Bruno Cornec 2019-08-20 02:21:48 CEST
Fixed with  python-jsonschema-3.0.2-1.1.mga7 uploaded to updates_testing

Status: NEW => ASSIGNED

Comment 2 Bruno Cornec 2019-09-04 12:30:24 CEST
Is it possible for the QA tea to move that package into updates or should I ask someone else ?

Assignee: bruno.cornec => qa-bugs

Comment 3 David Walser 2019-09-04 20:14:29 CEST
*** Bug 24706 has been marked as a duplicate of this bug. ***

CC: (none) => dieter

Comment 4 David Walser 2019-09-04 20:16:12 CEST
Yes Bruno, all updates must go through QA.  You need to provide an advisory though.
Comment 5 Len Lawrence 2019-09-20 10:36:27 CEST
mga7, x86_64

Confirmed that docker-compose fails with the error listed in description (comment 0).
Updated python2-jsonschema, with dependency python2-functools32.

docker-compose now launches OK.
$ docker-compose version
docker-compose version 1.23.2, build 1110ad0
docker-py version: 3.6.0
CPython version: 2.7.16
OpenSSL version: OpenSSL 1.1.0j  20 Nov 2018

I would hesitate to test this because there is a learning curve to navigate.
  
Leaving the OK until the suggested advisory appears.

CC: (none) => tarazed25

Thomas Backlund 2019-09-21 17:05:06 CEST

Whiteboard: (none) => MGA7-64-OK
CC: (none) => tmb, sysadmin-bugs
Keywords: (none) => advisory, validated_update

Comment 6 Mageia Robot 2019-09-21 18:06:30 CEST
An update for this issue has been pushed to the Mageia Updates repository.

https://advisories.mageia.org/MGAA-2019-0137.html

Resolution: (none) => FIXED
Status: ASSIGNED => RESOLVED


Note You need to log in before you can comment on or make changes to this bug.