Bug 25226 - can not find pam_userdb.so (lib64dbnss4.8-devel is needed as BuildRequires to make lib64pam0 contain that file)
Summary: can not find pam_userdb.so (lib64dbnss4.8-devel is needed as BuildRequires to...
Alias: None
Product: Mageia
Classification: Unclassified
Component: RPM Packages (show other bugs)
Version: 7
Hardware: All Linux
Priority: Normal normal
Target Milestone: ---
Assignee: QA Team
QA Contact:
Whiteboard: MGA7-64-OK
Keywords: advisory, validated_update
Depends on:
Reported: 2019-08-05 17:36 CEST by eric gerbier
Modified: 2019-08-12 23:09 CEST (History)
6 users (show)

See Also:
Source RPM: pam-1.3.1-1.mga7.src.rpm
Status comment:


Description eric gerbier 2019-08-05 17:36:51 CEST
Description of problem:
In previous releases (<= 6), I was using the pam module pam_userdb which allow
to manage accounts from a database

the module documentation is available in pam-doc package ( /usr/share/doc/pam-doc/txts/README.pam_userdb ), and in pam package ( /usr/share/doc/pam/html/sag-pam_userdb.html ), but the pam_userdb.so library is not in lib64pam0-1.3.1-1.mga7 package

I have checked the source package, the code is still avalaible ( Linux-PAM-1.3.1/modules/pam_userdb )

Version-Release number of selected component (if applicable):

How reproducible:
urpmf pam_userdb

Steps to Reproduce:
Comment 1 eric gerbier 2019-08-06 09:27:53 CEST
I have tried to rebuild the pam package with 
rpmbuild --rebuild pam-1.3.1-1.mga7.src.rpm
and I have the same result : no pam_userdb

So I enter the spec file, the configure and Makefile, and found the needed dependency. Because the spec file contains on line 200 : 
--with-db-uniquename=_nss \

the configure test for -ldb_nss (and not -ldb)
so it needs the lib64dbnss4.8-devel rpm package to build the pam module pam_userdb

Could you add the required BuildRequires in spec file, and provide a new lib64pam0 package ?
Marja Van Waes 2019-08-06 19:13:05 CEST

Assignee: bugsquad => basesystem
Whiteboard: (none) => MGA7TOO
Version: 7 => Cauldron
Summary: can not find pam_userdb.so => can not find pam_userdb.so (lib64dbnss4.8-devel is needed as BuildRequires to make lib64pam0 contain that file)
CC: (none) => makowski.mageia, marja11, thierry.vignaud

Comment 2 Jani Välimaa 2019-08-06 22:17:55 CEST
Pushed pam-1.3.1-1.1.mga7 to core/updates_testing for mga7. Please test. Fixed also in cauldron.

Assignee: basesystem => qa-bugs
Version: Cauldron => 7
Whiteboard: MGA7TOO => (none)

Comment 3 eric gerbier 2019-08-07 10:38:55 CEST
It works for me
thanks !
David Walser 2019-08-11 17:34:18 CEST

Whiteboard: (none) => MGA7-64-OK

Comment 4 Thomas Andrews 2019-08-12 03:05:00 CEST

Keywords: (none) => validated_update
CC: (none) => andrewsfarm, sysadmin-bugs

Thomas Backlund 2019-08-12 22:10:26 CEST

Keywords: (none) => advisory
CC: (none) => tmb

Comment 5 Mageia Robot 2019-08-12 23:09:29 CEST
An update for this issue has been pushed to the Mageia Updates repository.


Resolution: (none) => FIXED

Note You need to log in before you can comment on or make changes to this bug.