Bug 25061 - Unable to add Exchange EWS accounts in Evolution
Summary: Unable to add Exchange EWS accounts in Evolution
Status: NEW
Alias: None
Product: Mageia
Classification: Unclassified
Component: RPM Packages (show other bugs)
Version: 7
Hardware: x86_64 Linux
Priority: Normal normal
Target Milestone: ---
Assignee: QA Team
QA Contact:
URL: https://forums.mageia.org/en/viewtopi...
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-07-06 15:32 CEST by Matt Farrell
Modified: 2019-11-26 13:18 CET (History)
5 users (show)

See Also:
Source RPM: evolution-ews-3.32.2-1.mga7.src.rpm
CVE:
Status comment:


Attachments

Description Matt Farrell 2019-07-06 15:32:30 CEST
After installing both evolution and evolution-ews in a clean install of Mageia 7 the option to create accounts using Exchange Web Services does not appear in Evolution.

Version-Release number of selected component (if applicable):
evolution-3.32.2-1.mga7
evolution-ews-3.32.2-1.mga7

How reproducible:
Install evolution and evolution-ews then attempt to create either a mail account or a collection account with the server type of Exchange Web Services.

The error messages when Evolution is launched form the console are:

(evolution:4656): e-data-server-WARNING **: 14:59:41.251: module_load: libcamelews-priv.so: cannot open shared object file: No such file or directory
Failed to load module: /usr/lib64/evolution/modules/module-ews-configuration.so

(evolution:4656): camel-CRITICAL **: 14:59:41.371: camel_provider_list: Could not load /usr/lib64/evolution-data-server/camel-providers/libcamelews.so: libcamelews-priv.so: cannot open shared object file: No such file or directory

(evolution-alarm-notify:4683): camel-CRITICAL **: 14:59:41.592: camel_provider_list: Could not load /usr/lib64/evolution-data-server/camel-providers/libcamelews.so: libcamelews-priv.so: cannot open shared object file: No such file or directory

The file libcamelews-priv.so does exist in /usr/lib64/evolution-ews/.
Comment 1 Lewis Smith 2019-07-06 21:39:43 CEST
Assigning to you, Olav, rather than anybody, because you are the top Evolution committer! I will try this myself when I have a moment.

Assignee: bugsquad => olav
CC: (none) => lewyssmith

Comment 2 Matt Farrell 2019-07-07 21:00:31 CEST
In the forum thread linked doktor5000 was able to come up with a manual fix.  

Copying /usr/lib64/evolution-ews/libcamelews-priv.so, /usr/lib64/evolution-ews/libevolution-ews.so, and /usr/lib64/evolution-data-server/camel-providers/libcamelews.so to /usr/lib64 allowed Evolution to work correctly with Exchange Web Services.
Comment 3 r howard 2019-07-07 23:24:35 CEST
Matt Farrell did you try creating a link in /usr/lib64 for each of the .so instead of copying them?

CC: (none) => rihoward1

Comment 4 Matt Farrell 2019-07-07 23:31:05 CEST
No, I just copied them directly.  I will remove the copies and try creating links instead.  I will also try different combinations of the files to see if all three are needed.
Florian Hubold 2019-07-08 13:41:35 CEST

CC: (none) => doktor5000

Comment 5 Matt Farrell 2019-07-08 18:26:42 CEST
It appears that I was a little hasty in saying that the problem is fixed.  While either linking or copying the files to /usr/lib64/ allows the option to select Exchange Web Services for a mailbox type it is still not fully functional.

On my primary desktop the account settings were in place so it picked up as soon as the files were visible to the application.  On my test machine while the option showed up it would not save the account settings.
Comment 6 Matt Farrell 2019-07-08 19:34:57 CEST
I realized that the account that was not working was the one that I had been testing everything with.  I created new test accounts and verified that the fixes are working.

I tested with the three files copied into /usr/lib64/ and with both hard and symbolic links using three separate new test users.  In all three cases Exchange Web Services was offered as a server type and was able to connect without any problems.
Comment 7 Lewis Smith 2019-07-13 21:37:32 CEST
Thank you Matt for your exploration of this problem and its resolution.
.
The solution you found looks like a packaging issue. There are two developers seeing this bug; if you think it is not for you, please re-assign it to pkg-bugs or whoever you see as most appropriate. TIA.
Comment 8 Giuseppe Merigo 2019-11-25 12:00:32 CET
I can confirm that the workaround of creating the symlinks make both the Exchange account selectable in the configuration wizard and working afterwards. I choose the symlink because in case of an update if the file is overwritten the link points to the new one.

Maybe a workaround can be put in place in the package before the “right” solution can be implemented by making the post install of the rpm do the symlinks.

CC: (none) => g.merigo

Comment 9 Lewis Smith 2019-11-25 19:02:09 CET
Re-assigning to all packagers since the solution is identified, and nothing seems to be happening.
Thanks to RH, Matt & Giuseppe for your contributions.

Assignee: olav => pkg-bugs
CC: lewyssmith => (none)

Comment 10 José Jorge 2019-11-25 19:11:55 CET
I tried to understand which files are at the bad place, and could not :

Failed to load /usr/lib64/evolution/modules/module-ews-configuration.so
It does not fail when it is in /usr/lib64/module-ews-configuration.so ?

CC: (none) => lists.jjorge

Comment 11 David GEIGER 2019-11-25 19:34:25 CET
Could you try with upcoming evolution-ews-3.32.2-1.1.mga7 in Core/Updates_testing repo, please?

CC: (none) => geiger.david68210

Comment 12 Giuseppe Merigo 2019-11-26 08:47:25 CET
I could test it only this morning and - provided you remove the symlinks - it seems to work.

I can download emails and see calendar entries, and a brief search for contacts worked.
Comment 13 David GEIGER 2019-11-26 13:18:37 CET
Assigning to QA,


Advisory:
========================

This update fixes load errors with evolution-ews's private shared libraries enabling rpath.

For load errors reference:
(evolution:4656): e-data-server-WARNING **: 14:59:41.251: module_load: libcamelews-priv.so: cannot open shared object file: No such file or directory
Failed to load module: /usr/lib64/evolution/modules/module-ews-configuration.so.


========================

Packages in 7/core/updates_testing:
========================
evolution-ews-3.32.2-1.1.mga7.x86_64.rpm
evolution-ews-3.32.2-1.1.mga7.i586.rpm

Source RPM: 
========================
evolution-ews-3.32.2-1.1.mga7.src.rpm

Assignee: pkg-bugs => qa-bugs
Source RPM: (none) => evolution-ews-3.32.2-1.mga7.src.rpm


Note You need to log in before you can comment on or make changes to this bug.