Bug 25056 - Can't install mageia 7 when a mdadm raid array is present
Summary: Can't install mageia 7 when a mdadm raid array is present
Status: RESOLVED DUPLICATE of bug 22307
Alias: None
Product: Mageia
Classification: Unclassified
Component: Installer (show other bugs)
Version: 7
Hardware: x86_64 Linux
Priority: Normal normal
Target Milestone: ---
Assignee: Mageia Bug Squad
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-07-05 18:36 CEST by jeff
Modified: 2019-07-06 18:19 CEST (History)
1 user (show)

See Also:
Source RPM:
CVE:
Status comment:


Attachments

Description jeff 2019-07-05 18:36:43 CEST
Description of problem:
I have a computer which was running mageia 6.
It has a boot disk (/dev/sda) and 7 rand drives.
I tried updating it online via the command line, which bricked the box.
I then did a fresh install using a usb flash disk which I have used to install mageia 7 on four other computers successfully.

The installer starts up normally.
When looking for a disk to install mageia 7 on, it sees the raid drives, but can't recognize the partitions and asks if it can erase them. I always clock no.
It then says it can't find any space to install mageia 7.

I removed all of the raid disks, and left only /dev/sda (which happens to have win 10 also installed on it), and the installation was successful.

This is similar to bugs:
https://bugs.mageia.org/show_bug.cgi?id=22307
https://bugs.mageia.org/show_bug.cgi?id=11105

After I booted mageia 7 successfully, I installed the raid disks and they were automagically detected as an array, and the array was started successfully.

This problem of being unable to install with a raid array present has been around for several years, and really should be fixed.



Version-Release number of selected component (if applicable):
mageia 7

How reproducible:
100%

Steps to Reproduce:
1. try to install mageia 7
2. it can't find any disk space
3. cry
Comment 1 Lewis Smith 2019-07-06 18:19:57 CEST
Thank you for the report (and its bug references), which is clearer than bug 22307, but the same sort of problem.
> This problem of being unable to install with a raid array present has been
> around for several years, and really should be fixed.
Agree.
However, since the other bug is older, and has diagnostic advice, you will I hope excuse me in marking this one as a duplicate of the other.

*** This bug has been marked as a duplicate of bug 22307 ***

Status: NEW => RESOLVED
CC: (none) => lewyssmith
Resolution: (none) => DUPLICATE


Note You need to log in before you can comment on or make changes to this bug.