Bug 25023 - Minimal installation Mageia-7 via the network installer not the minimal
Summary: Minimal installation Mageia-7 via the network installer not the minimal
Status: RESOLVED FIXED
Alias: None
Product: Mageia
Classification: Unclassified
Component: RPM Packages (show other bugs)
Version: 7
Hardware: All Linux
Priority: Normal normal
Target Milestone: ---
Assignee: QA Team
QA Contact:
URL:
Whiteboard: MGA7-64-OK
Keywords: advisory, validated_update
Depends on:
Blocks:
 
Reported: 2019-06-29 20:24 CEST by Alex Grant
Modified: 2019-07-18 09:26 CEST (History)
4 users (show)

See Also:
Source RPM: meta-task, nvidia-nsight, drakx-installer-stage2
CVE:
Status comment:


Attachments
1-Mageia-7-NetInstall (182.41 KB, image/png)
2019-06-29 20:26 CEST, Alex Grant
Details
2-Mageia-7-NetInstall (184.23 KB, image/png)
2019-06-29 20:27 CEST, Alex Grant
Details
3-Mageia-7-NetInstall (189.18 KB, image/png)
2019-06-29 20:27 CEST, Alex Grant
Details
4-Mageia-7-NetInstall (169.28 KB, image/png)
2019-06-29 20:27 CEST, Alex Grant
Details
5-Mageia-7-NetInstall (324.35 KB, image/png)
2019-06-29 20:28 CEST, Alex Grant
Details
report.bug.xz for Manuel Hiebel (162.36 KB, application/x-xz)
2019-06-30 09:11 CEST, Alex Grant
Details
dependencies list (7.91 KB, text/plain)
2019-07-05 13:11 CEST, James Kerr
Details
6-Mageia-7-minimal-installation-from-classic-iso (204.78 KB, image/png)
2019-07-11 19:53 CEST, Alex Grant
Details
7-Mageia-7-minimal-netinstall-with-meta-task-7-1.1 (231.71 KB, image/png)
2019-07-11 19:54 CEST, Alex Grant
Details
List of packages installed from the classic DVD (minimal +X) (22.34 KB, text/plain)
2019-07-13 16:39 CEST, Alex Grant
Details
List of packages installed from the netinstall (minimal +X) (24.51 KB, text/plain)
2019-07-13 16:40 CEST, Alex Grant
Details
The difference of installed packages from a DVD and netinstall (13.15 KB, patch)
2019-07-13 16:42 CEST, Alex Grant
Details | Diff
report.bug.xz for Thomas Backlund (170.75 KB, application/x-xz)
2019-07-17 19:44 CEST, Alex Grant
Details
report.bug.xz with 20GB virtual HDD for Thomas Backlund (166.21 KB, application/x-xz)
2019-07-17 22:12 CEST, Alex Grant
Details
8-Mageia-7-minimal-netinstall-with-20GB-HDD-for-Thomas Backlund (224.90 KB, image/png)
2019-07-17 22:29 CEST, Alex Grant
Details
9-Mageia-7.1-minimal-netinstall-FIXED (240.87 KB, image/png)
2019-07-18 07:19 CEST, Alex Grant
Details

Description Alex Grant 2019-06-29 20:24:52 CEST
Description of problem:
Hello. To install Mageia-7 I use the network installer Mageia-7-netinstall-x86_64.iso or Mageia-7-netinstall-nonfree-x86_64.iso.

Minimal installation through any network installer is not minimal. Minimum installation size via any network installer is 2 times larger than the minimum installation from the classic ISO and is equal to 3GB. In installation an extra 
nvidia-nsight-10.1.168-1.mga7.nonfree.x86_64.rpm package is included and probably its dependencies. To remove "nvidia-nsight" does not work, because it "drakconf" and other important packages pull along.

If you disable NonFree mirrors during installation, the size is normalized (~1,5GB). Thus, the installation of any DE it turns out to be more than normal by 1.5 GB, if the installation is made through the network. Why when installing via any network installer is this happening?

The attachments contain screenshots of the minimum installation of Mageia-7 via the network and the result.


Version-Release number of selected component (if applicable):
Mageia-7-netinstall-x86_64.iso, Mageia-7-netinstall-nonfree-x86_64.iso


How reproducible:
Boot from Mageia-7-netinstall-x86_64.iso or Mageia-7-netinstall-nonfree-x86_64.iso and install the minimum version of Mageia-7.


Steps to Reproduce:
Boot from Mageia-7-netinstall-x86_64.iso or Mageia-7-netinstall-nonfree-x86_64.iso and install the minimum version of Mageia-7.
Comment 1 Alex Grant 2019-06-29 20:26:47 CEST
Created attachment 11134 [details]
1-Mageia-7-NetInstall
Comment 2 Alex Grant 2019-06-29 20:27:09 CEST
Created attachment 11135 [details]
2-Mageia-7-NetInstall
Comment 3 Alex Grant 2019-06-29 20:27:28 CEST
Created attachment 11136 [details]
3-Mageia-7-NetInstall
Comment 4 Alex Grant 2019-06-29 20:27:51 CEST
Created attachment 11137 [details]
4-Mageia-7-NetInstall
Comment 5 Alex Grant 2019-06-29 20:28:10 CEST
Created attachment 11138 [details]
5-Mageia-7-NetInstall
Comment 6 Manuel Hiebel 2019-06-30 00:27:23 CEST
Hi, could you add the /root/drakx/report.bug.xz as an attachment

(btw, for me, minimal is without X)
Comment 7 Thomas Backlund 2019-06-30 03:14:35 CEST

Yeah, the nonfree nvidia-nsight has several provides that makes it get selected over the wanted:

qt-creator
libhyphen0
lib64hyphen0
libjpeg8
lib64jpeg8
libpng12_0
lib64png12_0


I just pushed a  meta-task-7-1.1.mga7 that will make urpmi/rpmdrake prefer the free apps/libs from core

CC: (none) => tmb

Thomas Backlund 2019-06-30 03:14:51 CEST

Source RPM: (none) => meta-task, nvidia-nsight

Comment 8 Alex Grant 2019-06-30 09:11:54 CEST
Created attachment 11139 [details]
report.bug.xz for Manuel Hiebel
Comment 9 Thomas Backlund 2019-07-01 16:56:14 CEST
Advisory:
Updated preferred packages list

The nonfree nvidia-nsight package has some provides that sometimes can cause it to get installed instead of the expected qt-creator, lib(64)hyphen0, lib(64)jpeg8
and lib(64)png12_0 packages.

This update adds the expected packages to the preferred list, ensuring they get installed.


SRPMS:
mageia-repos-7-4.mga7.src.rpm
meta-task-7-1.1.mga7.src.rpm


i586:
mageia-repos-7-4.mga7.i586.rpm
mageia-repos-keys-7-4.mga7.noarch.rpm
mageia-repos-pkgprefs-7-4.mga7.noarch.rpm
meta-task-7-1.1.mga7.noarch.rpm


x86_64:
mageia-repos-7-4.mga7.x86_64.rpm
mageia-repos-keys-7-4.mga7.noarch.rpm
mageia-repos-pkgprefs-7-4.mga7.noarch.rpm
meta-task-7-1.1.mga7.noarch.rpm



Note to testers, the lib order is harder to test as urpmi mostly gets that right because of other deps on normal installs, but the qt-creator package is easy to test this update with:


Before this update:
LC_ALL=C urpmi "libCore.so()(64bit)"
In order to satisfy the 'qt-creator|nvidia-nsight' dependency, one of the following packages is needed:
 1- nvidia-nsight-10.1.168-1.mga7.nonfree.x86_64: NVIDIA Nsight IDE (to install)
 2- qt-creator-4.9.0-1.mga7.x86_64: Qt Creator is a lightweight, cross-platform integrated development environment (IDE) (to install)


After this update:
LC_ALL=C urpmi "libCore.so()(64bit)"
In order to satisfy the 'qt-creator|nvidia-nsight' dependency, one of the following packages is needed:
 1- qt-creator-4.9.0-1.mga7.x86_64: Qt Creator is a lightweight, cross-platform integrated development environment (IDE) (to install)
 2- nvidia-nsight-10.1.168-1.mga7.nonfree.x86_64: NVIDIA Nsight IDE (to install)


and if you want to test on 32bit, remove the "(64bit)" from the urpmi command

Component: Installer => RPM Packages

Manuel Hiebel 2019-07-01 19:52:16 CEST

Assignee: bugsquad => qa-bugs

Comment 10 James Kerr 2019-07-05 13:04:55 CEST
on mga7-64

Before update:
# urpmi "libCore.so()(64bit)"
In order to satisfy the 'qt-creator|nvidia-nsight' dependency, one of the following packages is needed:
 1- nvidia-nsight-10.1.168-1.mga7.nonfree.x86_64: NVIDIA Nsight IDE (to install)
 2- qt-creator-4.9.0-1.mga7.x86_64: Qt Creator is a lightweight, cross-platform integrated development environment (IDE) (to install)

packages installed cleanly:
- meta-task-7-1.1.mga7.noarch
- mageia-repos-7-4.mga7.x86_64
- mageia-repos-keys-7-4.mga7.noarch
- mageia-repos-pkgprefs-7-4.mga7.noarch

#  urpmi "libCore.so()(64bit)"
In order to satisfy the 'qt-creator|nvidia-nsight' dependency, one of the following packages is needed:
 1- qt-creator-4.9.0-1.mga7.x86_64: Qt Creator is a lightweight, cross-platform integrated development environment (IDE) (to install)
 2- nvidia-nsight-10.1.168-1.mga7.nonfree.x86_64: NVIDIA Nsight IDE (to install)

leaving the qt-creator package selected results in a long list of dependencies:
 
....
375MB of additional disk space will be used.
96MB of packages will be retrieved.
Proceed with the installation of the 114 packages? 

if that is expected, the update is OK for mga7-64

CC: (none) => jim

Comment 11 James Kerr 2019-07-05 13:11:30 CEST
Created attachment 11152 [details]
dependencies list


these are the dependencies referred to in comment#10
Comment 12 Thomas Backlund 2019-07-05 13:21:58 CEST
(In reply to James Kerr from comment #10)
> on mga7-64
> 
> Before update:
> # urpmi "libCore.so()(64bit)"
> In order to satisfy the 'qt-creator|nvidia-nsight' dependency, one of the
> following packages is needed:
>  1- nvidia-nsight-10.1.168-1.mga7.nonfree.x86_64: NVIDIA Nsight IDE (to
> install)
>  2- qt-creator-4.9.0-1.mga7.x86_64: Qt Creator is a lightweight,
> cross-platform integrated development environment (IDE) (to install)
> 
> packages installed cleanly:
> - meta-task-7-1.1.mga7.noarch
> - mageia-repos-7-4.mga7.x86_64
> - mageia-repos-keys-7-4.mga7.noarch
> - mageia-repos-pkgprefs-7-4.mga7.noarch
> 
> #  urpmi "libCore.so()(64bit)"
> In order to satisfy the 'qt-creator|nvidia-nsight' dependency, one of the
> following packages is needed:
>  1- qt-creator-4.9.0-1.mga7.x86_64: Qt Creator is a lightweight,
> cross-platform integrated development environment (IDE) (to install)
>  2- nvidia-nsight-10.1.168-1.mga7.nonfree.x86_64: NVIDIA Nsight IDE (to
> install)
> 

This confirms the expected order.


> leaving the qt-creator package selected results in a long list of
> dependencies:
>  
> ....
> 375MB of additional disk space will be used.
> 96MB of packages will be retrieved.
> Proceed with the installation of the 114 packages? 
> 
> if that is expected, the update is OK for mga7-64

Yeah, I forgot to mention that qt-creator is a development IDE, so it pulls in a lot of developent stuff..., ...

So it's all OK
James Kerr 2019-07-05 17:12:46 CEST

Whiteboard: (none) => MGA7-64-OK

Comment 13 Rémi Verschelde 2019-07-10 10:00:40 CEST
Testing `urpmi "libCore.so()(64bit)"` here, after installing meta-task, I get nvidia-nsight installed automatically.

It's likely because I already have qt-creator installed, so I guess it's expected.
Comment 14 Rémi Verschelde 2019-07-10 10:04:25 CEST
Advisory uploaded, validating.

Keywords: (none) => advisory, validated_update
CC: (none) => sysadmin-bugs

Comment 15 Mageia Robot 2019-07-10 12:45:35 CEST
An update for this issue has been pushed to the Mageia Updates repository.

https://advisories.mageia.org/MGAA-2019-0054.html

Resolution: (none) => FIXED
Status: NEW => RESOLVED

Comment 16 Alex Grant 2019-07-11 19:53:28 CEST
Created attachment 11174 [details]
6-Mageia-7-minimal-installation-from-classic-iso
Comment 17 Alex Grant 2019-07-11 19:54:02 CEST
Created attachment 11175 [details]
7-Mageia-7-minimal-netinstall-with-meta-task-7-1.1
Comment 18 Alex Grant 2019-07-11 19:57:28 CEST
Hello, Thomas Backlund.
I don't want to seem Intrusive... Still... Please look at the last two screenshots: 6-Mageia-7-minimal-installation-from-classic-iso and 7-Mageia-7-minimal-netinstall-with-meta-task-7-1.1.png. Why is the size of the minimum installation via netinstaller almost 2 times larger than the same minimum installation from the classic ISO: 3.0 GB vs 1.7 GB?

With respect,
Alex

Resolution: FIXED => (none)
Status: RESOLVED => REOPENED

Comment 19 Thomas Backlund 2019-07-11 20:09:32 CEST
Because stage2 installer on mirrors is not updated to have last meta-task yet.

It will be soon-ish

Status: REOPENED => RESOLVED
Resolution: (none) => FIXED

Comment 20 Thomas Backlund 2019-07-11 20:12:45 CEST
Also, net-install will always be a bit bigger than when installed from CI as the installer has a list of "install if available" so since there are more rpms on mirrors than on DVD...

Not to mention, if you allow "Recommended packages" to get installed it will be even bigger...
Comment 21 Alex Grant 2019-07-11 20:30:40 CEST
Thomas, 1.3 GB is a significant increase (we collect bootable flash drives from Mageia Linux). And without the recommended packages, problems usually emerge, primarily with graphics drivers and the network. You have in the distribution, incidentally, is still not enough packages wpa_supplicant and wpa_supplicant-gui: without them, the wifi is not working. But that's probably a different story, OK. Thank you, then I'll wait. Sorry to bother you.

p.s. And forgive me for my bad English. I write through online the translator.

With respect,
Alex
Comment 22 Alex Grant 2019-07-13 16:39:53 CEST
Created attachment 11177 [details]
List of packages installed from the classic DVD (minimal +X)
Comment 23 Alex Grant 2019-07-13 16:40:46 CEST
Created attachment 11178 [details]
List of packages installed from the netinstall (minimal +X)
Comment 24 Alex Grant 2019-07-13 16:42:27 CEST
Created attachment 11179 [details]
The difference of installed packages from a DVD and netinstall
Comment 25 Alex Grant 2019-07-13 16:45:45 CEST
(In reply to Thomas Backlund from comment #19)
> Because stage2 installer on mirrors is not updated to have last meta-task
> yet.
> 
> It will be soon-ish

Hello, Thomas Backlund.

I decided to compare the lists of packages that are put by default in the minimum installation (+X) c DVD and over the network with using Mageia-7-netinstall-x86_64.iso.

In the attachment You will find the files:
---
dvd - the list of packages, which is put from the classic DVD
netinstall - the list of packages that is installed when installing from the network
diff-result - comparison result file

I ask You to pay attention that the package "meta-task-7-1.1" (new) participates in installation of the minimum system from a network.

Please pay special attention to the "nvidia-nsight" package. It is this nonfree package that attracts the most some extra packages that increase the total size of the system on the disk by 1.3 GB when installed from the network. 

This package is not available when installing from a classic DVD. I do not exclude that in this list You will find and other unnecessary packages.

Additionally, I beg You to pay attention to the fact that with minimal installation via the network, the system lacks the package "lib64hyphen0", so drakconf does not start (this also applies to a network installation).

I hope that these lists and the result of the comparison will be useful in order to make a minimal installation of Mageia-7 minimal.

With respect,
Alex

Status: RESOLVED => REOPENED
Resolution: FIXED => (none)

Comment 26 Thomas Backlund 2019-07-15 23:48:08 CEST
As I told you, this will be fully fixed when the new installer lands on the mirrors (it's lfinally currently mirroring out)

The lib64hyphen0 is also provided by nvidia-nsight, so it got pulled in.

Wnth the new stage2 installer on the mirror, it has access to the correct meta-task, and wont install nvidia-nsight anymore

Resolution: (none) => FIXED
Status: REOPENED => RESOLVED

Comment 27 Alex Grant 2019-07-17 14:34:47 CEST
(In reply to Thomas Backlund from comment #26)
> As I told you, this will be fully fixed when the new installer lands on the
> mirrors (it's lfinally currently mirroring out)
> 
> The lib64hyphen0 is also provided by nvidia-nsight, so it got pulled in.
> 
> Wnth the new stage2 installer on the mirror, it has access to the correct
> meta-task, and wont install nvidia-nsight anymore

Hello, Thomas. I downloaded the new Mageia-7.1-netinstall-x86_64.iso and French mirrors installed Mageia-7.1. nvidia-nsight is back in place, and the minimum installation (+X) Mageia-7.1 from the network is still 1.3GB more classic with DVD and is as before 3.1GB. I use the right installer (stage2)?

With respect,
Alex
Comment 28 Thomas Backlund 2019-07-17 18:58:49 CEST
ok, that should not happend :/
It did not happend here :(

Can you attach the /root/drakx/report.bug.xz from an affected install
Comment 29 Alex Grant 2019-07-17 19:44:30 CEST
Created attachment 11194 [details]
report.bug.xz for Thomas Backlund
Comment 30 Thomas Backlund 2019-07-17 20:48:04 CEST
@Alex, how big partition are you installing on ?


@Thierry, any idea about this ?
Is this an urpmi bug (or feature) ?

from report.bug in comment 29:

In the begining it does the correct:
* requiring lib64hyphen0[== 2.8.8-7.mga7] for hyphen-2.8.8-7.mga7.x86_64
* chosen lib64hyphen0-2.8.8-7.mga7.x86_64 for lib64hyphen0[== 2.8.8-7.mga7]
* selecting lib64hyphen0-2.8.8-7.mga7.x86_64


But then we get size problems later on:
* disabling selected packages because too big for level 5: 5519605184 > 5426932879.5191
...
* unselecting lib64hyphen0-2.8.8-7.mga7.x86_64
...


and later on when it goes through the deps again:
* packageCallbackChoices: default choice ('nvidia-nsight') from nvidia-nsight,lib64hyphen0 for libhyphen.so.0()(64bit)
* replacing libhyphen.so.0()(64bit) with nvidia-nsight

even if we have in meta-task:
http://svnweb.mageia.org/packages/updates/7/meta-task/current/SOURCES/prefer.vendor.list?r1=1416229&r2=1416228&pathrev=1416229

# prefer free packages over nvidia-nsight
qt-creator
libhyphen0
lib64hyphen0
libjpeg8
lib64jpeg8
libpng12_0
lib64png12_0

I guess the reason I dont hit it is I usually have 20GB disks, even in vbox

CC: (none) => thierry.vignaud

Comment 31 Alex Grant 2019-07-17 22:10:43 CEST
Thomas, for a single DE installation I usually use: swap(1GB)+'/'(7GB). In addition I attach the report.bug.xz VM with 20GB hard drive [swap(1GB)+'/'(19GB)]. The result of the installation is the same, without changes. :(
Comment 32 Alex Grant 2019-07-17 22:12:11 CEST
Created attachment 11195 [details]
report.bug.xz with 20GB virtual HDD for Thomas Backlund
Comment 33 Alex Grant 2019-07-17 22:29:30 CEST
Created attachment 11196 [details]
8-Mageia-7-minimal-netinstall-with-20GB-HDD-for-Thomas Backlund
Comment 34 Thomas Backlund 2019-07-18 00:07:15 CEST
ok, you definately are able to trigger an urpmi bug:

here it keeps flipping between lib64jpeg8 and nvidia-nsight:

* packageCallbackChoices: default choice ('lib64jpeg8') from lib64jpeg8,nvidia-nsight for libjpeg.so.8()(64bit)
* packageCallbackChoices: default choice ('nvidia-nsight') from nvidia-nsight,lib64jpeg8 for libjpeg.so.8()(64bit)
* packageCallbackChoices: default choice ('lib64jpeg8') from lib64jpeg8,nvidia-nsight for libjpeg.so.8(LIBJPEG_8.0)(64bit)
* packageCallbackChoices: default choice ('nvidia-nsight') from nvidia-nsight,lib64jpeg8 for libjpeg.so.8()(64bit)

Status: RESOLVED => REOPENED
Resolution: FIXED => (none)
Source RPM: meta-task, nvidia-nsight => urpmi

Thomas Backlund 2019-07-18 00:07:40 CEST

Whiteboard: MGA7-64-OK => (none)
Keywords: advisory, validated_update => (none)
Assignee: qa-bugs => bugsquad

Thomas Backlund 2019-07-18 00:07:59 CEST

Assignee: bugsquad => thierry.vignaud

Comment 35 Thomas Backlund 2019-07-18 00:45:51 CEST
Ah, crap...

Seems we got bitten by the buildsystem bug that hit us way back when we had to remove versioned module provides for kernels

It failed to install the peferred meta-task in chroot when it built stage2, despite it was already in updates, so the fixed prefer.vendor.list is not in stage2

I will fix up stage2 again ....

Assignee: thierry.vignaud => tmb
Source RPM: urpmi => urpmi, drakx-installer-stage2

Comment 36 Thomas Backlund 2019-07-18 02:01:39 CEST
Ok, there is now a 18.21.1 stage2 installer mirroring out on the mirrors, so please try again with that...

I see its already available on D-C:
https://distrib-coffee.ipsl.jussieu.fr/pub/linux/Mageia/distrib/7/x86_64/install/stage2/
Comment 37 Alex Grant 2019-07-18 07:16:56 CEST
(In reply to Thomas Backlund from comment #36)
> Ok, there is now a 18.21.1 stage2 installer mirroring out on the mirrors, so
> please try again with that...
> 
> I see its already available on D-C:
> https://distrib-coffee.ipsl.jussieu.fr/pub/linux/Mageia/distrib/7/x86_64/
> install/stage2/

Hello, Thomas. Hurray! This variant works! The minimum installation size is normal and is 1.9GB, nvidia-nsight is missing and drakconf is works. Everything is great! Thank you very much for your help. :)
Comment 38 Alex Grant 2019-07-18 07:19:15 CEST
Created attachment 11198 [details]
9-Mageia-7.1-minimal-netinstall-FIXED
Comment 39 Thomas Backlund 2019-07-18 09:26:48 CEST
Great, thank you for testing

Resolution: (none) => FIXED
Status: REOPENED => RESOLVED
Whiteboard: (none) => MGA7-64-OK
Source RPM: urpmi, drakx-installer-stage2 => meta-task, nvidia-nsight, drakx-installer-stage2
Keywords: (none) => advisory, validated_update
Assignee: tmb => qa-bugs


Note You need to log in before you can comment on or make changes to this bug.