Bug 24961 - xdm resets approx every 90 sec
Summary: xdm resets approx every 90 sec
Status: RESOLVED FIXED
Alias: None
Product: Mageia
Classification: Unclassified
Component: RPM Packages (show other bugs)
Version: 7
Hardware: All Linux
Priority: release_blocker normal
Target Milestone: Mageia 7
Assignee: Martin Whitaker
QA Contact:
URL:
Whiteboard:
Keywords: 7RC
Depends on:
Blocks:
 
Reported: 2019-06-16 00:12 CEST by ben mcmonagle
Modified: 2019-06-17 07:43 CEST (History)
2 users (show)

See Also:
Source RPM: xdm-1.1.12-2.mga7?
CVE:
Status comment:


Attachments

Description ben mcmonagle 2019-06-16 00:12:38 CEST
Description of problem:  xdm resets at about a 90 sec interval. if you are logged in, to ay Plasma, the desktop will close un-expextedly and the login prompt re-appear.

If you just wait at the login prompt for about 90 sec, the login prompt with dissappear and then re-appear.
If you are running on an Nvidia graphics driver, the Nvidia logo would appear breifly, then the login prompt.

affected hardware: 
Compax Presario C700, intel graphics
HP 8510w . Nvidia  340 graphics
Toshiba Portege R930, intel 810 or later graphics



Version-Release number of selected component (if applicable):
Mageia-7-rc-x86_64
DATE.txt: Mon May 27 17:50:29 CEST 2019


How reproducible: if installed from above .iso and also upgrade


Steps to Reproduce:
1.install a DE from above .iso that includes xdm as a backup.
2.change DM to xdm and reboot
3.either login to DE, and or wait about 90 sec at login prompt.
4. after about 90 seconds from initial login prompt presentation, DM will reset and re-present login prompt
Comment 1 ben mcmonagle 2019-06-16 00:13:42 CEST
see also bug 24959
ben mcmonagle 2019-06-16 00:17:05 CEST

Priority: Normal => release_blocker

ben mcmonagle 2019-06-16 00:59:14 CEST

Source RPM: (none) => xdm-1.1.12-2.mga7?
Target Milestone: --- => Mageia 7
Keywords: (none) => 7RC

Comment 2 Tony Blackwell 2019-06-16 11:25:40 CEST
I confirm this behaviour, with the additional comment that time for a root login can be substantially shorter than 90 sec.  I'd estimate about 30 sec; (at times not quite enough to open MCC, go to boot and change display manager...)

It is true for root.  I've not been able to demonstrate it for normal users, as for me but 24959 prevents normal user login at all via XDM - login fails instantly with login dialog restarting.  Very short login time!

CC: (none) => tablackwell

Comment 3 Martin Whitaker 2019-06-16 16:17:03 CEST
Should be fixed in xdm-1.1.12-3.

CC: (none) => mageia

Martin Whitaker 2019-06-16 16:17:26 CEST

Assignee: bugsquad => mageia

Comment 4 ben mcmonagle 2019-06-17 07:43:04 CEST
seems to be fixed for me

Status: NEW => RESOLVED
Resolution: (none) => FIXED


Note You need to log in before you can comment on or make changes to this bug.