Bug 24866 - klatexformula produces images that do not fit onto display window of klatexformula
Summary: klatexformula produces images that do not fit onto display window of klatexfo...
Alias: None
Product: Mageia
Classification: Unclassified
Component: RPM Packages (show other bugs)
Version: Cauldron
Hardware: All Linux
Priority: Normal major
Target Milestone: ---
Assignee: Nicolas Lécureuil
QA Contact:
Depends on: 25294
  Show dependency treegraph
Reported: 2019-05-24 20:23 CEST by w unruh
Modified: 2019-08-31 15:31 CEST (History)
3 users (show)

See Also:
Source RPM: klatexformula
Status comment:

Picture of the bad output of klatexforumla (58.42 KB, image/png)
2019-05-24 20:25 CEST, w unruh
Patch included in Debian ghostscript-9.27~dfsg-2 to fix this problem (3.51 KB, patch)
2019-08-13 00:19 CEST, w unruh
Details | Diff

Description w unruh 2019-05-24 20:23:04 CEST
Description of problem:
When I run klatexformula (eitehr klatexformula-4.0.0-1.mga6 or 
klatexformula-4.0.0-4.mga7) The window in which latex writes the compiled formula is too small for the written text. Thus {1\over r} looses almost all of the 1, e^{ix} looses all except the very lowest part of the "ix". This is useless. 

Version-Release number of selected component (if applicable):

How reproducible:
Always. The program is useless as it stands. 

It may well be that it is a problem with latex, or with the way klatex calls latex. It works find in Mageia 6. It is completely broken in Mga7

Steps to Reproduce: Always
Comment 1 w unruh 2019-05-24 20:25:42 CEST
Created attachment 11024 [details]
Picture of the bad output of klatexforumla

As can be seen the display "window" is too small for the formula cutting off, in this case the "1". I made the background colour of the display white rather than transparent so one could see the background.
Comment 2 Marja Van Waes 2019-05-24 22:51:16 CEST
Assigning to the registered maintainer.

Assignee: bugsquad => mageia
CC: (none) => marja11

Comment 3 w unruh 2019-05-25 02:15:57 CEST
I have discovered that if I uncheck the 
ToggleShirnkExpandMode->Settings->Latex&Image-> RecalculateBoundingBox 
then things seem to work correctly. That this item was checked was either a holdover of past (eg Mga6) useage, or it was the default. While checking this box works in Mga6, it does not work in Mga7. Mga needs to make sure that unticked of this box is the default.
(I suppose ghostscript is behaving differently in the two versions)
Comment 4 w unruh 2019-06-04 01:55:35 CEST
According to the author Philippe Faist, this is a bug in ghostscript 2.97 (used on Mageia 7) 
It is apparently fixed in ghostscript git, but is not yet in any distribution of ghostscript. 
So at present the best "fix" is to make sure that by default klatexformula has that option in comment 3 unchecked in the Mageia 7 distribution.
Comment 5 w unruh 2019-08-13 00:15:40 CEST
This is claimed to be solved in ghostscript 9.27~dfsg-2 on debian buster
Comment 6 w unruh 2019-08-13 00:19:53 CEST
Created attachment 11250 [details]
Patch included in Debian ghostscript-9.27~dfsg-2 to fix this problem

Debian claims that the patch included in Buster ghostscript-9.27~dfsg-2 fixes this problem of ghostscript creating the wrong bounding box.
The Debian patch is included here.
Comment 7 David GEIGER 2019-08-19 10:48:58 CEST
Patch added for Cauldron and also for mga7 in 7/Core/updates_testing repo!

Please test it to see if it fixes your issue, thanks in advance!

CC: (none) => geiger.david68210

David Walser 2019-08-19 19:38:42 CEST

Depends on: (none) => 25294

Comment 8 Thomas Backlund 2019-08-31 15:31:05 CEST
An update for this issue has been pushed to the Mageia Updates repository.


Resolution: (none) => FIXED
CC: (none) => tmb

Note You need to log in before you can comment on or make changes to this bug.