Bug 24863 - filesystems inconsistancies with kernel-desktop-5.1.4-1.mga7
Summary: filesystems inconsistancies with kernel-desktop-5.1.4-1.mga7
Status: RESOLVED FIXED
Alias: None
Product: Mageia
Classification: Unclassified
Component: RPM Packages (show other bugs)
Version: 7
Hardware: x86_64 Linux
Priority: release_blocker critical
Target Milestone: ---
Assignee: Kernel and Drivers maintainers
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-05-23 15:41 CEST by Jean-François Bachelet
Modified: 2019-08-11 00:10 CEST (History)
3 users (show)

See Also:
Source RPM: kernel-5.1.4-1.mga7
CVE:
Status comment:


Attachments
excert from journalctl -xb (662.29 KB, image/jpeg)
2019-05-23 15:45 CEST, Jean-François Bachelet
Details
as request in comment 4 (169.05 KB, application/x-xz)
2019-05-24 23:32 CEST, Jean-François Bachelet
Details

Description Jean-François Bachelet 2019-05-23 15:41:32 CEST
Description of problem:
after some times of use and saving files to disk the /home filesystem shows some problems with the configuration files becoming un-writable, an attempt to repair the filesystems with fsck find some errors and correct it but the problem is back after the next reboot, thus the machine is impossible to use as nothing can be saved on any of the harddisks...


Version-Release number of selected component (if applicable):
Mageia 7b3 install with all latests updates done

How reproducible:
Got this problem on a machine with a mageia 7b1 install with all the latests updates upto yesterday, so I've replaced the system harddisk by a brand new one (was thinking it could be a pre-failure state of the disk) and redone the install from scrath with the mageia 7b3 dvd and applied all the latest updates.


Steps to Reproduce:
1.do a fresh system install with mageia 7b3 dvd, apply all updates, reboot and log in
2.do some work and save files to disk and surf the net using firefox
3.the bug should shows up more or less rapidly and the whole system become unusable for work :(
Jean-François Bachelet 2019-05-23 15:43:21 CEST

CC: (none) => jfbachelet
Priority: Normal => release_blocker

Comment 1 Jean-François Bachelet 2019-05-23 15:45:09 CEST
Created attachment 11020 [details]
excert from journalctl -xb
Comment 2 Jean-François Bachelet 2019-05-23 17:07:26 CEST
list of the last updates done before the bug strikes :

1 - first pass

GlibC 2.29 12.mga7
GlibC-devel 2.29 12.mga7
metatask 7 0.28.mga7
rpmdrake 6.29 1.mga7

2 - second pass

Binutils 2.32 8.mga7
cpupower 5.1.4 1.mga7
desktop-comon-data 6.13 1.mga7
drak3d 2.7 1.mga7
drakx-kbd-mouse-x11 1.28 1.mga7
drakx-kbd-mouse-x11-text 1.28 1.mga7
drakx-net 2.41 1.mga7
drakx-net-applet 2.41 1.mga7
drakx-net-text 2.41 1.mga7
drakxtools 18.18 1.mga7
drakxtools-backend 18.18 1.mga7
drakxtools-curses 18.18 1.mga7
harddrake 18.18 1.mga7
harddrake-ui 18.18 1.mga7
indexhtml 7.0 1.mga7
kernel-desktop-5.1.4-1.mga7 1 1.mga7
kernel-desktop-devel-5.1.4-1.mga7 1 1.mga7
kernel-desktop-latest 5.1.4 1.mga7
kernel-desktop-devel-latest 5.1.4 1.mga7
kernel-source-5.1.4-1.mga7 1 1.mga7
kernel-source-latest 1 1.mga7
kernel-userspace-headers 5.1.4 1.mga7
ldetect-lst 0.5.9 1.mga7
lib64dri-drivers 19.1.0 0.rc3.1.mga7
lib64gbm1 19.1.0 0.rc3.1.mga7
lib64gegl0.4-0 0.4.16 1.mga7
lib64glapi0 19.1.0 0.rc3.1.mga7
lib64javascriptcore-gir4.02.24.2 2.mga7
lib64javascriptcoregtk4.0.18 2.24.2 2.mga7
lib64vkontakte2 5.0.0 2.mga7
lib64mariadb3 10.3.15 1.mga7
lib64mesaegl1 19.1.0 0.rc3.1.mga7
lib64mesagl1 19.1.0 0.rc3.1.mga7
lib64mozjs60 60.4.0 2.mga7
lib64webkit2gtk-gir4.0 2.24.2 2.mga7
lib64webkit2gtk4.0_37 2.24.2 2.mga7
lib64xatracker2 19.1.0 0.rc3.1.mga7
libdrak3d 2.7 1.mga7
libdrakx-kbd-mouse-x11 1.28 1.mga7
libdrakx-net 2.41 1.mga7
libvkontakte-i18n 5.0.0 2.mga7
mageia-release-Default 7 0.16.mga7
mageia-release-common 7 0.16.mga7
mageia-welcome 1.98 1.mga7
mariadb 10.3.15 1.mga7
mariadb-client 10.3.15 1.mga7
mariadb-common 10.3.15 1.mga7
mariadb-common-core 10.3.15 1.mga7
mariadb-core 10.3.15 1.mga7
mariadb-extra 10.3.15 1.mga7
mesa 19.1.0 0.rc3.1.mga7
mgaonline 3.28 1.mga7
msec 2.7 1.mga7
msec-gui 2.7 1.mga7
net_monitor 0.25 1.mga7
nscd 2.29 12.mga7
perl-user 2.19 1.mga7
sgml-common 0.6.3 27.mga7
transfugdrake 1.9.13 1.mga7
userdrake 2.19 1.mga7
webkit2 2.24.2 2.mga7
x11-driver-video-amdgpu
Comment 3 Jean-François Bachelet 2019-05-23 17:12:12 CEST
end of comment 2 (sorry false keystroke)

x11-driver-video-amdgpu 19.0.1 3.mga7
x11-driver-video-ati 19.0.1 5.mga7

pfew!

it's after that last batch of updates that the systems became poblematic, I can't see what can be which that triger this error tought...
Comment 4 Marja Van Waes 2019-05-24 18:14:11 CEST
(In reply to Jean-François Bachelet from comment #0)

> 
> How reproducible:
> Got this problem on a machine with a mageia 7b1 install with all the latests
> updates upto yesterday, so I've replaced the system harddisk by a brand new
> one (was thinking it could be a pre-failure state of the disk) and redone
> the install from scrath with the mageia 7b3 dvd and applied all the latest
> updates.
> 
and it happened again :-(

If you did a non-live install, then please attach 

   /root/drakx/report.bug.xz


(In reply to Jean-François Bachelet from comment #3)

> 
> it's after that last batch of updates that the systems became poblematic, I
> can't see what can be which that triger this error tought...

did you reboot after those updates?

If so, can you try whether booting the previous kernel fixes the issue?

Assigning to the kernel & drivers maintainers, anyway, because even if it isn't a kernel issue, they'll be able to figure out what the real culprit is.

Source RPM: (none) => kernel?
Assignee: bugsquad => kernel
CC: (none) => marja11

Comment 5 Jean-François Bachelet 2019-05-24 23:32:51 CEST
Created attachment 11025 [details]
as request in comment 4
Comment 6 Jean-François Bachelet 2019-05-24 23:37:59 CEST
I've deinstalled "nscd" as it's readme was speaking about some problems (albeit with kernel 2.0) and the error is back but it is possible to save some things after closing the numerous requesters saying that "files xxx is not writable"... btw it's very slow but less blocking than before.
Comment 7 Jean-François Bachelet 2019-05-24 23:39:02 CEST
and yes I always reboot after applying updates ^^)
Comment 8 Jean-François Bachelet 2019-05-26 15:59:01 CEST
(In reply to Marja Van Waes from comment #4)
> (In reply to Jean-François Bachelet from comment #0)

> If so, can you try whether booting the previous kernel fixes the issue?
in fact yes, booting with the precedent kernel version did it and the error didn't show up.
Comment 9 Thomas Backlund 2019-05-26 16:44:59 CEST
Please try again with kernel-5.1.5-1.mga7

CC: (none) => tmb

Marja Van Waes 2019-05-26 21:50:41 CEST

Source RPM: kernel? => kernel-5.1.4-1.mga7
Summary: filesystems inconsistancies after the last updates to mageia 7b3 => filesystems inconsistancies with kernel-desktop-5.1.4-1.mga7

Comment 10 Jean-François Bachelet 2019-05-28 11:27:48 CEST
(In reply to Thomas Backlund from comment #9)
> Please try again with kernel-5.1.5-1.mga7

as soon as I boot with this kernel the problem shows up :(
Comment 11 Jean-François Bachelet 2019-06-03 09:58:09 CEST
(In reply to Jean-François Bachelet from comment #10)
> (In reply to Thomas Backlund from comment #9)
> > Please try again with kernel-5.1.5-1.mga7
> 
> as soon as I boot with this kernel the problem shows up :(

Oups! bad read, tried with kernel 5.1.5-1 and don't see the error yet ^^)
Jean-François Bachelet 2019-06-06 13:13:57 CEST

Summary: filesystems inconsistancies with kernel-desktop-5.1.4-1.mga7 => Resolved : filesystems inconsistancies with kernel-desktop-5.1.4-1.mga7

Comment 12 David Walser 2019-08-11 00:10:06 CEST
Please set RESOLVED in the Status, not the Summary.

Status: NEW => RESOLVED
Resolution: (none) => FIXED
Summary: Resolved : filesystems inconsistancies with kernel-desktop-5.1.4-1.mga7 => filesystems inconsistancies with kernel-desktop-5.1.4-1.mga7


Note You need to log in before you can comment on or make changes to this bug.