Bug 24206 - wsjtx must be updated as the FT8 and MSK144 protocols have been updated worldwide
Summary: wsjtx must be updated as the FT8 and MSK144 protocols have been updated world...
Status: RESOLVED FIXED
Alias: None
Product: Mageia
Classification: Unclassified
Component: RPM Packages (show other bugs)
Version: 6
Hardware: All Linux
Priority: Normal major
Target Milestone: ---
Assignee: QA Team
QA Contact:
URL:
Whiteboard: MGA6-64-OK
Keywords: advisory, validated_update
Depends on:
Blocks:
 
Reported: 2019-01-19 12:57 CET by Barry Jackson
Modified: 2019-01-30 20:40 CET (History)
3 users (show)

See Also:
Source RPM: wsjtx
CVE:
Status comment:


Attachments
wsjtx-2.0.0 running new FT8 protocol in Mga6 x86_64 screenshot (348.44 KB, image/png)
2019-01-19 13:30 CET, Barry Jackson
Details

Description Barry Jackson 2019-01-19 12:57:28 CET
Description of problem:
The FT8 and MSK144 protocols have been enhanced in a way that is not backward compatible with older program versions.  The new protocols become the world-wide standards starting on December 10, 2018, and all users should upgrade to WSJT-X 2.0 by January 1, 2019.  After that date, only the new FT8 and MSK144 should be used on the air.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
Comment 1 Barry Jackson 2019-01-19 12:59:42 CET
I have tested the new version in Mga6 and it is already in Cauldron.
I will push the new version to 6/updates_testing shortly.
Comment 2 Barry Jackson 2019-01-19 13:27:25 CET
This update should have been done before xmas, however due to a bug in my updates tracking script it slid under my radar!
####################################
Update Advisory
####################################

wsjtx-2.0.0-1.mga6 has been pushed to 6/core/updates_testing.

Description
####################################

This update moves wsjtx to the new protocols for FT8 and MSK144 which were introduced in Dec 2018 and should be used from Jan 2019 onwards worldwide.
Other functionality e.g. WSPR remains the same as the previous version.

Packages affected
####################################
wsjtx-2.0.0-1.mga6.x86_64.rpm
wsjtx-debuginfo-2.0.0-1.mga6.x86_64.rpm

wsjtx-2.0.0-1.mga6.i586.rpm
wsjtx-debuginfo-2.0.0-1.mga6.i586.rpm

From:
wsjtx-2.0.0-1.mga6.src.rpm

Testing
####################################

I can confirm that this works as expected in Mga6 x86_64 otherwise without the necessary ancillary equipment and licence it is impossible to test fully.
Screenshot to be attached running on 20m band.
I can summon the help of another amateur station I know to test this (x86_64 only) if needed. Otherwise QA can really only check that it updates and that the GUI opens cleanly.

Source RPM: (none) => wsjtx

Comment 3 Barry Jackson 2019-01-19 13:30:43 CET
Created attachment 10681 [details]
wsjtx-2.0.0 running new FT8 protocol in Mga6 x86_64 screenshot

Screenshot
Comment 4 Barry Jackson 2019-01-19 13:41:18 CET
Oops accidentally assigned to Cauldron should have been 6 of course!

Version: Cauldron => 6

Barry Jackson 2019-01-24 15:13:33 CET

Assignee: zen25000 => qa-bugs

Comment 5 Thomas Andrews 2019-01-25 16:56:20 CET
I do not own any of the necessary specialized equipment, so I tested according to the advice in Comment 2.

I had to install the old package(s) first. "wsjtx-debuginfo" was nowhere to be found. I have run into this before, where the "debugging" package is not a package that users will see, so I am ignoring it. As I recall it should not be included in the advisory, but I could be wrong about that.

The original wsjtx installed cleanly, and the gui opened without issue. I used the QA Repo tool to select and download the update, after which it installed cleanly as well. 

Running the gui this time included a notice about the new protocols, and how it's important that they should be used after January 1, 2019. Because of the nature of the update, the packager's tests, and the clean install, I am giving this a 64-bit OK and validating. Advisory information can be found in Comment 2.

Whiteboard: (none) => MGA6-64-OK
CC: (none) => andrewsfarm, sysadmin-bugs
Keywords: (none) => validated_update

Dave Hodgins 2019-01-26 05:36:53 CET

Keywords: (none) => advisory
CC: (none) => davidwhodgins

Comment 6 Mageia Robot 2019-01-30 20:40:50 CET
An update for this issue has been pushed to the Mageia Updates repository.

https://advisories.mageia.org/MGAA-2019-0006.html

Status: NEW => RESOLVED
Resolution: (none) => FIXED


Note You need to log in before you can comment on or make changes to this bug.