Bug 23930 - update nextcloud to version 13.0.8
Summary: update nextcloud to version 13.0.8
Status: RESOLVED FIXED
Alias: None
Product: Mageia
Classification: Unclassified
Component: RPM Packages (show other bugs)
Version: 6
Hardware: All Linux
Priority: Normal normal
Target Milestone: ---
Assignee: QA Team
QA Contact:
URL:
Whiteboard: MGA6-64-OK
Keywords: advisory, validated_update
Depends on:
Blocks:
 
Reported: 2018-12-02 15:09 CET by José Jorge
Modified: 2018-12-09 22:21 CET (History)
4 users (show)

See Also:
Source RPM: nextcloud
CVE:
Status comment:


Attachments

Description José Jorge 2018-12-02 15:09:03 CET
Advisory:
Nextcloud has several bugfixes in new version 13.0.8.
This version could work better with new client version 2.5.0.

SRPM :

nextcloud-13.0.8-1.mga6.srpm

RPMS :

nextcloud-13.0.8-1.mga6.noarch.rpm
nextcloud-mysql-13.0.8-1.mga6.noarch.rpm
nextcloud-postgresql-13.0.8-1.mga6.noarch.rpm
José Jorge 2018-12-02 15:09:07 CET

CC: (none) => lists.jjorge

Comment 1 Brian Rockwell 2018-12-07 01:55:15 CET
I was able to install 13.0.8.

I ran Nextcloud 13.0.6 before with sqlite.

Doesn't seem to support sqlite anymore, thus it forced me to upgrade to mariadb to make it work.

Installed all of the above modules, did not try postgesql on this one, someone else is welcome to try.

x86_64 - latest kernel.

Mixed feelings on this update, but it does work.

CC: (none) => brtians1

Comment 2 José Jorge 2018-12-07 18:26:38 CET
(In reply to Brian Rockwell from comment #1)
> Doesn't seem to support sqlite anymore, thus it forced me to upgrade to
> mariadb to make it work.

Strange : I have tested this upgrade with a MGA6 sqlite and it works. What was the error preventing the use of sqlite?
Comment 3 Brian Rockwell 2018-12-07 22:30:15 CET
this might be a clue on what is going on.  

Dec 07 15:27:12 localhost.localdomain httpd[6853]: {PHP} PHP Startup: Unable to load dynamic library 'sqlite3.so' (tried: /usr/lib64/php/extensions/sqlite3.so (/usr/lib64/php/extensions/sqlite3.so: undefined symbol: zend_object_store_get_object), /usr/lib64/php/extensions/sqlite3.so.so (/usr/lib64/php/extensions/sqlite3.so.so: cannot open shared object file: No such file or directory)) at Unknown

I'll try a fresh build of 13.0.6 on VM and then go to 13.0.8.  May be a few days.
Comment 4 José Jorge 2018-12-08 11:46:08 CET
(In reply to Brian Rockwell from comment #3)
> undefined symbol: zend_object_store_get_object),

You have messed your php libs, some are not updated. This has nothing to do with nextcloud, it is just a partial update done in your system ;-)
Comment 5 Brian Rockwell 2018-12-08 17:31:56 CET
yes it was.

I built out a new VM - implemented 13.06 with mariadb.

Upgraded to 13.08.

Working like a charm.

x86_64 approved - fyi, I won't check the 32-bit version.

Whiteboard: (none) => MGA6-64-OK

Comment 6 Lewis Smith 2018-12-08 20:48:49 CET
Thank you again Brian for great work. Validating. Advisory as comment 0.

Keywords: (none) => advisory, validated_update
CC: (none) => lewyssmith, sysadmin-bugs

Comment 7 Mageia Robot 2018-12-09 22:21:39 CET
An update for this issue has been pushed to the Mageia Updates repository.

https://advisories.mageia.org/MGAA-2018-0182.html

Status: NEW => RESOLVED
Resolution: (none) => FIXED


Note You need to log in before you can comment on or make changes to this bug.