Bug 23348 - freshplayerplugin update for FF60ESR (was flash player 30.0.0.134 doesn't work in chromium nor firefox)
Summary: freshplayerplugin update for FF60ESR (was flash player 30.0.0.134 doesn't wor...
Status: RESOLVED FIXED
Alias: None
Product: Mageia
Classification: Unclassified
Component: RPM Packages (show other bugs)
Version: 6
Hardware: All Linux
Priority: Normal normal
Target Milestone: ---
Assignee: QA Team
QA Contact:
URL:
Whiteboard: MGA6-64-OK MGA6-32-OK
Keywords: advisory, validated_update
Depends on:
Blocks:
 
Reported: 2018-07-26 03:00 CEST by andré blais
Modified: 2018-09-27 09:25 CEST (History)
7 users (show)

See Also:
Source RPM: freshplayerplugin-0.3.6-8.mga6.src.rpm
CVE:
Status comment:


Attachments

Description andré blais 2018-07-26 03:00:22 CEST
3 months to a few weeks ago, flash player worked perfectly in chromium, for a particular important site, on 2 different computers running Mageia 6, both fully updated.
(Flash is little if any used for other sites on these computers.)
The site hasn't been accessed for a few weeks, and now it no longer works in chromium.

The flash is used by the site to display static images.  Another site displays similar graphics as jpg images, but lacks certain critical functions.

When displaying a page with a flash image,
a classic puzzle piece is displayed in its' place, with the text

"Ce plug-in n'est pas compatible" (This plugin is not compatible)

A mouse-over displays the text "undefined".

The context menu shows under embed + properties that the page trying to display
  application/x-shockwave-flash

A microsoft based computer at a school correctly displays the flash images on the site in question.
(But I don't have microsoft available on which I can install flash.)

I installed firefox to test accessing the site, but firefox doesn't display the flash image, not even the puzzle piece in its' place.
Note that all other images and text are displayed as normally on these pages with both chromium and firefox.  Just not the flash images.

I tried the workaround for bug 20196, and it had no effect.  (I didn't expect it would work, since about a month ago everything displayed normally on the problem site.)

I also tried installing flash directly from the macromedia site, but it didn't change the problem for chromium.

I suspect that the bug fix with the latest flash caused the problem, since it also affects firefox.
Otherwise it may be a problem with chromium.
Comment 1 andré blais 2018-07-26 07:51:18 CEST
I just succeeded accessing admin privileges on another computer running ms-windows, so I could install flash, and the site displays the flash images perfectly, after restarting chromium.

So the problem is linux (or Mageia) specific.
Comment 2 andré blais 2018-07-26 07:56:59 CEST
BTW, to reset the admin password on the ms-windows box, I used the chntpw app in the core repository, along with sysrescuecd.
I discovered its' existance in an online search.
Comment 3 katnatek 2018-07-26 21:34:52 CEST
I use the npapi version of the plugin with firefox and works well
Comment 4 Marja Van Waes 2018-07-27 16:04:05 CEST
Assigning to the registered maintainer, CC'ing two committers

Assignee: bugsquad => anssi.hannula
Source RPM: (none) => flash-player-plugin-30.0.0.134-1.mga6.nonfree
CC: (none) => marja11, mrambo, smelror

Comment 5 katnatek 2018-07-29 21:01:14 CEST
I Think the issue is in the ppapi version
I test that and the plogin not works
The npapi version does
Comment 6 katnatek 2018-08-04 05:52:04 CEST
For test i build the cauldron's version of freshplayerplugin for mga6
Now the flash content loads with 30.0.0.134 ppapi but with some issues
Comment 7 David Walser 2018-08-04 17:48:32 CEST
Advisory:
----------------------------------------

The freshplayerplugin package has been updated to version 0.3.9 to fix various
bugs and to allow it to work with newer versions of Firefox.

References:
https://github.com/i-rinat/freshplayerplugin/releases
----------------------------------------

Updated packages in core/updates_testing:
----------------------------------------
freshplayerplugin-0.3.9-1.mga6

from freshplayerplugin-0.3.9-1.mga6.src.rpm

Source RPM: flash-player-plugin-30.0.0.134-1.mga6.nonfree => freshplayerplugin-0.3.6-8.mga6.src.rpm
Assignee: anssi.hannula => qa-bugs

Comment 8 katnatek 2018-08-06 02:52:29 CEST
(In reply to andré blais from comment #0)
What sites did you try i try with y8.com in chromium and
the games works

Try this suggestions https://forums.adobe.com/message/10180595#10180595
Comment 9 andré blais 2018-08-06 08:05:30 CEST
(In reply to katnatek from comment #8)
> (In reply to andré blais from comment #0)
> What sites did you try i try with y8.com in chromium and
> the games works

It was a password-protected school site, needed for a course.
As noted initially, the site did work a few months ago, but wasn't accessed for a few weeks, until just after the last flash update.

I discovered that many images are dynamic, which is why flash is used on this site.  The alternate site uses only still images (which are ambiguous in many cases), and is not associated with the school.

> 
> Try this suggestions https://forums.adobe.com/message/10180595#10180595

I've already tried all the suggestions, before I posted this bug report.

Next I'm going to try the old style plugin for firefox, since the msw computer is extremely slow.
Comment 10 andré blais 2018-08-06 08:52:00 CEST
I just discovered that chromium doesn't think that flash is installed.

chrome://components/
lists 7 items, none of which is flash.

I uninstalled/reinistalled mga flash package, no change to chrome://components page.

I uninstalled mga flash and installed upstream package, no change to chrome://components page.

So the bug seems to be in chromium, rather than flash.

chromium Version 67.0.3396.87 (Build de développement) Mageia.Org 6 (64 bits)
(The latest update)

chromium-browser-stable-67.0.3396.87-2.mga6.src.rpm
Comment 11 andré blais 2018-08-06 08:57:11 CEST
I don't know if it makes any difference, but chromium-browser is not installed.
 (it just requires chromium-browser-stable without doing anything else)
Comment 12 katnatek 2018-08-06 09:07:42 CEST
(In reply to andré blais from comment #10)
> I just discovered that chromium doesn't think that flash is installed.
> 
> chrome://components/
> lists 7 items, none of which is flash.
> 
> I uninstalled/reinistalled mga flash package, no change to
> chrome://components page.
> 
> I uninstalled mga flash and installed upstream package, no change to
>  page.
> 
> So the bug seems to be in chromium, rather than flash.
> 
> chromium Version 67.0.3396.87 (Build de développement) Mageia.Org 6 (64 bits)
> (The latest update)
> 
> chromium-browser-stable-67.0.3396.87-2.mga6.src.rpm

rpm -qa|grep chromium
chromium-browser-stable-67.0.3396.87-2.mga6

chrome://components don't list plugin but
chrome://flash/ and chrome://version  should
Comment 13 andré blais 2018-08-06 15:36:21 CEST
indeed, chrome://flash and chrome://version do list flash.

My mga user account became unaccessible, and I had to redo the account.
(Deleting the old one, creating a replacement, and transferring needed files.)
Now flash works in chromium.

Also certain functions, like rpmdrake, are much faster.

So the problem was something in my user account configuration was blocking flash.
For some reason, it affected 2 different mga based computers.

So invalid.  Sorry for the noise.

Status: NEW => RESOLVED
Resolution: (none) => INVALID

Comment 14 andré blais 2018-08-06 17:20:03 CEST
flash works in firefox now as well.
Comment 15 David Walser 2018-08-06 21:32:47 CEST
Did katnatek have the same issue in his user account, or does updating freshplayerplugin fix something for them?  If the latter, please re-open this bug (perhaps change the title to something more appropriate) so the update can be pushed.
Comment 16 katnatek 2018-08-07 06:45:05 CEST
(In reply to David Walser from comment #15)
> Did katnatek have the same issue in his user account, or does updating
> freshplayerplugin fix something for them?  If the latter, please re-open
> this bug (perhaps change the title to something more appropriate) so the
> update can be pushed.

-Maybe is due i use the 61 version of firefox.
Comment 17 José Jorge 2018-09-22 08:55:44 CEST
So according to Firefox ESR 60 testing, this update is needed to get flash working.

See https://bugs.mageia.org/show_bug.cgi?id=23348#c7 for details

Resolution: INVALID => (none)
Status: RESOLVED => REOPENED
CC: (none) => lists.jjorge

José Jorge 2018-09-22 08:56:36 CEST

Summary: flash player 30.0.0.134 doesn't work in chromium nor firefox => freshplayerplugin update for FF60ESR (was flash player 30.0.0.134 doesn't work in chromium nor firefox)

Comment 18 Thomas Andrews 2018-09-24 14:03:21 CEST
I found this weeks ago in the MGA6 testing repositories, installed it, and have been successfully using it with FF52ESR. I have not yet tried it with our FF60ESR in MGA6.

I know that it is meant to be used with FF60ESR, but as this package has been assigned to QA and FF60 has not - yet - it should be checked against FF52ESR, as well. It is also possible that some users will choose to continue to use FF52ESR, as FF60ESR will not work with many popular extensions. So, it should be tested against the older FF, as well.

CC: (none) => andrewsfarm

Comment 19 Thomas Andrews 2018-09-25 15:35:59 CEST
64-bit Plasma system, on real hardware.

Removed freshplayer 0.3.9 (and flashplayer), then re-installed the current flashplayer, which re-installed freshplayer 0.3.6. 

Ran FF52ESR, and confirmed that flash was working. Updated to the FF60ESR currently in the testing repositories, checked it, and confirmed that flash was no longer working.

Updated to freshplayer 0.3.9, returned to FF60ESR, and flash was now working.

OK here on 64-bit.

Whiteboard: (none) => MGA6-64-OK

Comment 20 Thomas Andrews 2018-09-25 17:03:43 CEST
32-bit Plasma system, on real hardware.

Checked Firefox 52ESR, and flashplayer is working. Updated to Firefox 60ESR, and the flashplayer stops working. Updated the freshplayer package, and flashplayer works again.

OK here for 32-bits. Validating.

Keywords: (none) => validated_update
Whiteboard: MGA6-64-OK => MGA6-64-OK MGA6-32-OK
CC: (none) => sysadmin-bugs

Dave Hodgins 2018-09-26 18:39:10 CEST

Keywords: (none) => advisory
CC: (none) => davidwhodgins

Comment 21 Mageia Robot 2018-09-27 09:25:33 CEST
An update for this issue has been pushed to the Mageia Updates repository.

https://advisories.mageia.org/MGAA-2018-0155.html

Resolution: (none) => FIXED
Status: REOPENED => RESOLVED


Note You need to log in before you can comment on or make changes to this bug.