Bug 23290 - Our nextcloud-client 2.3.2 have known bugs and is old. 2.5.0 is out.
Summary: Our nextcloud-client 2.3.2 have known bugs and is old. 2.5.0 is out.
Status: RESOLVED FIXED
Alias: None
Product: Mageia
Classification: Unclassified
Component: RPM Packages (show other bugs)
Version: 6
Hardware: All Linux
Priority: High major
Target Milestone: ---
Assignee: QA Team
QA Contact:
URL: https://www.nextcloud.com
Whiteboard: MGA6-64-OK
Keywords: advisory, validated_update
: 23832 (view as bug list)
Depends on:
Blocks:
 
Reported: 2018-07-09 12:39 CEST by Maat
Modified: 2018-12-09 22:21 CET (History)
8 users (show)

See Also:
Source RPM: nextcloud-client-2.3.2-1.mga6.src.rpm
CVE:
Status comment:


Attachments

Description Maat 2018-07-09 12:39:37 CEST
Hi packagers team !

Description of problem:

When syncing with the nexcloud-client 2.3.2 the error "“an if-match header was specified and the resource did not exist” raises and blocks synchronization.

See for more details : https://help.nextcloud.com/t/reoccuring-error-theme-an-if-martch-header-was-specified-and-the-resource-did-not-exist/18517

Version-Release number of selected component (if applicable):
2.3.2

How reproducible:

See explanation in the forum page (link above) and here under.

Steps to Reproduce:
1. install rpm
2. create an account on a nexcloud instance
3. use it with 40 or 50 pdf and video files mixed in a set of directories
4. sooner or later you'll get the bug described

It is fixed in the following version : 2.3.3

-> Could we consider packaging 2.3.3 instead of 2.3.2 for mga 6 or mga 6.1 ?

Cheers,
Maât
Marc Krämer 2018-07-09 13:01:35 CEST

CC: (none) => mageia
Assignee: bugsquad => mageia

Comment 1 Morgan Leijström 2018-07-09 18:35:25 CEST
Yes https://nextcloud.com/install/#install-clients say latest stable version is 2.3.3.

(BTW there it is a 64 bit NC client appimage, so if needed urgently you could use that maybe, and copy the configuration to it?)

My from mga6 package installed NC client 2.3.2 say in a GUI tab that it is built nov 11 2017 from git revision https://github.com/owncloud/client/commit/820899d07102b990b19e8b02121221e41f7fbf06

It used to be that OwnCloud and Nextcloud clients use same source, and same numbering.

Because we changed from packaging OwnCloud server to Nextcloud server we also changed clients.
This is a bit frustrating, as NC client developers have not followed up the client lately.
https://help.nextcloud.com/t/desktop-client-has-less-releases-and-is-behind-master/29407

For only connecting to Nextcloud updating to later versions may be less relevant, but also Mageia users may need to connect to updated owncloud servers on other systems, or manually installed on Mageia, and try bleeding edge features.

OwnCloud client 2.3.4 was released 2017-11-02, https://github.com/owncloud/client/releases
And they have now categorised even 2.3.4 as an old version! https://owncloud.org/download/older-versions/

Current OwnCloud client is
https://owncloud.org/news/desktop-client-2-4-1-release/
Maybe a later version if released when packager have the time.
( 2.4.2 is in rc2 and 2.5.0 in alpha1 )
https://github.com/owncloud/client/branches

For compiling 2.4.1 yourself there is code on https://owncloud.com/download/

BUT now Nextcloud is on the move to jump to 2.5.0: https://help.nextcloud.com/t/help-test-the-next-generation-nextcloud-desktop-clients/33448
And there are appimages to test: https://download.nextcloud.com/desktop/daily/Linux/  :)

So ultimately you/we can test if that works for us, provide feedback there, and when released we make our 2.5.0 rpm?

CC: (none) => fri

Comment 2 Bertrand Marne 2018-11-09 15:22:50 CET
*** Bug 23832 has been marked as a duplicate of this bug. ***

CC: (none) => mageia

Comment 3 Bertrand Marne 2018-11-09 15:30:55 CET
FYI I tried the AppImage of the latest stable Nextcloud client v2.3.3 on my Mageia 6 and It works very well, both with Nextcloud servers and Updated Owncloud servers (not working with the Mageia packaged v2.3.2). It works very well except icons in Dolphin that do not seem to be updated when sync is done/or not (maybe nextcloud-dolphin-client needs an update too).
Comment 4 Morgan Leijström 2018-11-09 16:29:14 CET
2.5.0 is at RC2 and it *may* be the final
https://help.nextcloud.com/t/good-news-everyone-rc2-of-the-desktop-client-is-here/40557
Comment 5 Morgan Leijström 2018-11-16 09:50:01 CET
Now 2.5.0 final is out :)
https://help.nextcloud.com/t/nextcloud-desktop-client-2-5-is-out-with-end-to-end-encryption-new-login-flow-and-much-more/41132


However it may be best to put this in backports?
Because it is a very big step and is not compatible with old unsupported owncloud servers that some of us are forced to stay with because hosted environment limitations - see comment 8, 9 in that link...


Or put it in updates, and user that have problems and need to connect to "ancient" ownCloud versions could change to the appimage 2.3.3, tested in comment 3 above, or revert to our 2.3.2 if the bugs are no problem for that users use case.

Summary: Packaging of nextcloud-client 2.3.3 instead of 2.3.2 to fix a bug in the software ? => Our nextcloud-client 2.3.2 have known bugs and is old. 2.5.0 is out.

Comment 6 Marc Krämer 2018-11-20 13:33:30 CET
Can we please have an update/backport?
The old client is unable to connect to the updated nextcloud server!
Comment 7 Marc Krämer 2018-11-26 11:27:28 CET
Is anyone working on it? I need to access my shares.

I want to access an nextcloud server with version 10.0.10 , and since it was updated, our nextcloud client refuses to connect:
Forbidden (unsupported client version)

Priority: Normal => High

Marc Krämer 2018-11-26 11:27:37 CET

Severity: normal => major

Comment 8 Bertrand Marne 2018-11-26 11:41:03 CET
(In reply to Marc Krämer from comment #7)
> Is anyone working on it? I need to access my shares.
> 
> I want to access an nextcloud server with version 10.0.10 , and since it was
> updated, our nextcloud client refuses to connect:
> Forbidden (unsupported client version)

For now, I’m using the AppImage of the 2.5.0 Nextcloud client and it is working very well.

https://nextcloud.com/install/#install-clients
Comment 9 Marc Krämer 2018-11-26 11:42:48 CET
yeah, that may work, but this is not my understanding of having a software distribution :)

This issue should be fixed!
Comment 10 Bertrand Marne 2018-11-26 13:13:05 CET
(In reply to Marc Krämer from comment #9)
> yeah, that may work, but this is not my understanding of having a software
> distribution :)
> 
> This issue should be fixed!

I agree!
Marc Krämer 2018-11-28 09:25:53 CET

Assignee: mageia => mageia

Comment 11 Marc Krämer 2018-11-28 09:26:43 CET
tested a build for cauldron, have check a few more things and do a compilation for mga6, I think I can push a new version to the mirrors.
Comment 12 Morgan Leijström 2018-11-28 10:09:31 CET
Great, thanks.
Coming to mga6 updates_testing?
Comment 13 Marc Krämer 2018-11-28 10:57:56 CET
I'm at work now - just tested for cauldron this morning. will build for updates_testing tonight. I'm not expecting issues on mga6 when cauldron is ok. I was able to connect to my server and sync data between it. The new client will be, as the package is named, a nextcloud client. I'm not sure if it is possible to connect to owncloud services as they are developing different clients.
Comment 14 Marc Krämer 2018-11-29 00:01:55 CET
I hope this one works for everyone. There are some changes to the old package. The new package was requiring a newer openssl lib, but I don't think they really need it.

Suggested advisory:
========================

Updated nextcloud-client to support the latest server version.
========================

Updated packages in core/updates_testing:
========================
lib64nextcloud-client-devel-2.5.0-1.mga6
lib64nextcloudsync0-2.5.0-1.mga6
lib64ocsync0-2.5.0-1.mga6
nextcloud-client-2.5.0-1.mga6
nextcloud-client-caja-2.5.0-1.mga6
nextcloud-client-debuginfo-2.5.0-1.mga6
nextcloud-client-dolphin-2.5.0-1.mga6
nextcloud-client-nautilus-2.5.0-1.mga6
nextcloud-client-nemo-2.5.0-1.mga6


Source RPMs: 
nextcloud-client-2.5.0-1.mga6.src.rpm

Assignee: mageia => qa-bugs

Comment 15 Marc Krämer 2018-11-29 11:50:49 CET
I've tested the packages on mate desktop. But for gnome/mate and kde there are some extensions for the filemanager etc. please test if it works on these desktops.
Comment 16 Manuel Hiebel 2018-12-01 17:57:18 CET
Tested on Plasma (with the dolphin integration too) x86_64, no regression found, works good
Comment 17 José Jorge 2018-12-02 14:08:32 CET
(In reply to Manuel Hiebel from comment #16)
> Tested on Plasma (with the dolphin integration too) x86_64, no regression
> found, works good

There are some regressions mentioned upstream with folder renaming that triggers a full sync with 2.5.0 version. Did you test that against our packaged nextcloud 13?

CC: (none) => lists.jjorge

Comment 18 Manuel Hiebel 2018-12-02 14:25:11 CET
No with self installed nextcloud 14.
To be real, I indeed make again a new account/full resync, I had an error about "server file discovery", but I had an old shared folder from an users disabled and a folder with the same name working, so I was thinking this made the mess
Comment 19 José Jorge 2018-12-02 15:10:45 CET
(In reply to Manuel Hiebel from comment #18)
> No with self installed nextcloud 14.

We should test against our own provided owncloud. I have pushed version 13.0.8 in bug MGA#23930 to see if it fixes this regression in MGA6 updates testing.
Comment 20 Marc Krämer 2018-12-02 18:20:52 CET
@José, you're right, but nevertheless, our current client is unable to sync with servers which are updated and not runnig mga - so we must have this update.
Comment 21 Morgan Leijström 2018-12-04 13:32:50 CET
Maybe a little quirk in dependencies?
Using mgaapplet, it correctly wants to install 

lib64nextcloudsync0-2.5.0-1.mga6
lib64ocsync0-2.5.0-1.mga6
nextcloud-client-2.5.0-1.mga6
nextcloud-client-dolphin-2.5.0-1.mga6

I believe the versions of all packages should be forced to be the same?
But when i tested is is possible to update a subset by mistake:

1) if i deselect lib64nextcloudsync0 it asks to deselect the other packages,  - except lib64ocsync0

and vice versa:

2) if i deselect lib64ocsync0 it asks to deselect the other packages - except lib64nextcloudsync0
Comment 22 Thomas Backlund 2018-12-04 13:55:40 CET
(In reply to Morgan Leijström from comment #21)
> Maybe a little quirk in dependencies?
> Using mgaapplet, it correctly wants to install 
> 
> lib64nextcloudsync0-2.5.0-1.mga6
> lib64ocsync0-2.5.0-1.mga6
> nextcloud-client-2.5.0-1.mga6
> nextcloud-client-dolphin-2.5.0-1.mga6
> 
> I believe the versions of all packages should be forced to be the same?

They are…

All are version 2.5.0-1

the "0" after the lib name is library major version, not package version

CC: (none) => tmb

Comment 23 Marc Krämer 2018-12-04 14:02:01 CET
there should be a second build "-2" available on testing which I pushed last week to fix dependency issues.
Comment 24 Morgan Leijström 2018-12-04 15:02:22 CET
(In reply to Thomas Backlund from comment #22)
> (In reply to Morgan Leijström from comment #21)
> > Maybe a little quirk in dependencies?
> > Using mgaapplet, it correctly wants to install 
> > 
> > lib64nextcloudsync0-2.5.0-1.mga6
> > lib64ocsync0-2.5.0-1.mga6
> > nextcloud-client-2.5.0-1.mga6
> > nextcloud-client-dolphin-2.5.0-1.mga6
> > 
> > I believe the versions of all packages should be forced to be the same?
> 
> They are…
> 
> All are version 2.5.0-1
> 
> the "0" after the lib name is library major version, not package version

I know ;)

The problem is that it is possible to not have a coherent *2.5.0-2 version of all related packages, if user selects packages manually, and i think that should be made impossible, no?  Another example: I can select to update only lib64ocsync0-2.5.0-2.mga6.x86_64, while the other are at our old 2.3.2.

(Just letting it select updates automatically there is no problem)
Comment 25 Marc Krämer 2018-12-04 15:46:03 CET
ok, I'll have another look at the dependencies (I was just using the existing ones). I'll post when another build is ready - FYI: I'll just change dependencies, so you can test functionality without waiting for the new build.
Comment 26 Thomas Backlund 2018-12-04 16:11:57 CET

(In reply to Morgan Leijström from comment #24)

> The problem is that it is possible to not have a coherent *2.5.0-2 version
> of all related packages, if user selects packages manually, and i think that
> should be made impossible, no?  Another example: I can select to update only
> lib64ocsync0-2.5.0-2.mga6.x86_64, while the other are at our old 2.3.2.
> 

It's a design decision.

We only support installing all updates, not cherrypicking...

> (Just letting it select updates automatically there is no problem)

An that is how it happends for normal endusers...

(In reply to Marc Krämer from comment #25)
> ok, I'll have another look at the dependencies (I was just using the
> existing ones). I'll post when another build is ready - FYI: I'll just
> change dependencies, so you can test functionality without waiting for the
> new build.

Please dont.
adding extra useless deps only forces bigger install transactions...
without them urpmi is free to spit it up in smaller transactions...

We only care that all packages are updated ...
Comment 27 Marc Krämer 2018-12-04 16:20:03 CET
I've had a look on the dependencies - they are clean and should install as expected. As Thomas said, there is no need for more dependencies if not needed.
Comment 28 Morgan Leijström 2018-12-04 16:28:55 CET
Great then! Thank you for the answers :)
Comment 29 Marc Krämer 2018-12-06 21:49:28 CET
Is this update ok, so we can push it to the mirrors?
Comment 30 José Jorge 2018-12-06 22:43:57 CET
(In reply to Marc Krämer from comment #29)
> Is this update ok, so we can push it to the mirrors?

I'd push the 2.5.1 version which is just out to testing, to ensure it doesn't fix the renamed folder buggy sync...
Comment 31 Brian Rockwell 2018-12-07 02:14:06 CET
Testing the client.

I installed the sync-client and the dophin modules.  They installed clean and the sync-client is working properly.

Dec 06 19:00:58 localhost drakrpm[2650]: transaction on / (remove=0, install=0, upgrade=50)
Dec 06 19:00:59 localhost [RPM][2650]: install lib64kconfigCore5-5.42.0-1.mga6.x86_64: success
Dec 06 19:00:59 localhost [RPM][2650]: install lib64kf5i18n5-5.42.0-1.mga6.x86_64: success
Dec 06 19:00:59 localhost [RPM][2650]: install lib64kf5coreaddons5-5.42.0-1.mga6.x86_64: success
Dec 06 19:00:59 localhost [RPM][2650]: install lib64qt5xml5-5.9.4-1.1.mga6.x86_64: success
Dec 06 19:00:59 localhost [RPM][2650]: install lib64kconfigGui5-5.42.0-1.mga6.x86_64: success
Dec 06 19:00:59 localhost [RPM][2650]: install lib64phonon4qt5_4-5:4.10.0-1.mga6.x86_64: success
Dec 06 19:00:59 localhost [RPM][2650]: install lib64phonon4qt5experimental4-5:4.10.0-1.mga6.x86_64: success
Dec 06 19:00:59 localhost [RPM][2650]: install phonon4qt5-5:4.10.0-1.mga6.x86_64: success
Dec 06 19:00:59 localhost [RPM][2650]: install lib64kf5sonnetcore5-5.42.0-1.mga6.x86_64: success
Dec 06 19:00:59 localhost [RPM][2650]: install lib64kf5dbusaddons5-5.42.0-1.mga6.x86_64: success
Dec 06 19:00:59 localhost [RPM][2650]: install lib64kf5service5-5.42.0-1.mga6.x86_64: success
Dec 06 19:00:59 localhost [RPM][2650]: install lib64kf5windowsystem5-5.42.0-1.mga6.x86_64: success
Dec 06 19:00:59 localhost [RPM][2650]: install lib64kf5kiocore5-5.42.0-1.mga6.x86_64: success
Dec 06 19:00:59 localhost [RPM][2650]: install lib64kf5sonnetui5-5.42.0-1.mga6.x86_64: success
Dec 06 19:00:59 localhost [RPM][2650]: install lib64kf5auth5-5.42.0-1.mga6.x86_64: success
Dec 06 19:01:00 localhost [RPM][2650]: install kitemviews-5.42.0-1.2.mga6.x86_64: success
Dec 06 19:01:00 localhost [RPM][2650]: install lib64kitemviews5-5.42.0-1.2.mga6.x86_64: success
Dec 06 19:01:00 localhost [RPM][2650]: install ktextwidgets-5.42.0-1.2.mga6.x86_64: success
Dec 06 19:01:00 localhost [RPM][2650]: install kjobwidgets-5.42.0-1.2.mga6.x86_64: success
Dec 06 19:01:00 localhost [RPM][2650]: install kcodecs-5.42.0-1.1.mga6.x86_64: success
Dec 06 19:01:00 localhost [RPM][2650]: install lib64kf5codecs5-5.42.0-1.1.mga6.x86_64: success
Dec 06 19:01:01 localhost [RPM][2650]: install kwidgetsaddons-5.42.0-1.1.mga6.x86_64: success
Dec 06 19:01:01 localhost [RPM][2650]: install lib64kf5widgetsaddons5-5.42.0-1.1.mga6.x86_64: success
Dec 06 19:01:01 localhost [RPM][2650]: install lib64kf5jobwidgets5-5.42.0-1.2.mga6.x86_64: success
Dec 06 19:01:01 localhost [RPM][2650]: install lib64qt5svg5-5.9.4-1.mga6.x86_64: success
Dec 06 19:01:01 localhost [RPM][2650]: install kcompletion-5.42.0-2.2.mga6.x86_64: success
Dec 06 19:01:02 localhost [RPM][2650]: install lib64kf5completion5-5.42.0-2.2.mga6.x86_64: success
Dec 06 19:01:02 localhost [RPM][2650]: install karchive-5.42.0-1.mga6.x86_64: success
Dec 06 19:01:02 localhost [RPM][2650]: install lib64karchive5-5.42.0-1.mga6.x86_64: success
Dec 06 19:01:02 localhost [RPM][2650]: install lib64kf5package5-5.42.0-1.mga6.x86_64: success
Dec 06 19:01:02 localhost [RPM][2650]: install attica-5.42.0-1.mga6.x86_64: success
Dec 06 19:01:02 localhost [RPM][2650]: install kconfigwidgets-5.42.0-1.1.mga6.x86_64: success
Dec 06 19:01:02 localhost [RPM][2650]: install lib64kf5guiaddons5-5.42.0-1.mga6.x86_64: success
Dec 06 19:01:02 localhost [RPM][2650]: install lib64kf5configwidgets5-5.42.0-1.1.mga6.x86_64: success
Dec 06 19:01:02 localhost [RPM][2650]: install lib64kf5iconthemes5-5.42.0-1.mga6.x86_64: success
Dec 06 19:01:03 localhost [RPM][2650]: install lib64kf5kiowidgets5-5.42.0-1.mga6.x86_64: success
Dec 06 19:01:03 localhost [RPM][2650]: install lib64kf5declarative5-5.42.0-1.mga6.x86_64: success
Dec 06 19:01:03 localhost [RPM][2650]: install lib64kf5textwidgets5-5.42.0-1.2.mga6.x86_64: success
Dec 06 19:01:03 localhost [RPM][2650]: install lib64attica5-5.42.0-1.mga6.x86_64: success
Dec 06 19:01:03 localhost [RPM][2650]: install lib64kf5solid5-5.42.0-1.mga6.x86_64: success
Dec 06 19:01:03 localhost [RPM][2650]: install kxmlgui-5.42.0-1.mga6.x86_64: success
Dec 06 19:01:03 localhost [RPM][2650]: install lib64snappy1-1.1.3-4.mga6.x86_64: success
Dec 06 19:01:03 localhost [RPM][2650]: install lib64qt5webchannel5-5.9.4-1.mga6.x86_64: success
Dec 06 19:01:03 localhost [RPM][2650]: install lib64qt5keychain1-0.7.0-2.mga6.x86_64: success
Dec 06 19:01:03 localhost [RPM][2650]: install lib64dolphinvcs5-1:17.12.2-1.mga6.x86_64: success
Dec 06 19:01:03 localhost [RPM][2650]: install lib64minizip1-1.2.11-4.1.mga6.x86_64: success
Dec 06 19:01:03 localhost [RPM][2650]: install lib64lmdb0-0.9.21-1.mga6.x86_64: success
Dec 06 19:01:03 localhost [RPM][2650]: install lib64dbusmenu-qt5_2-0.9.3-1.20160218.1.mga6.x86_64: success
Dec 06 19:01:03 localhost [RPM][2650]: install lib64re2_0-20160401-1.mga6.x86_64: success
Dec 06 19:01:04 localhost [RPM][2650]: install lib64kf5globalaccel5-5.42.0-1.mga6.x86_64: success
Dec 06 19:01:06 localhost [RPM][2650]: install lib64kconfigCore5-5.42.0-1.mga6.x86_64: success
Dec 06 19:01:06 localhost [RPM][2650]: install lib64kf5i18n5-5.42.0-1.mga6.x86_64: success
Dec 06 19:01:06 localhost [RPM][2650]: install lib64kf5coreaddons5-5.42.0-1.mga6.x86_64: success
Dec 06 19:01:06 localhost [RPM][2650]: install lib64qt5xml5-5.9.4-1.1.mga6.x86_64: success
Dec 06 19:01:06 localhost [RPM][2650]: install lib64kconfigGui5-5.42.0-1.mga6.x86_64: success
Dec 06 19:01:06 localhost [RPM][2650]: install lib64phonon4qt5_4-5:4.10.0-1.mga6.x86_64: success
Dec 06 19:01:06 localhost [RPM][2650]: install lib64phonon4qt5experimental4-5:4.10.0-1.mga6.x86_64: success
Dec 06 19:01:06 localhost [RPM][2650]: install phonon4qt5-5:4.10.0-1.mga6.x86_64: success
Dec 06 19:01:06 localhost [RPM][2650]: install lib64kf5sonnetcore5-5.42.0-1.mga6.x86_64: success
Dec 06 19:01:06 localhost [RPM][2650]: install lib64kf5dbusaddons5-5.42.0-1.mga6.x86_64: success
Dec 06 19:01:06 localhost [RPM][2650]: install lib64kf5service5-5.42.0-1.mga6.x86_64: success
Dec 06 19:01:06 localhost [RPM][2650]: install lib64kf5windowsystem5-5.42.0-1.mga6.x86_64: success
Dec 06 19:01:06 localhost [RPM][2650]: install lib64kf5kiocore5-5.42.0-1.mga6.x86_64: success
Dec 06 19:01:06 localhost [RPM][2650]: install lib64kf5sonnetui5-5.42.0-1.mga6.x86_64: success
Dec 06 19:01:06 localhost [RPM][2650]: install lib64kf5auth5-5.42.0-1.mga6.x86_64: success
Dec 06 19:01:06 localhost [RPM][2650]: install kitemviews-5.42.0-1.2.mga6.x86_64: success
Dec 06 19:01:06 localhost [RPM][2650]: install lib64kitemviews5-5.42.0-1.2.mga6.x86_64: success
Dec 06 19:01:06 localhost [RPM][2650]: install ktextwidgets-5.42.0-1.2.mga6.x86_64: success
Dec 06 19:01:06 localhost [RPM][2650]: install kjobwidgets-5.42.0-1.2.mga6.x86_64: success
Dec 06 19:01:06 localhost [RPM][2650]: install kcodecs-5.42.0-1.1.mga6.x86_64: success
Dec 06 19:01:06 localhost [RPM][2650]: install lib64kf5codecs5-5.42.0-1.1.mga6.x86_64: success
Dec 06 19:01:06 localhost [RPM][2650]: install kwidgetsaddons-5.42.0-1.1.mga6.x86_64: success
Dec 06 19:01:06 localhost [RPM][2650]: install lib64kf5widgetsaddons5-5.42.0-1.1.mga6.x86_64: success
Dec 06 19:01:06 localhost [RPM][2650]: install lib64kf5jobwidgets5-5.42.0-1.2.mga6.x86_64: success
Dec 06 19:01:06 localhost [RPM][2650]: install lib64qt5svg5-5.9.4-1.mga6.x86_64: success
Dec 06 19:01:06 localhost [RPM][2650]: install kcompletion-5.42.0-2.2.mga6.x86_64: success
Dec 06 19:01:06 localhost [RPM][2650]: install lib64kf5completion5-5.42.0-2.2.mga6.x86_64: success
Dec 06 19:01:06 localhost [RPM][2650]: install karchive-5.42.0-1.mga6.x86_64: success
Dec 06 19:01:06 localhost [RPM][2650]: install lib64karchive5-5.42.0-1.mga6.x86_64: success
Dec 06 19:01:06 localhost [RPM][2650]: install lib64kf5package5-5.42.0-1.mga6.x86_64: success
Dec 06 19:01:06 localhost [RPM][2650]: install attica-5.42.0-1.mga6.x86_64: success
Dec 06 19:01:06 localhost [RPM][2650]: install kconfigwidgets-5.42.0-1.1.mga6.x86_64: success
Dec 06 19:01:06 localhost [RPM][2650]: install lib64kf5guiaddons5-5.42.0-1.mga6.x86_64: success
Dec 06 19:01:06 localhost [RPM][2650]: install lib64kf5configwidgets5-5.42.0-1.1.mga6.x86_64: success
Dec 06 19:01:06 localhost [RPM][2650]: install lib64kf5iconthemes5-5.42.0-1.mga6.x86_64: success
Dec 06 19:01:06 localhost [RPM][2650]: install lib64kf5kiowidgets5-5.42.0-1.mga6.x86_64: success
Dec 06 19:01:06 localhost [RPM][2650]: install lib64kf5declarative5-5.42.0-1.mga6.x86_64: success
Dec 06 19:01:06 localhost [RPM][2650]: install lib64kf5textwidgets5-5.42.0-1.2.mga6.x86_64: success
Dec 06 19:01:06 localhost [RPM][2650]: install lib64attica5-5.42.0-1.mga6.x86_64: success
Dec 06 19:01:06 localhost [RPM][2650]: install lib64kf5solid5-5.42.0-1.mga6.x86_64: success
Dec 06 19:01:06 localhost [RPM][2650]: install kxmlgui-5.42.0-1.mga6.x86_64: success
Dec 06 19:01:06 localhost [RPM][2650]: install lib64snappy1-1.1.3-4.mga6.x86_64: success
Dec 06 19:01:06 localhost [RPM][2650]: install lib64qt5webchannel5-5.9.4-1.mga6.x86_64: success
Dec 06 19:01:06 localhost [RPM][2650]: install lib64qt5keychain1-0.7.0-2.mga6.x86_64: success
Dec 06 19:01:06 localhost [RPM][2650]: install lib64dolphinvcs5-1:17.12.2-1.mga6.x86_64: success
Dec 06 19:01:06 localhost [RPM][2650]: install lib64minizip1-1.2.11-4.1.mga6.x86_64: success
Dec 06 19:01:06 localhost [RPM][2650]: install lib64lmdb0-0.9.21-1.mga6.x86_64: success
Dec 06 19:01:06 localhost [RPM][2650]: install lib64dbusmenu-qt5_2-0.9.3-1.20160218.1.mga6.x86_64: success
Dec 06 19:01:06 localhost [RPM][2650]: install lib64re2_0-20160401-1.mga6.x86_64: success
Dec 06 19:01:06 localhost [RPM][2650]: install lib64kf5globalaccel5-5.42.0-1.mga6.x86_64: success
Dec 06 19:01:27 localhost drakrpm[2650]: transaction on / (remove=0, install=0, upgrade=50)
Dec 06 19:01:28 localhost [RPM][2650]: install lib64kf5xmlgui5-5.42.0-1.mga6.x86_64: success
Dec 06 19:01:28 localhost [RPM][2650]: install lib64qt5webengine5-5.9.4-1.mga6.x86_64: success
Dec 06 19:01:30 localhost [RPM][2650]: install qtwebengine5-5.9.4-1.mga6.x86_64: success
Dec 06 19:01:36 localhost [RPM][2650]: install lib64qt5webenginecore5-5.9.4-1.mga6.x86_64: success
Dec 06 19:01:36 localhost [RPM][2650]: install lib64kf5filemetadata5-5.42.0-1.mga6.x86_64: success
Dec 06 19:01:36 localhost [RPM][2650]: install lib64kf5notifications5-5.42.0-1.mga6.x86_64: success
Dec 06 19:01:36 localhost [RPM][2650]: install lib64kf5newstuffcore5-5.42.0-1.3.mga6.x86_64: success
Dec 06 19:01:36 localhost [RPM][2650]: install knewstuff-5.42.0-1.3.mga6.x86_64: success
Dec 06 19:01:36 localhost [RPM][2650]: install lib64kf5js5-5.42.0-1.mga6.x86_64: success
Dec 06 19:01:36 localhost [RPM][2650]: install lib64ocsync0-2.5.0-2.mga6.x86_64: success
Dec 06 19:01:36 localhost [RPM][2650]: install lib64kf5wallet5-5.42.0-1.mga6.x86_64: success
Dec 06 19:01:36 localhost [RPM][2650]: install lib64qt5quickwidgets5-5.9.4-1.mga6.x86_64: success
Dec 06 19:01:36 localhost [RPM][2650]: install lib64qt5webenginewidgets5-5.9.4-1.mga6.x86_64: success
Dec 06 19:01:37 localhost [RPM][2650]: install lib64nextcloudsync0-2.5.0-2.mga6.x86_64: success
Dec 06 19:01:37 localhost [RPM][2650]: install nextcloud-client-2.5.0-2.mga6.x86_64: success
Dec 06 19:01:37 localhost [RPM][2650]: install lib64kf5newstuff5-5.42.0-1.3.mga6.x86_64: success
Dec 06 19:01:37 localhost [RPM][2650]: install baloo-widgets-17.12.2-1.1.mga6.x86_64: success
Dec 06 19:01:37 localhost [RPM][2650]: install kbookmarks-5.42.0-1.2.mga6.x86_64: success
Dec 06 19:01:37 localhost [RPM][2650]: install lib64kf5bookmarks5-5.42.0-1.2.mga6.x86_64: success
Dec 06 19:01:37 localhost [RPM][2650]: install lib64kf5kiofilewidgets5-5.42.0-1.mga6.x86_64: success
Dec 06 19:01:37 localhost [RPM][2650]: install lib64kf5balooengine5-5.42.0-2.mga6.x86_64: success
Dec 06 19:01:37 localhost [RPM][2650]: install lib64kf5baloocore5-5.42.0-2.mga6.x86_64: success
Dec 06 19:01:37 localhost [RPM][2650]: install lib64kf5baloowidgets5-17.12.2-1.1.mga6.x86_64: success
Dec 06 19:01:38 localhost [RPM][2650]: install lib64dolphinprivate5-1:17.12.2-1.mga6.x86_64: success
Dec 06 19:01:38 localhost [RPM][2650]: install kcmutils-5.42.0-1.2.mga6.x86_64: success
Dec 06 19:01:38 localhost [RPM][2650]: install lib64kf5quickaddons5-5.42.0-1.mga6.x86_64: success
Dec 06 19:01:38 localhost [RPM][2650]: install lib64kf5kcmutils5-5.42.0-1.2.mga6.x86_64: success
Dec 06 19:01:38 localhost [RPM][2650]: install lib64ssh4-1:0.7.7-1.mga6.x86_64: success
Dec 06 19:01:38 localhost [RPM][2650]: install kpty-5.42.0-1.2.mga6.x86_64: success
Dec 06 19:01:38 localhost [RPM][2650]: install lib64kf5pty5-5.42.0-1.2.mga6.x86_64: success
Dec 06 19:01:38 localhost [RPM][2650]: install lib64kf5activities5-1:5.42.0-1.mga6.x86_64: success
Dec 06 19:01:38 localhost [RPM][2650]: install lib64qt5script5-5.9.4-1.mga6.x86_64: success
Dec 06 19:01:38 localhost [RPM][2650]: install kcrash-5.42.0-1.mga6.x86_64: success
Dec 06 19:01:38 localhost [RPM][2650]: install lib64kf5crash5-5.42.0-1.mga6.x86_64: success
Dec 06 19:01:39 localhost [RPM][2650]: install kinit-5.42.0-1.mga6.x86_64: success
Dec 06 19:01:39 localhost [RPM][2650]: install lib64kf5doctools5-5.42.0-1.mga6.x86_64: success
Dec 06 19:01:39 localhost [RPM][2650]: install lib64kf5kiontlm5-5.42.0-1.mga6.x86_64: success
Dec 06 19:01:40 localhost [RPM][2650]: install kio-5.42.0-1.mga6.x86_64: success
Dec 06 19:01:40 localhost [RPM][2650]: install lib64kioarchive5-17.12.2-4.1.mga6.x86_64: success
Dec 06 19:01:40 localhost [RPM][2650]: install lib64qt5sql5-5.9.4-1.1.mga6.x86_64: success
Dec 06 19:01:40 localhost [RPM][2650]: install kparts-5.42.0-1.mga6.x86_64: success
Dec 06 19:01:40 localhost [RPM][2650]: install lib64kf5parts5-5.42.0-1.mga6.x86_64: success
Dec 06 19:01:40 localhost [RPM][2650]: install lib64kf5khtml5-5.42.0-1.mga6.x86_64: success
Dec 06 19:01:41 localhost [RPM][2650]: install khtml-5.42.0-1.mga6.x86_64: success
Dec 06 19:01:41 localhost [RPM][2650]: install kdnssd-3:5.42.0-1.2.mga6.x86_64: success
Dec 06 19:01:41 localhost [RPM][2650]: install lib64kf5kdnssd5-3:5.42.0-1.2.mga6.x86_64: success
Dec 06 19:01:41 localhost [RPM][2650]: install lib64molletnetwork17-17.12.2-4.1.mga6.x86_64: success
Dec 06 19:01:41 localhost [RPM][2650]: install kio-extras-17.12.2-4.1.mga6.x86_64: success
Dec 06 19:01:42 localhost [RPM][2650]: install dolphin-1:17.12.2-1.mga6.x86_64: success
Dec 06 19:01:42 localhost [RPM][2650]: install nextcloud-client-dolphin-2.5.0-2.mga6.x86_64: success
Dec 06 19:01:47 localhost [RPM][2650]: install lib64kf5xmlgui5-5.42.0-1.mga6.x86_64: success
Dec 06 19:01:47 localhost [RPM][2650]: install lib64qt5webengine5-5.9.4-1.mga6.x86_64: success
Dec 06 19:01:47 localhost [RPM][2650]: install qtwebengine5-5.9.4-1.mga6.x86_64: success
Dec 06 19:01:47 localhost [RPM][2650]: install lib64qt5webenginecore5-5.9.4-1.mga6.x86_64: success
Dec 06 19:01:47 localhost [RPM][2650]: install lib64kf5filemetadata5-5.42.0-1.mga6.x86_64: success
Dec 06 19:01:47 localhost [RPM][2650]: install lib64kf5notifications5-5.42.0-1.mga6.x86_64: success
Dec 06 19:01:47 localhost [RPM][2650]: install lib64kf5newstuffcore5-5.42.0-1.3.mga6.x86_64: success
Dec 06 19:01:47 localhost [RPM][2650]: install knewstuff-5.42.0-1.3.mga6.x86_64: success
Dec 06 19:01:47 localhost [RPM][2650]: install lib64kf5js5-5.42.0-1.mga6.x86_64: success
Dec 06 19:01:47 localhost [RPM][2650]: install lib64ocsync0-2.5.0-2.mga6.x86_64: success
Dec 06 19:01:47 localhost [RPM][2650]: install lib64kf5wallet5-5.42.0-1.mga6.x86_64: success
Dec 06 19:01:47 localhost [RPM][2650]: install lib64qt5quickwidgets5-5.9.4-1.mga6.x86_64: success
Dec 06 19:01:47 localhost [RPM][2650]: install lib64qt5webenginewidgets5-5.9.4-1.mga6.x86_64: success
Dec 06 19:01:47 localhost [RPM][2650]: install lib64nextcloudsync0-2.5.0-2.mga6.x86_64: success
Dec 06 19:01:47 localhost [RPM][2650]: install nextcloud-client-2.5.0-2.mga6.x86_64: success
Dec 06 19:01:47 localhost [RPM][2650]: install lib64kf5newstuff5-5.42.0-1.3.mga6.x86_64: success
Dec 06 19:01:47 localhost [RPM][2650]: install baloo-widgets-17.12.2-1.1.mga6.x86_64: success
Dec 06 19:01:47 localhost [RPM][2650]: install kbookmarks-5.42.0-1.2.mga6.x86_64: success
Dec 06 19:01:47 localhost [RPM][2650]: install lib64kf5bookmarks5-5.42.0-1.2.mga6.x86_64: success
Dec 06 19:01:47 localhost [RPM][2650]: install lib64kf5kiofilewidgets5-5.42.0-1.mga6.x86_64: success
Dec 06 19:01:47 localhost [RPM][2650]: install lib64kf5balooengine5-5.42.0-2.mga6.x86_64: success
Dec 06 19:01:47 localhost [RPM][2650]: install lib64kf5baloocore5-5.42.0-2.mga6.x86_64: success
Dec 06 19:01:47 localhost [RPM][2650]: install lib64kf5baloowidgets5-17.12.2-1.1.mga6.x86_64: success
Dec 06 19:01:47 localhost [RPM][2650]: install lib64dolphinprivate5-1:17.12.2-1.mga6.x86_64: success
Dec 06 19:01:47 localhost [RPM][2650]: install kcmutils-5.42.0-1.2.mga6.x86_64: success
Dec 06 19:01:47 localhost [RPM][2650]: install lib64kf5quickaddons5-5.42.0-1.mga6.x86_64: success
Dec 06 19:01:47 localhost [RPM][2650]: install lib64kf5kcmutils5-5.42.0-1.2.mga6.x86_64: success
Dec 06 19:01:47 localhost [RPM][2650]: install lib64ssh4-1:0.7.7-1.mga6.x86_64: success
Dec 06 19:01:47 localhost [RPM][2650]: install kpty-5.42.0-1.2.mga6.x86_64: success
Dec 06 19:01:47 localhost [RPM][2650]: install lib64kf5pty5-5.42.0-1.2.mga6.x86_64: success
Dec 06 19:01:47 localhost [RPM][2650]: install lib64kf5activities5-1:5.42.0-1.mga6.x86_64: success
Dec 06 19:01:47 localhost [RPM][2650]: install lib64qt5script5-5.9.4-1.mga6.x86_64: success
Dec 06 19:01:47 localhost [RPM][2650]: install kcrash-5.42.0-1.mga6.x86_64: success
Dec 06 19:01:47 localhost [RPM][2650]: install lib64kf5crash5-5.42.0-1.mga6.x86_64: success
Dec 06 19:01:47 localhost [RPM][2650]: install kinit-5.42.0-1.mga6.x86_64: success
Dec 06 19:01:47 localhost [RPM][2650]: install lib64kf5doctools5-5.42.0-1.mga6.x86_64: success
Dec 06 19:01:47 localhost [RPM][2650]: install lib64kf5kiontlm5-5.42.0-1.mga6.x86_64: success
Dec 06 19:01:47 localhost [RPM][2650]: install kio-5.42.0-1.mga6.x86_64: success
Dec 06 19:01:47 localhost [RPM][2650]: install lib64kioarchive5-17.12.2-4.1.mga6.x86_64: success
Dec 06 19:01:47 localhost [RPM][2650]: install lib64qt5sql5-5.9.4-1.1.mga6.x86_64: success
Dec 06 19:01:47 localhost [RPM][2650]: install kparts-5.42.0-1.mga6.x86_64: success
Dec 06 19:01:47 localhost [RPM][2650]: install lib64kf5parts5-5.42.0-1.mga6.x86_64: success
Dec 06 19:01:47 localhost [RPM][2650]: install lib64kf5khtml5-5.42.0-1.mga6.x86_64: success
Dec 06 19:01:47 localhost [RPM][2650]: install khtml-5.42.0-1.mga6.x86_64: success
Dec 06 19:01:47 localhost [RPM][2650]: install kdnssd-3:5.42.0-1.2.mga6.x86_64: success
Dec 06 19:01:47 localhost [RPM][2650]: install lib64kf5kdnssd5-3:5.42.0-1.2.mga6.x86_64: success
Dec 06 19:01:47 localhost [RPM][2650]: install lib64molletnetwork17-17.12.2-4.1.mga6.x86_64: success
Dec 06 19:01:47 localhost [RPM][2650]: install kio-extras-17.12.2-4.1.mga6.x86_64: success
Dec 06 19:01:47 localhost [RPM][2650]: install dolphin-1:17.12.2-1.mga6.x86_64: success
Dec 06 19:01:47 localhost [RPM][2650]: install nextcloud-client-dolphin-2.5.0-2.mga6.x86_64: success


I also capture a screen print of it synching, but I doubt anyone is interested in this

mga6_x86_64 is fine.  Should I wait to try again with 2.5.1?

CC: (none) => brtians1

Comment 32 Brian Rockwell 2018-12-08 17:35:18 CET
Tested this out again today.  Working as designed for the nextcloud sync-client.  

will test thunar out now.
Comment 33 Brian Rockwell 2018-12-08 17:46:42 CET
I didn't find thunar, so set up caja and the nextcloud client.

Synching and working as designed.

Whiteboard: (none) => MGA6-64-OK

Comment 34 Lewis Smith 2018-12-08 20:17:20 CET
Ready to do the Advisory for this, but confused about exact SRPM version number: can I use the advisory from comment 14 as it is (2.5.0-1)? Comment 24 refers to something at 2.5.0-2; comment 30 to 2.5.1.
@Brian: you have worked hard on this, many thanks for same. Can you say what version you tested?

CC: (none) => lewyssmith

Comment 35 Brian Rockwell 2018-12-08 23:03:12 CET
Oops forgot to list:

Dec 06 19:01:47 localhost [RPM][2650]: install nextcloud-client-2.5.0-2.mga6.x86_64: success

Dec 08 10:42:27 localhost [RPM][7034]: install nextcloud-client-caja-2.5.0-2.mga6.x86_64: success
Comment 36 Marc Krämer 2018-12-09 00:49:09 CET
all have tested release 2.5.0-2 - I've added a correction (dependency) shortly after my post.
Comment 37 Lewis Smith 2018-12-09 21:18:39 CET
Thanks for the version info. Validating & advisoried from comments 14 & 35/36.

CC: (none) => sysadmin-bugs
Keywords: (none) => advisory, validated_update

Comment 38 Mageia Robot 2018-12-09 22:21:37 CET
An update for this issue has been pushed to the Mageia Updates repository.

https://advisories.mageia.org/MGAA-2018-0181.html

Resolution: (none) => FIXED
Status: NEW => RESOLVED


Note You need to log in before you can comment on or make changes to this bug.