Bug 23086 - MGAonline upgrade 5 to 6 Failures, probably caused by broken dacentec.com mirror
Summary: MGAonline upgrade 5 to 6 Failures, probably caused by broken dacentec.com mirror
Status: RESOLVED FIXED
Alias: None
Product: Mageia
Classification: Unclassified
Component: Release (media or process) (show other bugs)
Version: 6
Hardware: All Linux
Priority: Normal normal
Target Milestone: ---
Assignee: Sysadmin Team
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: 21340
  Show dependency treegraph
 
Reported: 2018-05-24 20:14 CEST by Brian Rockwell
Modified: 2018-06-19 15:04 CEST (History)
4 users (show)

See Also:
Source RPM:
CVE:
Status comment:


Attachments
log from the attempted upgrade (328.60 KB, application/zip)
2018-05-24 20:21 CEST, Brian Rockwell
Details
second attempt with latest updates (209.53 KB, application/zip)
2018-05-25 15:31 CEST, Brian Rockwell
Details

Description Brian Rockwell 2018-05-24 20:14:42 CEST
Description of problem:  using mgaapplet --testing get large number of errors and failed upgrade


Version-Release number of selected component (if applicable): 5.1 going to 6


How reproducible:


Steps to Reproduce:
1.  running mgaapplet --testing
2.
3.
Comment 1 Brian Rockwell 2018-05-24 20:21:47 CEST
Created attachment 10187 [details]
log from the attempted upgrade

using virtualbox on upgraded MGA 5.1 64-bit running KDE

- multiple reports of conflicts, etc.
Comment 2 Nicolas Lécureuil 2018-05-24 23:45:25 CEST
are we missing obsoletes in plasma ?

CC: (none) => mageia

Comment 3 Brian Rockwell 2018-05-25 15:31:55 CEST
Created attachment 10191 [details]
second attempt with latest updates

Second attempt reveals new errors.

Latest log.

Hope this helps, Brian
Comment 4 Marja Van Waes 2018-05-25 17:11:27 CEST
(In reply to Brian Rockwell from comment #3)
> Created attachment 10191 [details]
> second attempt with latest updates
> 
> Second attempt reveals new errors.
> 
> Latest log.
> 
> Hope this helps, Brian

That's all about libreoffice and java-1.8.0-openjdk (why does the latter seem to have a higher version in mga5 than in mga6... oh, I see: the mirror is outdated

http://mirror.dacentec.com/mageia/distrib/6/x86_64/media/core/updates/

6/core/java-1.8.0-openjdk-1.8.0.171-1.b10.1.mga6 was pushed to updates on 4 May, but it isn't on that mirror.

http://mirrors.mageia.org/status shows that mirror fully red, for all Mageia releases. Seems it didn't sync since 2018-02-01 :-(

It's a pity we still don't have Mirrorbrain working.

We should contact that mirror (I won't atm, sorry) or remove it.

Assignee: bugsquad => sysadmin-bugs
CC: (none) => marja11
Summary: MGAonline upgrade 5 to 6 Failures => MGAonline upgrade 5 to 6 Failures, probably caused by broken dacentec.com mirror

Comment 5 Dave Hodgins 2018-06-07 04:35:15 CEST
Just ran into this in an i586 upgrade test that selected the princeton mirror
which is up-to-date.
For Mageia 6, the mirror has
java-1.8.0-openjdk-1.8.0.171-1.b10.1.mga6.i586.rpm

From Mageia 5, the installed version is
java-1.8.0-openjdk-1.8.0.171-1.b10.1.mga5.i586.rpm

Both have epoch set to 1, so I'm not clear on what's causing the problem.

As that upgrade is still running, on a Mageia 5 x86_64 vb guest, tried removing
the media, adding the Mageia 6 media, so that I could try just installing
openjdk and openjdk-headless under debug. Everything looks fine until it
gets to ...
Marking java-1.8.0-openjdk-headless as manually installed, it won't be auto-orphaned
Marking java-1.8.0-openjdk as manually installed, it won't be auto-orphaned

So it's not seeing the .mga6 package as being different, let alone newer than
the Mageia 5 package.

CC: (none) => davidwhodgins

Dave Hodgins 2018-06-07 04:36:37 CEST

Blocks: (none) => 21340

Comment 6 Dave Hodgins 2018-06-19 15:04:39 CEST
Didn't happen on a repeat test after the changes to perl-URPM.
Closing as fixed. Please reopen if you see it again.

Status: NEW => RESOLVED
Resolution: (none) => FIXED


Note You need to log in before you can comment on or make changes to this bug.