Bug 23036 - gnucash bugfix update 2.6.21
Summary: gnucash bugfix update 2.6.21
Status: RESOLVED FIXED
Alias: None
Product: Mageia
Classification: Unclassified
Component: RPM Packages (show other bugs)
Version: 6
Hardware: All Linux
Priority: Normal normal
Target Milestone: ---
Assignee: QA Team
QA Contact:
URL:
Whiteboard: MGA6-32-OK MGA6-64-OK
Keywords: advisory, validated_update
Depends on:
Blocks:
 
Reported: 2018-05-15 16:19 CEST by José Jorge
Modified: 2018-06-06 20:16 CEST (History)
3 users (show)

See Also:
Source RPM: gnucash
CVE:
Status comment:


Attachments

Description José Jorge 2018-05-15 16:19:41 CEST
Version 2.6.21 fixes bugs opening a gnucash file that was edited with gnucash 3.X versions. This update will ensure users can go back before we upgrade gnucash to version 3.x in some weeks.
Comment 1 José Jorge 2018-05-15 16:23:53 CEST
Suggested advisory :

Gnucash 2.6.21 brings some bugfixes among our previous 2.6.19 one. Main fix is correct opening of files modified with new gnucash 3 version.

RPMS :

gnucash-2.6.21-1.mga6.i586.rpm
gnucash-ofx-2.6.21-1.mga6.i586.rpm
gnucash-hbci-2.6.21-1.mga6.i586.rpm
libgnucash-devel-2.6.21-1.mga6.i586.rpm
libgnucash0-2.6.21-1.mga6.i586.rpm
python2-gnucash-2.6.21-1.mga6.i586.rpm

SRPM:
gnucash-2.6.21-1.mga6.srpm
Comment 2 José Jorge 2018-05-31 08:14:27 CEST
This package was not submitted, or the build system eated it. I submitted it today.

Status: NEW => ASSIGNED

Comment 3 Ulrich Beckmann 2018-06-02 16:21:21 CEST
Installed programs
gnucash-2.6.21-1.mga6
lib64gnucash0-2.6.21-1.mga6

Got some real money to play with ...
I invoked GnuCash and entered some accounts and bookings. Please note that I use this program for the first time.

It looks everything ok.

However I could not test GnuCash 3 from Cauldron. It crashes

[beq-jrt@mag7-cauldron ~]$ LANGUAGE=de_DE LANG=de_DE gnucash %f
gnucash: error while loading shared libraries: libgncmod-gnome-utils.so: cannot open shared object file: No such file or directory
[beq-jrt@mag7-cauldron ~]$

Actually there is a file libgncmod-gnome-utils.so in the system.

Ulrich

CC: (none) => bequimao.de

Comment 4 José Jorge 2018-06-04 17:08:00 CEST
Tested on both i586 and x86_64 working for some hours on a document. I suppose this is enough ;-)

Whiteboard: (none) => MGA6-32-OK MGA6-64-OK

Comment 5 José Jorge 2018-06-04 17:09:29 CEST
(In reply to Ulrich Beckmann from comment #3)
> However I could not test GnuCash 3 from Cauldron. It crashes
> 
> [beq-jrt@mag7-cauldron ~]$ LANGUAGE=de_DE LANG=de_DE gnucash %f
> gnucash: error while loading shared libraries: libgncmod-gnome-utils.so:
> cannot open shared object file: No such file or directory
> [beq-jrt@mag7-cauldron ~]$
> 
> Actually there is a file libgncmod-gnome-utils.so in the system.
> 

Thanks for testing in cauldron, but please don't hijack this bug report : just create a new bug report and assign it to me.
Comment 6 Ulrich Beckmann 2018-06-04 18:20:33 CEST
(In reply to José Jorge from comment #5)
> 
> Thanks for testing in cauldron, but please don't hijack this bug report :
> just create a new bug report and assign it to me.

That is not intended. But I will not open bug reports in Cauldron before the release of Mag 6.1 due to lack of time.

Ulrich
Comment 7 claire robinson 2018-06-05 18:17:41 CEST
Is the issue in comment 3 a regression in this mga6 update too Ulrich?

Any German users confirm please?

CC: (none) => sysadmin-bugs
Keywords: (none) => validated_update

claire robinson 2018-06-05 18:18:33 CEST

Keywords: validated_update => (none)

Comment 8 Ulrich Beckmann 2018-06-06 03:22:54 CEST
(In reply to claire robinson from comment #7)
> Is the issue in comment 3 a regression in this mga6 update too Ulrich?
> 
> Any German users confirm please?

No, as I said before- It's working fine in Mga6. You can safely validate this update.

Ulrich
Dave Hodgins 2018-06-06 11:15:53 CEST

Depends on: (none) => 22834

Comment 9 Dave Hodgins 2018-06-06 11:16:11 CEST
Tested with the updated perl-Finance-Quote from bug 22834.

Validating the update.

CC: (none) => davidwhodgins
Depends on: 22834 => (none)
Keywords: (none) => advisory, validated_update

Comment 10 Mageia Robot 2018-06-06 20:16:35 CEST
An update for this issue has been pushed to the Mageia Updates repository.

https://advisories.mageia.org/MGAA-2018-0111.html

Resolution: (none) => FIXED
Status: ASSIGNED => RESOLVED


Note You need to log in before you can comment on or make changes to this bug.